Jump to content

Headless Client on a "custom" IP Server

Recommended Posts


I've configured my dedicated server with a secondary IP under its NIC.

I can start the Server by using the -ip parameter inside my server's .cfg file (eg -ip=123.456.789.0). The server starts, I can find it and play in it with no problems at all, and it has the set ip.


The problem is that I can't have my headless client (local to the dedicated) to connect to the server.


Without the use of a defined IP with the -ip parameter, I used to set


and my headless clients had -connect= / -connect=localhost as parameters.

With the new IP, for example the said "123.456.789.0", HCs can't connect even if I tried what follows:

//server .cfg

//server config.cfg

//headless params

Do someone how to achieve the headless client connection with a defined IP on the server?

thank you.

Share this post

Link to post
Share on other sites

Just a thought but have you got both a headless client logic placed in your mission (set playable and with a name) and have you tried putting the -password=yourpass in as a parameter (if one is needed)

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now