Jump to content

Linux DS - cannot load missions

Recommended Posts

Trying to set up a dedicated server for the first time, there are "a few" hurdles. I'm creating the configuration with TADST, then copying it and the .pbo files manually to the server, if needed adjusting manually and starting it with edited command line. No mods are used.




1) Stuck in infinite loading screen before lobby or anything. Can hear the wind/wave sound. No help if I wait for a few minutes, disconnect, and reconnect again.

2) Admin login is not succesful. Ie. I try to type in group chat eg. "# login", "#login", "#login <password>" - no entries in the log


This run with a standard mission file but none of a bunch of different user created missions work either. Server log:




Configuration file:



// Config file generated 17/09/2018 23:44 with TADST.

hostName = "CTI 53 BECTI-DYN Zerty/HTom/Yoshi_E+Varis XPR";
password = "****";
passwordAdmin = "****";
serverCommandPassword = "";
logFile = "logfile_console.log";

motd[] = {
        "Experimental test server for BECTI-DYN based on Zerty's Mod",
        "Test agenda:",
        "-Validate sensibility of core design goals / implemented core changes"
motdInterval = 5;

maxPlayers = 12;
kickduplicate = 0;
verifySignatures = 0;
allowedFilePatching = 0;
requiredSecureId = 0;

voteMissionPlayers = 3;
voteThreshold = 0.33;

disableVoN = 0;
vonCodecQuality = 12;
persistent = 1;
timeStampFormat = "short";
BattlEye = 0;

doubleIdDetected = "";
onUserConnected = "";
onUserDisconnected = "";
onHackedData = "";
onDifferentData = "";
onUnsignedData = "";
regularCheck = "";

class Missions

        class Mission_2
                template = "MP_COOP_m08.Altis";
                difficulty = "regular";





What we tried so far:

-the "Loading Screen Fix" using endLoadingScreen;

-mission file, configuration in lower case

Share this post

Link to post
Share on other sites
A3\missions_f_gamma\mpscenarios\MP_COOP_m08.Altis\mission.sqm/Mission/Entities/Item26/Entities/Item4.type: Unknown enum value SeekAndDestroy

Try a different non-broken mission.

29 minutes ago, Varis said:

Admin login is not succesful

Try to make sure your admin password is ascii characters only. Maybe lowercase only. Maybe test something like 1234.

Share this post

Link to post
Share on other sites

Get the feeling it is some strange ARMA bug or something very basic which however isn't evident from reading the dedicated server instructions.


Have tried "everything" including hitting §, treema and tilde 3x. Any other ideas how to troubleshoot it? There should be a wiki about this... :dozingoff:


Should connecting always work on the first time?


Tried it with almost all mods in -mod and also without -mod altogether.

Share this post

Link to post
Share on other sites

Found something odd in configuration:


MaxBandwidth = -100663296;


Fixing that helped and at least vanilla missions work nicely now!


TADST is great software but could use better protection against user idiocy :don9:

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now