Jump to content

Expression not running in custom Eden attribute

Recommended Posts

Quick question there, I have a custom Eden attribute defined that way :

class GSRI_frigate_attribute_addWeapons {
  expression="_this setVariable ['toto',_value,true]";

It works just fine in Eden, as the checkbox is properly displayed with the correct name, tooltip and default value. Similarly, displaying this class with the in-game config viewer shows that the attribute is correctly added. However, when I run the mission, there is no variable "toto" in the object's namespace. I'm probably missing something very obvious but I can't put my finger on it. Any idea ?

Share this post

Link to post
Share on other sites

Tried with a very simple "diag_log 'gabuzomeu'", but there is nothing in the log file either. It seems not to be executed, and I don't understand why

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now