Jump to content
Sign in to follow this  

Arma: Gold Edition not working

Recommended Posts

I have recently completed Operation Flashpoint GOTY once more (original campaign as well as Resistance and Red Hammer expansions) and decided to give the newer instalments a try. Fortunately, Steam was having a sale so I picked up a bundle that included CWA, Arma: Gold Edition, and Arma 2. Since I've already played the first game from 2001 I've decided to give the one from 2007 a try.


Unfortunately I'm having trouble with it.


  • In the third tutorial (Leader Course) I can't order my squad to enter the APC. They simply ignore my commands. Selecting all and clicking on the Stryker doesn't work. Selecting individuals with the Function keys doesn't work. Neither does using the menu and pressing 4 [Mount] - 5 [Stryker] - 1 [Anywhere].
  • In the fourth tutorial (Armor Course) I get stuck after destroying the targets. Nothing happens. I have since managed to get past this but it is slow - very slow. Execution of commands is inconsistent. Sometimes it happens immediately and sometimes it takes an eternity to register.
  • When trying the "Armed Assault" campaign the whole thing is weird. Lots of silence, a bit of driving around, long pauses where the vehicles don't move and nothing happens, and then the HMMWV gets destroyed without me being able to do anything. I went on YouTube to check and it is clear that my game isn't behaving like it is supposed to. I don't get the intro where Porter introduces himself - instead there's a news report. There is complete silence after one of the characters says the "stay here half-a-year..." sentence - there should be more chatter after that but there isn't. I also don't get the order to disembark where I'm supposed to which leads to everyone dying shortly thereafter when the vehicles get destroyed.


I've tried a bunch of stuff like re-installing the game, verifying integrity of game files, running in Windows XP SP3 compatibility mode, running as administrator, and creating a new in-game user profile - but nothing has worked.

What is going on? Can this be fixed?

Windows 10 (64-bit)
Intel i7-3770 (3.4 Ghz / 3.9 Ghz)
AMD Radeon HD 7900 (3 GB VRAM) (driver version 18.12.2 - latest recommended)

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this