Jump to content
Sign in to follow this  

Can't get multiplayer to work

Recommended Posts

Hello, recently after playing dayz overpoch on a server for a night I was having difficulties connecting to the server (not sure if dayz is relevant in any way just describing situation). Then I was no longer able to connect at all. Then I tried connecting to vanilla arma 2 oa server, none show in the server browser anymore. When I try to make a new listen server on either lan or internet the window does not come up, nothing happens when i click new.

I have tried

-re installing/updating battleye

-validating arma 2 and arma 2 oa and all dlcs

-deleting everything and starting from scratch by redownloading

-turning off firewall, forwarding router ports

Does anyone have any idea why the multiplayer would just break like this? I cannot view any servers in the server browser even if I use remote ip and default filter settings. I know that previously it would take up to 30 seconds for the servers to show up, now I cannot view any at all.

Any help is greatly appreciated as this is my favorite game. Arma III works perfectly fine.

Share this post

Link to post
Share on other sites

I have the same issue as the op I think

I ran A2 OA (steam) and there was only 1 maybe 2 servers listed in multi-player. Like on the screen https://dl.dropboxusercontent.com/u/21346889/2015-05-19_00001.jpg

- It was all working when I was playing like a week ago or so.

- I can connect to that one server and play, no problem with that. It says it requires BattlEye and it initializes without problems. So it's not a global ban or anything like that.

- I opted in for beta update and still no servers.

- Both srvers are from my country (Poland). Not sure why.

- I did try validating arma 2 and arma 2 oa and all dlcs

- I did reset my router, forwarded ports (newer needed that but to be sure)

- I did netsh winsock reset thing from BattlEye faq

I can provide any info about my system and what is running on it if you want.

Adational info:

If i go to Steam> View > Servers > I can't see any servers as well...

So, the server issue is because of updates? Steam issue? Or something else? Where to look for help?

EDIT: Noticed something strange

If I go to filters and Change game/mission type I see one or two different servers with that mission type... That way, i can find maybe 6 servers via in-game server browser... I Have no idea what the heck is going on here :|

EDIT:2 I just checked if changing ping i filters to 0 helps. No change. It is still the same.

The thing is. If I change a mission type from that menu: https://dl.dropboxusercontent.com/u/21346889/2015-05-21_00003.jpg

I can see one or two different servers, but if I choose that first blank option I should see all servers. At last all servers that I can see with other mission types. But still I see only one or two random servers :/

Edited by Invi
Update 2

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this