Jump to content
Sign in to follow this  

Arma2oaserver v1.63.125.402 problem - NetServer::finishDestroyPlayer

Recommended Posts

This is the messagem on create local server after update. *Same config before update.

Waiting for host(forever)

== C:\Program Files (x86)\Steam\SteamApps\common\Arma 2 Operation Arrowhead\arma2oaserver.exe
== "C:\Program Files (x86)\Steam\SteamApps\common\Arma 2 Operation Arrowhead\arma2oaserver.exe" "-par=C:\servers\profiles\1\1.txt"
Exe timestamp: 2014/06/30 10:56:05
Current time:  2014/07/01 00:22:47

Version 1.63.125402
0:22:47 NetServer::finishDestroyPlayer(605910197): DESTROY immediately after CREATE, both cancelled

No one can connect in new version.

Share this post

Link to post
Share on other sites

I had the same problem at times. My servers will get stuck at waiting on host. Seemed like deleting verifysignatures from server.cfg fixed it.

Share this post

Link to post
Share on other sites

Yes, fixed for me too, thanks Switcher. :)

But this isnt right, function "verifysignatures" is very important and usefull, developers can´t read some posts.

New version 1.63.125548 not correct this problem.

Share this post

Link to post
Share on other sites

For anyone having the issues regarding your server NOT showing using the in-game serverlist while having verifysignatures=2 or verifysignatures=1

Other issues regarding this problem:

While the above problem is happening, The server will show up if added using remote button, When a player connects he will hang at "Wait for host" indefinetly.

Possible other undocumented issues caused by this.

The server will show this error in the RPT:

NetServer::finishDestroyPlayer(605910197): DESTROY immediately after CREATE, both cancelled

Possible Causes:

1. Windows file permissions!

2. Corrupted/Bad .bikey files

Possible Issues:

1. The key files do not have proper permissions for the Windows Account that the server exe is being run under.

This causes the server exe to start normally with the problems I stated above ^^

2. The key files are corrupted or for some reason they are not compatible with 1.63

Solution 1:

Delete all user-added .bikey files from the keys directory/folder leaving only bi.bikey and bi2.bikey, Run the server, see if it works.

If this works, you will need to add keys 1 by 1 or in small batches to determine the trouble maker.

Personally, a combination of the 2 solutions worked for me, I ended up finding 1 user-added .bikey file that was causing these issues to occur.

Trouble Makers (Filenames):


Solution 2:

Right click keys folder, click properties, click Security tab, Click Advanced button, Click Change Permissions button, Click the Owner tab, Click the Edit button, Select the account your server exe is run under, Tick the "Replace owner on subcontainer and objects" check box at the bottom, Click apply, Click yes on any prompts.

Attempt to run the server again, it should have the proper permissions to access the key files and the server should operate correctly.

(If needed, You may want to repeat the above solution for the root Arma folder, this way all files inside the folder should have the proper permissions)

Additional Notes:

This problem did not appear to occur before the 1.63 major push to stable, only after updating from 1.62->1.63~

This has not been confirmed on Linux Dedicated.

Solution 2 is mainly for people whom have direct access to their server box or are hosting on their home machines etc..

If Solution 1 does not work for you and If you host from a server provider/GSP contact them with solution 1 and I'm sure they can fix your issues, otherwise poke around your control panel for some form of repair file permission/repair account options.


Windows Server 2012 R2

Arma 2 OA Version 1.63.125548

Cheers -sc

Edited by -sc-
Additional Problems discovered.

Share this post

Link to post
Share on other sites

Your solution works great for windows, thank you sc.

But unfortunaty not work in linux at all. Problem is old Linux Dedicated Server v1.63.112555 code, we need new binary to work before we lost more players to another game. Sad but true...

Share this post

Link to post
Share on other sites

Thank you sc, your post led me to an older key that was causing my server to burn 100% CPU and not let anyone join.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this