Jump to content
Sign in to follow this  

WRP and RVMAT file menace!

Recommended Posts


so previously I've binarized all of my files and popped them into a nice snug little folder for ARMA2 to find and everything worked just fine. Super. Last night I re-binarized to update my map and then spent the following two hours quietly 'whisper shouting' diabolical threats at my computer through firmly clenched teeth (I didn't want to wake up my girlfriend, though I suspect if it had been in the middle of the day, I would have looked something like Arnie at the end of Total Recall, all eyes popping and face bulging) because it had decided that this process was no longer something it wanted to do. "could not open file "blah/blah/p_000-000_102.rvmat" " would constantly appear upon opening the editor, and then after reading that RVMATs can sometimes binarize incorrectly, I added them to the list of things not to binarize, and suddenly, without reason, ARMA2 would then not find the map at all. After a few indignantly smoked roll-ups and a sweet cup of tea I eventually had the idea to not binarize my WRP file, and it worked. Why is ARMA2 doing this to me?! I've been nothing but nice to it!

Anyway, I have gone through all of my notes and can not find a hint that this was what I had done at any point before, I am sure the WRP was binarized the first time I did it, and reading back through Bushes' guide I remembered the section about removing "*.wrp" from the list of things not to binarize, I even made a note of this in my notes (thus proving I had in fact binarized the WRP file), so I MUST have done that section, also, it was not present in the list, so I must have removed it, and it worked before! (ffffuuuuuu....)

Does anyone have any idea what could be going on, and why? It's not a show stopper, as Roy Walker would say "It's good... but it's not right." and, it's not right, the bloody WRP file should be binarized! So is therefore causing me to wake up in the middle of the night, sweaty, and grasping the sheets with insomniant (real word?) rage... well... sort of, though I did have a stress dream last night involving compiling impossible lists, with a cameo from Derren Brown (which was actually not so bad since I'm quite a fan).

Also, and lastly, would an unbinarized WRP file and RVMATs cause it to load any slower? I've noticed my map now taking a bloody long time to load up in game.


Edited by daringd

Share this post

Link to post
Share on other sites
would an unbinarized WRP file and RVMATs cause it to load any slower? I've noticed my map now taking a bloody long time to load up in game.

This is primary reason for binarizing .wrp's - though not the only one... As you discovered, an unbinarized one WILL work, but it's likely to be quite slow...

I've had this missing .rvmat thing before as well - for no apparent reason sometimes..

I've often found that rebinarizing solves the problem... other times I've reloaded buldozer, saved a fresh .wrp, cleared the temp folder and then rebinarized, and that's worked too...

In short, it's an occasional hiccup which I've experienced myself and you occasionally see other people mention too - there's another recent thread on the topic, and if you read thru the early days of Sgt Ace's tutorial thread you'll see it turn up there too...

I'd just curse a little more - go thru all the motions again, and it'll probably go away..... ;)

Not exactly a techie answer but it'll probably work....

In general, the deal with BinPbo and .rvmats is....

When you import Sat & Mask you're asked if you'd like the rvmats that are about to be created in human-readable form, or not (binary or txt)... if you're planning any jiggery-pokery with them to squeeze 6 colours per segment, or even if you're just following normal convention then at that stage you say "txt please", just in case...

Since they're in text format then sooner or later they'll need binarized, so you make sure that *.rvmat is NOT on you "list of files to copy directly" in BinPbo, so they WILL be binarized...

If, on the other hand, you chose "binary" back at the Sat & Mask stage, then the rvmats don't need binarized all over again - in fact, that might even cause errors, so you DO add *.rvmat to your BinPbo list, so they're just copied directly and AREN'T binarized...

It's that simple, a basic "now or later" situation...

.wrp's on the other hand, should always be binarized, so you should make sure it's NOT on your list of files to be copied directly... (why it's on the BinPbo "skip list" by default in the initial Tools install, I have no idea!)


Share this post

Link to post
Share on other sites


I just re read over your guide again and the point you make about binarizing the WRP file holds true, I DO want it binarized! so, I'll go back to re saving the world file in V3 and re do the whole process again, if I had been not so tired this process may have naturally occurred to me logically as the next step in ruling out an anomaly somewhere in the entire process. I'll give it a shot, and I'm almost 100% sure it will work, if it doesn't, I'm going to seriously throw my toys out of the pram, before duly trying it all a second time, of course.

The joys of map making! With an amused yet well worn smile on my face I dare but to stray into the territory of well trodden phrase usages "if it was easy to do, everybody would be doing it.".

Thanks again for your guidance, reassurance and support Mr Lurker, or as I have now begun to regard you, Obi-Wan.

My skin grows ever thicker.


Share this post

Link to post
Share on other sites


Now I'm having constant problems, it seems no matter how many times I export the world file, save and re save the PEW, then re export the WRP, re binarize, and various variations thereof, my map will not show up in game...

this is my text file created listing errors upon binarization, maybe someone can spot something...

Cannot register unknown string STR_STATE_HEALSOLDIER
Cannot register unknown string STR_STATE_FIRST_AID
Cannot register unknown string STR_UI_RADARRANGE
Cannot register unknown string STR_ACTION_LAUNCHCM
Cannot register unknown string STR_ACTION_NEXTCM
Cannot register unknown string STR_USRACT_ACTION_CONTEXT
Cannot register unknown string STR_USRACT_OPTICS_MODE
Cannot register unknown string STR_USRACT_ZEROING_UP
Cannot register unknown string STR_USRACT_ZEROING_DOWN
Cannot register unknown string STR_USRACT_NETWORK_DS_INTERFACE
Cannot register unknown string STR_USRACT_BULD_TERRAIN_RAISE_10CM
Cannot register unknown string STR_USRACT_BULD_TERRAIN_LOWER_10CM
Cannot register unknown string STR_USRACT_BULD_TERRAIN_RAISE_50CM
Cannot register unknown string STR_USRACT_BULD_TERRAIN_LOWER_50CM
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_0
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_1
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_2
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_3
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_4
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_5
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_6
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_7
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_8
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_9
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_10
Cannot register unknown string STR_INPUT_DEVICE_FREETRACK_11
Cannot register unknown string STR_DISP_LEFT
Cannot register unknown string STR_DIFF_CAMERA_SHAKE
Cannot register unknown string STR_FREETRACK
Cannot register unknown string STR_ADDON_ACTIONS_INSTALL_CORE
Cannot register unknown string STR_ADDON_ACTIONS_INSTALL_MOD
Cannot register unknown string STR_ADDON_ACTIONS_PLAY_MISSION
Cannot register unknown string STR_ADDON_ACTIONS_TRY_ENTITY
Cannot register unknown string STR_ADDON_ACTIONS_TRY_WEAPON
Cannot register unknown string STR_MSG_ADDON_NOT_FOUND
Cannot register unknown string STR_MSG_ADDON_CANNOT_OPEN
Cannot register unknown string STR_MSG_ADDON_UNKNOWN_PRODUCT
Cannot register unknown string STR_INCOMPATIBLE_LOAD_GAME_ATTEMPT
Warning: CfgVehicles missing in PreloadConfig - may slow down vehicle creation
Warning: CfgAmmo missing in PreloadConfig - may slow down vehicle creation
Warning: CfgNonAIVehicles missing in PreloadConfig - may slow down vehicle creation
<model = "p:\daringd\bg\bg_items\bg_deadbodies\hanged.p3d">
Creating texture headers file...
1010 texture headers saved to file "P:\bin_temp\daringd\bg\texHeaders.bin"
w:\C_branch\Poseidon\Arrowhead\El\FileServer\fileServer.cpp(2513) : Assertion failed 'req->RefCounter()==1'

any help would be appreciated!


Share this post

Link to post
Share on other sites

Hi daringd!


there's very little in that .rpt... less than I'd expect even...

All the "Cannot registers" are irrelevant - ignore them

Same with the "PreLoad Config" stuff - just the tools griping about irrelevant stuff

Then you have?? - a custom dead body?

Then the texture header creation

And finally an "assertion failed" - a slightly different one from the norm, but - usually - you can ignore this error too... I'm not absolutely sure what that one's about, but it occurs quite frequently and doesn't usually affect the final outcome...

In short - no clues here! :(

In the absence of further info, the first thing I'd do is run the basic sequence from the start - carefully...

During the course of making a terrain you do these things so many times it's easy to switch to autopilot - little mistakes can occasionally creep in...


Go to your project\data folder - delete the "Layers" folder

Check layers.cfg - just to be sure everything is correct...

Reimport Sat & mask - choose .txt .rvmats...

Run Buldozer - make sure everything is ok

Export .wrp - save .pew and head to BinPbo

Run BinPbo - check ALL paths - check the "list of files to copy directly" - make sure everything's correct - tick the "clear temp folder" box & binarize the bugger...

As a secondary measure - quickly hop to your "users\yourname\AppData\Arma2OA\" folder (or wherever) and delete the .rpt file

Now try your binarized result in-game...

If you still have problems - check both the binpbo log, and the main game report - post anything from either that seems relevant here, and we'll try to puzzle it out...


Edited by Bushlurker

Share this post

Link to post
Share on other sites


Check it out, I did everything you said here, re checked EVERYTHING I have done, looked through all of the deleted older versions (I don't delete I move them to dated folders called so I can 'roll back', incidently, previous versions that did work won't work either) and checked out the unPBOed contents, confige files and what not, and I could find nothing out of place, everything works in buldozer, all my layers work fine, no problems.

1. I re imported sat map and mask, re saved, re exported the WRP, double checked (and got my girlfriend to check along side me from your tutorial). - Everything binarized, and still would not show up in game (no surprise).

2. Next I added wrp to the 'do not binarize' list, and it shows up as an option in game but once again I get this problem with one of the RVMAT files.

3. I added RVMAT to the list again (keep in mind this is just so I can get the map in-game and see that everything works and there are no errors with the map it's self, and to prove to myself this is a problem occuring somewhere else) packed it all, and everything worked, map shows up in game, and all is well.

4. The next step was (and we will see if it fits the pattern that occured last time) to now go re export the WRP, remove RVMAT and WRP from the list, and re pack. - Everything worked in game, no problems, PBO binarized, RVMATs binarized...

So it seems to me that there is something strange at work here, I doubt it is the binarisation process though.

I checked out the RPT file and it listed nothing as errors after the first time it failed to load, when I got it to show up in game but got the RVMAT errors it listed a shed load of RVMAT errors, but nothing else, and the last two times it listed a few problems with a missing file that I know about, nothing mysterious.

I'm all about narrowing this down, so I've tried to take a systematic approach, to rule out one thing at a time.

So the long and short of it is, that I have it working now, but it seems I have to go through this process to get it working... as though I need to 'encourage' ARMA with an unbinarized WRP and RVMATs, before pulling the rug from under it and sneaking in the binarized versions... what thinks ye?


Share this post

Link to post
Share on other sites

@daringd I've tried your way and guess what - when I click "Pack" two error messages pops out: Error in config p:\tut\tut_samplemap\config.cpp

I am unable to see map itself now even in the main menu, after get rid of *.wrp;*.rvmat; - still the same errors - and the same result.


I did it your way and it is working great! Bless you :)

Edited by fragmachine

Share this post

Link to post
Share on other sites

Sorry I haven't been checking up on the biards for a while, I've had some rather hefty 'first life' commitments to honour, that have taken me completely out of map making for a bit, the cool thing is, I'm coming back within a few weeks to thrash the shit out of it again, I'm glad this worked for you, I don't know what the error was that you were getting but I guess it was some syntax problem in the config.cpp? glad it's working now though... I simply can not wait to get my head back into this malarkey.


Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this