Jump to content

Search the Community

Showing results for tags 'waypoint'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • BOHEMIA INTERACTIVE
    • BOHEMIA INTERACTIVE - NEWS
    • BOHEMIA INTERACTIVE - JOBS
    • BOHEMIA INTERACTIVE - GENERAL
  • FEATURED GAMES
    • Vigor
    • DAYZ
    • ARMA 3
    • ARMA 2
    • YLANDS
  • MOBILE GAMES
    • ARMA MOBILE OPS
    • MINIDAYZ
    • ARMA TACTICS
    • ARMA 2 FIRING RANGE
  • BI MILITARY GAMES FORUMS
  • BOHEMIA INCUBATOR
    • PROJECT LUCIE
  • OTHER BOHEMIA GAMES
    • ARGO
    • TAKE ON MARS
    • TAKE ON HELICOPTERS
    • CARRIER COMMAND: GAEA MISSION
    • ARMA: ARMED ASSAULT / COMBAT OPERATIONS
    • ARMA: COLD WAR ASSAULT / OPERATION FLASHPOINT
    • IRON FRONT: LIBERATION 1944
    • BACK CATALOGUE
  • OFFTOPIC
    • OFFTOPIC
  • Die Hard OFP Lovers' Club's Topics
  • ArmA Toolmakers's Releases
  • ArmA Toolmakers's General
  • Japan in Arma's Topics
  • Arma 3 Photography Club's Discussions
  • The Order Of the Wolfs- Unit's Topics
  • 4th Infantry Brigade's Recruitment
  • 11th Marine Expeditionary Unit OFFICIAL | 11th MEU(SOC)'s 11th MEU(SOC) Recruitment Status - OPEN
  • Legion latina semper fi's New Server Legion latina next wick
  • Legion latina semper fi's https://www.facebook.com/groups/legionlatinasemperfidelis/
  • Legion latina semper fi's Server VPN LEGION LATINA SEMPER FI
  • Team Nederland's Welkom bij ons club
  • Team Nederland's Facebook
  • [H.S.O.] Hellenic Special Operations's Infos
  • BI Forum Ravage Club's Forum Topics
  • Exilemod (Unofficial)'s General Discussion
  • Exilemod (Unofficial)'s Scripts
  • Exilemod (Unofficial)'s Addons
  • Exilemod (Unofficial)'s Problems & Bugs
  • Exilemod (Unofficial)'s Exilemod Tweaks
  • Exilemod (Unofficial)'s Promotion
  • Exilemod (Unofficial)'s Maps - Mission Files
  • TKO's Weferlingen
  • TKO's Virolahti
  • TKO's Rules
  • TKO's Changelog
  • TKO's Help
  • TKO's What we Need
  • TKO's Saint Kapaulio
  • TKO's Cam Lao Nam
  • MSOF A3 Wasteland's Server Game Play Features
  • MSOF A3 Wasteland's Problems & Bugs
  • MSOF A3 Wasteland's Maps in Rotation
  • SOS GAMING's Server
  • SOS GAMING's News on Server
  • SOS GAMING's Regeln / Rules
  • SOS GAMING's Ghost-Town-Team
  • SOS GAMING's Steuerung / Keys
  • SOS GAMING's Div. Infos
  • SOS GAMING's Small Talk
  • SOS GAMING's TS³ Viewer
  • NAMC's Topics
  • NTC's New Members
  • NTC's Enlisted Members
  • The STATE's Topics
  • CREATEANDGENERATION's Intoduction
  • CREATEANDGENERATION's HAVEN EMPIRE (NEW CREATORS COMMUNITY)
  • HavenEmpire Gaming community's HavenEmpire Gaming community
  • Polska_Rodzina's Polska_Rodzina-ARGO
  • Carrier command tips and tricks's Tips and tricks
  • Carrier command tips and tricks's Talk about carrier command
  • ItzChaos's Community's Socials
  • Photography club of Arma 3's Epic photos
  • Photography club of Arma 3's Team pics
  • Photography club of Arma 3's Vehicle pics
  • Photography club of Arma 3's Other
  • Spartan Gamers DayZ's Baneados del Servidor

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Yahoo


Jabber (xmpp)


Skype


Biography


Twitter


Google+


Youtube


Vimeo


Xfire


Steam url id


Raptr


MySpace


Linkedin


Tumblr


Flickr


XBOX Live


PlayStation PSN


Origin


PlayFire


SoundCloud


Pinterest


Reddit


Twitch.Tv


Ustream.Tv


Duxter


Instagram


Location


Interests


Interests


Occupation

Found 38 results

  1. I am going to start off and say I've been trying to troubleshoot this code for several hours. Basically I have a market set up and I want a lot of AI to walk to different points of interest. Right now I have several flagpoles set up with variable names set as "POI_1" to "POI_15". The Code: _pois = [POI_1,POI_2,POI_3,POI_4,POI_5,POI_6,POI_7,POI_8,POI_9,POI_10,POI_11,POI_12,POI_13,POI_14,POI_15]; _rtime = 5; // random time for completion of waypoint _spd = (random (2))+1; // decude whether to walk to sprint _wpradius = 0; // waypoint radius _wp = (group (_this select 0)) addWaypoint [getPos (_pois select (random (count _pois))), _wpradius]; // create waypoint _wp setWaypointBehaviour "CARELESS"; _wp setWaypointCombatMode "BLUE"; _wp setWaypointCompletionRadius 3; _wp setWaypointForceBehaviour true; // _wp setWaypointPosition // _wp setWaypointScript if (_spd==1) then { _wp setWaypointSpeed "NORMAL"} else { _wp setWaypointSpeed "LIMITED"}; _wp setWaypointStatements ["true","_null = [this]execVM('ai_behavior.sqf');"]; _wp setWaypointTimeout [1, _rtime/2, _rtime]; _wp setWaypointType "MOVE"; Additionally, this is set up in the init box of the AI: _null = [this]execVM('ai_behavior.sqf'); And the problem is that this script works absolutely perfectly when there is one AI. I can set it to fast-forward and let it run for a very long time and the AI will walk to different flagpoles either walking or jogging to each, and the script will never hang up. The problem stems from having multiple AI. Then I get errors saying the following: '...ius = 0; _wp = (group (_this select 0)) |#|addWaypoint [getPos (_pois select (random (count _pois))), _wpradius]; Error 0 elements provided, 3 expected File C:\Users\****\Documents\Arma 3 - Other Profiles\Giraffe%20PVT%2e\missions\black_market.pja305\ai_behavior.sqf, line 38 Ignore the fact that is says line 38 - I have a lot of comments at the top of the script. This is for a multiplayer mission. Thanks for reading. EDIT: Oh yeah, and this isn't for a "life" server. (I know that carries a negative stigma for many people.) It's for a new PvP gamemode I am working on. EDIT2: CORRECTED CODE
  2. Hello, I have a problem with the AI helicopter after paradrop. The helicopter stop following his waypoints after the paradrop. It just stay in hovering flight. I would like to make the helicopter follow his waypoints again after paradroping.... Here is the command that I've put in the "On Activation" field of the helicopter drop waypoint: paratroopers leaveVehicle heli; {_x action ["Eject", vehicle _x];} forEach units paratroopers; I d'ont see what other command line(s) I should use. I defeinitely need an expert. ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- Here is my test senario (3D editor): https://mega.nz/#!FgAn3Rqa!2MR4nIZOQGo2l92l2l0nbHKg8Ar20hm6_r1uW06v1UI GOAL: the helicopter must land at Camp Rogain after paradrop. Thanks and regards. PS: the problem does not happen when the player is the paratroop team leader.
  3. Hi. In my mission my AI has to move and invade an airfield. But it just sits somewhere 500m away from it sniping and generally moves really careful, our LAV does not move in but rather stay out and snipe enemies from there which i do not want. Anything i can do?
  4. How to create trough scripting each of the | (marked) waypoints ? _________________________| \|/
  5. i ve 2 groups with 3 waypoints for each of them placed at 2D editor. there r 2 move waypoints and the last is a cycle waypoint to let em walk along the waypoints continuously. I ve synced every pair of waypoints each other. wp 1 of group 1 is synced with wp 1 of group 2 wp 2 of group 1 is synced with wp 2 of group 2 wp 3 of group 1 is synced with wp 3 of group 2 my thougts were that the group which is faster waits for the slower group on each waypoint. that works for the first and second waypoint but at the third (cycle) waypoint the faster group isnt waiting but running to wp 1 and waiting there until the slower group is at wp 1. I just need a confirmation for that behaviour to know if thats normal that syncing of cycle waypoints seems to be senseless... thx alot. EDIT after some more testing I noticed that cycle waypoints dont execute the "On Activation" field. I entered a systemChat in it which works if its a move waypoint but not if its a cycle waypoint. Is that intended or a bug?
  6. Edit: I've did some editing to the mission and it seems like the issue does not happen as much as it did before, or at least it occurs much less frequently. There is still a problem with helicopters not working at all, but that is being handled by a different script, so I am probably gonna open another thread with focus just on that. Hello! I am having a problem with AI in Arma 3. It's simple, I want to spawn an enemy vehicle with AI in it and then send it on a death mission where it gets almost surely destroyed by players' heavy fire. However, oftentimes (at ~25% chance) the unit just sits still after its spawn and does nothing at all. So, this is my (almost) whole code. The important part is marked between ↓↓↓↓↓ and ↑↑↑↑↑: _group = createGroup east; _type = _usableUnits select floor random count _usableUnits; if (_type isKindOf "Car") then { _unit = objNull; if (_type == "B_G_Offroad_01_armed_F") then{ _unit = [_spawnLocation, random 360, _type, resistance] call bis_fnc_spawnvehicle; }else{ _unit = [_spawnLocation, random 360, _type, EAST] call bis_fnc_spawnvehicle; }; (_unit select 0) setdamage enemySpawnDamage; driver (_unit select 0) spawn scr_killWhenOnFoot; gunner (_unit select 0) spawn scr_killWhenOnFoot; _unit join _group; (_unit select 0) spawn scr_noFuelWhenCarIsStatis; AIunits = AIunits + (_unit select 1); // ↓↓↓↓↓ _wp = _group addWaypoint [posTarget, 0]; [_group, 1] setWaypointType "HOLD"; _group setCombatMode "YELLOW"; _group setBehaviour "CARELESS"; _group allowFleeing 0; driver (_unit select 0) spawn { while {alive _this} do { _startPos = Position _this; sleep 10; _currentPos = Position _this; if ( (_startPos distance _currentPos) < 1 ) then { _this DoMove posTarget; }; }; }; // ↑↑↑↑↑ }; This code is a part of a larger script which spawns a vehicle, fills it with AI units and then sends it to position posTarget through a waypoint. The last part is the problem. The unit sometimes refuses to move, even if its path is not obstructed at all. I've tried to fix this by telling the unit to DoMove every 10 seconds if its detected to be still, but it still doesn't fix the problem. Does anyone else have similar problem? Do you know how to fix this, or work around this issue?
  7. I have a helicopter with three waypoints; a MOVE waypoint, which is connected to a trigger, a LAND waypoint attached to an invisible helipad and with the condition that all units are inside it, and a third MOVE waypoint. I expected the helicopter to move in and land on the helipad once the first MOVE waypoint is skipped, but instead it simply flies over and stays hovering in midair over the trigger attached to it's MOVE waypoint. Why is this happening, and how can I get it to land on the helipad? Edit: Here's an example mission that demonstrates my problem; https://mega.nz/#!sMUByIQb!2snm5wTgDpMsCGJYxSXzoMZjqMKxWOa__TaDh0_AORE The helicopter should move past the first waypoint once the trigger is activated, but it simply stays in midair and doesn't move at all. There are no enemies on the map, or any other characters besides me and the pilot. As an extra note, I'm playing this mission in multiplayer. Edit: I was able to solve my problem by using multiple waypoints; I first used a Move waypoint right next to the helicopter that's connected to a trigger, and is skipped when the trigger activates. Then a Move waypoint attached to the helipad with a condition of true and an Actrivation with 'heli land "land";' in it. Then a Scripted waypoint also connected to the helipad, with a condition of "me in heli", then, a final Move waypoint out in the distance with a condition of true. Here is a more complicated mission I created using this information; it features a helicopter that ferries the player between sides of the lake whenever they get inside, and waits for them to reenter; https://mega.nz/#!FUkiFIYI!jm-56z1QLBkh9lEIPdt8iPOyHZKEWdnGU3dTsa2TD3Q
  8. I have a series of move waypoints assigned to my unit's squad, and the first one of them attached to a trigger. I expected that when the trigger is activated, the waypoint would complete and the next one would become available, but instead the waypoint stays uncompleted and its name changes from its default description to "WAIT". After that nothing seems able to complete the waypoint. Is this a bug?
  9. I'm trying to sling-load a Slammer with a Huron, using the 'lift cargo' waypoint (so that the AI will pick it up). I've lowered the Slammer's weight, but all the Huron does is descend over it, then fly away again, unattached. I've looked for scripts, but they all seem to just allow the player to airlift heavy objects, not the AI. Can anybody help, or recommend a simple method I can use? (I'm not very good at scripting, so may need a pretty clear explanation!) Thanks!
  10. Using the 'drop cargo' waypoint, an AI helicopter carrying a vehicle takes a very long time to descend and release its cargo, even in very open fields. It will slow down, approach the landing site, then suddenly veer off at speed, circle the area a few times, and try again. This can repeat for many times before the cargo is finally dropped. I'm using version: 1.56.134627, on the main branch, Windows 10. Here is a link to an example mission: https://drive.google.com/file/d/0ByElbgVZoI3SYVJmWEF2RnpqNlU/view?usp=sharing (The Hurons carrying the Hunters demonstrate this behaviour. The Slammer is being dropped using some code.)
  11. Hello, I've been working on a mission, and I had no errors for now, but now I have an issue with the Unload transport waypoint. Well I have a scripted helicopter route that: Takes off and land, drop off a squad, then go to another LZ, picks up another squad and flies away. Well, everything worked fine until I got to picking up another squad... I've linked the GET IN waypoint with the LOAD waypoint of the Helo and all this, but not working... so I jumped in the pilot's view and then I saw the issue. When dropping off the first squad, (all the squad was out the Helo) the waypoint stays at "HOLD", and it doesn't moves to the next waypoint. Can anybody help me to find the mistake here? I thought that maybe I have to assign the pilot and copilot as driver and commander, or the squad as cargo maybe? EDIT: the problem here, was that I had to assignAsCargo the squads you need to drop. so the code would be:
  12. Haveing difficulty with this one. Basically what's in the title. Set a waypoint where there's a marker, set the type, in my case it's loiter with range of 500m, behavoir is never fire and altitude 'High Altitude 500m'. Thanks in advance
  13. narcisissma

    Waypoint Marker

    The waypoint marker keeps blending into the terrain. Is there some way to make it another color than the grass ?
×