Jump to content

Search the Community

Showing results for tags 'leak'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • BOHEMIA INTERACTIVE
    • BOHEMIA INTERACTIVE - NEWS
    • BOHEMIA INTERACTIVE - JOBS
    • BOHEMIA INTERACTIVE - GENERAL
  • FEATURED GAMES
    • Arma Reforger
    • Vigor
    • DAYZ
    • ARMA 3
    • ARMA 2
    • YLANDS
  • MOBILE GAMES
    • ARMA MOBILE OPS
    • MINIDAYZ
    • ARMA TACTICS
    • ARMA 2 FIRING RANGE
  • BI MILITARY GAMES FORUMS
  • BOHEMIA INCUBATOR
    • PROJECT LUCIE
  • OTHER BOHEMIA GAMES
    • ARGO
    • TAKE ON MARS
    • TAKE ON HELICOPTERS
    • CARRIER COMMAND: GAEA MISSION
    • ARMA: ARMED ASSAULT / COMBAT OPERATIONS
    • ARMA: COLD WAR ASSAULT / OPERATION FLASHPOINT
    • IRON FRONT: LIBERATION 1944
    • BACK CATALOGUE
  • OFFTOPIC
    • OFFTOPIC
  • Die Hard OFP Lovers' Club's Topics
  • ArmA Toolmakers's Releases
  • ArmA Toolmakers's General
  • Japan in Arma's Topics
  • Arma 3 Photography Club's Discussions
  • The Order Of the Wolfs- Unit's Topics
  • 4th Infantry Brigade's Recruitment
  • 11th Marine Expeditionary Unit OFFICIAL | 11th MEU(SOC)'s 11th MEU(SOC) Recruitment Status - OPEN
  • Legion latina semper fi's New Server Legion latina next wick
  • Legion latina semper fi's https://www.facebook.com/groups/legionlatinasemperfidelis/
  • Legion latina semper fi's Server VPN LEGION LATINA SEMPER FI
  • Team Nederland's Welkom bij ons club
  • Team Nederland's Facebook
  • [H.S.O.] Hellenic Special Operations's Infos
  • BI Forum Ravage Club's Forum Topics
  • Exilemod (Unofficial)'s General Discussion
  • Exilemod (Unofficial)'s Scripts
  • Exilemod (Unofficial)'s Addons
  • Exilemod (Unofficial)'s Problems & Bugs
  • Exilemod (Unofficial)'s Exilemod Tweaks
  • Exilemod (Unofficial)'s Promotion
  • Exilemod (Unofficial)'s Maps - Mission Files
  • TKO's Weferlingen
  • TKO's Green Sea
  • TKO's Rules
  • TKO's Changelog
  • TKO's Help
  • TKO's What we Need
  • TKO's Cam Lao Nam
  • MSOF A3 Wasteland's Server Game Play Features
  • MSOF A3 Wasteland's Problems & Bugs
  • MSOF A3 Wasteland's Maps in Rotation
  • SOS GAMING's Server
  • SOS GAMING's News on Server
  • SOS GAMING's Regeln / Rules
  • SOS GAMING's Ghost-Town-Team
  • SOS GAMING's Steuerung / Keys
  • SOS GAMING's Div. Infos
  • SOS GAMING's Small Talk
  • NAMC's Topics
  • NTC's New Members
  • NTC's Enlisted Members
  • The STATE's Topics
  • CREATEANDGENERATION's Intoduction
  • CREATEANDGENERATION's HAVEN EMPIRE (NEW CREATORS COMMUNITY)
  • HavenEmpire Gaming community's HavenEmpire Gaming community
  • Polska_Rodzina's Polska_Rodzina-ARGO
  • Carrier command tips and tricks's Tips and tricks
  • Carrier command tips and tricks's Talk about carrier command
  • ItzChaos's Community's Socials
  • Photography club of Arma 3's Epic photos
  • Photography club of Arma 3's Team pics
  • Photography club of Arma 3's Vehicle pics
  • Photography club of Arma 3's Other
  • Spartan Gamers DayZ's Baneados del Servidor
  • Warriors Waging War's Vigor
  • Tales of the Republic's Republic News
  • Operazioni Arma Italia's CHI SIAMO
  • [GER] HUSKY-GAMING.CC / Roleplay at its best!'s Starte deine Reise noch heute!
  • empire brotherhood occult +2349082603448's empire money +2349082603448
  • NET88's Twitter

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Yahoo


Jabber (xmpp)


Skype


Biography


Twitter


Google+


Youtube


Vimeo


Xfire


Steam url id


Raptr


MySpace


Linkedin


Tumblr


Flickr


XBOX Live


PlayStation PSN


Origin


PlayFire


SoundCloud


Pinterest


Reddit


Twitch.Tv


Ustream.Tv


Duxter


Instagram


Location


Interests


Interests


Occupation

Found 3 results

  1. hello guys, i made a script to spawn/de-spawn AI in a bubble around players, but on long run times (my aim is to make it run at least 24h) server crash with this error : 0xC0000005 - STATUS_ACCESS_VIOLATION after investigating, appears that is a generic error, there is no solution, and probably linked to memory leaks. i tried 100% vanilla server and 100% vanilla client, and server crash in few hours. considering that the server does not crash (24h+) if noone enters....and that the only script difference is that "AI bubble" around players does not spawn any units if there are no players, i take a wild guess and suppose its the "AI bubble" script causing this. here is the script: in init.sqf: call compile preprocessFileLineNumbers "DDscripts\Dbubble.sqf"; null = [] execVM "DDscripts\DambientSPAWN.sqf"; and here is the DambientSPAWN.sqf: this actually works perfectly for few hours (from 1h to 4h usually), then the crash... So i'm doing something "wrong"...and i mean unefficient or causing leaks ? the goal (if possible) it to leave no trace in the memory or in the game itself of the units created and then deleted, or at least minimize the impact on the system to make it run as long as possible. really thansk for any help!
  2. hello, after 2 days of tests, i sadly found a lethal problem for dedicated server: memory usage is constantly increasing in presence of AI....when it goes over 2000mb server crash with "out of memory" error. at first i thinked it was my mission, and to exclude that i made a fresh new mission, just placed 3 playable units, and 6 rifle squads (8 men each) and 4 tank platoons (4 tanks each), all with a "move" waypoint and a "cycle" waypoint. sadly....even there, the memory usage slowly increase. seems to be directly related to how many AI is there, for example, here are the results of test of different missions: in an empty map with just that AI placed by editor...there should be no possibility of "external problems" (i use no mods, just pure vanilla for tests). to see the memory increasing i used " #monitor 1 " at start,, but noticed that windows task manager is even better to monitor it! hope that gets fixed soon, as it is game-breaking! image of error found in the morning after leaving server running in the night: https://ibb.co/k30HBa
  3. EDIT AS SUGGESTED: ----------------------------------------------original message------------------------------- hi guys! i've noticed that in my MP dedicated mission, the initial RAM usage is about 1100Mb. but checking it with " #monitor 1 " command....but its slowly and constantly increasing!! it goes up about 1 Mb every 2-3 seconds, but keeps increasing until reach 2000Mb...and at that point server choke to death!! any idea what can be or how i can track the trouble ? thanks! ----------------------------------------------original message------------------------------- PROBLEM DESCRIPTION: dedicated server memory usage keeps increasing at a variable rate apparently influenced by number of AI in mission. it keeps increasing more or less constantly and endlessly. on 32bit "arma3server.exe" when over 2000MB it start to choke, decreasing down to 2 FPS, and ultimately crashing with htis error: https://ibb.co/k30HBa 3D EDEN CREATED TEST MISSION from NEW (empty): (lets ignore my mission for now, and focus on standard test): Altis, 6 WEST rifle quads (8 men each) 4 WEST combined tank platoon (4 tanks each), 3 playable units, all with a move waypoint and a cycle waypoint. (can double the numbers to accelerate the process). WHAT I DID EXACTLY STEP BY STEP TO REPRODUCE THE PROBLEM: launch TADST v3.0.0, leave default settings (for testing purposes) checked box "persistent battlefield" and "auto-init", selected "arma3server.exe" and tried also with "arma3server_x64.exe". (different starting memory usage, but both were increasing). selected previously created TEST mission. Launched the server. Opened the windows task manager. keeps monitoring the "arma3server.exe" process memory usage. Notice slow, but pretty constant increase in memory usage. WHAT OTHER TEST I DID: i tested my mission with all my scripts (and they are many) except the ones spawning AI. in my mission all AI is spawned by script, so there were 0 AI. server did not had increasing memory usage. i tested an old mission version (more than 6 months ago), that i'm sure it was running fine for at least 24 hours (i remember playing on it with friends one night, then forgetting server up, then the following evening playing again on it with friends). the test now showed a memory usage increasing. i tested other missions made in the past, i dont have any documented previous check on them about memory usage, but now its increasing at various rate, apparently related to numbers of AI. MY HARDWARE / SOFTWARE / CONFIG ecc... i5 4440 3.10ghz, 12Gb ram, 64bit, NO-SSD, connection: ADSL 7Mb upload 0.4Mb download. (its the same configuration i had at the time of the 24 hours server running with no problem) i always used 32bit "arma3server.exe" except for the very latest test. LINK to latest version of my mission (here problem is accentuated due to spawn-despawn units based on player distance): https://mega.nz/#!KtZ2GLiQ!-PxDcaPxXqjeuAaSeUEk2YT1e-UDZf22TXr0dhrVS5E thanks for any help!
×