Jump to content

Search the Community

Showing results for tags 'dynamic simulation'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • BOHEMIA INTERACTIVE
    • BOHEMIA INTERACTIVE - NEWS
    • BOHEMIA INTERACTIVE - JOBS
    • BOHEMIA INTERACTIVE - GENERAL
  • FEATURED GAMES
    • Vigor
    • DAYZ
    • ARMA 3
    • ARMA 2
    • YLANDS
  • MOBILE GAMES
    • ARMA MOBILE OPS
    • MINIDAYZ
    • ARMA TACTICS
    • ARMA 2 FIRING RANGE
  • BI MILITARY GAMES FORUMS
  • BOHEMIA INCUBATOR
    • PROJECT LUCIE
  • OTHER BOHEMIA GAMES
    • ARGO
    • TAKE ON MARS
    • TAKE ON HELICOPTERS
    • CARRIER COMMAND: GAEA MISSION
    • ARMA: ARMED ASSAULT / COMBAT OPERATIONS
    • ARMA: COLD WAR ASSAULT / OPERATION FLASHPOINT
    • IRON FRONT: LIBERATION 1944
    • BACK CATALOGUE
  • OFFTOPIC
    • OFFTOPIC
  • Die Hard OFP Lovers' Club's Topics
  • ArmA Toolmakers's Releases
  • ArmA Toolmakers's General
  • Japan in Arma's Topics
  • Arma 3 Photography Club's Discussions
  • The Order Of the Wolfs- Unit's Topics
  • 4th Infantry Brigade's Recruitment
  • 11th Marine Expeditionary Unit OFFICIAL | 11th MEU(SOC)'s 11th MEU(SOC) Recruitment Status - OPEN
  • Legion latina semper fi's New Server Legion latina next wick
  • Legion latina semper fi's https://www.facebook.com/groups/legionlatinasemperfidelis/
  • Legion latina semper fi's Server VPN LEGION LATINA SEMPER FI
  • Team Nederland's Welkom bij ons club
  • Team Nederland's Facebook
  • [H.S.O.] Hellenic Special Operations's Infos
  • BI Forum Ravage Club's Forum Topics
  • Exilemod (Unofficial)'s General Discussion
  • Exilemod (Unofficial)'s Scripts
  • Exilemod (Unofficial)'s Addons
  • Exilemod (Unofficial)'s Problems & Bugs
  • Exilemod (Unofficial)'s Exilemod Tweaks
  • Exilemod (Unofficial)'s Promotion
  • Exilemod (Unofficial)'s Maps - Mission Files
  • TKO's Weferlingen
  • TKO's Virolahti
  • TKO's Rules
  • TKO's Changelog
  • TKO's Help
  • TKO's What we Need
  • TKO's Saint Kapaulio
  • MSOF A3 Wasteland's Server Game Play Features
  • MSOF A3 Wasteland's Problems & Bugs
  • MSOF A3 Wasteland's Maps in Rotation
  • SOS GAMING's Server
  • SOS GAMING's News on Server
  • SOS GAMING's Regeln / Rules
  • SOS GAMING's Ghost-Town-Team
  • SOS GAMING's Steuerung / Keys
  • SOS GAMING's Div. Infos
  • SOS GAMING's Small Talk
  • SOS GAMING's TS³ Viewer
  • NAMC's Topics
  • NTC's New Members
  • NTC's Enlisted Members
  • The STATE's Topics
  • CREATEANDGENERATION's Intoduction
  • CREATEANDGENERATION's HAVEN EMPIRE (NEW CREATORS COMMUNITY)
  • HavenEmpire Gaming community's HavenEmpire Gaming community
  • Polska_Rodzina's Polska_Rodzina-ARGO
  • Carrier command tips and tricks's Tips and tricks
  • Carrier command tips and tricks's Talk about carrier command
  • ItzChaos's Community's Socials

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Yahoo


Jabber (xmpp)


Skype


Biography


Twitter


Google+


Youtube


Vimeo


Xfire


Steam url id


Raptr


MySpace


Linkedin


Tumblr


Flickr


XBOX Live


PlayStation PSN


Origin


PlayFire


SoundCloud


Pinterest


Reddit


Twitch.Tv


Ustream.Tv


Duxter


Instagram


Location


Interests


Interests


Occupation

Found 5 results

  1. I need expert help from the Arma dev experts here to understand a fundamental behavior difference between hosted/editor and dedi-MP. * Nutshell: ObjectX (not a vehicle, has no brain) was placed in the editor at Position 1. The sole player in the mission starts near Position 1 but is teleported *very far* away (>10km) to Position 999. The player takes action that tells the server to perform a REMOTEEXEC target=0 SETPOSASL command on ObjectX to move it 100m to Position 2. * Expectation: ObjectX should be at Position 2 on both the server and the client. * Actuality: In hosted/editor runs ObjectX is at Position 2 on both the server and the client even when the player is at Position 999, but on dedi-MP ObjectX is at Position 2 only on the server but remains at Position 1 on the client, regardless of what the mission scripting does with information age commands ON THE CLIENT (setTargetAge, Reveal, disabling dynamicsimulation). I've confirmed in dedi-MP that ObjectX on the server has moved to Position 2 by executing a 'localize' command to dump a getpos ObjectX to the server .rpt file. I've confirmed using Debug Console on the client that ObjectX on the client remains at Position 1. * Confusion: Even with the dynamic simulation system disabled entirely this still happens. Since the player is at Position 999 very far away, information age issues are expected, but they should be controlled by setTargetAge and Reveal commands. * My guess: Maybe dedicated servers are by default configured to override a mission's control over information age? I don't see a setting in dedi server .cfg that could change that. What the frakkin frak is going on??? <<edited 5/31: ObjectX has dynamic simulation DISabled, by the way. But I suspect the game is applying dynamic simulation anyway at long distances>> <<edited 5/31, pt2: To be clear, when the player is near ObjectX, sending the command to the server to have the server move ObjectX via that remoteexec call works just fine. But when the player is very far from ObjectX that's when that same process simply does not move ObjectX on the client. (even with dynamic simulation disabled for that object and disabled via enableDynamicSimulationSystem false, even after setting "prop" setDynamicSimulationDistance 60000;. (Also, as an aside, the reason this is an issue is because I'm trying to attach a camera object to ObjectX to use from afar, sort of like a UAV but not a UAV.)>> <<edited 6/2, pt3: Is it possible that static objects are *always* treated on dedicated server similarly to dynamically simulated objects, but separately from the dynamicSimulation system? (I could see it being like that, since normally static objects are always just that, static.) If that's true, it could explain everything I'm seeing. If so, any idea if there's a workaround aside from making a descendant class as a mod and altering whatever property(ies) cause this? <<edited 6/2, pt 4: I'm going to have to conclude that on dedicated server, dynamic simulation is always enabled beyond a certain distance, regardless of mission settings. Dealing with that will require some radical re-thinking of my approach, but I do have some ideas. Admins, you can retire/delete this post if you like.>>
  2. Hello there to Everyone , i'm trying to create a dynamic Simulation scrpt , but to be honest , i don't know really if the current is working or not ! I 'm not also sure about dynamicSimulationSystem generally , because i haven't seen this working on another script either ! My try below for everyone : - deleted any help will be much appreciated ! Thank you very much !!! _______________________________________________________________________________________________________________ the solution :
  3. As from topic, I was thinking that they are almost the same but, after a little bit of testing, it seems they work in pretty different ways: - Dynamic simulation stops the simulation of units at a given distance from the player without despawning them, leaving them "freezed" until the distance with the player doesn't fall under the give threshold; - The Simulation management module doesn't only stops simulation, but it seems to despawn units until the player reduces the distance to the given threshold; when this happens units respawn exactly where they was, in the same position, and the simulation restarts normally. I'm not sure but it seems that, to enable this behaviour, you don't need to flag the same voice in the unit attributes that enables the dynamic simulation. Am I correct? I've also noticed peculiar interaction between those two features: if Dynamic simulation threshold is smaller than the Simulation manager module, it seems that - since units should spawn when simulation is stopped, they cannot spawn anymore; in the opposite situation, simulation starts even if they are not spawned and, when this happens, they have already moved (similarly to ALive VI system) but (although I'm not sure) without interacting with other units, spawned or not. Any suggestions or corrections? Thanks!
  4. Is some ways ,better then checking all objects with loop, to execute somethng when dynamic simulation waking up unit ?
  5. Hi! I tried using Dynamic Simulation to increase framerate in my mission, but surprisingly it doesn't work. The units which have DS enabled don't "wake up" at all. The simulation does not start, therefore I have quite a big problem. If I disable DS for a unit, the simulation goes normally, same for global disabling of DS - all units behave as they should. I'm using 3den Enhanced, but don't think that's what's causing this situation, since I've read that it works normally with 3E. Any ideas where the issue lies?
×