Jump to content

Search the Community

Showing results for tags 'Linux'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • BOHEMIA INTERACTIVE
    • BOHEMIA INTERACTIVE - NEWS
    • BOHEMIA INTERACTIVE - JOBS
    • BOHEMIA INTERACTIVE - GENERAL
  • FEATURED GAMES
    • Vigor
    • DAYZ
    • ARMA 3
    • ARMA 2
    • YLANDS
  • MOBILE GAMES
    • ARMA MOBILE OPS
    • MINIDAYZ
    • ARMA TACTICS
    • ARMA 2 FIRING RANGE
  • BI MILITARY GAMES FORUMS
  • BOHEMIA INCUBATOR
    • PROJECT LUCIE
  • OTHER BOHEMIA GAMES
    • ARGO
    • TAKE ON MARS
    • TAKE ON HELICOPTERS
    • CARRIER COMMAND: GAEA MISSION
    • ARMA: ARMED ASSAULT / COMBAT OPERATIONS
    • ARMA: COLD WAR ASSAULT / OPERATION FLASHPOINT
    • IRON FRONT: LIBERATION 1944
    • BACK CATALOGUE
  • OFFTOPIC
    • OFFTOPIC
  • Die Hard OFP Lovers' Club's Topics
  • ArmA Toolmakers's Releases
  • ArmA Toolmakers's General
  • Japan in Arma's Topics
  • Arma 3 Photography Club's Discussions
  • The Order Of the Wolfs- Unit's Topics
  • 4th Infantry Brigade's Recruitment
  • 11th Marine Expeditionary Unit OFFICIAL | 11th MEU(SOC)'s 11th MEU(SOC) Recruitment Status - OPEN
  • Legion latina semper fi's New Server Legion latina next wick
  • Legion latina semper fi's https://www.facebook.com/groups/legionlatinasemperfidelis/
  • Legion latina semper fi's Server VPN LEGION LATINA SEMPER FI
  • Team Nederland's Welkom bij ons club
  • Team Nederland's Facebook
  • [H.S.O.] Hellenic Special Operations's Infos
  • BI Forum Ravage Club's Forum Topics
  • Exilemod (Unofficial)'s General Discussion
  • Exilemod (Unofficial)'s Scripts
  • Exilemod (Unofficial)'s Addons
  • Exilemod (Unofficial)'s Problems & Bugs
  • Exilemod (Unofficial)'s Exilemod Tweaks
  • Exilemod (Unofficial)'s Promotion
  • Exilemod (Unofficial)'s Maps - Mission Files
  • TKO's Weferlingen
  • TKO's Virolahti
  • TKO's Livonia
  • TKO's Rules
  • TKO's Changelog
  • TKO's Help
  • TKO's What we Need
  • MSOF A3 Wasteland's Server Game Play Features
  • MSOF A3 Wasteland's Problems & Bugs
  • MSOF A3 Wasteland's Maps in Rotation
  • SOS GAMING's Server
  • SOS GAMING's News on Server
  • SOS GAMING's Regeln / Rules
  • SOS GAMING's Ghost-Town-Team
  • SOS GAMING's Steuerung / Keys
  • SOS GAMING's Div. Infos
  • SOS GAMING's Small Talk
  • NAMC's Topics
  • NTC's New Members
  • NTC's Enlisted Members

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Yahoo


Jabber (xmpp)


Skype


Biography


Twitter


Google+


Youtube


Vimeo


Xfire


Steam url id


Raptr


MySpace


Linkedin


Tumblr


Flickr


XBOX Live


PlayStation PSN


Origin


PlayFire


SoundCloud


Pinterest


Reddit


Twitch.Tv


Ustream.Tv


Duxter


Instagram


Location


Interests


Interests


Occupation

Found 78 results

  1. Hi everyone, I've been attempting to install and run an Arma 3 server off of my Linux server for about a week now and I seem to be running into a wall with my configuration. I have the server installed through LinuxGSM and that seems to be working correctly, the server launches and I can see/connect to it, albeit only via the LAN IP, not the WAN IP (also the password param in the config file doesn't seem to be working correctly but thats another issue for another day), and as such anyone trying to connect from outside my LAN can't. This seems to be a port forwarding issue because when I check what ports are active and listening on my linux machine, ports 2302-2306 are being used by the Arma 3 Server, but they are not listening and nothing I do makes them listen whether I try to open the ports from my router diagnostics or through commandline on the server itself (through iptables). I can't seem to find any tutorials that solve the issue either so I figured I'd ask myself. Thanks for any help!
  2. Hey Guys, I'm trying to build an Arma 3 server on Linux with Docker, but I'm having problems because I have no experience managing Arma servers. I tried these images from Docke Hub because their Dockerfiles both look pretty promising. https://hub.docker.com/r/wilkesystems/arma3 https://hub.docker.com/r/synixebrett/arma3server The server seems to be created, but I can't connect to the server by IP I'm have no clue on how to troubleshoot this but maybe someone around here may have. Here is the log Redirecting stderr to '/root/Steam/logs/stderr.txt' ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt". [ 0%] Checking for available update... [----] Downloading update (0 of 50772 KB)... [ 0%] Downloading update (3130 of 50772 KB)... [ 6%] Downloading update (6277 of 50772 KB)... [ 12%] Downloading update (9123 of 50772 KB)... [ 17%] Downloading update (11704 of 50772 KB)... [ 23%] Downloading update (14278 of 50772 KB)... [ 28%] Downloading update (16862 of 50772 KB)... [ 33%] Downloading update (19448 of 50772 KB)... [ 38%] Downloading update (22285 of 50772 KB)... [ 43%] Downloading update (24873 of 50772 KB)... [ 48%] Downloading update (27454 of 50772 KB)... [ 54%] Downloading update (30255 of 50772 KB)... [ 59%] Downloading update (31552 of 50772 KB)... [ 62%] Downloading update (32849 of 50772 KB)... [ 64%] Downloading update (34275 of 50772 KB)... [ 67%] Downloading update (35568 of 50772 KB)... [ 70%] Downloading update (36856 of 50772 KB)... [ 72%] Downloading update (38160 of 50772 KB)... [ 75%] Downloading update (39577 of 50772 KB)... [ 77%] Downloading update (40867 of 50772 KB)... [ 80%] Downloading update (42171 of 50772 KB)... [ 83%] Downloading update (43461 of 50772 KB)... [ 85%] Downloading update (44750 of 50772 KB)... [ 88%] Downloading update (46140 of 50772 KB)... [ 90%] Downloading update (47430 of 50772 KB)... [ 93%] Downloading update (48718 of 50772 KB)... [ 95%] Downloading update (50006 of 50772 KB)... [ 98%] Downloading update (50772 of 50772 KB)... [100%] Download Complete. [----] Applying update... [----] Extracting package... [----] Extracting package... [----] Extracting package... [----] Extracting package... [----] Installing update... [----] Installing update... [----] Installing update... [----] Installing update... [----] Installing update... [----] Installing update... [----] Installing update... [----] Installing update... [----] Cleaning up... [----] Update complete, launching... WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work. Redirecting stderr to '/root/Steam/logs/stderr.txt' [ 0%] Checking for available updates... [----] Verifying installation... Steam Console Client (c) Valve Corporation -- type 'quit' to exit -- Loading Steam API...Failed to init SDL priority manager: SDL not found Failed to set thread priority: per-thread setup failed Failed to set thread priority: per-thread setup failed OK. Logging in user '*******' to Steam Public ... Generated client id: 6072502404465025025 Listening for IPv4 broadcast on: 27036 Listening for connections on: 0.0.0.0:27036 Logged in OK Waiting for user info...OK Update state (0x3) reconfiguring, progress: 0.00 (0 / 0) Update state (0x5) validating, progress: 67.94 (4822537169 / 7098641499) Failed to set thread priority: per-thread setup failed Failed to set thread priority: per-thread setup failed Failed to set thread priority: per-thread setup failed Failed to set thread priority: per-thread setup failed Failed to set thread priority: per-thread setup failed Failed to set thread priority: per-thread setup failed Failed to set thread priority: per-thread setup failed Update state (0x61) downloading, progress: 1.01 (71995331 / 7098641499) Update state (0x61) downloading, progress: 3.27 (231898275 / 7098641499) Update state (0x61) downloading, progress: 5.56 (394586091 / 7098641499) Update state (0x61) downloading, progress: 8.20 (582029328 / 7098641499) Update state (0x61) downloading, progress: 10.70 (759636271 / 7098641499) Update state (0x61) downloading, progress: 13.20 (937292536 / 7098641499) Update state (0x61) downloading, progress: 15.68 (1112796763 / 7098641499) Update state (0x61) downloading, progress: 16.59 (1177808475 / 7098641499) Update state (0x61) downloading, progress: 19.02 (1350262823 / 7098641499) Update state (0x61) downloading, progress: 21.52 (1527844768 / 7098641499) Update state (0x61) downloading, progress: 23.84 (1692058149 / 7098641499) Update state (0x61) downloading, progress: 26.02 (1847390112 / 7098641499) u_str ESTAB 0 0 * 1046879741 * 1046879740 u_str ESTAB 0 0 * 1046879811 * 1046879810 u_str ESTAB 0 0 * 1161018837 * 1161018842 u_str ESTAB 0 0 * 1046898024 * 1046848466 7:09:19 7:09:19 ======================= 7:09:19 7:09:19 ============================================================================================= List of mods =============================================================================================== 7:09:19 modsReadOnly = true 7:09:19 safeModsActivated = false 7:09:19 customMods = true 7:09:19 hash = 'A2552C89CDA2014B5CA21B2F5E88D41A6CCFBE2E' 7:09:19 hashShort = '39f0992e' 7:09:19 name | modDir | default | official | origin | hash | hashShort | fullPath 7:09:19 ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- 7:09:19 Community Base Addons v3.14.0 | @CBA_A3 | false | false | GAME DIR | a5315e09b0dceb50d870b228b1d0b9fb06e992e8 | d8563337 | /arma3/mods/@CBA_A3 7:09:19 Arma 3 Contact (Platform) | enoch | true | true | GAME DIR | 0d59242b58e23b2ede068fee2616d3e4be87376b | 71bb1cea | /arma3/enoch 7:09:19 Arma 3 Tanks | tank | true | true | GAME DIR | 73ad2cd4eae68045cea7a7221caef9e6e955ae45 | ff97ef57 | /arma3/tank 7:09:19 Arma 3 Tac-Ops | tacops | true | true | GAME DIR | c42217db4f55205cf6f0f05e2a5d8f24384cf638 | cf74c5ae | /arma3/tacops 7:09:19 Arma 3 Laws of War | orange | true | true | GAME DIR | 5acbf43a6a9a45060e8fb9c973bffdf5923ec29c | 12b76d7a | /arma3/orange 7:09:19 Arma 3 Malden | argo | true | true | GAME DIR | b09aeef5451d9f0d3d4a61e77179267a70ff6da6 | 2afda5f3 | /arma3/argo 7:09:19 Arma 3 Jets | jets | true | true | GAME DIR | 5bfa24542528e0d2ccbaa89eee6b0b3d353e8d4e | 20520625 | /arma3/jets 7:09:19 Arma 3 Apex | expansion | true | true | GAME DIR | 430f7b474885b219790a57de4de3eea2fb15b448 | 5032127f | /arma3/expansion 7:09:19 Arma 3 Marksmen | mark | true | true | GAME DIR | 23a8722eb5c8b4175c3103c877cc7822bf13dd9a | d102ca49 | /arma3/mark 7:09:19 Arma 3 Helicopters | heli | true | true | GAME DIR | 5c6a375b889b703d247e6f7134d0b4749be7d25d | bee51663 | /arma3/heli 7:09:19 Arma 3 Karts | kart | true | true | GAME DIR | d9d59f8a35c0c4cf9e1583f1d778f01a3843bb8f | b421f4ed | /arma3/kart 7:09:19 Arma 3 Zeus | curator | true | true | GAME DIR | 48863ef9dd9aa7bca9c81544fc489dddc71f629a | a8deee88 | /arma3/curator 7:09:19 Arma 3 | A3 | true | true | NOT FOUND | | | 7:09:19 ========================================================================================================================================================================================================== 7:09:19 InitSound ... 7:09:19 InitSound - complete 7:09:19 Dedicated host created. 7:09:19 PhysX3 SDK Init started ... 7:09:19 PhysX3 SDK Init ended. 7:09:23 [CBA] (xeh) INFO: [0,28.119,0] PreStart started. 7:09:23 [CBA] (settings) INFO: Userconfig: Ignored. 7:09:24 [CBA] (xeh) INFO: [0,28.487,0] PreStart finished. 7:09:24 core\skyobject\skyobject.p3d: No geometry and no visual shape 7:09:24 a3\data_f\krater.p3d: No geometry and no visual shape 7:09:24 a3\data_f\koule.p3d: No geometry and no visual shape 7:09:25 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted. a3_characters_f 7:09:25 Loading movesType CfgGesturesMale 7:09:26 MovesType CfgGesturesMale load time 600 ms 7:09:26 Loading movesType CfgMovesMaleSdr 7:09:30 Warning: looped for animation: a3\anims_f_epa\data\anim\sdr\cts\hubcleaned\briefing\hubbriefing_loop.rtm differs (looped now 0)! MoveName: hubbriefing_ext 7:09:33 Warning: looped for animation: a3\anims_f_epa\data\anim\sdr\cts\hubcleaned\spectator\hubspectator_stand.rtm differs (looped now 1)! MoveName: hubspectator_stand_contact 7:09:36 MovesType CfgMovesMaleSdr load time 10028 ms 7:09:36 a3\characters_f\proxies\flag.p3d: No geometry and no visual shape 7:09:36 BattlEye server updated to version: 217 7:09:36 BattlEye Server: Initialized (v1.217) Setting breakpad minidump AppID = 107410 7:09:36 Game Port: 2302, Steam Query Port: 2303 7:09:36 Initializing Steam server - Game Port: 2302, Steam Query Port: 2303 Arma 3 Console version 1.96.146114 x86 : port 2302 7:09:36 Host identity created. 7:09:37 Connected to Steam servers
  3. Hello all, A while back I used to host a Arma 3 Dedicated server on Linux. After a while I stopped hosting it and deleted the Dedicated server off the linux box to make room for other applications. But now I have decided to reinstall the arma server again so I can host my mission once more. However I am stumbling into a weird problem when it comes to connecting to the server. Everytime a player connects, the player gets stuck in the loading screen. On the server side, the following line is spammed into the terminal until the player disconnects: 13:28:57 Server error: Player without identity Altay (id 1727490217) This happens on all missions. If I don't specify a startup mission in the config cfg, and then manually load my own mission using the #mission command then it loads without any problem. But setting my own mission as the default startup mission is a no-go. One thing that seems to fix it is to disable verifySignatures in the config file but I don't think this is a good solution to this. The server itself is just a vanilla install with no mods loaded. It was installed with SteamCMD using the guide found on the bohermia wiki. The server is started with the following command: ./arma3server -config=aad_config.cfg -name=AAD It is weird because this is the same exact mission file that I used to run in the past on the same machine and it just worked. But now it doesn't anymore. I setup a local Windows Server instance and tested the windopws version of the server there and it works fine without any issues. I tried both Debian 10 and Ubuntu Server 18.04 LTS and both didn't have an impact. Here is the full console output from server startup to shutdown: Here is the config file that I use:
  4. Marceldev89s original script, from which I forked. Introduction: a3update.py is a simple, lightweight python script that handles: Updating the arma server Installing and updating mods Generating an importable preset.html ideal to accompany @Dahlgren's Arma Server Web Admin which as of yet does not provide those features. Here is an example modpack.html I setup for a friend using this script Download (Github Gist) Requirements: SteamCMD, Python3, Python3-urllib3, a Steam account with Arma 3 Installation (Ubuntu): Follow the initial server installation instructions on the BIWiki `sudo apt-get install steamcmd python3 python3-urllib3` `wget https://gist.githubusercontent.com/Freddo3000/a5cd0494f649db75e43611122c9c3f15/raw/4854ac4a78c7d347ade1e9ab9fcac147d7dbe3e9/a3update.py` Edit the following settings: STEAM_CMD - Point this at your steamcmd installation, alternatively simply enter "steamcmd" STEAM_USER - Your login username STEAM_PASS - Your login password A3_SERVER_DIR - Point this at your A3 server installation directory A3_MODS_DIR - Point this to where you want your mods to be symlinked. If you are using the suggested Arma Server Web Admin, make this the same as A3_SERVER_DIR A3_KEYS_DIR - Point this at the Keys folder in your installation directory MODPACK_NAME - Change this to what the title should be for the A3 launcher imported preset MODPACK_PATH - This will be the output preset.html file. Point this to wherever you wish for it to be stored, such as /var/www/html for the Apache web server MODS - Your list of mods in the format "@mod_folder" : "https://steamcommunity.com/sharedfiles/filedetails/?id=450814997". Avoid special and capital characters SERVER_MODS - List of server mods, only add folder names here. These also have to be present in the MODS list. Server keys will not be copied for these mods OPTIONAL_MODS - List of server mods, only add folder names here. These also have to be present in the `MODS` list. These mods will not get symlinks in your A3_MODS_DIR, but will have their server keys copied. DLC - List of CDLC in format "Name" : "https://store.steampowered.com/app/1042220/Arma_3_Creator_DLC_Global_Mobilization__Cold_War_Germany/" Optional: Install Arma Server Web Admin `chmod +x a3update.py` // Might be a good idea to limit access, as you have your password stored in plaintext Run it! `./a3update.py` Importing preset via URL: Open the A3 Launcher, go to mods, select "PRESET" at the top right and "IMPORT" Copy the link to the modpack.html (Example: https://somewebsite.com/modpack.html) Paste it into the "File name" field and press Open Notes: This has only been tested on Linux, though I wouldn't be surprised if it also works on Windows Known issues: Does currently not handle installation and updates of CDLC Doesn't work well with 2FA due to how steam stores login tokens Optional DLC is not kept when preset is imported With larger mod lists some data may fail to transfer to the launcher, therefore if you intend to keep the server public you'll want to run less than 15 mods. You can increase the amount of transferable data by shortening each mods mod.cpp file, making each mod take less space to transfer. Alternatively, you can use the ACE checkPBOs framework to make sure players are running the correct mods. License: MIT License Credits: @marceldev89 from who I forked this project
  5. Hi guys, I've set up a dedicated server on linux and I'm having issues with the Arma3Profile file. The difficulty settings the server loads are not the one I've set in the file. The file is located at ~/steam/.local/share/Arma 3 - Other Profiles/server/server.Arma3Profile and the command to launch the server includes -name=server. I was playing around with changing some settings, for example third person view, but any changes I make are ignored by the server. On the other hand, changing the -name parameter meant the server was no longer loading the Antistasi save (which is stored in server.vars.Arma3Profile). So it definitely knows where the files are. I've seen a few threads with this issue but couldn't find a solution. Any ideas what the issue could be? Thanks.
  6. Hello im trying to get a dedicated server to run for myself and some friends. Im running it off Ubuntu 18.04 and SteamCMD latest copies of everything. Im trying to load up and run the Vanilla Antistasi BluFor Mission. I have everything installed and I execute the server with the following command in my terminal ./arma3server -config=server.cfg It launches the server using the settings from my server.cfg file which I copied from the dedicated server guide section on these forums and you can view my exact settings here. Download server.cfg The server boots and I can join it however I see 1 error on the terminal when its booting up which reads. Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted. a3_characters_f and then the whole console gets spammed when a user joins the server with Mission Antistasi.Altis read from bank. and nothing happens client side, the server just idles there and any user connecting stares at a loading page for 3 minutes before the server auto boots you. Anything im doing wrong here I am new to the dedicated server side of things. If anyone can include their server.cfg or any pointers i can do please help. Direct instructions would be nice.
  7. I have just installed steamcmd and Arma 3 on a dedicated Ubuntu-based server, and have been following this tutorial to help me set it up. As described at the top of the document, arma3 is installed in /home/steamcmd/arma3/ install, but the config files etc are in /home/steamcmd/arma3/public. There is also a script in /home/steamcmd/arma3/public called start.sh which should start and configure the arma server. ./arma3server can be executed correctly from /home/steamcmd/arma3/install, and there is a symbolic link to this executable in /home/steamcmd/arma3/public. However when I run ./arma3server from within /home/steamcmd/arma3/public, I get the following error: 2:54:04 No product.bin found, using defaults for a core engine. Running Steam on ubuntu 19.04 64-bit STEAM_RUNTIME is enabled automatically Unpack runtime failed, error code 1 Error: Couldn't set up the Steam Runtime. Are you running low on disk space? Continuing... Press enter to continue: I have narrowed it down to the fact that when I run ./arma3server from /home/steamcmd/arma3/install, it uses steamcmd.sh (located in /home/steamcmd/). However when I run it from /home/steamcmd/arma3/public, it uses steam.sh (also located in /home/steamcmd/) which I gather is a legacy executable. My question is how do I make it use steamcmd.sh instead of steam.sh, as steam.sh causes the error. Thanks for any help.
  8. I have figured out how to get Arma 3 to work with Proton and have full mod support. After downloading Arma 3 using Steam play Proton, go to your Arma 3 directory, and rename the “arma3launcher.exe” to anything. Then rename your “arma3_x64.exe” or “arma3.exe” to “arma3launcher.exe”. After that you can just launch the game through Steam, but if you have audio issues you need to use “WINEPREFIX=/path/to/steam/steamapps/compatdata/107410/pfx winecfg”. Go to libraries, add “xaudio2_6” and “xaudio2_7” setting both to “native,builtin”. Finally if you want to use any mods that use .dlls you need to source a imagehlp.dll from a windows installation, and drop it in your “/path/to/steam/steamapps/compaydata/107410/pfx/drive_c/windows/system32” directory. Then use winecfg and set "imagehlp" to "native". That will let arma load mods that use .dlls properly. Suggested tools for a better experience Proton Wine Manager Arma3-Proton-Launcher
  9. Hey guys So I'm having a problem with the starting parameters for my server. I'm just trying to host a small server for my friends and I and for some reason I can only load one mod at a time. For context I'm using a LGSM server install on an Ubuntu 18.04 LTS. The mods are loaded in the root directory of my Arma server install and no matter how I set up my content I can only load one mod. Here is an example -mods=@RHSAFRF;@CBA_A3 this only loads RHSAFRF and if I set it up this way -mods=@CBA_A3;@RHSAFRF this only loads CBA_A3. What could the issue be?
  10. Hello! Was trying to get the game working in steam proton but it just crashes. I've tried different proton versions and setting -nolauncher but it still just crashes. Are there any logs I can include?
  11. So I'm trying to load mods on my server but no matter how I copy over the files (either links or an actual copy of the dir) it still doesn't load the mod when I launch the server. The directory also has all lower case but it still does not help. The server runs good otherwise. Anything input would help thanks!
  12. Hello everyone! This is my first time posting here and I just need some help troubleshooting my server. So I've been having some issues and currently I'm getting a segfault when I launch my server. I was having issues prior to that as well where the server would close immediately with some lock out error and before that my server would not load mission when voted it would just kick me back to voting another mission. Any help would be great! thanks again
  13. Hello Folks, I'm trying to host a mission downloaded from the workshop on my new dedicated Linux server (my server running OpenSuSE Leap 42.3). However, I can't seem to get it to appear on the server. I downloaded the mission via steamcmd: workshop_download_item 107410 230239528 This resulted in the directory: /home/steam/Steam/steamapps/workshop/content/107410/230239528 with a single file in it: 940560531083087031_legacy.bin I coped this into my: /home/steam/Steam/arma3/mpmissions But when I fire up the server. I only see the vanilla missions as options. I tried renaming this to a .pbo extension, but no joy. On my windows box I subscribed to the mission via. steam workshop, and it shows up fine. Any help please? (I've had the same problem with other missions I've tried to download, including: 761149851 and 489171976.) I can't get any of them to work.
  14. Well, it's been a while since I posted, huh? Nothing that much has changed in my situation. I can't even find the original thread I posted so long ago, to be honest. Well, the same issues are being had. I am trying to run the game, but it immediately crashes upon booting to the menu. Relevant system specs are here: Processor: AMD A10-6700 Memory: 8 GB Graphics: Integral GPU, not specified but probably a cheapo POS Storage: 1x 1TiB HDD Operating System: Arch Linux, attempting to run the game through SteamOS and Proton. Mods installed: None The crash log is right over here. If anyone can help me with this, please do.
  15. Ok, I've struggled with this for awhile now and am pretty sure my issue is something small that I'm just not seeing. I just want some fresh eyes to look over my work and tell me what they see. The issue is that my custom difficulty settings don't seem to take. The server comes up fine, people can join, and mods are working great. But I can't get my FCserver.Arma3Profile to be read by the game (I think). When ever I start a mission on custom difficulty I get a default template instead of my settings. This is a Linux server (Ubuntu 18.10) Startup Script: ./arma3server -config=FC.cfg -name=FCserver "-mod=mods/@ace;mods/@ace_compat1;mods/@ace_compat2;mods/@ace_c... File path to Arma Server: gameserver/server/arma File path to Arma 3 - Other Profiles / Arma 3 folders: gameserver/.local/share/Arma 3 - Other Profiles gameserver/.local/share/Arma 3 Inside Arma 3 - Other Profiles is the FCserver folder it contains 2 files and 1 folder: FCserver.Arma3Profile <--- (To my understanding this is the difficulty file) FCserver.vars.Arma3Profile <---(Don't know what this does) Saved <--- (Folder with some steam stuff in it) The FCserver.Arma3Profile was generated by the server automatically, then edited by me (I stole it from the community wiki). FCserver.Arma3Profile: FC.cfg: ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------ Thank you for reading this, overall I've spent the better part of 3 weeks banging my head on this. I am so sure that it's gonna be something incredibly small. I will answer any questions you have for me.
  16. Trying to get a new arma3 server setup following the guide posted here: https://community.bistudio.com/wiki/Arma_3_Dedicated_Server#Configuration However when I attempt to start the server the following happens [steam@galactica arma3]$ ./arma3server Segmentation fault (core dumped) I have tried the fixes previously posted here: Please assist if possible. i also have tried running ./arma3server debug but the same issue arises with the segmentation fault. If the logs from the core are needed, i will need assistance locating them as i cant seem to find them on my server.
  17. Well the Arma Gods have rained their blessings .. not Ryan Blessings ... over us Linux users :D And it makes us so happy, I mean "Screw windows 10 and their facebook ways!", Linux for ever and ever and ever.. Vulcan API and all that niceness. that said.. The damn Server Browser doesn't work on 1.82, and I did verify my data, and it did work properly on 1.80, all other Steam Linux games work properly.. What is going on? Can anybody help? Does it work for other Linux users?
  18. Why can people with the Linux client still not connect to the larger multiplayer network? Almost nobody is running legacy servers for Linux users, so almost nobody is playing this game on Linux either... If you're gonna make the effort to port this game to Linux, at least also make the effort to let the Linux players play with their Windows using friends... I would understand if there was some huge feature incompatibility here, but we're talking about a constant difference of 2 minor release versions. This is not some insurmountable barrier, especially since you're not letting Linux catch up on purpose and have it fixed at being 2 minor releases behind. It's pretty infuriating...
  19. Hello. I have purchased ArmA III quite some time ago, but a very serious problem has been affecting me. Essentially, every single time I attempt to run the game, it crashes before it even gets to the title screen. I have the crash log over here. If you can tell me what is happening to cause this error, please tell me. This crash happened when I was using the SteamOS version of the game, on both the Fedora distribution of Linux (based on Red Hat Enterprise Linux) and the Antergos distribution (based on Arch Linux; it's labeled as such in the crash log for some reason). If any of you can provide help, please do so.
  20. Hey guys, a community is recently having problems in terms of loading my terrain (HEBONTES) up on a linux server. This is the server message:: Thank you guys for ANY ideas to find a solution. Lg Hunger
  21. Hi there. I have yet another Server problem. If we play on a server and we for example kill a lot of AIs or similar, the server freezes. No, its not clients. WE see each other walking in one place and.. well.. the server is frozen. No response from arma3 process, can login to putty normally. HTOP shows 100% cap on arma3 proccess, however normally it "flows" between cores. Stuck. Can share logs, however there is nothing in them at the time of the crash. As if the whole proccess is frozen. anyone got ideas? Thanks in beforehand.
  22. maesevil

    Launcher for linux/mac?

    As the tittle say, will be possible a launcher for linux/mac, i know there are already launchers for unix, but i would like to know about an official launcher with all the features of the windows launcher.
  23. Hello there! TL;DR: While trying to play on Lythium, I get this error: "no entry 'bin\config.bin/cfgworlds.lythium'." and same in server log. Mod is running on server and even while connecting throught launcher server requests to load mod Lythium. Other mods work flawlessly. Now the long explanation... I have a linux server for a few months now, crisp clean Debian with nothing but arma and some other services, tho I keep it clear because of lacking power. We play on it with typical mods like RHS, Ace and so on, the "Must have" mods and everything works flawlessly. So flawlessly that we can actually maintain playable fps while Antistasi fucks up with too many AIs. Anyway, we have recently tried to play on lythium. Long story short, it doesnt work. It somehow acts as if the map wasnt on server even tho it is and launcher requests it to load. I am doing something wrong, and its propably stupidly easy but I am in the end with my head right now... Order of mods is okay, and even if it wasnt I tried to change my param so Lythium loads: First, last, before JBAD, after it, somewhere around CUPS (I know it has no connection but....better try) and no change. What it does: Basically, the map is not on the server. Exept it is. Map, mission and all of its stuf works on localhost, mine and my friends. Tried across more machines, works. With or without -mods=@lythium\;(other mods here) server shows the same error over and over again. no entry 'bin\config.bin/cfgworlds.lythium'. Does anyone know what it might be or at least why does this happen? I know its this error because I tried to load the server with nothing but jbad and lyhium. Same results. It must be something with either jbad or lythium mod. Will try something more but any help is appreciated. EDIT: While loading server with NOTHING but lythium, it loads with no problems and doesnt request its dependency or crashes with error. It feels werid, as if the mod was just nothing but name...
  24. I've been playing Arma 3 for a long time, but because the Linux port of it was always incompatible with current servers, I stopped after a while. Recently I've re-installed Arma 3, but with wine, because a new technology (DXVK) came out, which enables D3D11 calls to be mapped to Vulkan calls, improving the performance of quite a few Wine titles. Unfortunately, dxvk requires replacing the original d3d libraries, which I guess can be considered tampering with DX11. So I was wondering if playing with DXVK can get me banned.
  25. Hi, i'm really sorry about this but I'm getting a pretty serious error on my Ubuntu 16.04 Arma Server. Every time I shut down my server, with CTRL - C, i get the following error. This happens, all the time, everytime, with/without mods. It started the moment i first launched the server and still happens weeks later. It dumps huge core files (2GB), which isn't good, my storage is running out rapidly. I dont know whether It is safe to do so or not, or if there are any unexpected reprocussions after deleting them. How can I stop these damn errors? Please help, It's really frustrating. Let me know if you need any other information, i will happily get back to you as soon as possible. Fin
×