Jump to content

SSgt Ryan

Member
  • Content Count

    51
  • Joined

  • Last visited

  • Medals

Community Reputation

15 Good

About SSgt Ryan

  • Rank
    Lance Corporal

Profile Information

  • Gender
    Not Telling

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Always the last thing you check, lol glad to help
  2. Are you sure none of those mods requires @CBA_A3? Last thing if you want to try. I converted all of your information to the old way i used to do it, .cmd style. Try giving this a run as a .cmd: start "" "C:\TCAFiles\Users\komurikunmeow13\7\arma3hcserver.exe" ^ -mod=@Exile;@A2OP;@ryanzombies;@RZInfection_for_Exile;@NATO_Russian_SF_Vehicles;@NATO_Russian_SF_Weapons;@EBM;@RDS_Civilian_Pack; ^ -profiles=C:\TCAFiles\Users\komurikunmeow13\7\ ^ -name=HC_1 ^ -port=2346 ^ -connect=127.0.0.1:2342 ^ -client ^ -noSound ^ -High ^ -password=1test And here it is again with public IP. If neither those work i'm not sure what the issue is: start "" "C:\TCAFiles\Users\komurikunmeow13\7\arma3hcserver.exe" ^ -mod=@Exile;@A2OP;@ryanzombies;@RZInfection_for_Exile;@NATO_Russian_SF_Vehicles;@NATO_Russian_SF_Weapons;@EBM;@RDS_Civilian_Pack; ^ -profiles=C:\TCAFiles\Users\komurikunmeow13\7\ ^ -name=HC_1 ^ -port=2346 ^ -connect=94.23.252.71:2342 ^ -client ^ -noSound ^ -High ^ -password=1test
  3. Those saying still broken. How are you connecting HC to the server? You must be using the local loop (127.0.0.1) not the public IP. We finally figured out that the -connect=127.0.0.1:2302 NEEDS the port of the server. At least in windows 2012 RC2 it does, and our naked AI issues vanished unless we drop like 300+ AI in less then a minute.
  4. Well I feel like you're doing everything right Arma 3 wise at this point to be honest. Sometimes it's something so silly when people aren't used to each others way of doing it. Like you could be missing quotes, or used the wrong ones somewhere. I'd have no idea. But it all looks good to me. I would try it finally with the public IP address, from the box (not from a different pc). If that doesn't work then I would say you're going to have do some digging in your OS / on the forums to find the answer. Sorry i can't help more.
  5. Just to clarify as best as possible since i haven't heard back and am now on my PC so i can type a bit better: This is my setup for running the headless client: In the Arma 3 main folder i have: arma3server.exe arma3server_op_1_hc_1.exe I use shortcuts to run them. Here is the server line: C:\steamcmd\arma_main\arma3server_op_1.exe -profiles=D:\A3_serverCFG\arma_main_CONFIG\ -par=D:\A3_serverCFG\OP_1_Param.txt The server cfg settings for that may (i'm no 100% on all of them) HC: kickduplicate = 0; verifySignatures = 0; allowedFilePatching = 0; requiredSecureId = 0; requiredSecureId = 0; headlessClients[]={"127.0.0.1","104.243.34.34"}; //List of IPs allowed to connect for Headless //If the HC are located on within the same VM guest use 127.0.0.1, otherwise use the local IP addressing of the VM host //This connection must have unlimited bandwidth and almost no latency otherwise BAD THINGS HAPPEN! localClient[]={"127.0.0.1","104.243.34.34"}; //List of IPs allowed unlimited bandwidth for Headless //If the HC are located on within the same VM guest use 127.0.0.1, otherwise use the local IP addressing of the VM host //This connection must have unlimited bandwidth and almost no latency otherwise BAD THINGS HAPPEN! BattlEye = 0; The param file for the server: -name=server -config=D:\A3_serverCFG\arma_main_CONFIG\op_1_config.cfg -cfg=D:\A3_serverCFG\arma_main_CONFIG\op_1_basic.cfg -mod=@CBA_A3;@RHSAFRF;@RHSUSAF;@RHSGREF;@RHSSAF;@task_force_radio;@CUP_Terrains; -port=2302 -cpuCount=4 -High The HC shortcut: C:\steamcmd\arma_main\arma3server_op_1_hc_1.exe -profiles=D:\A3_serverCFG\arma_main_CONFIG\Headless_Clients\ -par=D:\A3_serverCFG\OP_1_HC_1_Param.txt The param file for the hc: -name=HC_1 -mod=@CBA_A3;@RHSAFRF;@RHSUSAF;@RHSGREF;@RHSSAF;@task_force_radio;@CUP_Terrains; -port=2305 -connect=127.0.0.1:2302 -client -noSound -password=****** -High Hope that helps.
  6. Looked at your other thread. Both the headlessclients[]= and local clients[]= need the IPs wrapped in double quotes. Also try with battle eye disabled. Finally -profiles should be a directory / folder location. Not sure if the way you have it for Linux is correct, but for window it is a file path
  7. Because you are using the public IP address to find the server which defaults to the 2302 port, (or whatever the server instance is using) using the internal 127.0.0.1 does not default the port for some reason. This has been something I've been meaning to add to the wiki, but it's always down or I forget my user account when I go to do it.
  8. I was unclear in that part of my post. I meant the arma3 main folder should contain all your mods, but yes, the mods should be broken up. You just don't need multiple installations of the game on the same PC to run multiple servers.
  9. Actually, you are defining the port that the headless is running on with -port. Trust me. I've tested this many, many times. Any instance of arma3 or arma3server.exe requires a port because technically even clients can host their own instance that is multiplayer capable. I run multiple servers and hc's for those servers all on the same IP. How do you think you think you tell the different HC to connect to the right server when all instances are running on a box with the same IP?
  10. Actually, you can and should use the same folder for all mods. I think your only problem is that in your connect line you need to add the port of the server. -connect 127.0.0.1:2302
  11. Have you noticed the naked AI issues that come with setGroupOwner command? I've tried everything script wise to get it to not occur, and my last thought was to use an EH to get the group parameters, delete the group, then spawn them on the HC. But if you've found some workaround that would be highly useful to the community.
  12. SSgt Ryan

    Expect more from this setup

    CPS / FPS are capped if i'm not mistaken. Only way to test is play with 50+ players and see where it goes. Could be bad mission, or need to play with the bandwidth settings.
  13. SSgt Ryan

    Eden Feature Requests

    Now that we can change group names, would it be possible to add a toggle switch as to whether or not the changed group name is copied to a new mission? Unfortunately, I think somehow the fact that it doesn't is having an effect on code like this in the init box: group this setgroupid [""Havoc 6""]; As occasionally half way through the mission all the group names will change. Because if you do go through the trouble of changing all the Arma assigned group names, they don't copy over to new mission's and I have to redo them every time.
  14. Thanks for the hard numbers. Actually just went and built load sharing for 2hc into my EH. Will be testing soon. Just wish they would stop losing clothes. Have you noticed if the group amount or just total ai makes a difference. Aka 150 groups with 1ai vs 10 groups of 15 ai?
  15. "It's the same.... but different!" +Makes circular hand motions+ In all seriousness, yes. They are certainly related, unfortunately with Zeus there is no way that I've found to directly spawn the ai onto hc, they are always owned by the player that spawns them. A workaround could be a module that detects hc presence and spawns zeus placed ai directly to hc ownership. But then it would run directly to your issue. It would be best, imho, if the command was looked at, along with associated net code. Incidentally, I've also noticed with patch 1.58 that all groups in the mission load screen are created as empty groups, and any spawn group that is killed or deleted also retains it's empty group id. To combat this I put a simple script on my hc to delete empty groups they own, along with the server. I too eagerly await a fix, as hc does seem to provide around a 5 fps boost when working.
×