Jump to content

t1lt3rr0r

Member
  • Content Count

    1
  • Joined

  • Last visited

  • Medals

Community Reputation

10 Good

About t1lt3rr0r

  • Rank
    Newbie
  1. t1lt3rr0r

    Altis Life RPG

    First of all, thank you for this awesome mod! I am helping out a friend who has his own server and I have some real problems with getting custom textures for the police characters working. I know that some servers have custom textures and after trying lot of script modifications without any luck I'm asking for some assistance. This what I know already: - I need to set the custom textures via the "setObjectTexture" function - The function has to be run by every client to make texture changes "global" What I tried so far: - Found this custom snipped of code at pastebin.com/FuACdj9v NOT WORKING - Tried this: In \init.sqf fn_objecttexture = { _unit = _this select 0; _texture = _this select 1; _unit setobjecttexture _texture; }; Didnt know where to put this but tried multiple locations like "\dialog\function\fn_spawnConfirm.sqf", "\core\cop\fn_loadGear.sqf" and some other file. [[player,[0,'textures\police.paa']], "fn_objecttexture",nil,false] spawn BIS_fnc_MP; Also tried [[player,[0,'textures\police.paa']], "fn_objecttexture",nil,false] spawn life_fnc_MP; NOT WORKING - Found another snipped but didnt know where to put so not tested: _swat = [ p1, p2, p3, p4, p5, p6, p7, p8, p9, p10 ]; [ [ {_x setobjecttexture [ 0, "Texture\swat.paa" ]; } forEach _swat ], "BIS_fnc_Spawn", true, true ] spawn BIS_fnc_MP; I found it in a forum thread where the author said it is working with this solution, but where to place it? I do a try and error for the last 3 days and it get me frustrating :( Here some other things I need to fix but couldnt take any time for it right now: - Latest patch notes says "Fixed: Cop vehicles pulled from the garage couldn't use siren lights.". Lights are working on the offroad but not on the SUV. After buying the SUV its working but after a respawn/relogg or put in garage lights are not working anymore(dont even give me the option to 'turn sirene lights on' in scrollmenu) - Restrained civilians cant be put in vehicle. Sometimes it works but most of the time it doesnt. Tried all different locations around the car but it doesnt give me the option 'Put in car' via scrollmenu - Civilians can open cop vehicle door while sitting inside the cop car (when 'put in car' had randomly worked and also when manually entering the car) and can jump out of it. Some bugs i found and could already be fixed: - Northern rebel outpost is missing spawnpoint for vehicles (fix was already mentioned some pages before) - Police hq boat shop doesnt have an garage so cops can only spawn boats at civil boatshop (check the civil boatshop guy in editor and copy the code containing the garage part to the police boat shop) - Civilian weapons and some gear not saving. This is not a bug, its wanted from the author but if you want to change, check out this post: forums.bistudio.com/showthread.php?168139-Altis-Life-RPG&p=2630179&viewfull=1#post2630179 - Also not a bug but if you want to change vehicle textures: forums.bistudio.com/showthread.php?168139-Altis-Life-RPG&p=2628981&viewfull=1#post2628981 Thank you for reading the wall of text. I hope someone can help me and I could help some of you with my information.
×