Jump to content

Walkero0

Member
  • Content Count

    91
  • Joined

  • Last visited

  • Medals

  • Medals

Posts posted by Walkero0


  1. 1 hour ago, RoF said:

    That's normal, your error is most likely due to not exporting a fresh .wrp / not using pboproject.

     

    Or could be you grid file is corrupt. Clear all files from layers folder, then delete YourMapName.grid.000.v4w (its saved where TB project is). Then export layers again and pack with pboproject.

     

    Also use this to convert your layers, TB does it really slow https://pmc.editing.wiki/doku.php?id=arma3:terrain:convert-layers-png-fast

    Thank you now it works.


  2. Hy I experienced an issue during generating layers in terrain builder.

    I edit my surfacemask and diffuse map in photoshop, upload it to my source folder, start terrain builder.

    On Rasters I update content from sourde. and then I generate the layers with mapframe-->properties-->processing. (https://imgur.com/a/hym0s0S)

    After Generating Layers I have png files in the generated rvmat layer files. Example: (https://pastebin.com/DAgVcMDz)

    When I start my map in Arma3 it comes with error loading rvmat, which is understandable.

    But why are there png files and not paa in the generated rvmats?

    paa is aviable in the layers folder.


  3. hy,

    I want to remove all warnings from my mod and

    PboProject won't pack my basicDefines_A3.hpp because of this warning:

    ***warning***:In file '\wlk_roads\basicdefines_A3.hpp': macro 'LOAD': trailing ; should be in each caller. Never the macro body. 

     

     

    My basicDefines_A3:

    Spoiler
    
    #define true 1
    #define false 0
    
    #define VSOFT 0
    #define VARMOR 1
    #define VAIR 2
    
    // type scope
    #define private 0
    #define protected 1
    #define public 2
    
    #define CANSEERADAR 1
    #define CANSEEEYE 2
    #define CANSEEOPTICS 4
    #define CANSEEEAR 8
    #define CANSEECOMPASS 16
    #define CANSEERADARC CANSEERADAR+CANSEECOMPASS
    #define CANSEEALL 31
    #define CANSEEPERIPHERAL 32
    		
    //lock acquiring
    #define MANUALLA      0		
    #define AUTOMATICLA   1
    
    //lockable target type
    #define LOCKGROUNDTT      0
    #define LOCKAIRGROUNDTT   1
    #define LOCKAIRTT         2
    #define LOCKGROUND      0
    #define LOCKAIRGROUND   1
    #define LOCKAIR         2
    
    //missile lock type
    #define FIREANDFORGETLT   0
    #define KEEPLOCKEDLT      1
    #define MANUALLT          2
    
    #define SPEED_STATIC 1e10
    
    #define LOCKNO		0
    #define LOCKCADET	1
    #define LOCKYES		2
    
    enum {STABILIZEDINAXESNONE,STABILIZEDINAXISX,STABILIZEDINAXISY,STABILIZEDINAXESBOTH, STABILIZEDINAXESXYZ};
    
    #define STABILIZEDINAXESNONE 0		
    #define STABILIZEDINAXISX 1
    #define STABILIZEDINAXISY 2
    #define STABILIZEDINAXESBOTH 3
    #define STABILIZEDINAXESXYZ 4
    
    #define CM_NONE        0
    #define CM_LOCK_VISUAL 1
    #define CM_LOCK_IR     2
    #define CM_LOCK_LASER  4
    #define CM_LOCK_RADAR  8
    #define CM_MISSILE     16
    
    
    #define CMIMMUNITY_GOOD 0.9
    #define CMIMMUNITY_MIDDLE 0.65
    #define CMIMMUNITY_BAD    0.5
    
    #define MAG_XX(A,B) CLASS _XX_##A {MAGAZINE = A; COUNT = B;}
    #define WEAP_XX(A,B) CLASS _XX_##A {WEAPON = A; COUNT = B;}
    #define ITEM_XX(A,B) CLASS _XX_##A {NAME = A; COUNT = B;}
    #define BAG_XX(A,B) CLASS _XX_##A {BACKPACK = A; COUNT = B;}
    
    #define DEFAULT_SLOT 0
    #define MUZZLE_SLOT 101
    #define OPTICS_SLOT 201
    #define FLASHLIGHT_SLOT 301
    #define NVG_SLOT 602
    #define GOGGLE_SLOT 603
    #define HEADGEAR_SLOT 605
    #define UNIFORM_SLOT 801
    
    #define HMD_SLOT       616
    #define BINOCULAR_SLOT 617
    #define MEDIKIT_SLOT   619
    #define RADIO_SLOT    611
    
    #define VEST_SLOT      701
    #define BACKPACK_SLOT  901
    
    #define LOAD(weight,capacity) maximumLoad = ##capacity##; \
    							  mass = ##weight##;
    							  
    #define HEADARMOURCOEF 2.5
    #define BODYARMOURCOEF 10
    #define HANDARMOURCOEF 5
    #define LEGARMOURCOEF 5

     

    How can I fix this line 87?


  4. Hi once again I ask for your help.

    I tried to configure dynamic airport on my map to land planes with autopilot.

    I went through every step at https://community.bistudio.com/wiki/Arma_3:_Dynamic_Airport_Configuration

    But something is fucked up in my config. I don't really know how to set Longitude and Latitude or mapArea correctly (I think that's causing this).

    My Plane Autopilot is always trying to land on the left lower corner of the map (ocean) and crash landing.

    I got the coordination values for the dynamic airport configuration in eden -->rightclick somewhere-->Log-->Log Position to Clipboard.

     

    config

     

    I got the direction values with debug console:

    _unit = player getDir jet; 
    copyToClipboard format["%1",_unit]; 
    hint format["%1",_unit];

    Mapframe:

    Location

    Samplers

     

    What values are causing this with left lower corner on map?

    Plz help.

     


  5. I have this class in my config.cpp:

    class cfgsounds
    {
    	class bear_roar
    	{
    		name = "bear_roar";
    		sound[] = {"\wlk_animals\bear\sounds\bear_idle_roar",0.70794576,1};
    		titles[] = {0,""};
    	};
    };

    and added this to my class States:

    class Bear_Idle_Walk: Bear_Idle_Stop
    		{
    			duty = -0.7;
    			file = "\wlk_animals\bear\anim\bear_walk";
    			speed = 0.4;
    			variantsAI[] = {};
    			looped = 1;
    			soundEdge[] = {0.5}; 
    			soundEnabled = 1;
    			soundOverride = "bear_roar";
    			head = "headDefault";
    			connectTo[] = {"Bear_Idle_Stop",0.1};
    			interpolateTo[] = {"Bear_Idle_Run",0.1,"Bear_Idle_Eat",0.1,"Bear_Idle_Stop",0.1,"Bear_Stop",0.5,"Bear_Walk",0.5,"Bear_Run",0.5,"Bear_Die",0.1};
    		};

    but it is still silent when animation is running.


  6. So i managed to get a working model with crappy animations.

    But I have some questions:

    Does the walk animation need to move forward in the animation itself? Because it won't move forward like my animation in blender.

    Does all animation need to have the same pose on start? I have weird Legs from walking to running.


  7. try this on open door :

    condition = ((this animationSourcePhase 'door_01') < 0.5);
    statement = this animateSource ["door_01",1];

    this on close door:

    condition = ((this animationSourcePhase 'door_01') >= 0.5);
    statement = this animateSource ["door_01",0];

    and make shure that you have the door selections right in all lods, especially with geometry lod


  8. Hy. I'm working on a bear for arma.

    I have the problem when packing with PBOProject:

    AUZj40m.png

     

    I have read and watched many tutorials for animations(I think all of them).

    I export the animation from blender as bhv file to oxygen and modify the bones size until it fits.

    Then I set Autotime 1.0 and export as RTM.

    When i test the RTM on the model it works.

    All bones in p3d animation fit the names of the bear model.

    What do i miss with this error?

     

    my model.cfg: https://pastebin.com/g6S2Dg3f

    my config: https://pastebin.com/sCQuTYwK

     

    my model: https://cloud.walk3r.info/index.php/s/HXzqUubt9jTbime

    with brownbear_animations.p3d i create the rtms per LOD. (not all animations fit correctly. last lod works)

     

×