Jump to content

logan83

Member
  • Content Count

    125
  • Joined

  • Last visited

  • Medals

  • Medals

Posts posted by logan83


  1. On 22/2/2017 at 0:39 AM, tpw said:

    Hi logan83. 

     

    There's no reason why that trigger shouldn't work. I have a similar trigger set up as a test on altis and it works as advertised. The various tpw_xxx_active variables all definitely work

     

    Because you're allowing 15 seconds for the trigger to kick in it's possible that some of the TPW MODS will have spawned things before being deactivated.

     

    What happens if you enter hint str tpw_civ_active  in the debug console?

    Ok i reduce the time in the condition to 10 secs, and check all the modules with the Hint Str command and now all are false except tpw_Cars_active, i check the condition "tpw_car_delay" in userconfig\tpw_mods\tpw_mods.hpp and its set to 10Secs,well, i reduce the time in the trigger condition to 5 seconds and works well :) im sorry was my fault. thanks for all!


  2. in a trigger :

    on act: tpw_air_active=false; tpw_boat_active=false; tpw_car_active = false; tpw_civ_active = false; tpw_park_active = false; tpw_radio_active = false; tpw_skirmish_active = false; tpw_soap_active = false; tpw_streetlights_active = false; 

    shape type circle over all stratis island 

    type: bluefor present rep.

    condition: vehicle player in thislist && time > 15;

     

    this dont work to me, cars spawning everytime people and all the stuff... whats wrong?

     

    omly can disable enable stuff in userconfig file


  3. Hi Dudes! im Working in a training mision to my Campaign, and have some Firing Ranges With Random Targets etc... But I want to make a Range with Raised targets, and when i shoot to them make a downed targets count, like in a Raid or a COF. Some Body Know how can i make it? i try this but doesnt work :(

    popup=FALSE;
    _count = 0;
    _targets  = [CQB_1, CQB_2, CQB_3, CQB_4, CQB_5, CQB_6, CQB_7, CQB_8, CQB_9, CQB_10, CQB_11, CQB_12, CQB_13, CQB_14, CQB_15, CQB_16, CQB_17, CQB_18, CQB_19, CQB_20, CQB_21, CQB_22, CQB_23, CQB_24, CQB_25, CQB_26, CQB_27];
    nopop=true;
    {_x  animate["terc",0]} forEach _targets;
    hint "GoGoGo";
    sleep 5;
    
    while {_count<26} do {
    sleep 2;
     if (_targets animationPhase "terc" > 0.1) then {
    		_count = _count+1;
    		    };
    
       hint format ["Hit :%2",_count];
    
    };
    sleep 4;
    

  4. hi lifetap, this dont work

     

    FFV seems to use the cargo view LOD by default, but switches to the gunner view LOD when you aim.

     

    The roll bars may be missing from your gunner view LOD.

     

    Setting the LODTurnin/LODTurnout to 1000, which is the gunner LOD, will not bring back the roll bars, as they're missing from the model.

     

    Try setting it to 1200 (Cargo view LOD)

    hi lifetap thanks for yor answer, i tryed this, dont work, im think i miss something in the P3d model... somebody have any idea?? 

     

    ----------------------------------------------------------------SOLVED----------------------------------------------------------------------------------------

     

    A simple space in a proxy name :(


  5. 		class Turrets {
    			class CargoTurret_01: CargoTurret {							/// position for Firing from Vehicles
    				gunnerAction 				= "passenger_inside_1";		/// generic animation for sitting inside with rifle ready
    				gunnerCompartments 			= "Compartment2";			/// gunner is not able to switch seats
    				memoryPointsGetInGunner 	= "pos Fpos";				/// specific memory points to allow choice of position
    				memoryPointsGetInGunnerDir 	= "pos Fpos dir";			/// direction of get in action
    				gunnerName 					= "Firing Seat (LEFT)";		/// name of the position in the Action menu
    				proxyIndex 					= 6;						/// what cargo proxy is used according to index in the model
    				maxElev 					= 30;						/// what is the highest possible elevation of the turret
    				minElev 					= -25;						/// what is the lowest possible elevation of the turret
    				maxTurn 					= 50;						/// what is the left-most possible turn of the turret
    				minTurn 					= -85;						/// what is the right-most possible turn of the turret
    				isPersonTurret 				= 1;						/// enables firing from vehicle functionality
    				ejectDeadGunner 			= 0;						/// seatbelts included
    				LODTurnedIn 				= 1000;
    				LODTurnedOut 				= 1000;
    				//enabledByAnimationSource 	= "Doors";					/// doesn't work unless the said animation source is 1
    			};
    
    			class CargoTurret_02: CargoTurret {							/// position for Firing from Vehicles
    				gunnerAction 				= "passenger_inside_1";		/// generic animation for sitting inside with rifle ready
    				gunnerCompartments 			= "Compartment2";			/// gunner is not able to switch seats
    				memoryPointsGetInGunner 	= "pos Fpos1";				/// specific memory points to allow choice of position
    				memoryPointsGetInGunnerDir 	= "pos Fpos1 dir";			/// direction of get in action
    				gunnerName 					= "Firing Seat (RIGHT)";	/// name of the position in the Action menu
    				proxyIndex 					= 7;						/// what cargo proxy is used according to index in the model
    				maxElev 					= 30;						/// what is the highest possible elevation of the turret
    				minElev 					= -25;						/// what is the lowest possible elevation of the turret
    				maxTurn 					= 85;						/// what is the left-most possible turn of the turret
    				minTurn 					= -34;						/// what is the right-most possible turn of the turret
    				isPersonTurret 				= 1;						/// enables firing from vehicle functionality
    				ejectDeadGunner 			= 0;						/// seatbelts included
    				LODTurnedIn 				= 1000;
    				LODTurnedOut 				= 1000;
    				//enabledByAnimationSource 	= "Doors";					/// doesn't work unless the said animation source is 1
    			};
    		};
    

    what im doing wrong?


  6. Do not prompt how to do it ? Or is there some guide on this ?

     

    the Proxy, in the 3Dmodel, to create a Fire From Vehicle position, simply move up/elevate the position about 30 centimeters... proxy for FFV seats appear slightly below the rest of proxys when you load the model in the game... in my Land Rover i Have to modify the proxys position to let all at the same height.


  7. Hi dudes, im makin a PMC mod and one of the vehicles ive included has giving me head pain... its a chevrolet suburban, with two issues, when i shoot to the car, the impact sounds like metal or glass, depending where i shoot, but the particles are like sand :( it hurt my eyes :S how can i Fix This?

     

    pkB5sX6.jpg

     

    The other issue, its in the mirrors, i want to put PIP mirrors, but i cant, this is my CFG

    // Pip Imagen Retrovisores
    		class RenderTargets {
    			class LeftMirror {
    				renderTarget = "rendertarget0";			/// parameter renderTarget defines which texture shall the source be mapped at (only the rendertargetX part is used)
    				class CameraView1 {						/// class CameraView1 is a subclass of this source and contains all the parameters for rendered scene
    					pointPosition = "PIP0_pos";			/// pointPosition and pointDirection should be respective memory points in model
    					pointDirection = "PIP0_dir";
    					renderQuality = 2;					/// renderQuality is in range from 0 to 2 and defines quality of rendering for said source
    					renderVisionMode = 4;				/// renderVisionMode defines the vision mode - 0 = HDR, 1 = NightVision, 2 = ThermalVision, 3 = Color, 4 = Mirror
    					fov = 0.7;							/// fov defines field of view of this source
    				};
    			};
    			class RightMirror {
    				renderTarget = "rendertarget1";
    				class CameraView1 {
    					pointPosition = "PIP1_pos";
    					pointDirection = "PIP1_dir";
    					renderQuality = 2;
    					renderVisionMode = 4;
    					fov = 0.7;
    				};
    			};
    			class FrontCam {
    				renderTarget = "rendertarget2";
    				class CameraView1 {
    					pointPosition		= "PIP2_pos";
    					pointDirection		= "PIP2_dir";
    					renderQuality 		= 2;
    					renderVisionMode 	= 4;
    					fov 				= 0.7;					
    				}; 			
    			};			
    		};
    	};

    Im Not having any errors simply dont work, searching in BIWiky i found this:

    "renderTarget: what texture is going to be used, it should be mapped in model like #(argb,256,512,1)r2t(rendertarget0,1.0)" but cant Understand this and dont know how do this... its chinese for my :S

     

    Sorry about my english Guys :(


  8. Hi dudes, im trying to add 2 FFV Seats in a LAND LOVER, but have a issue, in third view all works like a charm, if i Aim trough the optics/ironsights of the weapons works perfectly, but wen i enter in first person, the model lose the antiroll bars, the other tubes, and the benches... it only happen in the FFV seat, the cargo seats and driver seat are fine. Some Help? I think It culd be aproblem of the 3D model but Im a newbie. I search and cant find a solution only a buddy with a similar problem...

     

    ironshigt view, its ok

    AsU77fo.jpg

     

     

    First Person view, Where are the RollBars and the Benches?

    U48Etx2.jpg

     

    Extract of Confing where define FFV

    		class Turrets {
    			class CargoTurret_01: CargoTurret {							/// position for Firing from Vehicles
    				gunnerAction 				= "passenger_inside_1";		/// generic animation for sitting inside with rifle ready
    				gunnerCompartments 			= "Compartment2";			/// gunner is not able to switch seats
    				memoryPointsGetInGunner 	= "pos Fpos";				/// specific memory points to allow choice of position
    				memoryPointsGetInGunnerDir 	= "pos Fpos dir";			/// direction of get in action
    				gunnerName 					= "Firing Seat (LEFT)";		/// name of the position in the Action menu
    				proxyIndex 					= 6;						/// what cargo proxy is used according to index in the model
    				maxElev 					= 30;						/// what is the highest possible elevation of the turret
    				minElev 					= -25;						/// what is the lowest possible elevation of the turret
    				maxTurn 					= 50;						/// what is the left-most possible turn of the turret
    				minTurn 					= -85;						/// what is the right-most possible turn of the turret
    				isPersonTurret 				= 1;						/// enables firing from vehicle functionality
    				ejectDeadGunner 			= 0;						/// seatbelts included
    				//enabledByAnimationSource 	= "Doors";					/// doesn't work unless the said animation source is 1
    			};
    
    			class CargoTurret_02: CargoTurret {							/// position for Firing from Vehicles
    				gunnerAction 				= "passenger_inside_1";		/// generic animation for sitting inside with rifle ready
    				gunnerCompartments 			= "Compartment2";			/// gunner is not able to switch seats
    				memoryPointsGetInGunner 	= "pos Fpos1";				/// specific memory points to allow choice of position
    				memoryPointsGetInGunnerDir 	= "pos Fpos1 dir";			/// direction of get in action
    				gunnerName 					= "Firing Seat (RIGHT)";	/// name of the position in the Action menu
    				proxyIndex 					= 7;						/// what cargo proxy is used according to index in the model
    				maxElev 					= 30;						/// what is the highest possible elevation of the turret
    				minElev 					= -25;						/// what is the lowest possible elevation of the turret
    				maxTurn 					= 85;						/// what is the left-most possible turn of the turret
    				minTurn 					= -34;						/// what is the right-most possible turn of the turret
    				isPersonTurret 				= 1;						/// enables firing from vehicle functionality
    				ejectDeadGunner 			= 0;						/// seatbelts included
    				//enabledByAnimationSource 	= "Doors";					/// doesn't work unless the said animation source is 1
    			};
    		};
    

  9. Hi Silola,

    The X-CAM program really Looks great, but on Startup, I do not get the menu which lets me activate the object classes as shown in your Video. The X-Cam just loads up and Shows the Player charater, but all of the object menus are empty. When I try to go to the Rebuild Object Library Menu, I can select an object class to rebuild, but when I do so, there is still nothing listed under the OBJ tab. Furthermore, when I try to Rebuild the Vehicle Library, I get an error message that the required script is not found. I checked my install against your Video instructions, but there are still no objects listed under the OBJ tab.

    I wonder if anyone else has seen similar behavior?

    Anyway, the Editor Looks great, I hope I can get it to work...

    Thanks for the help!!

    Im Having the same trouble, my X-cam version was dowloaded from Armaholic (last version) i have installed like the videos says, was placed the X-Cam Logic, but wen I startUp the X-Cam, No Loading addons Windows appears, and the utility dont Work

    Runing Windows7 64bits, installed and reinstalled several times the X-Cam :( Some Help?

    PS: The Tool looks awesome!

    ---------- Post added at 17:16 ---------- Previous post was at 16:49 ----------

    Here two Msg error when execute x-cam

    Q2AytMW.jpg

×