Jump to content

tinter

Member
  • Content Count

    526
  • Joined

  • Last visited

  • Medals

  • Medals

Everything posted by tinter

  1. I was wondering if it was possible to make it so that only squad leaders and certain other units have NVGs, and all others get flashlights for their gun. I'm spawning enemies by script, they're AI, so it would need to be a script that checks in every few seconds or so, I'd presume.
  2. I actually managed to fix it, but it was right before I went to work so I didn't get to post it here. It was indeed a problem on my side, but no big issue. Here's the code I used. _loop=true; while {_loop} do { { if((side _x == opfor) && ((leader group _x) != _x)) then { // if you're a baddie and not your own group leader _x unassignItem "NVGoggles"; _x removeItem "NVGoggles"; _x removePrimaryWeaponItem "acc_pointer_ir"; _x addPrimaryWeaponItem "acc_flashlight"; _x enableGunLights "ForceOn"; }; } foreach (allUnits); sleep 30; };
  3. Alright, I'll try to mess with it a bit.
  4. Your code is giving me an error about _x being an undefined variable. It's stopping the script from working.
  5. I'm spawning them using the EOS script. It's not my script so I'm not sure how I'd go about editing them like that. ---------- Post added at 23:38 ---------- Previous post was at 23:36 ---------- Anyway, thanks for the help. I'm sure I'll be able to work something out now. I appreciate it.
  6. I know how to remove NVG and add flashlights. And I guess I could just loop the script so it would work for all newly spawned enemies, but I haven't heard about how to do a class check? I'm having a bit of trouble finding anything related to it. ---------- Post added at 22:33 ---------- Previous post was at 22:30 ---------- I was thinking more something that goes like this: Warning, pseudo code. checking = false check classname of each spawned opfor unit if a leader or some other thing then do nothing else then remove nvgs and add flashlights to gun and make them use it wait 10 seconds or whatever. checking=true to loop
  7. Is it possible to have a 30% of spawning 1 APC? Since for my mission, I found if I just used random 1, it spawned way too many vehicles.
  8. Hey it's me again! I fixed the vehicle despawning problem, mostly. In eos_SpawnVehicle.sqf line 70. Change if (!_active) then { To if (!_active && !(player in _vehicle) ) then { . The vehicle will not depsawn, but once the player has left it, it disappears instantly. To fix this I added an else command in as line 75, it says else {_loop=false};
  9. It had happened on a few occasions before, but I don't think it's that much of a problem, it's not that common anyway, and it seems to happen less now.
  10. It also looks like you took out the reinforcements option. I used this to spawn random enemies the player would encounter in my mission. I would have used the light patrol option, but I found it would sometimes spawn the squads right next to the player. Particularly when starting the mission. ---------- Post added at 09:33 ---------- Previous post was at 09:32 ---------- I guess I'll just switch back to light patrols.
  11. I don't suppose I could add a code that checks if a player is inside a vehicle then? I've tried looking through the scripts to see what I could do myself with my limited knowledge, but I'm not even sure I can find the part I'm looking for.
  12. I'd be fine if you could tell me how to make it so nothing despawns, since I could just use the simulation manager for that.
  13. I made my own version of Escape From Stratis using this. I was just wondering, is it possible I can take out the part of the script that despawns units once they get too far away from their zones? I want it because if a player steals an enemy vehicle, it'll despawn and that's very bad if a player is using a boat to escape the island. I was thinking if I took it out, I could just use the simulation manager module to make sure enemies aren't taking up resources. ---------- Post added at 21:51 ---------- Previous post was at 21:48 ---------- Also is it possible to fill the assault boats and vehicles? I was just thinking since it sometimes spawns the Zamak and HEMTT transports, they're kinda useless if they're empty.
  14. I'm very willing to try. Just need to know what files to edit, but it looks like I can figure that out myself. Want me to report back if I have any luck? ---------- Post added at 22:32 ---------- Previous post was at 21:05 ---------- So I tried. Don't know how functions work, but I just replaced BIS_fnc_relPos with BIS_fnc_findSafePos in line 96 and 106. Got some errors, caught these two. Don't know what to make of this. If I had to make a guess, it looks to be something with the function itself. ---------- Post added at 22:35 ---------- Previous post was at 22:32 ---------- A quick google, it expects a boolean, but isflatempty returns an array. Zero divisor? Never heard of it.
  15. Oh is this something I can possibly add myself?
  16. Love this script. There's just the problem that it seems vehicles sometimes spawn inside buildings or stuff like that. Then they explode.
  17. @Kju That is correct. I'm not lone in this issue as it happened to my friend too. It was only for pistols, all other weapons worked fine. ---------- Post added at 14:58 ---------- Previous post was at 14:56 ---------- Also I can see others have reported the issue of the Javelin and Metis aiming backwards, as in through the computer, but still firing forwards. Not to mention it seems that when you actually fire the computer of the launchers disappear.
  18. Here's my rpt. I deleted about 58,000 lines complaining about bones not existing. It's down to still 1,200 lines. Sorry. http://pastebin.com/Pg4nk88a Also, I should be running the very latest, cleanly installed version. I'll try to rename it and download it again. Also, running a clean, newly download .bat. ---------- Post added at 20:10 ---------- Previous post was at 20:00 ---------- Please ignore my issue. It got fixed when I ran a whole new clean mod folder. I'm sorry for any confusion. ---------- Post added at 20:48 ---------- Previous post was at 20:10 ---------- So through the scientific method, I have concluded the cause of ironsights being broken for pistol was because I had moved the AiA_ActivateA3Models.pbo and .bisign files.
  19. I read somebody had a similar issue and it didn't work for my friend either. I don't suppose you could take pictures?
  20. That's odd. I specifically tried without any mods.
  21. I'm saying that the pistol ironsights don't work in that when you try, the weapon does not move and the crosshair just dissappears and a slight blur appears. It's broken for all pistols, Arma 2 and Arma 3. Were you not aware of this?
  22. I guess it's no secret that pistol ironsights don't work. Does anybody know why, and can it be fixed? It's all pistol ironsights including Arma 3.
  23. I'm using the FDF mod and it works fine, but the sound is many kinds of messed up. On the RK-95 there's no shooting sound. The pistol just make a weird little click and the helicopter is just terrible. Does anybody know what can be the cause of sounds not working correctly?
  24. @.kju I've found out that the overlay used differs from mission to mission and doesn't show anything when I just preview in the editor. The mission I showed was the Zargabad Life showcase. I also tries PMC Showcase which was even worse since I couldn't even see anything when flying a helicopter, but I'll just steer away from these missions. If there's anything you do want to know, then ask me and I'll be happy to provide.
  25. I hope this isn't some known issue that I know nothing about, but it seems that on Arma 2 maps there's this color overlay which looks ugly and drops my fps down by 10. It doesn't show in the options screen and I couldn't find any option that helped with the problem. Comparison pictures. Has anybody encountered something like this? Also I'm glad you devoted your time to make this, I really appreciate this mod. ---------- Post added at 22:29 ---------- Previous post was at 22:29 ---------- It wouldn't let me post links without having posted a post first, so I hope it's alright I put it in a second reply. http://i.imgur.com/IclNduS.jpg http://i.imgur.com/gz1THf9.jpg
×