Jump to content

allarvendla

Member
  • Content Count

    14
  • Joined

  • Last visited

  • Medals

  • Medals

Community Reputation

10 Good

About allarvendla

  • Rank
    Private First Class

Contact Methods

  • Twitch.Tv
    allavett

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Looking really good! (Y)
  2. Ok, as a last resort I turned to Hex editing (not the most "legal" way of doing things, I know), but that fixed it. So, my question now is, should I submit a ticket for the issue? Or is there still a mistake in my code (rvmat or config - maybe I am using hiddenSelectionsMaterials wrong??)?
  3. Made a small video of the problem I am having. Maybe this will spark new ideas :)
  4. Yes, exactly like that :) And I know that custom RVMAT is being used, because I can see that my custom NOHQ map is there. Also, I tried using only hiddenSelectionsMaterials without hiddenSelectionsTextures and still got the same result. And as I stated in OP that I even tried using original RVMAT file. I did it like this: hiddenSelectionsMaterials[] = {"A3\weapons_f\ammoboxes\bags\data\backpack_fast.rvmat"}; Did not change a thing. Only way to have normal backpack is if I don't add hiddenSelectionsMaterials. But then it does not look exactly how I want it to look :'(
  5. Jackal326, thanks for the suggestions. Tried all of your ideas, but still no joy :/
  6. Hello guys! I have created a custom texture for a backpack (B_Kitbag_Base). New texture Works fine, but I also want to change NOHQ map. This means I need to change RVMAT. I created custom RVMAT and made a change in my config.cpp to point at it. But as I added the line hiddenSelectionsMaterials[] = {"edf\Data\edf_kitbag_medic_nohq.paa"}; It screwed up the models materials. Model lost shadow and seems to be half transparent: http://i.gyazo.com/297e4dfffd3c02815327366969d6bc87.png (216 kB) At first I thought there is something wrong with my RVMAT file and tried using original RVMAT (in its original direction). That gave same result. config.cpp: class B_Kitbag_Base; class Bacpack_Medic_Forest_retexture: B_Kitbag_Base { scope = 2; displayName = "EDF Kitbag Medic [Forest]"; picture="\edf\data\ui\edf_kitbag_medic_icon_co.paa"; hiddenSelections[] = {"Camo"}; hiddenSelectionsTextures[] = {"\edf\data\forest\edf_kitbag_forest_medic_co.paa"}; hiddenSelectionsMaterials[] = {"\edf\data\edf_kitbag_medic.rvmat"}; }; RVMAT code: class StageTI { texture="a3\data_f\default_ti_ca.paa"; }; ambient[]={1,1,1,1}; diffuse[]={1,1,1,1}; forcedDiffuse[]={0,0,0,0}; emmisive[]={0,0,0,1}; specular[]={1,1,1,1}; specularPower=100; PixelShaderID="Super"; VertexShaderID="Super"; class Stage1 { texture="edf\Data\edf_kitbag_medic_nohq.paa"; uvSource="tex"; class uvTransform { aside[]={1,0,0}; up[]={0,1,0}; dir[]={0,0,0}; pos[]={0,0,0}; }; }; class Stage2 { texture="#(argb,8,8,3)color(0.5,0.5,0.5,1,DT)"; uvSource="tex"; class uvTransform { aside[]={1,0,0}; up[]={0,1,0}; dir[]={0,0,0}; pos[]={0,0,0}; }; }; class Stage3 { texture="#(argb,8,8,3)color(0,0,0,0,MC)"; uvSource="tex"; class uvTransform { aside[]={1,0,0}; up[]={0,1,0}; dir[]={0,0,0}; pos[]={0,0,0}; }; }; class Stage4 { texture="a3\weapons_f\ammoboxes\bags\data\backpack_fast_as.paa"; uvSource="tex"; class uvTransform { aside[]={1,0,0}; up[]={0,1,0}; dir[]={0,0,0}; pos[]={0,0,0}; }; }; class Stage5 { texture="a3\weapons_f\ammoboxes\bags\data\backpack_fast_smdi.paa"; uvSource="tex"; class uvTransform { aside[]={1,0,0}; up[]={0,1,0}; dir[]={0,0,0}; pos[]={0,0,0}; }; }; class Stage6 { texture="#(ai,64,64,1)fresnel(1,0.7)"; uvSource="none"; }; class Stage7 { texture="a3\data_f\env_land_co.paa"; uvSource="tex"; class uvTransform { aside[]={1,0,0}; up[]={0,1,0}; dir[]={0,0,0}; pos[]={0,0,0}; }; }; Any thoughts and suggestions are more then welcome :)
  7. allarvendla

    Military cap without headset

    Ok, thanks for the tip. I'll do some more digging :)
  8. Hello guys! I am working on an addon to retexture some items. At the moment I am working on cappatrol.3pd retexture. I would love to have 2 variants of it. One without the headest and one with the headset. But there seems to be only one variant of it. And that's with the headset. So I opened the model in oxygen and saw that it has two textures (one for the cap and one for the headset). Doing some testing I discovered that changing headset texture with an empty one (inside O2) made the headset dissapear. I don't want to change the model (as I understand it is forbidden to change BIs work) I wonder if there is some way I could replace headgears texture with empty texture using config or some other voodoo.. I searched through the config.cpp's but did not find anything on headset texture. At this point I have ran out of ideas. Maybe You have some useful suggestions? :) Allar
  9. Viba, thank you, thank you, thank you! Kiitos! Aitäh!:rolleyes: My final script looks like this: BIS_Effects_Burn=compile preprocessFileLineNumbers "\ca\Data\ParticleEffects\SCRIPTS\destruction\burn.sqf"; //Run a check on the server for helis, if unable to fly make them burn. if (isMultiplayer) then { while {true} do { _helicopters = [heli1, heli2, heli3, heli4, heli5, heli6, heli7, heli8, heli9, heli11, heli12]; //add all the helis here { _heli = _x; _fuel = fuel _heli; if (!(canMove _heli) && (_fuel > 0)) then { _heli setHit ["motor", 1]; _heli setFuel 0; [_heli, 3, time, false, true] spawn BIS_Effects_Burn; _heli vehiclechat "Engine is on fire!"; _heli vehiclechat "It might explode at any moment!"; _heli sideChat format["I am going down!"]; sleep 0.01; }; } forEach _helicopters; }; }; And it seems to work perfectly! :) I could not have done it without your help! Now I have to get some friends and test it out for real.
  10. Thank you Viba! This is almost what I want. But there are slight "problems" with it. Helos, that are unmanned won't run this script and therfore will not start burning. Using your idea I wrote this: if (isMultiplayer) then { while {true} do { _damage1 = getDammage heli1; if (!canMove heli1 and _damage1 < 0.9) then { heli1 setDammage 0.95; [heli1, 3, time, false, true] spawn BIS_Effects_Burn; heli1 vehiclechat "Engine is on fire!"; heli1 vehiclechat "It might explode at any moment!"; sleep 0.2; heli1 sideChat format["I am going down!"]; }; _damage2 = getDammage heli2; if (!canMove heli2 and _damage2 < 0.9) then { heli2 setDammage 0.95; [heli2, 3, time, false, true] spawn BIS_Effects_Burn; heli2 vehiclechat "Engine is on fire!"; heli2 vehiclechat "It might explode at any moment!"; sleep 0.2; heli2 sideChat format["I am going down!"]; }; _damage3 = getDammage heli3; etc.. }; }; to check each helo one by one. This will give me the result I am going for. But I have 12 helos on the map and I wonder if there is some way I could use arrays to solve it? Seems a bit stupid to write all this code. And making changes to it will be really tedious :/
  11. Sorry for that, did not manage to ask a proper question indeed :/ I'll explain it a little further. My goal is to respawn helos that can't fly anymore. To achieve this, I use the script shown in OP. This script is attached to every helo on the map. So if the mission starts this script will run on each helo to check it's ability to fly. If helo gets damaged it will explode at a random moment and then respawn. This is done on the first half of the script, that will only run on server: if (isDedicated) then { while{_loopServer} do{ if (!canMove _heli) then{ sleep (5 + (random 25)); _heli setdammage 1; sleep 1; _new = _type createVehicle _pos; _new setPos _pos; nul = [_new] execVM "heli_respawn.sqf"; _new setVehicleInit format ["%1 = this; this setVehicleVarName ""%1""", _heli]; processInitCommands; _loopServer = false; }; }; }; And the second half will run on client to set helo on fire and give notification to player that it is wise to eject. while{_loopClient} do{ if (!canMove _heli) then{ [_heli, 3, time, false, true] spawn BIS_Effects_Burn; Vehicle _heli vehiclechat "Engine is on fire!"; Vehicle _heli vehiclechat "It might explode at any moment!"; sleep 0.2; _heli sideChat format["I am going down!"]; _loopClient = false; }; }; }; The problem is that after respawn the second half of the script will not run on client but on server. And so players won't see the messages or the smoke. How could I force the second half to run again on clients?
  12. Hello, I have been scratching my head for a while now conserning a little MP DM "mission" I am working on. The probleem is that I want to send messages via Chat if their helo is not able to fly anymore. And also add some smoke efect to the bird when it has failed. Here is the main code that respawns helos and sends messages: _heli = _this select 0; _pos = [((getPos _heli) select 0) + random 15 - random 15, ((getPos _heli) select 1) + random 15 - random 15, ((getPos _heli) select 2) + 0.1]; _dmg = getDammage _heli; _type = typeOf _heli; _loopServer = true; _loopClient = true; if (isDedicated) then { while{_loopServer} do{ if (!canMove _heli) then{ sleep (5 + (random 25)); _heli setdammage 1; sleep 1; _new = _type createVehicle _pos; _new setPos _pos; nul = [_new] execVM "heli_respawn.sqf"; _new setVehicleInit format ["%1 = this; this setVehicleVarName ""%1""", _heli]; processInitCommands; _loopServer = false; }; }; }; while{_loopClient} do{ if (!canMove _heli) then{ [_heli, 3, time, false, true] spawn BIS_Effects_Burn; Vehicle _heli vehiclechat "Engine is on fire!"; Vehicle _heli vehiclechat "It might explode at any moment!"; sleep 0.2; _heli sideChat format["I am going down!"]; _loopClient = false; }; }; }; As can be seen, first half of it runs on the server side of things - so I don't get multiple helos spawned. The second half runs or should run on client. I tried using if (isMultiplayer) then ..blabla for the second half. But it did not help. "Works" the same without it. The script itself is attached to every helo on the map. So multiple instances of it run at the same time but each helo has its own name. Everything works as it should until first respawn for each bird. I don't know if there is a solution to what I'm asking or if anyone even understood my problem, but I hope that someone just might know how to help me. I am quite new to scripting :/ So I would really appreciate any help I can get :) I also made a little video of it: http://www.twitch.tv/allavett/b/506866092
  13. allarvendla

    BAF setup crashes on Windows 8.1

    Download new setup files from Bohemia store and all will be good. I promise, it was for me ;)
  14. As was said in earlyer post, in Arma 3 the script does not work correctly. Use the one suggested instead. I tried it and it worked
×