Jump to content

logitrust

Member
  • Content Count

    98
  • Joined

  • Last visited

  • Medals

Posts posted by logitrust


  1. New issue accured. Now the missions will not load on first atempt after restarting the server. But when restart mission 2'nd the mother.f.... will start running. here's somthing from the .RPT

    Server error: Player without identity Logitrust (id ********)

    ca\missions\MPScenarios\MP_Deathmatch.chernarus: string @str_mpdeathmatch_subname cannot be localized client-side - move to global stringtable

    FuelStation is not soldier nor transport.

    No transport

    [19021,417.866,0,"XEH: PreInit Started"]

    [19021,419.268,0,"MISSINIT","Objective Takistan v01d","Takistan",true,true,true]

    [19021,424.355,0,"XEH: PreInit Finished"]

    Error in expression <//RuckBox//>

    Error position: <//RuckBox//>

    Error Invalid number in expression

    Error in expression <};>

    Error position: <};>

    Error Missing {

    ...

    Fixed. Server re-install did the work. now allsow running a ace-update script to the server ;-)


  2. Hi! I'm experiencing a very odd sound problem with the game. i have tested and see if its differnce from hosting from annother pc/server and from my own pc.. what I learned is that the audio / bombs / shots in the

    peripheral 200m does not sound. One can see that it is fired from aweapon at about 150 - 200m, but no sound. Same goes with bombing (a10) and arty at longer distances. What, and why? solution? Rembember when only playing ArmA2 that this was no issue. Do run some soundmods, i list them here:

    CSM2BAF_v0.1a

    JSRS_Mod_Beta0.99b

    Whats wierd, is that it happens without these enabled, so I exclude that they may have something to do with this.


  3. Whats wrong here. This appare after updated my server to the latest patch 1.55 from bohemia

    Copy of .RPT

    -mod=@ACE;@ACEX;@ACEX_SM;@CBA;@ACRE
    
    Exe timestamp: 2010/11/16 09:14:25
    Current time:  2010/11/16 18:16:38
    
    Version 1.55.75446
    Item str_disp_server_control listed twice
    Failed to get key "Software\Bohemia Interactive Studio\ArmA 2 OA" from registry.
    Cannot get serial number from registry path "Software\Bohemia Interactive Studio\ArmA 2 OA"
    Failed to get serial numbers for header decryption.
    Failed to create serial header protection class.
    Warning Message: Failed to load file "baf\addons\air_d_baf.pbo" - decryption of headers failed.
    


  4. So let me get this straight... rather than follow the good example of the many people who follow up and explain the solution, you are choosing to follow the bad example of some of the people who don't?

    For the record, I *always* post solutions that I find. I search HEAVILY before posting a question, and rely on past questions and answers to find solutions. I have benefited greatly from the knowledge and experience posted by others. And I am grateful to them for having done it.

    So, the irony monster is grinning broadly at the fact that I actually helped you find the solution, but then you refuse to post the actual solution for the benefit of others.

    GG, sir... GG.

    *golf clap*

    heh, heavy man.. Your input had no influence in this context. Rather I had been somewhat dull when I made the marker script. for reference, see line 6 do_markers.sqf

    Hasta Luego!


  5. Well, in the init, I didn't get very far.

    First, you define 'n' twice, with 2 different things. It might work, but I don't think it is very good coding.

    Then in the second addeventhandler, you're trying to add it to 'this' - but I'm not sure that makes any sense. I've never done a respawn like that, though.

    Then you get into ACE and DAC. Both great mods/addons, but also are at least one order of complexity greater than most scripters can handle. :)

    Good luck.

    All this make sense. Problem solved, and this time im not going to tell how i did it, so i can follow the trend this forum have... :)


  6. Hi! Have some issues with player-units on my OA mp-map wont get there markers after respawning to base. Im alssow using ACE Weapon Respawn script by Cyborg11 thru an eventhandler. Can somone who have expertise take a look at my files, and tell me what i have done wrong? thanks for your attention!

    init.sqf

    setViewDistance 2500;
    
    n=[] execVM "briefing.sqf";
    n=[] execVM "do_marker.sqf";
    
    _KilledHandler = player addEventHandler ["killed", {_this execVM "playerkilled.sqf"}];
    this addEventHandler ["killed", {_this execVM "weaponrespawn.sqf"}];
    
    skiptime (((paramsarray select 0) - daytime + 24) % 24);
    
    ace_sys_tracking_markers_enabled=false;
    
    if(!isServer) then {waitUntil{!isNull player}};
    DAC_Zone = compile preprocessFile "DAC\Scripts\DAC_Init_Zone.sqf";
    DAC_Objects	= compile preprocessFile "DAC\Scripts\DAC_Create_Objects.sqf";
    execVM "DAC\DAC_Config_Creator.sqf";
    
    sleep 2;
    [str ("Mission made for STF") ,   str("by Logitrust")] spawn BIS_fnc_infoText;
    

    playerkilled.sqf

    waituntil {(alive player)};
    
    execVM "briefing.sqf";
    [player] execVM "do_Marker.sqf";
    

    I allsow have poop = [alpha_01] execVM "do_marker.sqf"; in the players init field.

    Have tryed 50 different combinations to get this to work, but still no sucsess.

    ---------- Post added at 03:01 PM ---------- Previous post was at 01:12 PM ----------

    Here is my do_marker.sqf if it can help to find the problem :/

    do_marker.sqf

    //////////////////////////////////////////////////////////////////

    // Function file for Armed Assault //

    // Created by: Logitrust/twirly - Enchanced by kylania //

    //////////////////////////////////////////////////////////////////

    // Call by:

    // poop = [object] execVM "do_marker.sqf";

    private ["_markerType","_unit","_markerName","_markerText","_markerColor"];

    // Grab unit object

    _unit = _this select 0; //

    // Create marker values

    _markerName = "marker" + str(_unit); //

    _markerText = if (isPlayer _unit) then {toUpper name _unit} else {""};

    _markerType = ""; // "Man"

    _markerColor = ""; // "ColorWhite"

    // Assign marker type and color

    if (_unit isKindOf "Man") then {_markerType = "Man"; _markerColor = "ColorWhite"};

    if (_unit isKindOf "Tank") then {_markerType = "Tank"; _markerColor = "ColorGreen"};

    if (_unit isKindOf "Air") then {_markerType = "Air"; _markerColor = "ColorOrange"};

    if (_unit isKindOf "Car") then {_markerType = "Car"; _markerColor = "ColorBlue"};

    // If non matching item, give defaults

    if (_markerType == "") then {_markerType = "Dot"};

    if (_markerColor == "") then {_markerColor = "ColorBlack"};

    // Create the marker

    createMarker[_markerName,[1,1,1]];

    _markerName setMarkerShape "ICON";

    _markerName setMarkerType _markerType;

    _markerName setMarkerText _markerText;

    _markerName setMarkerColor _markerColor;

    // Maintain marker.

    while {alive _unit} do

    {

    _markerName setMarkerPos getPos _unit;

    sleep 2;

    };

    // Clean up.

    deleteMarker _markerName;

    ---------- Post added at 03:59 PM ---------- Previous post was at 03:01 PM ----------

    allmost 60 hits, and no feedback. this forum can be so funny!


  7. okay, then there is certainly something in what you say there, when I go into the server via ftp it looks there is a arma2oa.exe, arma2oaserver.exe and arma2server.exe.

    But is that not entirely hopeless? Does that mean the people who not have combined, like myself, can not play with those who have it, and vice versa? Poorly thought of bis I must say...

    One more thing, i see that my server runs 1.54, that means that its compatible with BAF, am i right?

    ---------- Post added at 08:45 AM ---------- Previous post was at 08:28 AM ----------

    Just standard mission's at the moment. I went to armaholic and downloaded a mission cald co40_adayinthelife.Takistan_v1.pbo , chekd out the mission.sqm, and other files, seams not to be any addons to that mission. But im still getting the same error.

    What can pay off then. Reinstalling arma2 and arrohead to the same root folder, then update ace2 via six, or updating ace2 like situation is now(preserve ace2) and then uninstall, install the games together in same root? Think that I must have the proper ace files for the server side, in this case i do not see any other solution than update ace2 via the client, then add the new files over via ftp to the server after i have added the mods to the commando line to the server. Is it any update scripts out there? As I recall from having played arma2 since it came out, it was updates average every other day, every week.


  8. Hi! Now i have converted my server to ArmA2 Operation Arrowhead. All have been done with a fresh install. Its the staff on Gameservers.com who have done that, since i am renting a dedicated server from them. My goal is to host ace2 and acre mods on the server for our new clan, but first i want to test with no mod's to see that the servers works. I have done that, and unfortunately it was not for the expectations. Error when trying to connect:

    you cannot play/edit this mission; it is dependent on downloadable content that has been deleted. cabuildings2_misc_cargo , caweapons_ammoboxes

    My arma2oaserver.RPT seams fine, i think? hehe

    ==========================================================

    == c:\games\217_195_179_109\853524\arma2\arma2oaserver.exe

    == c:\games\217_195_179_109\853524\arma2\arma2oaserver.exe -port=2302 -config=default\server.cfg -cfg=default\arma2.cfg -profiles=default -exThreads=1

    ==========================================================

    Exe timestamp: 2010/08/31 06:07:53

    Current time: 2010/10/11 09:22:31

    Version 1.54.72889

    Item str_disp_server_control listed twice

    String STR_BAF_CFGMAGAZINES_BAF_PUTIED_V10 not found

    String STR_BAF_CFGMAGAZINES_BAF_PUTIED_V20 not found

    String STR_BAF_CFGMAGAZINES_BAF_PUTIED_V30 not found

    String STR_BAF_CFGMAGAZINES_BAF_PUTIED_V40 not found

    01: Deathmatch: string @str_mpdeathmatch_subname cannot be localized client-side - move to global stringtable

    01: Deathmatch: string @str_mpdeathmatch_subname cannot be localized client-side - move to global stringtable

    No player found for channel 162032640 - message ignored

    On the clientside i run ArmA2 and OA separated. With other words, I have not installed them into the same folder, and I run the BAF -mod to OA. Could it have anything to do with that? OR, can it be that it have somthing to do with the fresh install on the server? If, i have to explain to the staff what we have to do different to get it to work :lecture:

    Thanks for feedbacks in advance


  9. Somone know about another respawn script i can use then? tryd to modify this one, but no luck. Have to be suported to MP

    ---------- Post added at 02:50 PM ---------- Previous post was at 12:57 PM ----------

    okei. to make it more simple. Somone know how to i make a script to the init.sqf who calls the the player's marker script = do_markers.sqf. Thats all i need to know. Right now i have done this like this:

    init.sqf:

    execVM "weaponrespawn.sqf";

    weaponrespawn.sqf:

    while {true} do {

    waitUntil {!alive player};

    _weapons = weapons player;

    _magazines = magazines player;

    _deadbody = player;

    waitUntil {alive player};

    _p = player;

    removeAllItems _p;

    removeAllWeapons _p;

    hideBody _deadbody;

    {_p addMagazine _x} forEach _magazines;

    {_p addWeapon _x} forEach _weapons;

    _primw = primaryWeapon _p;

    if (_primw != "") then {

    _p selectWeapon _primw;

    // Fix for weapons with grenade launcher

    _muzzles = getArray(configFile>>"cfgWeapons" >> _primw >> "muzzles");

    _p selectWeapon (_muzzles select 0);

    };

    [player] execVM "do_Marker.sqf";

    };

    And yes, i want to know how i can give back the players the markers they started with after they have died, and spawnd back.

    who look like this:

    do_markers.sqf

    //////////////////////////////////////////////////////////////////

    // Function file for Armed Assault //

    // Created by: Logitrust/twirly - Enchanced by kylania //

    //////////////////////////////////////////////////////////////////

    // Call by:

    // poop = [object] execVM "do_marker.sqf";

    private ["_markerType","_unit","_markerName","_markerText","_markerColor"];

    // Grab unit object

    _unit = _this select 0; //

    // Create marker values

    _markerName = "marker" + str(_unit); //

    _markerText = if (isPlayer _unit) then {toUpper name _unit} else {""};

    _markerType = ""; // "Man"

    _markerColor = ""; // "ColorOrange"

    // Assign marker type and color

    if (_unit isKindOf "Man") then {_markerType = "Man"; _markerColor = "ColorOrange"};

    if (_unit isKindOf "Tank") then {_markerType = "Tank"; _markerColor = "ColorGreen"};

    if (_unit isKindOf "Air") then {_markerType = "Air"; _markerColor = "ColorYellow"};

    if (_unit isKindOf "Car") then {_markerType = "Car"; _markerColor = "ColorBlue"};

    // If non matching item, give defaults

    if (_markerType == "") then {_markerType = "Dot"};

    if (_markerColor == "") then {_markerColor = "ColorBlack"};

    // Create the marker

    createMarker[_markerName,[1,1,1]];

    _markerName setMarkerShape "ICON";

    _markerName setMarkerType _markerType;

    _markerName setMarkerText _markerText;

    _markerName setMarkerColor _markerColor;

    // Maintain marker.

    while {alive _unit} do

    {

    _markerName setMarkerPos getPos _unit;

    sleep 2;

    };

    // Clean up.

    deleteMarker _markerName;

    Anyone?


  10. Any ide getting this to work on dedicated server? Not player(client side).

    while {true} do {

    waitUntil {!alive player};

    _weapons = weapons player;

    _magazines = magazines player;

    waitUntil {alive player};

    _p = player;

    {_p addMagazine _x} forEach _magazines;

    {_p addWeapon _x} forEach _weapons;

    _primw = primaryWeapon _p;

    if (_primw != "") then {

    _p selectWeapon _primw;

    // Fix for weapons with grenade launcher

    _muzzles = getArray(configFile>>"cfgWeapons" >> _primw >> "muzzles");

    _p selectWeapon (_muzzles select 0);

    };

    [player] execVM "do_Marker.sqf";

    };

    Have isues that players on my server wont spawn with gear,ammo,weapon etc. Think this can have somthing to do that this script is for local only.

    Read more about my problem here:

    http://forums.bistudio.com/showpost.php?p=1763993&postcount=17

    thank you for your attention -


  11. Since this thread deals with respawn /weaponrespawn, and not least

    while {true} do {

    waitUntil {!alive player};

    _weapons = weapons player;

    _magazines = magazines player;

    waitUntil {alive player};

    _p = player;

    {_p addMagazine _x} forEach _magazines;

    {_p addWeapon _x} forEach _weapons;

    _primw = primaryWeapon _p;

    if (_primw != "") then {

    _p selectWeapon _primw;

    // Fix for weapons with grenade launcher

    _muzzles = getArray(configFile>>"cfgWeapons" >> _primw >> "muzzles");

    _p selectWeapon (_muzzles select 0);

    };

    [player] execVM "do_Marker.sqf";

    };

    I have some questions about the text and summaries of get this to work on a deticated server. Have been searching all over this forum and other, can see that most of the same people are Q'ing there Q's in the other threads, but no answer for the big ''Q'' to find. And im talking about the same problem that larsiano have over here. And since this wrap'dtext(weaponrespawn.sqf) for getting weapons spawn does not work on a server. I've realized this is just something that applies to single-players (LocalSystem). What kind of script/func shall i use? No clue my self. Main reason i want to use this is to respawn the marker with the players after they have met death itself, and repsawn back in base. see? Unfortunately is Norrins script something i can't use in this mission. In terms of the healing part of his script.

    To fix a good solution on weapons respawn is so far no challenge. But nice if included as done here in the weaponrespawn.sqf. As there are many ''ammobox/save gear'' script's out there, i dont see that as a major challenge.

    do_marker.sqf:

    //////////////////////////////////////////////////////////////////

    // Function file for Armed Assault //

    // Created by: Logitrust/twirly - Enchanced by kylania //

    //////////////////////////////////////////////////////////////////

    // Call by:

    // poop = [object] execVM "do_marker.sqf";

    private ["_markerType","_unit","_markerName","_markerText","_markerColor"];

    // Grab unit object

    _unit = _this select 0; //

    // Create marker values

    _markerName = "marker" + str(_unit); //

    _markerText = if (isPlayer _unit) then {toUpper name _unit} else {""};

    _markerType = ""; // "Man"

    _markerColor = ""; // "ColorOrange"

    // Assign marker type and color

    if (_unit isKindOf "Man") then {_markerType = "Man"; _markerColor = "ColorOrange"};

    if (_unit isKindOf "Tank") then {_markerType = "Tank"; _markerColor = "ColorGreen"};

    if (_unit isKindOf "Air") then {_markerType = "Air"; _markerColor = "ColorYellow"};

    if (_unit isKindOf "Car") then {_markerType = "Car"; _markerColor = "ColorBlue"};

    // If non matching item, give defaults

    if (_markerType == "") then {_markerType = "Dot"};

    if (_markerColor == "") then {_markerColor = "ColorBlack"};

    // Create the marker

    createMarker[_markerName,[1,1,1]];

    _markerName setMarkerShape "ICON";

    _markerName setMarkerType _markerType;

    _markerName setMarkerText _markerText;

    _markerName setMarkerColor _markerColor;

    // Maintain marker.

    while {alive _unit} do

    {

    _markerName setMarkerPos getPos _unit;

    sleep 2;

    };

    // Clean up.

    deleteMarker _markerName;

    [player] execVM "do_Marker.sqf";

    My init.sqf

    setViewDistance 5000;

    execVM "briefing.sqf";

    execVM "weaponrespawn.sqf";

    skiptime (((paramsarray select 0) - daytime + 24) % 24);

    if(!isServer) then {waitUntil{!isNull player}};

    DAC_Zone = compile preprocessFile "DAC\Scripts\DAC_Init_Zone.sqf";

    DAC_Objects = compile preprocessFile "DAC\Scripts\DAC_Create_Objects.sqf";

    execVM "DAC\DAC_Config_Creator.sqf";

    Hope someone can get me onto something here :notworthy:. been

    sitting in the same place for a few days now with intense efforts to

    try to find a solution to this without success.

    Ps. I also use the do_markers.sqf in Simple Vehicle Respawn Script v1.7 by Tophe of Östgöta Ops [OOPS]. Works great on cars, air, tank etc..

    can this be somthing?

    http://forums.bistudio.com/showthread.php?t=91366


  12. Scandinavian Task Force



    www.scantask.net

    WE ARE BACK!





    Hostname:

    Scandinavian Task Force

    Clan Tag:

    {STF}

    Gamestyle:

    Co-op & TvT

    Server location:

    Norway

    Timezone:

    GMT+1 Central Europe /NOR/SWE/DEN - English Language

    Contact e-mail:

    scantask@live.com

    Website address:

    www.scantask.net

    Age Restriction:

    18+

    Team Speak 3 Dedicated Server:

    Address = scantask.net

    http://www.teamspeak.com/invite/scantask.net

    Regards,

    Scandinavian Task Force Administration & Command

    d0an.png


  13. okei! :) but remember that the reason I have 74 different markers is

    Because I have 74 different things. that is, different nato-symbols with different colors, etc. planes, tanks, cars, goals, etc.

    this is my markers74.sqf

    createMarker["marker74",[0,0,0]];

    "marker74" setMarkerShape "ICON";

    "marker74" setMarkerType "Man";

    "marker74" setMarkerText "Papa-01";

    "marker74" setMarkerColor "Colororange";

    while {alive papa_01} do

    {

    "marker74" setMarkerPos getpos papa_01;

    sleep 2;

    };

    deletemarker "marker74";

    ---------- Post added at 03:14 PM ---------- Previous post was at 03:13 PM ----------

    so an overview for eatch marker look like this.

    //Markerscript - By Logitrust for Scandinavian Task Force

    //S.T.F.(Scantask.net)

    //markers01.sqf

    :MV-22 Osprey_alpha

    //markers02.sqf

    :MV-22 Osprey_bravo

    //markers03.sqf

    :ah6_alpha

    //markers04.sqf

    :ah6_bravo

    //markers05.sqf

    :ah64d_alpha

    //markers06.sqf

    :ah64d_bravo

    //markers07.sqf

    :ah1z_alpha

    //markers08.sqf

    :ah1z_bravo

    //markers09.sqf

    :uh1y_alpha

    //markers10.sqf

    :uh1y_bravo

    //markers11.sqf

    :mh6_alpha

    etc.etc

    and thats just the choppers.

    ---------- Post added at 04:40 PM ---------- Previous post was at 03:14 PM ----------

    but no bad idea to gather them. Since all this choppers i posted over, is all the same. And cars/ will be same, just slice them up. Somone who know how to turn them into functions?

    createMarker["marker09",[0,0,0]];
    "marker09" setMarkerShape "ICON";
    "marker09" setMarkerType "AIR";
    "marker09" setMarkerText "";
    "marker09" setMarkerColor "ColorYellow";
    
    while {alive uh1y_alpha} do
    
    {
    
    "marker09" setMarkerPos getpos uh1y_alpha;
    
    sleep 2;
    
    };
    
    deletemarker "marker09";
    


  14. have encountered a problem here. I run the DAC mod in my mission, and a few other script mods like acre, etc. These will not start when I run all my markers. With other words, the mission seams laggy.

    Copy of my init.sqf there you can see all my markers.:

    execVM "briefing.sqf";

    execVM "markerpos\markers01.sqf";

    execVM "markerpos\markers02.sqf";

    execVM "markerpos\markers03.sqf";

    execVM "markerpos\markers04.sqf";

    execVM "markerpos\markers05.sqf";

    execVM "markerpos\markers06.sqf";

    execVM "markerpos\markers07.sqf";

    execVM "markerpos\markers08.sqf";

    execVM "markerpos\markers09.sqf";

    execVM "markerpos\markers10.sqf";

    execVM "markerpos\markers11.sqf";

    execVM "markerpos\markers12.sqf";

    execVM "markerpos\markers13.sqf";

    execVM "markerpos\markers14.sqf";

    execVM "markerpos\markers15.sqf";

    execVM "markerpos\markers16.sqf";

    execVM "markerpos\markers17.sqf";

    execVM "markerpos\markers18.sqf";

    execVM "markerpos\markers19.sqf";

    execVM "markerpos\markers20.sqf";

    execVM "markerpos\markers21.sqf";

    execVM "markerpos\markers22.sqf";

    execVM "markerpos\markers23.sqf";

    execVM "markerpos\markers24.sqf";

    execVM "markerpos\markers25.sqf";

    execVM "markerpos\markers26.sqf";

    execVM "markerpos\markers27.sqf";

    execVM "markerpos\markers28.sqf";

    execVM "markerpos\markers29.sqf";

    execVM "markerpos\markers30.sqf";

    execVM "markerpos\markers31.sqf";

    execVM "markerpos\markers32.sqf";

    execVM "markerpos\markers33.sqf";

    execVM "markerpos\markers34.sqf";

    execVM "markerpos\markers35.sqf";

    execVM "markerpos\markers36.sqf";

    execVM "markerpos\markers37.sqf";

    execVM "markerpos\markers38.sqf";

    execVM "markerpos\markers39.sqf";

    execVM "markerpos\markers40.sqf";

    execVM "markerpos\markers41.sqf";

    execVM "markerpos\markers42.sqf";

    execVM "markerpos\markers43.sqf";

    execVM "markerpos\markers44.sqf";

    execVM "markerpos\markers45.sqf";

    execVM "markerpos\markers46.sqf";

    execVM "markerpos\markers47.sqf";

    execVM "markerpos\markers48.sqf";

    execVM "markerpos\markers49.sqf";

    execVM "markerpos\markers50.sqf";

    execVM "markerpos\markers51.sqf";

    execVM "markerpos\markers52.sqf";

    execVM "markerpos\markers53.sqf";

    execVM "markerpos\markers54.sqf";

    execVM "markerpos\markers55.sqf";

    execVM "markerpos\markers56.sqf";

    execVM "markerpos\markers57.sqf";

    execVM "markerpos\markers58.sqf";

    execVM "markerpos\markers59.sqf";

    execVM "markerpos\markers60.sqf";

    execVM "markerpos\markers61.sqf";

    execVM "markerpos\markers62.sqf";

    execVM "markerpos\markers63.sqf";

    execVM "markerpos\markers64.sqf";

    execVM "markerpos\markers65.sqf";

    execVM "markerpos\markers66.sqf";

    execVM "markerpos\markers67.sqf";

    execVM "markerpos\markers68.sqf";

    execVM "markerpos\markers69.sqf";

    execVM "markerpos\markers70.sqf";

    execVM "markerpos\markers71.sqf";

    execVM "markerpos\markers72.sqf";

    execVM "markerpos\markers73.sqf";

    execVM "markerpos\markers74.sqf";

    _KilledHandler = player addEventHandler ["killed", {_this execVM "playerkilled.sqf"}];

    skiptime (((paramsarray select 0) - daytime + 24) % 24);

    switch (paramsarray select 1) do {

    case 1: { 0 setOvercast 0; 0 setRain 0; 0 setFog 0 };

    case 2: { 0 setOvercast 1; 0 setRain 1; 0 setFog 0.2 };

    case 3: { 0 setOvercast 0.7; 0 setRain 0; 0 setFog 0 };

    case 4: { 0 setOvercast 0.7; 0 setRain 1; 0 setFog 0.7 };

    };

    if (isServer) then {

    ace_sys_tracking_markers_enabled = false;

    publicVariable "ace_sys_tracking_markers_enabled"

    };

    Found the root of the problem, and it is all the execVM "markerpos\markersXX.sqf"; in the init file who fuck things up. When I delete some , to lets say i got 10 markers left, DAC and acre start to work when i start running the mission. I wonder if its another way to do this. realy need to have veeled,wings,mhq01,mhq02 and other things marked on the mission map to get this finish'd.

    Thanks in advance for feedback.

    ---------- Post added at 02:39 PM ---------- Previous post was at 02:35 PM ----------

    each markersXX looks like this:

    createMarker["markerXX",[0,0,0]];

    "marker01" setMarkerShape "";

    "marker01" setMarkerType "";

    "marker01" setMarkerText "";

    "marker01" setMarkerColor "";

    while {alive XXX} do

    {

    "marker01" setMarkerPos getpos XXX;

    sleep 2;

    };

    deletemarker "markerXX";

    Will it work better if i make one execVM "markerpos\markers.sqf"; to the init.sqf and throw all the markers in one markers.sqf file maybe? have tryd out some things there, but cant get it to work. Any idea folks? :-)

    Alex


  15. Hi guys! Working on our clan's new public mission/server to ArmA2/A.O. Right now im working on a ''marker script'' so the vehicles/air/m.h.q etc. can be shown/tracked on map. All that works fine on the global side.

    createMarker["marker01",[0,0,0]];

    "marker01" setMarkerShape "ICON";

    "marker01" setMarkerType "AIR";

    "marker01" setMarkerText "";

    "marker01" setMarkerColor "ColorYellow";

    while {alive osprey_alpha} do

    {

    "marker01" setMarkerPos getpos osprey_alpha;

    sleep 2;

    };

    deletemarker "marker01";

    And now my little ''nut'':

    The problem is that i dont know how to get the script ''smarter'' so

    that the marker will follow the vehicles/air/m.h.q etc. when using Tophe's Simple Vehicle Respawn Script v1.7. (The script works fine). Seen around on BIS, but have not found any similar problem, with solution. When created the createMarker i used the http://community.bistudio.com/wiki/createMarker

    In other words, The marker must follow the vehicle back when it has been destroyed or, stranded in time.

    Tell me if something is explained to difficult.

    Hoping for an answer - maybe its not so difficult as i think hehe.

    Thank you in advance for feedback.

    ---------- Post added at 12:33 PM ---------- Previous post was at 11:47 AM ----------

    Tried to take away deletemarker "marker01"; with out succses to see if the marker returns with the vehicles/air/m.h.q to the respawn-basically, but was only left where the device was destroyed.


  16. sry, think i posted on wrong place

    ---------- Post added at 11:49 AM ---------- Previous post was at 11:44 AM ----------

    not sure how I can delete this thread, but hope some moderator can do it for me. found out that this question of mine probably belongs under Arma 2 & OA - MISSION Editing & Scripting. So opened my thread there instead.

    http://forums.bistudio.com/showthread.php?p=1755089 # post1755089

×