Jump to content

logitrust

Member
  • Content Count

    98
  • Joined

  • Last visited

  • Medals

Posts posted by logitrust


  1. Hi, i see that the @sfp_islands v0.0.4 only comes with @sfp_island in the armaholic download mirrror, but in PlayWithSix our community gets @sfp as well with all kind of weapons and sh...

    @GranQ & Sonsalt6: Is it posible to get the - "@sfp_islands" only when adding this to our reposetory, as i see when downloading the armaholic vers. its not any dependencies regarding thoes islands (you only get what you download: @sfp_islands)....

    Thanks in advance...


  2. Hi, checking in to this thread again to hear if anybody have found a solution yet? I still have the same problem only with ArmA3. Got the Hotas Warthog an Saitek Rudder pedals. Both disappear if I dear trying to move close to the esc> controllers for re-mapping or anything while in-game. Restarting ArmA is the only solution i have found so far. Tested with both USB 3 and USB 2 ports 2 different usb2 and 3 controller cards. Turned off USB legacy in the bios and so far everything between heaven and earth I can think of, still no luck...

    Next test tomorrow is to try running the game in compatibly mode, rollback to older versions, do not particularly believe it will give any positive results, since i gave up troubleshooting on this problem back in the days.

    According to Windows Support this is not a problem with the OS, so there's something muffins with A3 here... Hope BIS understand the seriousness of this problem and that they are losing a public face. Flying in A3 should be possible with controllers as joystick and pedals, right? Or maybe im completely wrong and have misunderstood the whole idea of ​​using air vec. in this game?


  3. Scandinavian Task Force



    www.scantask.net

    WE ARE BACK!



    Join us today!

    http://scantask.net/recruitment



    Hostname:

    Scandinavian Task Force

    Clan Tag:

    {STF}

    Gamestyle:

    Co-op & TvT

    Server location:

    Norway

    Timezone:

    GMT+1 Central Europe /NOR/SWE/DEN - English Language

    Contact e-mail:

    scantask@live.com

    Website address:

    www.scantask.net

    Age Restriction:

    18+

    Team Speak 3 Dedicated Server:

    Address = scantask.net

    http://www.teamspeak.com/invite/scantask.net

    Regards,

    Scandinavian Task Force Administration & Command

    d0an.png


  4. Do you have a copy of your mission.sqm?

    mission.sqm

    https://www.dropbox.com/s/zntk6tyd37ynsay/mission.sqm

    Mods used in mission:

    - @CBA_A3

    - @A3MP

    - @Alive

    - @Everon2014

    - @Blastcore_A3

    - @Blastcore-Tracers

    - @task_force_radio

    - @mrb_a3_voicestop

    - @JSRS2

    - @VTS_Weaponresting

    - @sthud_a3

    - @safety

    - @LHM

    - @st_nametags

    - @st_stamina_bar

    - @compassfix

    - @ultra_shadow

    - @hafm_nvg

    - @XActionUi

    - @XLib

    - @XMedSys

    Addons/scripts:

    fpsFix\vehicleManager.sqf

    scripts\BoatPush.sqf

    scripts\jump.sqf

    R3F_LOG

    taw_vd

    I can send you the "stock" editor version, but mission.sqf in link includes these editor commando line targets: -mod=@Cba_a3;@alive;@a3mp;@everon2013;@task_force_radio;@XActionUi;@XLib;@Xmedsys

    Dedicated server runs these mods:

    @A3MP

    @ALiVE

    @Arma2NET

    @ASR_AI3

    @cba_a3

    @everon2014_2.0

    @task_force_radio

    @VTS_DuckHunt

    @XActionUi

    @XLib

    @XMedSys


  5. Hi,

    not shure what it could be, but when trying to connect to our Virtual Entities Zeus slot in lobby, it connects and show a black screen, with other words its not working as it should be.

    This have happend after adding Virtual Arsenal or the ALiVEmod in to the mission.

    PS: We allsow have the Zeus GameMaster module in the mission. All setup correct and tried sync the unit (Zeus unit with the Zeus GameMaster module) with no luck.

    Confirming that it is the ALiVEmod who are causing this after setting condition of presence to false on all editor placed alivemodules.

    Is Alivemod compatible with Zeus atm.?

    Thanks in advance.

    PS: Great job with the latest update :)


  6. Hi,

    not shure what it could be, but when trying to connect to our Virtual Entities Zeus slot in loby, it connects and show a black screen, with other words its not working as it should be.

    This have happend after adding Virtual Arsenal or the ALiVEmod in to the mission.

    PS: We allsow have the Zeus GameMaster module in the mission. All setup corect and tried sync the unit (Zeus unit with the Zeus GameMaster module) with no luck.

    Could The Virtual Arsenal interfere with Zeus in any way, or what could cause this? No error in .rpt.

    ---------- Post added at 07:24 PM ---------- Previous post was at 07:07 PM ----------

    Confirming that it is the ALiVEmod who are causing this, il check with them in their thred.

    http://forums.bistudio.com/showthread.php?169350-ALiVE-Advanced-Light-Infantry-Virtual-Environment


  7. Im trying to get the tickets to work with the class params before starting the missions, so far so god. but need a re-wright, will post here when i get it working:

    class Respawns

    {

    title = "RESPAWNS:";

    values[] = {0,1,2,3,4,5,6};

    texts[] = {"No Respawn","One Respawn","Two Respawns","Three Respawns","Four Respawns","Five Respawns","Unlimited Respawns"};

    default = 6;

    };

    }


  8. You may want to download the correct version of arma2net from the Server Edit page. Please follow the instructions, there is a CUSTOM download of arma2net on that page that is required.

    That is the exact version we installed, from the war room install site.

    ---------- Post added at 12:47 AM ---------- Previous post was at 12:42 AM ----------

    http://www.alivemod.com/downloads/@Arma2NET.7z

    Is where the link points to, confirmed with a md5 checksum.

    I deleted all @arma2net files on the server, and then re-added them from a fresh download, perhaps you guys released a new version very recently? this information havenot been with me in here if so. Il do a test now and see if this offers get results!.

    regards,


  9. Ok, been having close dialog with our server host for some days now. All is done 100% after the instructions to get the server connect to warrrom.

    The alive.cfg is not produsing any log neither spitting out any type repport data/log, only arma2net is producing one atm.

    Error function: SendJSON ["GET", "sys_data/config", "" , "arma3live"]

    Error Caught exception of type System.Net.WebException

    System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

    Can confirmt that its nothing on their end blocking the fraffic between gameserver and your side..

    here is the current baretail from arma2net.log

    03/25/2014 18:07:30 Log: Unmanaged side loaded

    03/25/2014 18:07:30 Info Arma2NET 2.2.0.0 running on CLR 4.0.30319.1022

    03/25/2014 18:07:30 Info Loaded into process arma3server

    03/25/2014 18:07:30 Info Loading addins

    03/25/2014 18:07:30 Info Domain Name Version Publisher Description

    03/25/2014 18:07:30 Info Arma2NETMySQLPlugin Arma2NETMySQL 0.1.0.0 firefly2442 Runs MySQL procedure commands.

    03/25/2014 18:07:30 Info Arma2NETMySQLPlugin Arma2NETMySQLCommand0.1.0.0 firefly2442 Runs raw MySQL/SQLite commands

    03/25/2014 18:07:30 Info BaseFunctionsPlugin CompareVersion 2.0.0.0 Scott_NZ Compares two version strings and returns an integer indicating how they compare.

    03/25/2014 18:07:30 Info BaseFunctionsPlugin ClrVersion 2.0.0.0 Scott_NZ Retrieves the version of the Common Language Runtime.

    03/25/2014 18:07:30 Info BaseFunctionsPlugin Version 2.0.0.0 Scott_NZ Returns the version of Arma2NET.

    03/25/2014 18:07:30 Info CommandLinePlugin CommandLine 2.0.0.0 Scott_NZ Returns the command line used to start the application.

    03/25/2014 18:07:30 Info DateTimePlugin DateTime 2.0.0.0 Scott_NZ Returns the current date and time.

    03/25/2014 18:07:30 Info ServerPlugIn ServerLocation 0.1.0.0 Tupolov Returns the ARMA 2 server geo location.

    03/25/2014 18:07:30 Info ServerPlugIn ServerName 0.1.0.0 Tupolov Returns the ARMA 2 server name.

    03/25/2014 18:07:30 Info ServerPlugIn ServerAddress 0.1.0.0 Tupolov Returns the ARMA 2 server IP address.

    03/25/2014 18:07:30 Info Arma2NET initialized in 00:00:00.3105111

    03/25/2014 18:07:30 Error Caught exception of type Arma2Net.Managed.FunctionNotFoundException

    Arma2Net.Managed.FunctionNotFoundException: The specified addin was not found: GroupName

    at Arma2Net.Managed.AddInManager.InvokeAddIn(String addInName, String arguments, Int32 maxResultSize)

    at Arma2Net.Managed.Bridge.InvokeBuiltInOrAddIn(String function, Int32 maxResultSize)

    at Arma2Net.Managed.Bridge.InvokeFunction(String function, Int32 maxResultSize)

    03/25/2014 18:07:30 Error function: GroupName

    03/25/2014 18:07:30 Error maxResultSize: 10239

    03/25/2014 18:07:30 Error Caught exception of type Arma2Net.Managed.FunctionNotFoundException

    Arma2Net.Managed.FunctionNotFoundException: The specified addin was not found: SendJSON

    at Arma2Net.Managed.AddInManager.InvokeAddIn(String addInName, String arguments, Int32 maxResultSize)

    at Arma2Net.Managed.Bridge.InvokeBuiltInOrAddIn(String function, Int32 maxResultSize)

    at Arma2Net.Managed.Bridge.InvokeFunction(String function, Int32 maxResultSize)

    03/25/2014 18:07:30 Error function: SendJSON ["GET", "sys_data/config", "" , "arma3live"]

    03/25/2014 18:07:30 Error maxResultSize: 10239

    03/25/2014 18:07:51 Error Caught exception of type System.Net.WebException

    System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

    at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

    at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)

    --- End of inner exception stack trace ---

    at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)

    at System.Net.WebClient.DownloadString(Uri address)

    at System.Net.WebClient.DownloadString(String address)

    at ServerPlugIn.ServerAddress._download_serialized_json_data[T](String url)

    at ServerPlugIn.ServerAddress.Invoke(String args, Int32 maxResultSize)

    at Arma2Net.Managed.AddInManager.DomainInvokeAddIn()

    at System.AppDomain.DoCallBack(CrossAppDomainDelegate callBackDelegate)

    at System.AppDomain.DoCallBack(CrossAppDomainDelegate callBackDelegate)

    at Arma2Net.Managed.AddInManager.InvokeAddIn(String addInName, String arguments, Int32 maxResultSize)

    at Arma2Net.Managed.Bridge.InvokeBuiltInOrAddIn(String function, Int32 maxResultSize)

    at Arma2Net.Managed.Bridge.InvokeFunction(String function, Int32 maxResultSize)

    03/25/2014 18:07:51 Error function: ServerAddress

    03/25/2014 18:07:51 Error maxResultSize: 10239

    03/25/2014 18:07:51 Error Caught exception of type Arma2Net.Managed.FunctionNotFoundException

    Arma2Net.Managed.FunctionNotFoundException: The specified addin was not found: GroupName

    at Arma2Net.Managed.AddInManager.InvokeAddIn(String addInName, String arguments, Int32 maxResultSize)

    at Arma2Net.Managed.Bridge.InvokeBuiltInOrAddIn(String function, Int32 maxResultSize)

    at Arma2Net.Managed.Bridge.InvokeFunction(String function, Int32 maxResultSize)

    03/25/2014 18:07:51 Error function: GroupName

    03/25/2014 18:07:51 Error maxResultSize: 10239

    From this, the only thing I can see can be rationally causing this connection problem is the "@alive;" plugin is not properly being called or loaded from the mission file.

    I have a vanilla version of the mission ready to export for you if you want to take a look. Nice to get to the bottom of this :-)

    I can allso send you the server .rpt if this can be of interest.


  10. Some RPT errors just because it's fun to be funny! :torture:

    _veh = [_pos, _dire, _type, _grop] call BIS_fnc_spawnV>

    2014/03/23, 6:08:36 Error position: <_dire, _type, _grop] call BIS_fnc_spawnV>

    2014/03/23, 6:08:36 Error Undefined variable in expression: _dire

    2014/03/23, 6:08:36 File x\alive\addons\mil_convoy\fnc_addVehicle.sqf, line 24

    2014/03/23, 6:08:36 Error in expression <nc_spawnVehicle;

    (_veh select 0) setdir _dire;

    _veh;

    >

    2014/03/23, 6:08:36 Error position: <_dire;

    _veh;

    >

    2014/03/23, 6:08:36 Error Undefined variable in expression: _dire

    2014/03/23, 6:08:36 File x\alive\addons\mil_convoy\fnc_addVehicle.sqf, line 25

    2014/03/23, 6:08:36 Error in expression < [_logic, call _fnc_SelectStartPosList, _dir, _grp] call ALIVE_fnc_AddVehicle;

    }>

    2014/03/23, 6:08:36 Error position: <_dir, _grp] call ALIVE_fnc_AddVehicle;

    }>

    2014/03/23, 6:08:36 Error Undefined variable in expression: _dir

    2014/03/23, 6:08:36 File x\alive\addons\mil_convoy\fnc_startConvoy.sqf, line 142

    2014/03/23, 6:08:36 Error in expression < must be an Array!"; []};

    if ((typeName _azi) != (typeName 0)) exitWith {debugLo>

    2014/03/23, 6:08:36 Error position: <_azi) != (typeName 0)) exitWith {debugLo>

    2014/03/23, 6:08:36 Error Undefined variable in expression: _azi

    2014/03/23, 6:08:36 File A3\functions_f\spawning\fn_spawnVehicle.sqf, line 47

    2014/03/23, 6:08:36 Error in expression <call ALiVE_fnc_DumpR;

    };

    _veh = [_pos, _dire, _type, _grop] call BIS_fnc_spawnV>

    2014/03/23, 6:08:36 Error position: <_dire, _type, _grop] call BIS_fnc_spawnV>

    2014/03/23, 6:08:36 Error Undefined variable in expression: _dire

    2014/03/23, 6:08:36 File x\alive\addons\mil_convoy\fnc_addVehicle.sqf, line 24

    2014/03/23, 6:08:37 Error in expression <nc_spawnVehicle;

    (_veh select 0) setdir _dire;

    _veh;

    >

    2014/03/23, 6:08:37 Error position: <_dire;

    _veh;

    >

    2014/03/23, 6:08:37 Error Undefined variable in expression: _dire

    2014/03/23, 6:08:37 File x\alive\addons\mil_convoy\fnc_addVehicle.sqf, line 25

    2014/03/23, 6:08:37 Error in expression <= [_logic,call _fnc_SelectStartPosList, _dir, _grp, "Truck_F"] call ALIVE_fnc_Ad>

    2014/03/23, 6:08:37 Error position: <_dir, _grp, "Truck_F"] call ALIVE_fnc_Ad>

    2014/03/23, 6:08:37 Error Undefined variable in expression: _dir

    2014/03/23, 6:08:37 File x\alive\addons\mil_convoy\fnc_startConvoy.sqf, line 171


  11. What does alive.log say?

    Somthing it doesn't like, i think :P ........

    log Arma2net

    03/22/2014 16:55:13 Info Arma2NET 2.2.0.0 running on CLR 4.0.30319.1022
    03/22/2014 16:55:13 Info Loaded into process arma3server
    03/22/2014 16:55:13 Info Loading addins
    03/22/2014 16:55:13 Info Domain Name Version Publisher Description
    03/22/2014 16:55:13 Info Arma2NETMySQLPlugin Arma2NETMySQL 0.1.0.0 firefly2442 Runs MySQL procedure commands.
    03/22/2014 16:55:13 Info Arma2NETMySQLPlugin Arma2NETMySQLCommand0.1.0.0 firefly2442 Runs raw MySQL/SQLite commands
    03/22/2014 16:55:13 Info BaseFunctionsPlugin CompareVersion 2.0.0.0 Scott_NZ Compares two version strings and returns an integer indicating how they compare.
    03/22/2014 16:55:13 Info BaseFunctionsPlugin ClrVersion 2.0.0.0 Scott_NZ Retrieves the version of the Common Language Runtime.
    03/22/2014 16:55:13 Info BaseFunctionsPlugin Version 2.0.0.0 Scott_NZ Returns the version of Arma2NET.
    03/22/2014 16:55:13 Info CommandLinePlugin CommandLine 2.0.0.0 Scott_NZ Returns the command line used to start the application.
    03/22/2014 16:55:13 Info DateTimePlugin DateTime 2.0.0.0 Scott_NZ Returns the current date and time.
    03/22/2014 16:55:13 Info ServerPlugIn ServerLocation 0.1.0.0 Tupolov Returns the ARMA 2 server geo location.
    03/22/2014 16:55:13 Info ServerPlugIn ServerName 0.1.0.0 Tupolov Returns the ARMA 2 server name.
    03/22/2014 16:55:13 Info ServerPlugIn ServerAddress 0.1.0.0 Tupolov Returns the ARMA 2 server IP address.
    03/22/2014 16:55:13 Info Arma2NET initialized in 00:00:00.3159573
    03/22/2014 16:55:13 Error Caught exception of type Arma2Net.Managed.FunctionNotFoundException
    Arma2Net.Managed.FunctionNotFoundException: The specified addin was not found: GroupName
    at Arma2Net.Managed.AddInManager.InvokeAddIn(String addInName, String arguments, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeBuiltInOrAddIn(String function, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeFunction(String function, Int32 maxResultSize)
    03/22/2014 16:55:13 Error function: GroupName
    03/22/2014 16:55:13 Error maxResultSize: 10239
    03/22/2014 16:55:13 Error Caught exception of type Arma2Net.Managed.FunctionNotFoundException
    Arma2Net.Managed.FunctionNotFoundException: The specified addin was not found: SendJSON
    at Arma2Net.Managed.AddInManager.InvokeAddIn(String addInName, String arguments, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeBuiltInOrAddIn(String function, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeFunction(String function, Int32 maxResultSize)
    03/22/2014 16:55:13 Error function: SendJSON ["GET", "sys_data/config", "" , "arma3live"]
    03/22/2014 16:55:13 Error maxResultSize: 10239
    03/22/2014 16:55:14 Error Caught exception of type Arma2Net.Managed.FunctionNotFoundException
    Arma2Net.Managed.FunctionNotFoundException: The specified addin was not found: GroupName
    at Arma2Net.Managed.AddInManager.InvokeAddIn(String addInName, String arguments, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeBuiltInOrAddIn(String function, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeFunction(String function, Int32 maxResultSize)
    03/22/2014 16:55:14 Error function: GroupName
    03/22/2014 16:55:14 Error maxResultSize: 10239
    03/22/2014 17:25:33 Error Caught exception of type Arma2Net.Managed.FunctionNotFoundException
    Arma2Net.Managed.FunctionNotFoundException: The specified addin was not found: GroupName
    at Arma2Net.Managed.AddInManager.InvokeAddIn(String addInName, String arguments, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeBuiltInOrAddIn(String function, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeFunction(String function, Int32 maxResultSize)
    03/22/2014 17:25:33 Error function: GroupName
    03/22/2014 17:25:33 Error maxResultSize: 10239
    03/22/2014 17:25:33 Error Caught exception of type Arma2Net.Managed.FunctionNotFoundException
    Arma2Net.Managed.FunctionNotFoundException: The specified addin was not found: SendJSON
    at Arma2Net.Managed.AddInManager.InvokeAddIn(String addInName, String arguments, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeBuiltInOrAddIn(String function, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeFunction(String function, Int32 maxResultSize)
    03/22/2014 17:25:33 Error function: SendJSON ["GET", "sys_data/config", "" , "arma3live"]
    03/22/2014 17:25:33 Error maxResultSize: 10239
    03/22/2014 17:25:34 Error Caught exception of type Arma2Net.Managed.FunctionNotFoundException
    Arma2Net.Managed.FunctionNotFoundException: The specified addin was not found: GroupName
    at Arma2Net.Managed.AddInManager.InvokeAddIn(String addInName, String arguments, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeBuiltInOrAddIn(String function, Int32 maxResultSize)
    at Arma2Net.Managed.Bridge.InvokeFunction(String function, Int32 maxResultSize)
    03/22/2014 17:25:34 Error function: GroupName
    03/22/2014 17:25:34 Error maxResultSize: 10239

    msg. from the server host: The alive.cfg is in the proper users folder as the instructions state since my reply on the 21st.

    The alive.cfg goes inside c:\users\%user%\appdata\local which is where it currently is.

    However I do see a new version just came out today. Maybe it's needed for the new A3 version?


  12. hehe, better to be frugal vs. sloppy this regard. hope maybe this can help others serverhost amateurs like myself by describing in picture form ....

    on my local computer all folders are not hidden.. Should the alive.cfg be placed on the server or on my local computer/client?

    On the server if so be, it seams that its hidden since its not in the root directory where a3 is installed. il contact the host.


  13. ok, two things here.. thanks for help in advance....

    Q1: Profile i get this box when connecting to the server. Where to start troubleshooting?

    The player ID is correct in warroom and all good in the mission with the modules etc.

    3rpu.png

    Profile looks like this:

    i78r.png

    (Ps. using an .xml on my player hosted on our webpage server. could this make some type of interference?)

    __________________________________________________________________________________

    Q2: Server

    Next thing, getting the sever showing stats in warrom.....

    ic5m.png

    All should be added correctly regarding ALiVE WarRoom registration tutorial.

    We have maked shure that our gameserver host "Jestservers" have fixed all on the server(Microsoft .NET Framework 4 Client Profile + Microsoft Visual C++ 2010) regarding the install guide inkl. running the mission with the @Arma2NET. In the mission we have the database and player persistence module

    Im unsure of where to place the alive.cfg on the server..... In the tutorial im a little unshure as well if Arjay says, "it should only be placed on the client or on the server?" If its on the server we have a user folder, looks like this: Is this the correct location to the file?

    dcco.png

    re9g.png

    jphn.png


  14. Hey, any JIP(MP) scirpts that moves the player to a marker when joining the sever out there? for ex: (respawn_west)

    No respawn on placed player position in editor.

    Thanks in advance!

    ---------- Post added at 10:41 PM ---------- Previous post was at 09:33 PM ----------

    For this example we have a tvt mp mission (blufor, opfor, indepenent and civ.)...

    We need the units spawn when joining in progress on placed positions in editor for ex. "respawn_west" , but only after killed or "esc.respawn" they move to the respawn marker when doing nothing without

    respawn = "BASE";

    respawnDelay = 180;

    for ex.

    I read up in wiki and found that i could add this to the player init.

    player setPos (getMarkerPos "respawn_east_01");

    When using that with the description.exe respawn attributes all should be good i hoped.

    respawn = "BASE";

    respawnDelay = 180;

    respawnDialog = 0;

    respawnTemplates[] = {"MenuPosition"};

    When using

    player setPos (getMarkerPos "respawn_east_01");

    It spawns the unit to its marker, but when jip player connect, all players on the faction are spawning back the marker you get when killed for ex. "respawn_west", so no go...

    any tips on getting this globally in any way?

    could

    if (!isDedicated) then {
    work?

    or maybe

    if (isServer) then {
    ?

    all till now is failur. :-/

    ---------- Post added at 10:51 PM ---------- Previous post was at 10:41 PM ----------

    and why the hell is the MP multiplayer markers showing for all factions/sides when its set to "show side only"..?

    and whats the deal with the

    // 1 to execute respawn templates when a player joins the game. Available only for INSTANT and BASE respawn types.

    respawnOnStart = 1;

    does anyone get this to work at all? havnt seen any mission with the dialog showing up when joining a mission yet. :www:

  15. while pvp multiplayer, where to define side types of objects to spawn?

    _sideName = switch ((_cfgInfo select 5)) do {case 0: {"EAST"}; case 1: {"WEST"}; case 2: {"GUER"}; case 3: {"CIV"}; default {"UNKNOWN"}};
    this addAction["Virtual Vehicle Spawner",VVS_fnc_openVVS,["VVS_all_1","all"]];

    say we want all content form east, west, guer and civ to be separated to only be provided for each faction at different locations?


  16. Hi, adding some markers only visible for each playable side to a misison, all good but getting a error with "-ShowScriptErrors" when spawning as resistance aka. greenfor on our dedicated server. All markers showing and no errors on other faction sides.

    All feedback is cool, cheers!

    Error msg:

    pj8h.png

    Ok, here we go:

    init.sqf:

    if (!isDedicated) then 
    {
    {_x setMarkerAlphaLocal 0} forEach ["mkrA","mkrB","mkrC","mkrD","mkrE","mkrF","mkrG","mkrH","mkrI","mkrJ","mkrK","mkrL","mkrM","mkrN","mkrO","mkrP","mkrQ","mkrR","mkrS","mkrT","mkrU","mkrV","mkrW","mkrX","mkrY","mkrZ"];
    waitUntil {!isNull player};
    switch (side player) do 
    {
    	case WEST: 
    	{
    		{_x setMarkerAlphaLocal 1} forEach ["mkrA","mkrB","mkrC"];
    	};
    	case EAST: 
    	{
    		{_x setMarkerAlphaLocal 1} forEach ["mkrD","mkrE","mkrF","mkrG","mkrH","mkrI","mkrJ","mkrK","mkrL"];
    	};
    	case GUER:
    	{
    		{_x setMarkerAlphaLocal 1} forEach ["mkrM","mkrN","mkrO","mkrP"];
    	};
    	case CIVILIAN: 
    	{
    		{_x setMarkerAlphaLocal 1} forEach ["mkrQ","mkrR","mkrS","mkrT","mkrU","mkrV","mkrW","mkrX","mkrY","mkrZ"];
    	};
    };
    [] execVM "scripts\markers.sqf";
    };

    scripts\markers.sqf:

    if (side player == blufor) then {
       _mkrA = createMarkerLocal ["mkrA", getMarkerPos "mil_dot_blufor_01"];
       _mkrA setMarkerColorLocal "ColorBlue";
       _mkrA setMarkerShapeLocal "ICON";
       _mkrA setMarkerTypeLocal "mil_triangle";
       _mkrA setMarkerTextLocal "";
    
       _mkrB = createMarkerLocal ["mkrB", getMarkerPos "mil_dot_blufor_02"];
       _mkrB setMarkerColorLocal "ColorBlue";
       _mkrB setMarkerShapeLocal "ICON";
       _mkrB setMarkerTypeLocal "mil_triangle";
       _mkrB setMarkerTextLocal "";
    
       _mkrC = createMarkerLocal ["mkrC", getMarkerPos "mil_dot_blufor_03"];
       _mkrC setMarkerColorLocal "ColorBlue";
       _mkrC setMarkerShapeLocal "ICON";
       _mkrC setMarkerTypeLocal "mil_triangle";
       _mkrC setMarkerTextLocal "";
    };
    
    if (side player == opfor) then {
       _mkrD = createMarkerLocal ["mkrD", getMarkerPos "mil_dot_east_01"];
       _mkrD setMarkerColorLocal "ColorRed";
       _mkrD setMarkerShapeLocal "ICON";
       _mkrD setMarkerTypeLocal "mil_triangle";
       _mkrD setMarkerTextLocal "";
    
       _mkrE = createMarkerLocal ["mkrE", getMarkerPos "mil_dot_east_02"];
       _mkrE setMarkerColorLocal "ColorRed";
       _mkrE setMarkerShapeLocal "ICON";
       _mkrE setMarkerTypeLocal "mil_triangle";
       _mkrE setMarkerTextLocal "";
    
       _mkrF = createMarkerLocal ["mkrF", getMarkerPos "mil_dot_east_03"];
       _mkrF setMarkerColorLocal "ColorRed";
       _mkrF setMarkerShapeLocal "ICON";
       _mkrF setMarkerTypeLocal "mil_triangle";
       _mkrF setMarkerTextLocal "";
    
       _mkrG = createMarkerLocal ["mkrG", getMarkerPos "mil_dot_east_04"];
       _mkrG setMarkerColorLocal "ColorRed";
       _mkrG setMarkerShapeLocal "ICON";
       _mkrG setMarkerTypeLocal "mil_triangle";
       _mkrG setMarkerTextLocal "";
    
    _mkrH = createMarkerLocal ["mkrH", getMarkerPos "mil_dot_east_05"];
       _mkrH setMarkerColorLocal "ColorRed";
       _mkrH setMarkerShapeLocal "ICON";
       _mkrH setMarkerTypeLocal "mil_triangle";
       _mkrH setMarkerTextLocal "";
    
    _mkrI = createMarkerLocal ["mkrI", getMarkerPos "mil_dot_east_06"];
       _mkrI setMarkerColorLocal "ColorRed";
       _mkrI setMarkerShapeLocal "ICON";
       _mkrI setMarkerTypeLocal "mil_triangle";
       _mkrI setMarkerTextLocal "";
    
    _mkrJ = createMarkerLocal ["mkrJ", getMarkerPos "mil_dot_east_07"];
       _mkrJ setMarkerColorLocal "ColorRed";
       _mkrJ setMarkerShapeLocal "ICON";
       _mkrJ setMarkerTypeLocal "mil_triangle";
       _mkrJ setMarkerTextLocal "";
    
    _mkrK = createMarkerLocal ["mkrK", getMarkerPos "mil_dot_east_08"];
       _mkrK setMarkerColorLocal "ColorRed";
       _mkrK setMarkerShapeLocal "ICON";
       _mkrK setMarkerTypeLocal "mil_triangle";
       _mkrK setMarkerTextLocal "";
    
    _mkrL = createMarkerLocal ["mkrL", getMarkerPos "mil_dot_east_09"];
       _mkrL setMarkerColorLocal "ColorRed";
       _mkrL setMarkerShapeLocal "ICON";
       _mkrL setMarkerTypeLocal "mil_triangle";
       _mkrL setMarkerTextLocal "";
    };
    
    if (side player == resistance) then {
       _mkrM = createMarkerLocal ["mkrM", getMarkerPos "mil_dot_green_01"];
       _mkrM setMarkerColorLocal "ColorGreen";
       _mkrM setMarkerShapeLocal "ICON";
       _mkrM setMarkerTypeLocal "mil_triangle";
       _mkrM setMarkerTextLocal "";
    
       _mkrN = createMarkerLocal ["mkrN", getMarkerPos "mil_dot_green_02"];
       _mkrN setMarkerColorLocal "ColorGreen";
       _mkrN setMarkerShapeLocal "ICON";
       _mkrN setMarkerTypeLocal "mil_triangle";
       _mkrN setMarkerTextLocal "";
    
       _mkrO = createMarkerLocal ["mkrO", getMarkerPos "mil_dot_green_03"];
       _mkrO setMarkerColorLocal "ColorGreen";
       _mkrO setMarkerShapeLocal "ICON";
       _mkrO setMarkerTypeLocal "mil_triangle";
       _mkrO setMarkerTextLocal "";
    
       _mkrP = createMarkerLocal ["mkrP", getMarkerPos "mil_dot_green_04"];
       _mkrP setMarkerColorLocal "ColorGreen";
       _mkrP setMarkerShapeLocal "ICON";
       _mkrP setMarkerTypeLocal "mil_triangle";
       _mkrP setMarkerTextLocal "";
    };
    
    if (side player == civilian) then {
       _mkrQ = createMarkerLocal ["mkrQ", getMarkerPos "mil_dot_depot_01"];
       _mkrQ setMarkerColorLocal "ColorWhite";
       _mkrQ setMarkerShapeLocal "ICON";
       _mkrQ setMarkerTypeLocal "mil_triangle";
       _mkrQ setMarkerTextLocal "";
    
       _mkrR = createMarkerLocal ["mkrR", getMarkerPos "mil_dot_depot_02"];
       _mkrR setMarkerColorLocal "ColorWhite";
       _mkrR setMarkerShapeLocal "ICON";
       _mkrR setMarkerTypeLocal "mil_triangle";
       _mkrR setMarkerTextLocal "";
    
       _mkrS = createMarkerLocal ["mkrS", getMarkerPos "mil_dot_depot_03"];
       _mkrS setMarkerColorLocal "ColorWhite";
       _mkrS setMarkerShapeLocal "ICON";
       _mkrS setMarkerTypeLocal "mil_triangle";
       _mkrS setMarkerTextLocal "";
    
       _mkrT = createMarkerLocal ["mkrT", getMarkerPos "mil_dot_depot_04"];
       _mkrT setMarkerColorLocal "ColorWhite";
       _mkrT setMarkerShapeLocal "ICON";
       _mkrT setMarkerTypeLocal "mil_triangle";
       _mkrT setMarkerTextLocal "";
    
    _mkrU = createMarkerLocal ["mkrU", getMarkerPos "mil_dot_depot_05"];
       _mkrU setMarkerColorLocal "ColorWhite";
       _mkrU setMarkerShapeLocal "ICON";
       _mkrU setMarkerTypeLocal "mil_triangle";
       _mkrU setMarkerTextLocal "";
    
    _mkrV = createMarkerLocal ["mkrV", getMarkerPos "mil_dot_depot_06"];
       _mkrV setMarkerColorLocal "ColorWhite";
       _mkrV setMarkerShapeLocal "ICON";
       _mkrV setMarkerTypeLocal "mil_triangle";
       _mkrV setMarkerTextLocal "";
    
    _mkrW = createMarkerLocal ["mkrW", getMarkerPos "mil_dot_camp_07"];
       _mkrW setMarkerColorLocal "ColorWhite";
       _mkrW setMarkerShapeLocal "ICON";
       _mkrW setMarkerTypeLocal "mil_box";
       _mkrW setMarkerTextLocal "";
    
    _mkrX = createMarkerLocal ["mkrX", getMarkerPos "mil_dot_camp_08"];
       _mkrX setMarkerColorLocal "ColorWhite";
       _mkrX setMarkerShapeLocal "ICON";
       _mkrX setMarkerTypeLocal "mil_box";
       _mkrX setMarkerTextLocal "";
    
    _mkrY = createMarkerLocal ["mkrY", getMarkerPos "mil_dot_camp_09"];
       _mkrY setMarkerColorLocal "ColorWhite";
       _mkrY setMarkerShapeLocal "ICON";
       _mkrY setMarkerTypeLocal "mil_box";
       _mkrY setMarkerTextLocal "";
    
    _mkrZ = createMarkerLocal ["mkrZ", getMarkerPos "mil_dot_camp_10"];
       _mkrZ setMarkerColorLocal "ColorWhite";
       _mkrZ setMarkerShapeLocal "ICON";
       _mkrZ setMarkerTypeLocal "mil_box";
       _mkrZ setMarkerTextLocal "";
    
    };

    This for referral:

    https://community.bistudio.com/wiki/resistance

    https://community.bistudio.com/wiki/Arma_3_Respawn

    ---------- Post added at 01:25 AM ---------- Previous post was at 01:09 AM ----------

    lol, after 10x "preview" and testing with editor il found out that using:

    case RESISTANCE: instead of case GUER:

    did the trick! no more error :-P

    All good now!

×