Jump to content

[kh]jman

Member
  • Content Count

    884
  • Joined

  • Last visited

  • Medals

  • Medals

Everything posted by [kh]jman

  1. norrin, Typo in revive_sqf\mobile\vcl_respawn.sqf @ line 45 this addEventHandler ['GETOUT',{[_this select 0] execVM 'revive_sqf\mobile\mobile_remove_spawn.sqf'}];"; this addEventHandler ['GETOUT',{[_this select 0] execVM 'revive_sqf\mobile\mobile_remove_spawn.sqf'}]; Also might be worth inserting after line 42: _vcl_new lock false; _vcl_new setVehicleLock "UNLOCKED"; So in single player the mobile respawn is not locked after it respawns ;)
  2. Try this in the editor debugger (A3 dev version): position 1862.41,5762.52, 0.00143862 will spawn the unit infront of the air traffic control building at the airbase _unit = objNull; _grp = createGroup east; _unit = _grp createUnit ["O_Soldier_AR_F", [1862.41,5762.52,0.00143862], [], 0, "NONE"]; _grp selectLeader _unit; _unit setUnitAbility 0.60000002; _unit setDir 24.95896; _unit setVehicleVarName "su"; _unit setVehicleAmmo 0; _initinit = format["[{%1 setunitpos '%2'; %1 disableAI '%3';}]", _unit, "MIDDLE", "MOVE"]; [call compile format["%1",_initinit],"BIS_fnc_spawn", true, false] spawn BIS_fnc_MP; _unit call compile format ["%1=_this; publicvariable '%1'",_unit]; If it's for multiplayer on a dedicated you could try it with the new Arma3 netId/objectFromNetId commands, it won't return an id if you test this in the editor (shame): _unit = objNull; _grp = createGroup east; _unit = _grp createUnit ["O_Soldier_AR_F", [1862.41,5762.52,0.00143862], [], 0, "NONE"]; _grp selectLeader _unit; _unitname = "su"; _initinit = format["[{ (objectFromNetId '%1') setVehicleVarName '%4'; (objectFromNetId '%1') setunitpos '%2'; (objectFromNetId '%1') disableAI '%3'; (objectFromNetId '%1') setVehicleAmmo %5; (objectFromNetId '%1') setUnitAbility %6; (objectFromNetId '%1') setDir %7; }]", (netId _unit), "MIDDLE", "MOVE", _unitname, 0, 0.60000002, 24.95896]; [call compile format["%1",_initinit],"BIS_fnc_spawn", true, false] spawn BIS_fnc_MP; _unit call compile format ["%1=_this; publicvariable '%1'", _unitname]; References: http://community.bistudio.com/wiki/netId http://community.bistudio.com/wiki/objectFromNetId https://community.bistudio.com/wiki/BIS_fnc_MP http://community.bistudio.com/wiki/publicVariable
  3. [kh]jman

    How to access new fog system

    Yes correct.
  4. [kh]jman

    How to access new fog system

    Arma 3's setFog implementation is the same a VBS2's so you can use the same reference: http://resources.bisimulations.com/wiki/setFog
  5. I believe that the answer may be in this error: missionTasks.sqf: diag_log format["_taskState: %1 Type: %2",_taskState, typeName _taskState]; diag_log format["_taskID: %1 Type: %2",_taskID, typeName _taskID]; case "objective_1": { if (_taskState == "") then { [ [units group player, // Task owner(s) _taskID, // task ID (used when setting task state, destination or description later) ["Clear the beach camp of enemy and secure.","Secure beach camp",""], // Task params position objective_target_1, // task destination true // true to set task as current upon creation ], "BIS_fnc_taskCreate", // task function true, // execution on all clients; true // true for persistent execution (i.e., also for players connected by JIP) ] call BIS_fnc_MP; } else { if (_taskState == "Current") then {_taskID call BIS_fnc_taskSetCurrent} else {[_taskID, _taskState] call BIS_fnc_taskSetState} } }; Output when player JIP's: "_taskState: CREATED Type: STRING" "_taskID: objective_3 Type: STRING" Error in expression <exitWith {_task = _x select 1}} forEach _taskList; _task> Error position: <_taskList; _task> Error Undefined variable in expression: _tasklist File A3\functions_f\Tasks\fn_taskReal.sqf, line 35 Error in expression <ent = _x call BIS_fnc_taskCurrent; if (_taskCurrent == _taskName && _state != "> Error position: <_taskCurrent == _taskName && _state != "> Error Undefined variable in expression: _taskcurrent File A3\functions_f\Tasks\fn_taskSetState.sqf, line 57 It appears that BI's JIP code is still broken/buggy and as I say many .sqf files that work for players whom start from the beginning of the mission fail to run at all for JIP players (even if placed in initJIPcompatible.sqf). No diag_log output, nothing.
  6. Yeah sorry for not replying sooner. No it did not work. Many .sqf files that work for players whom start from the beginning of the mission fail to run at all for JIP players. No diag_log output, nothing. My feeling is that it will need an engine change to address this.
  7. [kh]jman

    SweetFX in Arma 3

    For all AMD users, download Radon Pro. It has SweetFX support along with many other tweaks and works with any games you setup a profile for. http://www.radeonpro.info
  8. I believe it's an engine issue, I have scripts that cease to work on JIP, no diag log or errors seems to suggest that the engine is not calling scripts for JIP players on dedicated.
  9. Out of interest, go to Video Options -> Quality -> Texture Quality and set it to Standard and see if that makes a difference. My LOD issues with this card are solved in Arma2 in a similar way.
  10. @Holmes Please refer to my response here
  11. @Holmes The legacy standalone version of pdb that you are trying to use contains many bugs/issues one of which relates to the tsc = any issue. The code fix will be in the mso dev git branch but will more than likely be reliant on other changes that were made in that branch. When A2 1.62 final patch is released we will be releasing the final version of A2 mso which will contain all the pdb fixes and after that if I have time I might update the standalone version. If you cannot wait and know Sqf/dB I would suggest that you pull back the mso dev git branch and try to refractor the legacy base code from it.
  12. For info. As of: 11-04-2013 EXE rev. 103960 Some class names have been renamed. Here are two I've come across whilst updating missions: RoadBarrier_long -> RoadBarrier_F RoadCone -> RoadCone_F
  13. [kh]jman

    Crew Info in vehicles

    Yeah that will not work for some resolutions. I suggest you just move it down (y) a little on the left side i.e class crewinfotext { idc = 10101; type = CT_STRUCTURED_TEXT; style = ST_LEFT; x = (SafeZoneX + 0.02); y = (SafeZoneY + 0.60); w = 0.3; h = 0.6; size = 0.018; colorBackground[] = { 0, 0, 0, 0 }; colortext[] = {0,0,0,0.7}; text =""; };
  14. I was my understanding that nil would execute on all clients. Taken form BI Wiki: [["Hello World"],"BIS_fnc_guiMessage",nil,true] spawn BIS_fnc_MP; Send a message containing "Hello World" to every player, including the ones who joins later using JIP. I will change it to true and see what happens. :)
  15. I guess you did not review my pastebin link before replying.
  16. @Moricky I see that missionTasks.sqf is called automatically. Is this the case for JIP players too? I ask because it seems that in my mission on dedicated, JIP players are not seeing the tasks. Players see them fine if they join from the beginning. As you can see I am using BIS_fnc_MP I am using the latest A3 DEV version at all times. missionTasks.sqf: http://pastebin.com/ndUhqTyL
  17. [kh]jman

    =BTC= Revive

    BTC_vehs_mobile_west = [mobile_west_0] Set it to an empty array if you do not have an vehicle named mobile_west_0 otherwise you will get this error. Same for the other ones i.e BTC_vehs_mobile_east = []
  18. I can view that camera angle just fine with no CTD so it might indeed be just you.
  19. [kh]jman

    Crew Info in vehicles

    In the editor if you make a change to the description.ext you MUST reload the mission back into the editor before previewing it or it will not see your changes... that's prob what caused it. Other than that re-check that the crewinfo dir exists in the root of your mission.
  20. @norrin Thx I've got the mobile respawn working now by adding the r_mobile_spawn_vcl name to the vehicle and attaching the EVH's to the mobile vehicle so it can be deployed (as outlined in mobile\vcl_respawn.sqf) which I'd completely missed!. Yes norrin your newFnc\returnLoadOut.sqf and newFnc\currentLoadout.sqf appear to be the cause of this. I was also losing NVG and backpack contents as well as optics on the primary weapon. I have revised those files (I use the DEV A3 version) and also edited the respawn\respawn.sqf (just to rem out the removeWeapons and mags code since they get removed in the revised returnLoadOut.sqf. Here's my revised code edits norrin: download
  21. [kh]jman

    Crew Info in vehicles

    just put #include <crewinfo\dialog.hpp> after: class RscTitles { and before: titles[]={};
  22. [kh]jman

    Crew Info in vehicles

    Just combine the two includes into one RscTitles class
  23. [kh]jman

    Crew Info in vehicles

    Indeed. I've just knocked up a quick standalone version of it for you all. Enjoy! Download CrewInfo Script Screenshot Link
  24. Make sure you move the respawn_west marker away from the primary respawn area and create a marker (insertion in demo, mine is called Camp Tempest and is a hidden marker) which then acts as the respawn marker. Do not place the marker next to the respawn_west marker then it will work. make sure you create the center and boot_hill markers as in the demo and add the includes to description.ext norrin, everything is working fine except I cannot get the mobile respawn to work on vehicle. I have named the vehicle mobile_respawn_west, added that to the revive_init.sqf: http://pastebin.com/xjmTZE2k When the player dies only an option for spawn at 'Camp Tempest' displays...
×