Jump to content

CN_Lurker_1011

Member
  • Content Count

    22
  • Joined

  • Last visited

  • Medals

Posts posted by CN_Lurker_1011


  1. On 3/29/2022 at 9:59 PM, Waldemar 337 said:

    I think, the advanced flight model should be enabled in the server's settings.

    I think, it is a global server's setting which can not be changed per each separate vehicle in the game.

    I am not a developer of this game, though, so I might be wrong. If I am wrong, please, correct me.

    i found the reason, the RTDconfig file must be named as RTD_[your pbo name].xml, and packed together with your config.bin(packed in one same folder),

    dont forget to add *.xml in the List of files to copy directly in Addon Builder option

    you cant just copy all class RotorLibHelicopterProperties from other heli.

     

    but after i resolved this issue, i encountered a new issue( VME PLA MOD of hcpookie also encounter it ), the wheels of helicopter sink below the ground after enable Advanced Helicopter Flight Model, (the physX collision is missing),

    i try to write class wheels to add wheels collision using memory points just like land vehicle, but nothing changed


  2. I tried to add damage textures to my tankX vehicle following the wiki, but i found the collision between physX object (vehicles) and Non-physX object (player) stopping running after tank destroyed, it seemed as if Geometry_LOD had been removed from the vehicle. it is not occurred in my wheeled vehicles.

    the only way i found for this issue is to make a standalone wreckage model in a new p3d with new geometry LOD, and attach it with Main p3d by proxy, just like the vanilla Tanks, it is very inconvenient and the camo of wreckage cant be changed when the camo of vehicle model is changed.


  3. Solved by copying Memory LOD form AFV-4 , but i still dont know which memory points are particular for amphibious vehicles

     

    Also, i had rewrited the model.cfg and CfgVehicles, but nothing change before i copied Memory LOD form AFV-4

     

    0c0ea31ec859c5056a525d3c912a027b.jpg

     

    Memory point my wheeled APC used to solve the issue

     

    d1564f80ec5bce770e1ce584213ce7a7.png

     

    62016026dc8d51cc17b2498a18719636.jpg

     

    Momery LOD my tracked APC used, also my Wheeled APC used before(just remove some wheel axis/bounds)

     

    baa84fe115285e72557f5692740e9a5a.png

     

     

     


  4. I  copy the PhysX part of APC_Wheeled_03 (AFV_4 in game) for my Wheeled APC, and followed all the steps of ShipX on the BIS wiki,  everything working fine, but it does only floats (always keep on the speed of 8km/h when floats) does not steer or accelerate in the water(No propelling force, No friction, just like a space ship lose power in outer space)

     

    I had tried to copy the PhysX part form BTR80 of RHS, also not work, (not the problem of PhysX i guess)

     

    (Important)Also, my animations what use the sources of "InWater"   "propeller" does not work, like the game dont think my APC is floating on the water

     

    I have made one successful Tracked Amphibious Vehicles before use the PhysX from BMP3 of RHS

     

    CfgVehicle: https://pastebin.com/uZrniYr3

    PhysX.hpp: https://pastebin.com/E2Fv0vev

     

    buoyancy=1 was added to the geometry LOD and geometry_physX LOD (i confirmed it deterministically)


  5. 1 hour ago, Jackal326 said:

    To elaborate a little on that;

    A section is created when you assign a texture to it, and is again increased in number if you apply different rvmats and alpha-layering to different parts, even though they use the same texture. You also add new sections if you copy and paste model parts from one LOD to another.

    To cut down on the number of sections/draw calls you can select the entire model that uses each texture (and assuming they use the same RVMAT), by going to Window -> Resource Library -> (in the new window that opens) Current LOD -> hold CTRL and double-click a texture.

    Then, in the main Object Builder window the parts of the model using that texture will be selected.

    Then press CTRL+SHIFT+END to move all of those faces to the bottom of the Alpha sorting then press E. 

    Then in the new window press Apply and close the window. You should now see the number of sections has dropped as all of those faces were presumably on separate sections and are now on one.

     

    thanks a lot, it worked

    it is the first time i'd heard of " sections" after i made 8 vehicles for my New PLA mod 


  6. T100 

    c0e96fd2048c385845a51e93f2315d38.jpg

    My custom vehicle 1 

    34600 faces in totall ( 58000 tris)

    2*  4096*4096 textures

    2* 2040-2048 textures

    1*  1024*1024 textures

    1* 512*512 textures

    More faces, high resolution textures , But high FPS 

    1dcf4ca9297d977ae0ac29f0d3befa0b.jpg

     

    My custom vehicle 2 

    18377 faces in totall ( 31388 tris)

    No  4096*4096 textures

    3* 2040-2048 textures

    1*  1024*1024 textures

    1* 512*512 textures

     

    less faces lower resolution textures, But unbelievable FPS

     

    c142f0baab28f22c6d0049ef3323f95a.jpg

     

    FPS would be increased if i remove all the textures

     

    If i work in a wrong way, both of my custom vehicles could encounter same problem, but not 

     

     

     

     


  7. But some of my vehicles can cause an extreme FPS lagging, 

     

    My game can run at 100+FPS even i spawn 10+ T100 (R5 5600X is a very good CPU for Arma3), but get 40+FPS if i spawn only three of my modding vehicles(such as the vehicle in the screenshot above), FPS can be increased if i remove all crews.

     

     

     

     

     


  8. I want to use the sound config of official Tank like MBT_01(Merkava) MBT_02(T100) MBT_03(MBT52) for my custom tank, but i cant find the Sound config files and i dont know how to attach it to my mod (Only found the official *.wss of inbuild tanks)

    Anyone know How to use inbuild sound.hpp directly, or where is it?

     

     

     

     

    I do not want to rewrite the sound.hpp of arma samples and test the codes one by one


  9. 7 hours ago, Jackal326 said:

    They are Binarized within the models themselves and are not openly available. The only open-source model.cfgs are part of the sample models.

    Question solved(XD), the model.cfg inside the p3d can be read directly by Eliteness  of mikero's Dos Tools....thanks for your information


  10. Where is the model.cfg of official vehicles (e.g. T100  M2A1) located in?

    i try to learn modding from Arma sample files, but i found there are many problems in the sample tank (Test_Tank_01) and i cant fix them, than i try to debinarize the official P3d and config.cpp but did not find anything about model.cfg.

     

     

×