Jump to content

Prodeath21

Member
  • Content Count

    12
  • Joined

  • Last visited

  • Medals

Community Reputation

5 Neutral

About Prodeath21

  • Rank
    Private First Class

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Solution: Hey, I added the class´s you mentioned above, but it was still not working. In the end I found out, that > vehicleClass = "Structures"; < was missing. After adding it everything was working. Here´s my final config: class CfgVehicles { class House; class House_F: House { class DestructionEffects; }; class Ruins_F; class Land_PDE_larmschutz_tur : House_F { author = "Prodeath21"; displayName = "$STR_PDE_larmschutz_tur"; scope = 2; scopecurator = 2; model = "\projekt_deutschland_structures\larmschutz\larmschutz_tur.p3d"; icon = "iconObject_4x1"; editorCategory = "PDE_Addon"; editorSubcategory = "PDE_larmschutz"; editorPreview = "\projekt_deutschland_structures\larmschutz\icons\preview_PDE_larmschutz_tur.jpg"; vehicleClass = "Structures"; //NEW class AnimationSources { class Door_1_sound_source { source = "user"; initPhase = 0; animPeriod = 1; sound = "MetalOldDoorsSound"; //From: A3\sounds_f\config.cpp soundPosition = "Door_1_trigger"; }; class Door_1_noSound_source { source = "user"; initPhase = 0; animPeriod = 1; }; class Door_1_locked_source { source = "user"; initPhase = 0; animPeriod = 0.80000001; }; }; class UserActions { class OpenDoor { displayNameDefault = "<img image='\A3\Ui_f\data\IGUI\Cfg\Actions\open_door_ca.paa' size='2.5' />"; displayName = "$STR_DN_OUT_O_DOOR"; position = "Door_1_trigger"; priority = 1; actionNamedSel = "door"; radius = 2; aiMaxRange = 5.25; onlyForPlayer = 0; condition = "((this animationSourcePhase 'Door_1_sound_source') < 0.5) && (cameraOn isKindOf 'CAManBase')"; statement = "([this, 1, 1] call BIS_fnc_Door)"; }; class CloseDoor: OpenDoor { displayNameDefault = "<img image='\A3\Ui_f\data\IGUI\Cfg\Actions\open_door_ca.paa' size='2.5' />"; displayName = "$STR_DN_OUT_C_DOOR"; priority = 1; condition = "((this animationSourcePhase 'Door_1_sound_source') >= 0.5) && ((this getVariable ['bis_disabled_Door_1', 0]) != 1) && (cameraOn isKindOf 'CAManBase')"; statement = "([this, 1, 0] call BIS_fnc_Door)"; }; }; }; }; Thanks for your help!
  2. Okay will try that, will take some time. Thank you!
  3. I am using mikeros 🙂
  4. Hey guys, I have created several buildings and objects to use them on my terrain. After placing them with the terrain builder and exporting them ingame, the doors are not working anymore. No scroll option either. In EDEN everything is working perfect! Here´s my object class and model.cfg class CfgVehicles { class Static; class PDE_larmschutz_tur : Static { author = "Prodeath21"; displayName = "$STR_PDE_larmschutz_tur"; scope = 2; scopecurator = 2; model = "\projekt_deutschland_structures\larmschutz\larmschutz_tur.p3d"; icon = "iconObject_4x1"; editorCategory = "PDE_Addon"; editorSubcategory = "PDE_larmschutz"; editorPreview = "\projekt_deutschland_structures\larmschutz\icons\preview_PDE_larmschutz_tur.jpg"; class AnimationSources { class Door_1_sound_source { source = "user"; initPhase = 0; animPeriod = 1; sound = "MetalOldDoorsSound"; //From: A3\sounds_f\config.cpp soundPosition = "Door_1_trigger"; }; class Door_1_noSound_source { source = "user"; initPhase = 0; animPeriod = 1; }; class Door_1_locked_source { source = "user"; initPhase = 0; animPeriod = 0.80000001; }; }; class UserActions { class OpenDoor { displayNameDefault = "<img image='\A3\Ui_f\data\IGUI\Cfg\Actions\open_door_ca.paa' size='2.5' />"; displayName = "$STR_DN_OUT_O_DOOR"; position = "Door_1_trigger"; priority = 1; actionNamedSel = "door"; radius = 2; aiMaxRange = 5.25; onlyForPlayer = 0; condition = "((this animationSourcePhase 'Door_1_sound_source') < 0.5) && (cameraOn isKindOf 'CAManBase')"; statement = "([this, 1, 1] call BIS_fnc_Door)"; }; class CloseDoor: OpenDoor { displayNameDefault = "<img image='\A3\Ui_f\data\IGUI\Cfg\Actions\open_door_ca.paa' size='2.5' />"; displayName = "$STR_DN_OUT_C_DOOR"; priority = 1; condition = "((this animationSourcePhase 'Door_1_sound_source') >= 0.5) && ((this getVariable ['bis_disabled_Door_1', 0]) != 1) && (cameraOn isKindOf 'CAManBase')"; statement = "([this, 1, 0] call BIS_fnc_Door)"; }; }; }; }; My P3D name: "larmschutz_tur.p3d" class CfgSkeletons { class Default { isDiscrete = 1; skeletonInherit = ""; skeletonBones[] = {}; }; class PDE_larmschutz_sceleton: Default { skeletonInherit = "Default"; skeletonBones[]= { "", "" }; }; class PDE_larmschutz_tur_sceleton: Default { skeletonInherit = "Default"; skeletonBones[]= { "door", "" }; }; }; class CfgModels { class Default { skeletonName=""; sections[]={}; sectionsInherit=""; }; class larmschutz: Default { skeletonName="PDE_larmschutz_sceleton"; sections[]={""}; sectionsInherit=""; }; class larmschutz_tur: larmschutz { skeletonName="PDE_larmschutz_tur_sceleton"; sections[]={""}; class Animations { class Door_1 { type = rotation; source = Door_1_sound_source; selection = door; axis = door_axis; memory = 1; minValue = 0.1; maxValue = 1; angle0 = 0; angle1 = (rad 80); }; }; }; }; In the Geometry LOD I added the propertys "class = building", "map = wall" I allready tryed for 2 weeks without a solution... Thx for your help! :)
  5. Man, you are the best! Finaly it´s working fine 😄. Followed your workflow described above. Thanks.
  6. Thanks for your answer, I just made it work. I replaced the selected section in the geometry LOD with a simple cube and now it´s working. Still using the static class. But theres still one problem. When climbing the ladder the player is looking into the wrong direction... 90° to the right with his hole body. Don´t know why. Do you know where to change that? Thanks for your help. 🙂
  7. Prodeath21

    Problems with ladder class config

    Toppic Closed and transfered --> https://forums.bohemia.net/forums/topic/231663-problems-with-ladder-class-config/
  8. Hey, I am currently working on an Arma object and now want to implement the ladder function on to the model. But it´s not working and I don´t know why. Tryed out several things, but still not working... I also surched for a thread about it but could not fined one. Here´s my object class class Static; class Pro21_Autobahnschild : Static { author = "Prodeath21"; displayName = "$STR_Pro21_autobahnschild"; scope=2; model = "\Pro21_Autobahnschild\autobahnschild\autobahnschild.p3d"; //icon = "\Pro21_Autobahnschild\autobahnschild\icons\autobahnschild.paa"; editorCategory="Pro21_Addon"; editorSubcategory="Pro21_Objects"; //editorPreview="\A3\EditorPreviews_F\Data\CfgVehicles\I_Boat_Transport_01_F.jpg"; //picture = "\Pro21_Autobahnschild\autobahnschild\icons\autobahnschild.paa"; //vehicleClass = ""; ladders[]= { { "Ladder_1_start", "Ladder_1_end", 2.5, "Ladder_1_action" } }; }; I configured: Ladder_1_start -> Memory LOD -> at the start of the ladder Ladder_1_end -> Memory LOD -> at the end of the ladder Ladder_1_action -> Geometry LOD -> geometry selection of the ladder I looked it up here: https://community.bistudio.com/wiki/CfgVehicles_Config_Reference#ladders But the player option to climbe is still not showing up ingame.. Am I missing something? Pls Help Thanks in advance.
  9. Hey, I am currently working on an Arma object and now want to implement the ladder function on to the model. But it´s not working and I don´t know why. Tryed out several things, but still not working... I also surched for a thread about it but could not fined one. Here´s my object class class Static; class Pro21_Autobahnschild : Static { author = "Prodeath21"; displayName = "$STR_Pro21_autobahnschild"; scope=2; model = "\Pro21_Autobahnschild\autobahnschild\autobahnschild.p3d"; //icon = "\Pro21_Autobahnschild\autobahnschild\icons\autobahnschild.paa"; editorCategory="Pro21_Addon"; editorSubcategory="Pro21_Objects"; //editorPreview="\A3\EditorPreviews_F\Data\CfgVehicles\I_Boat_Transport_01_F.jpg"; //picture = "\Pro21_Autobahnschild\autobahnschild\icons\autobahnschild.paa"; //vehicleClass = ""; ladders[]= { { "Ladder_1_start", "Ladder_1_end", 2.5, "Ladder_1_action" } }; }; I configured: Ladder_1_start -> Memory LOD -> at the start of the ladder Ladder_1_end -> Memory LOD -> at the end of the ladder Ladder_1_action -> Geometry LOD -> geometry selection of the ladder I looked it up here: https://community.bistudio.com/wiki/CfgVehicles_Config_Reference#ladders But the player option to climbe is still not showing up ingame.. Am I missing something? Pls Help Thanks in advance. Transfered to other section --> https://forums.bohemia.net/forums/topic/231663-problems-with-ladder-class-config/
  10. Hey, thats my final addon! Check it out. https://steamcommunity.com/sharedfiles/filedetails/?id=2135377122
  11. Thank you!! It finally is slower and works! I set "maxValue = 10;" to slow it down even more and get the perfect result. I also set "source = "::time";", so the windmill is starting automatically with the animation when placing it in EDEN. Here are my final lines of code: My objects Class (inherited into CfgVehicles (config.cpp)) class Pro21_Bahn_5 : Static { author = "Prodeath21"; displayName = "$STR_Pro21_Bahn_5"; scope=2; model = "\Pro21_Minigolf\Bahn_5\Bahn_5.p3d"; icon = "\Pro21_Minigolf\default\icons\minigolf.paa"; editorCategory="Pro21_Addon"; editorSubcategory="Pro21_Objects"; //picture = "\Pro21_Minigolf\default\icons\default.paa"; //vehicleClass = ""; class AnimationSources { class windrad { source = "::time"; //to start the animation automatically }; }; }; My model.cfg class CfgSkeletons { class Default { isDiscrete = 1; skeletonInherit = ""; skeletonBones[] = {}; }; class Pro21_Bahn_5_sceleton: Default { skeletonInherit = "Default"; skeletonBones[]= { "wind","" }; }; }; class Rotation; class CfgModels { class Default { skeletonName=""; sections[]={}; sectionsInherit=""; }; class Bahn_5: Default { skeletonName="Pro21_Bahn_5_sceleton"; sections[]={""}; sectionsInherit=""; class Animations { class windrad { type = "rotation"; source = "::time"; selection = "wind"; axis = "wind_axis"; sourceAddress="loop"; memory = 1; minValue = 0; maxValue = 10; animPeriod = 0; angle0 = "0"; angle1 = "rad -360"; }; }; }; };
  12. Hey, currently I am working on a small "just for fun" addon to get better knowledge about Arma´s static objects and how to create them. At the moment I am creating a mini golf course with a windmill and i want to animate (spinn) the rotor of it. My Problem is, that i want to constantly rotate the windmill like the default windturbines in Arma 3, but slower. I was looking into the default turbines configs but had problems to understand how the animations work and start at the spawn. I also tryed to trigger my animation via a UserActions in the config.cpp, wich worked but it still was/is not the final solution for me. I also found out about the "sourceAddress="loop";" option after researching but it´s still not working 😞 I hope that explained my problem pretty well. Has anyone a solution, on how to fix that? My objects Class (inherited into CfgVehicles (config.cpp)) class Pro21_Bahn_5 : Static { author = "Prodeath21"; displayName = "$STR_Pro21_Bahn_5"; scope=2; model = "\Pro21_Minigolf\Bahn_5\Bahn_5.p3d"; icon = "\Pro21_Minigolf\default\icons\minigolf.paa"; editorCategory="Pro21_Addon"; editorSubcategory="Pro21_Objects"; //picture = "\Pro21_Minigolf\default\icons\default.paa"; //vehicleClass = ""; class AnimationSources { class windrad { source = "user"; //default "user" animPeriod = 12; //Dauer einer periode (Sekunden) }; }; }; My model.cfg class CfgSkeletons { class Default { isDiscrete = 1; skeletonInherit = ""; skeletonBones[] = {}; }; class Pro21_Bahn_5_sceleton: Default { skeletonInherit = "Default"; skeletonBones[]= { "wind","" }; }; }; class Rotation; class CfgModels { class Default { skeletonName=""; sections[]={}; sectionsInherit=""; }; class Bahn_5: Default { skeletonName="Pro21_Bahn_5_sceleton"; sections[]={""}; sectionsInherit=""; class Animations { class windrad { type = "rotation"; source = "user"; selection = "wind"; axis = "wind_axis"; sourceAddress="loop"; memory = 1; minValue = 0; maxValue = 1; animPeriod = 0; angle0 = "0"; angle1 = "rad -360"; }; }; }; }; Thank you for your help! 🙂
×