Jump to content

blackyesp

Member
  • Content Count

    18
  • Joined

  • Last visited

  • Medals

Posts posted by blackyesp


  1. Hi,

    I couldn't get around with the config to create my own flag. Texture not found pops up and the flag is invisible.

     

    config.bin

    class CfgPatches
    {
    	class ESAT_flags
    	{
    		author="Blacky";
    		units[]=
    		{
    			"ESAT_Flags"
    		};
    		weapons[]={};
    		requiredVersion=0.1;
    		requiredAddons[]=
    		{
    			"A3_Structures_F_Mil_Flags"
    		};
    	};
    	class Markers
    	{
    		units[]={};
    		weapons[]={};
    		requiredVersion=1;
    	};
    };
    class CfgVehicles
    {
    	class FlagCarrier;
    	class ESAT_Flag_F: FlagCarrier
    	{
    		author="Blacky";
    		_generalMacro="ESAT_Flag_F";
    		scope=2;
    		scopeCurator=2;
    		displayName="Bandera ESAT";
    		editorPreview="banderas_esat\preview\prev.jpg";
    		hiddenSelectionsTextures[]=
    		{
    			"\A3\Structures_F\Mil\Flags\Data\Mast_mil_CO.paa"
    		};
    		hiddenSelectionsMaterials[]=
    		{
    			"\A3\Structures_F\Mil\Flags\Data\Mast_mil.rvmat"
    		};
    		class EventHandlers
    		{
    			init="(_this select 0) setFlagTexture 'banderas_esat\flag\flag_esat.paa'";
    		};
    	};
    	class Banner_01_F;
    	class Banner_ESAT: Banner_01_F
    	{
    		displayName="Banner ESAT";
    		editorPreview="banderas_esat\preview\prev.jpg";
    		hiddenSelectionsTextures[]=
    		{
    			"banderas_esat\flag\flag_esat.paa"
    		};
    	};
    };
    class cfgMods
    {
    	author="Blacky";
    	timepacked="1622227573";
    };
    

    Perhaps I can't get the pathing right bc I'm kinda new in this.

     

    My addon structure is:

    Quote

    @Banderas_Esat/ Addons/ banderas_esat.pbo / ...

    Inside the pbo is the config file and 2 folders "flag" containing the flag_esat.paa and "preview" containing prev.jpg images.

     

    I checked the names multiple times and they should be all correct.

     

    What am i missing??

     

    Thanks in advance


  2. 7 hours ago, Grumpy Old Man said:

    Hm, interestingly enough I'm getting the same, on current devbranch.

    This was definitely not happening before and has to be new.

     

    Everything on ultra, pedal to the metal.

     

    VIKhnfq.jpg

     

    Cheers

     

    hey GOM!

    Thing is that it happens on some signs with just .paa textures as well, while others just with r2t. So it's definetly a bug. Maybe it's something related to the material?

     

    regards!

    • Like 2

  3. Hi! I've been placing some custom textures in .paa format and some r2t on objects like screens and signs. Being the texture still visible it appears to be some strange noise while playing ingame. Some objects display the noise but others don't, so I couldn't really find any reason or solution  to this. Anyone know what could possibly cause this?

     

    Help please :)

    (Two of three objects displaying the noise issue)

    ?interpolation=lanczos-none&output-forma

    • Like 1

  4. I've done all what the video says but my radio doesn't play. I tested it on a vanilla showcase with ACE. this is my config:
     

    Spoiler

    class CfgPatches {
        class klpq_musicRadio_configs_1514566847 {
            units[] = {};
            weapons[] = {};
            requiredVersion = 1;
            requiredAddons[] = {};
        };
    };

    class CfgMusic {
        tracks[] = {};

        class klpq_musicRadio_cefcb2f3cc85c970b0e76178019d1c3c {
            sound[] = {"NegroFM\ParadiseCity_GunsRoses.ogg", db+3, 1};
            tag = "klpq_musicRadio_v1";
            theme = "no_theme";
            duration = 413;
            artist = "";
            title = "";
            klpq_ignoreTrack = 0;
        };
        class klpq_musicRadio_fcea88787eed6de7da566d3f12cde863 {
            sound[] = {"NegroFM\WeAreNotGonnaTakeIt_TwisterSister.ogg", db+3, 1};
            tag = "klpq_musicRadio_v1";
            theme = "no_theme";
            duration = 220;
            artist = "";
            title = "";
            klpq_ignoreTrack = 0;
        };
    };

    class CfgSounds {
        tracks[] = {};

        class klpq_musicRadio_cefcb2f3cc85c970b0e76178019d1c3c {
            sound[] = {"NegroFM\ParadiseCity_GunsRoses.ogg", db+6, 1, 100};
            titles[] = {};
        };
        class klpq_musicRadio_cefcb2f3cc85c970b0e76178019d1c3c_vol0 {
            sound[] = {"NegroFM\ParadiseCity_GunsRoses.ogg", db+0, 1, 100};
            titles[] = {};
        };
        class klpq_musicRadio_cefcb2f3cc85c970b0e76178019d1c3c_vol1 {
            sound[] = {"NegroFM\ParadiseCity_GunsRoses.ogg", db+3, 1, 100};
            titles[] = {};
        };
        class klpq_musicRadio_cefcb2f3cc85c970b0e76178019d1c3c_vol2 {
            sound[] = {"NegroFM\ParadiseCity_GunsRoses.ogg", db+6, 1, 100};
            titles[] = {};
        };
        class klpq_musicRadio_cefcb2f3cc85c970b0e76178019d1c3c_loud_vol0 {
            sound[] = {"NegroFM\ParadiseCity_GunsRoses.ogg", db+0, 1, 500};
            titles[] = {};
        };
        class klpq_musicRadio_cefcb2f3cc85c970b0e76178019d1c3c_loud_vol1 {
            sound[] = {"NegroFM\ParadiseCity_GunsRoses.ogg", db+6, 1, 500};
            titles[] = {};
        };
        class klpq_musicRadio_cefcb2f3cc85c970b0e76178019d1c3c_loud_vol2 {
            sound[] = {"NegroFM\ParadiseCity_GunsRoses.ogg", db+12, 1, 500};
            titles[] = {};
        };
        class klpq_musicRadio_fcea88787eed6de7da566d3f12cde863 {
            sound[] = {"NegroFM\WeAreNotGonnaTakeIt_TwisterSister.ogg", db+6, 1, 100};
            titles[] = {};
        };
        class klpq_musicRadio_fcea88787eed6de7da566d3f12cde863_vol0 {
            sound[] = {"NegroFM\WeAreNotGonnaTakeIt_TwisterSister.ogg", db+0, 1, 100};
            titles[] = {};
        };
        class klpq_musicRadio_fcea88787eed6de7da566d3f12cde863_vol1 {
            sound[] = {"NegroFM\WeAreNotGonnaTakeIt_TwisterSister.ogg", db+3, 1, 100};
            titles[] = {};
        };
        class klpq_musicRadio_fcea88787eed6de7da566d3f12cde863_vol2 {
            sound[] = {"NegroFM\WeAreNotGonnaTakeIt_TwisterSister.ogg", db+6, 1, 100};
            titles[] = {};
        };
        class klpq_musicRadio_fcea88787eed6de7da566d3f12cde863_loud_vol0 {
            sound[] = {"NegroFM\WeAreNotGonnaTakeIt_TwisterSister.ogg", db+0, 1, 500};
            titles[] = {};
        };
        class klpq_musicRadio_fcea88787eed6de7da566d3f12cde863_loud_vol1 {
            sound[] = {"NegroFM\WeAreNotGonnaTakeIt_TwisterSister.ogg", db+6, 1, 500};
            titles[] = {};
        };
        class klpq_musicRadio_fcea88787eed6de7da566d3f12cde863_loud_vol2 {
            sound[] = {"NegroFM\WeAreNotGonnaTakeIt_TwisterSister.ogg", db+12, 1, 500};
            titles[] = {};
        };
    };

     

    I converted the .ogg using the following online tool: https://audio.online-convert.com/convert-to-ogg
    And I packed 2 PBOs into addons with Addon Builder.


    This is my file structure:

    098657d01a.png

    Everything seems fine to me. Any help? I really would like to try this mod, because it looks so cool :)


  5. Just now, phronk said:

    Difficulties regular - elite do not need to be defined anymore.  Example from my server:

     

    class DifficultyPresets
    {
    class CustomDifficulty
    {
    class Options
    {
    groupIndicators=2;
    friendlyTags=1;

    .........

    Fuck. The parameters are called different as the ones I run. Could you please send me your file and I will try it on my server?
    is forcedDifficulty = "Options"; your config line?

     

    ty for quick response


  6. Hi,

    I tried several times to change my server's difficulty to custom parameters, but can't get it to work properly. I checked wiki pages (https://community.bistudio.com/wiki/server.armaprofile ), but in my opinion the info and params seem poor or outdated regarding Arma 3 (in comparison with the one from other Arma series). However the process seems very basic and with a bit of logic it's very simple to set up, but for some reason it does not work for me. I checked video tutorials about it and I'm doing everything as told but still no result. I created new profiles but the file seems to reset to default whenever I start the server. I made sure to change the config.bin value as well...

    I feel lost now. Could anyone help me please?

    Arma3Profile:

    class Difficulties
    {
    	class Recruit
    	{
    		class Flags
    		{
    			Armor=1;
    			FriendlyTag=1;
    			EnemyTag=1;
    			HUD=1;
    			HUDPerm=1;
    			HUDWp=1;
    			HUDWpPerm=1;
    			WeaponCursor=1;
    			AutoAim=1;
    			AutoGuideAT=1;
    			3rdPersonView=1;
    			ClockIndicator=1;
    			Map=1;
    			Tracers=1;
    			AutoSpot=1;
    			UltraAI=0;
    			DeathMessages=1;
    			NetStats=1;
    			VonID=1;
    		};
    		skillFriendly=0.34999999;
    		skillEnemy=0.34999999;
    		precisionFriendly=0.2;
    		precisionEnemy=0.2;
    	};
    	class Regular
    	{
    		class Flags
    		{
    			Armor=1;
    			FriendlyTag=1;
    			EnemyTag=0;
    			HUD=1;
    			HUDPerm=0;
    			HUDWp=1;
    			HUDWpPerm=1;
    			WeaponCursor=1;
    			AutoAim=0;
    			AutoGuideAT=0;
    			3rdPersonView=1;
    			ClockIndicator=1;
    			Map=1;
    			Tracers=1;
    			AutoSpot=0;
    			UltraAI=0;
    			DeathMessages=1;
    			NetStats=1;
    			VonID=1;
    		};
    		skillFriendly=0.44999999;
    		skillEnemy=0.44999999;
    		precisionFriendly=0.34999999;
    		precisionEnemy=0.34999999;
    	};
    	class Veteran
    	{
    		class Flags
    		{
    			Armor=0;
    			FriendlyTag=0;
    			EnemyTag=0;
    			HUD=1;
    			HUDPerm=0;
    			HUDWp=1;
    			HUDWpPerm=1;
    			WeaponCursor=0;
    			AutoAim=0;
    			AutoGuideAT=0;
    			3rdPersonView=0;
    			ClockIndicator=1;
    			Map=0;
    			Tracers=1;
    			AutoSpot=0;
    			UltraAI=0;
    			DeathMessages=0;
    			NetStats=0;
    			VonID=1;
    		};
    		skillFriendly=0.75;
    		skillEnemy=0.75;
    		precisionFriendly=0.75;
    		precisionEnemy=0.75;
    	};
    	class Expert
    	{
    		class Flags
    		{
    			Armor=0;
    			FriendlyTag=0;
    			EnemyTag=0;
    			HUD=1;
    			HUDPerm=0;
    			HUDWp=1;
    			HUDWpPerm=1;
    			WeaponCursor=0;
    			AutoAim=0;
    			AutoGuideAT=0;
    			3rdPersonView=0;
    			ClockIndicator=1;
    			Map=0;
    			Tracers=1;
    			AutoSpot=0;
    			UltraAI=0;
    			DeathMessages=0;
    			NetStats=0;
    			VonID=0;
    		};
    		skillFriendly=0.94999999;
    		skillEnemy=0.94999999;
    		precisionFriendly=0.94999999;
    		precisionEnemy=0.94999999;
    	};
    	class Custom
    	{
    		class Flags
    		{
    			Armor=1;
    			FriendlyTag=1;
    			EnemyTag=0;
    			HUD=1;
    			HUDPerm=0;
    			HUDWp=1;
    			HUDWpPerm=1;
    			WeaponCursor=0;
    			AutoAim=0;
    			AutoGuideAT=0;
    			3rdPersonView=1;
    			ClockIndicator=1;
    			Map=1;
    			Tracers=1;
    			AutoSpot=0;
    			UltraAI=0;
    			DeathMessages=0;
    			NetStats=1;
    			VonID=1;
    		};
    		skillFriendly=0.44999999;
    		skillEnemy=0.44999999;
    		precisionFriendly=0.34999999;
    		precisionEnemy=0.34999999;
    	};
    };
    singleVoice=0;
    maxSamplesPlayed=96;

    config.bin:

    forcedDifficulty = "Custom";

     

    Help me senpais


  7. Hi,

    I tried several times to change my server's difficulty to custom parameters, but can't get it to work properly. I checked wiki pages (https://community.bistudio.com/wiki/server.armaprofile ), but in my opinion the info and params seem poor or outdated regarding Arma 3 (in comparison with the one from other Arma series). However the process seems very basic and with a bit of logic it's very simple to set up, but for some reason it does not work for me. I checked video tutorials about it and I'm doing everything as told but still no result. I created new profiles but the file seems to reset to default whenever I start the server. I made sure to change the config.bin value as well...

    I feel lost now. Could anyone help me please?

    Arma3Profile:

    class Difficulties
    {
    	class Recruit
    	{
    		class Flags
    		{
    			Armor=1;
    			FriendlyTag=1;
    			EnemyTag=1;
    			HUD=1;
    			HUDPerm=1;
    			HUDWp=1;
    			HUDWpPerm=1;
    			WeaponCursor=1;
    			AutoAim=1;
    			AutoGuideAT=1;
    			3rdPersonView=1;
    			ClockIndicator=1;
    			Map=1;
    			Tracers=1;
    			AutoSpot=1;
    			UltraAI=0;
    			DeathMessages=1;
    			NetStats=1;
    			VonID=1;
    		};
    		skillFriendly=0.34999999;
    		skillEnemy=0.34999999;
    		precisionFriendly=0.2;
    		precisionEnemy=0.2;
    	};
    	class Regular
    	{
    		class Flags
    		{
    			Armor=1;
    			FriendlyTag=1;
    			EnemyTag=0;
    			HUD=1;
    			HUDPerm=0;
    			HUDWp=1;
    			HUDWpPerm=1;
    			WeaponCursor=1;
    			AutoAim=0;
    			AutoGuideAT=0;
    			3rdPersonView=1;
    			ClockIndicator=1;
    			Map=1;
    			Tracers=1;
    			AutoSpot=0;
    			UltraAI=0;
    			DeathMessages=1;
    			NetStats=1;
    			VonID=1;
    		};
    		skillFriendly=0.44999999;
    		skillEnemy=0.44999999;
    		precisionFriendly=0.34999999;
    		precisionEnemy=0.34999999;
    	};
    	class Veteran
    	{
    		class Flags
    		{
    			Armor=0;
    			FriendlyTag=0;
    			EnemyTag=0;
    			HUD=1;
    			HUDPerm=0;
    			HUDWp=1;
    			HUDWpPerm=1;
    			WeaponCursor=0;
    			AutoAim=0;
    			AutoGuideAT=0;
    			3rdPersonView=0;
    			ClockIndicator=1;
    			Map=0;
    			Tracers=1;
    			AutoSpot=0;
    			UltraAI=0;
    			DeathMessages=0;
    			NetStats=0;
    			VonID=1;
    		};
    		skillFriendly=0.75;
    		skillEnemy=0.75;
    		precisionFriendly=0.75;
    		precisionEnemy=0.75;
    	};
    	class Expert
    	{
    		class Flags
    		{
    			Armor=0;
    			FriendlyTag=0;
    			EnemyTag=0;
    			HUD=1;
    			HUDPerm=0;
    			HUDWp=1;
    			HUDWpPerm=1;
    			WeaponCursor=0;
    			AutoAim=0;
    			AutoGuideAT=0;
    			3rdPersonView=0;
    			ClockIndicator=1;
    			Map=0;
    			Tracers=1;
    			AutoSpot=0;
    			UltraAI=0;
    			DeathMessages=0;
    			NetStats=0;
    			VonID=0;
    		};
    		skillFriendly=0.94999999;
    		skillEnemy=0.94999999;
    		precisionFriendly=0.94999999;
    		precisionEnemy=0.94999999;
    	};
    	class Custom
    	{
    		class Flags
    		{
    			Armor=1;
    			FriendlyTag=1;
    			EnemyTag=0;
    			HUD=1;
    			HUDPerm=0;
    			HUDWp=1;
    			HUDWpPerm=1;
    			WeaponCursor=0;
    			AutoAim=0;
    			AutoGuideAT=0;
    			3rdPersonView=1;
    			ClockIndicator=1;
    			Map=1;
    			Tracers=1;
    			AutoSpot=0;
    			UltraAI=0;
    			DeathMessages=0;
    			NetStats=1;
    			VonID=1;
    		};
    		skillFriendly=0.44999999;
    		skillEnemy=0.44999999;
    		precisionFriendly=0.34999999;
    		precisionEnemy=0.34999999;
    	};
    };
    singleVoice=0;
    maxSamplesPlayed=96;

    config.bin:

    forcedDifficulty = "Custom";

     

    Help me senpais


  8. Hi once more!

    So... I've been playing with the PublicVariable command for a while now, but I never really got to understand the workflow of Variables. I just used them as basic true/false trigger conditions and they always worked fine, so I never bothered to find out how they really work until I started my dedicated server today, invited a friend to play and realized that those triggers activated at the beginning of the mission without any reason.
    Pissed, I tried to fix it by myself and maybe I wasn't using the right command or Var type that suited my needs, so I decided to do some research. I understood the difference between Local, Global and Public, but now I'm more confused, because more concepts as i.e. PublicVariableServer appearead and I still don't know which one to use for MP. Let me show you a simple example of my problem:
     

    There are 3 Editor-spawned triggers:

     

    trig1
    OnAct: Dog = true; PublicVariable "Dog";
    ------

    trig2

    OnAct: Cat = true; PublicVariable "Cat";

    ------

    trig3
    Condition: Dog AND Cat    
    OnAct: hint "It worked!"

    ------

     

    All of this works fine in SP and also in dedicated MP alone. But whenever a player joins the mission (Not necessary JIP) the variables mess up and trig3 gets activated without any aparent reason.
    I guess the answer is simple and probably I already found an explanation to my problem on the wiki pages, but I'm struggling trying to process all the new information. So, before I start changing stuff to fix it I want someone to please explain me what is happening and how to do it the right way.  :)

     

    Thank you in advance.

     

     

     


  9. I wanted to do something different, that whenever certain amount of civilians die, no matter who or what killed them, the mision fails. Most of the deaths are roadkills and the Side command didn't really work with that, because when a unit dies it is set to CIV side and it was hard to tell in my script if the killedunit was a CIV or a soldier. So I ended using the Faction command and it worked like a charm:

    MyCivKillCounter = 0;
    
    addMissionEventHandler ["EntityKilled",{
    
        params ["_killed","_killer","_instigator"];
    
    	 _faction = faction _killed;
    	
        if (_faction isEqualto "CIV_F") then {
    
            MyCivKillCounter = MyCivKillCounter + 1;
    
            if (MyCivKillCounter >= 1) then {["end2", false] call BIS_fnc_endMission; hint "One or more civilians died!"};
    
        };
    
    }];

    Edit: Using Side command also affects all the editor spawned objets. They belong to the civilian group as well and also recognised by _killed if they get destroyed. This could cause unwanted results. Faction command only gives you the original faction name.
     

    • Like 2

  10. On 19/10/2016 at 10:07 AM, Grumpy Old Man said:

     

    Like KK said, once a unit is dead its side is civilian regardless of the side it belonged to before dying/getting destroyed.

    Unfortunately this is some wonky solution to stop units shooting at stuff that's already dead.

     

    Why there is no "dead" side is beyond me, would make more sense.

     

    Possible solution:

    
    MyWestKillCounter = 0;
    
    addMissionEventHandler ["EntityKilled",{
    
        params ["_killedUnit","_killer","_triggerMan"];
    
        _configSide = [getNumber (configfile >> "CfgVehicles" >> typeOf _killedUnit >> "side")] call BIS_fnc_sideType;
        hint str _configside;
    
        if (_configSide isEqualTo west AND side _triggerMan isEqualTo west) then {
    
            MyWestKillCounter = MyWestKillCounter + 1;
    
            if (MyWestKillCounter >= 3) then {endMission "End4"};
    
        };
    
    }];

    This will check for the side of the units config.

     

    Could cause errors since after killing 2-3 units the killer gets put on the "enemy" side, making the second condition in the first if statement false.

    To prevent this you have to check for the config side of the shooters unit too, which isn't really a simple solution either, if you're switching sides or setting captive states during the mission.

     

    Cheers

     

    They didn't thank you, but lemme do it for them:
    Thank you, sir.  Your support given to this thread helped me a lot :)

    • Like 2

  11. Hello!

    I'm trying to do the following on my mission but can't find the way to do it:

    I made a Marker (Ellipse) to be randomly set on a position that is relative to an Object, so that the Object isn't located in the center of the Marker. I used the following Script:

    _Pos = [getPos Object1, random 150, random 360] call BIS_fnc_relPos;
    "Circle1" setMarkerPos _Pos;

    ELI5 version: Circle1 is set on a random position around 150 units from Object1. Circle1 has a 150 radius, too. Object1 has to be found and Circle1 shows its position on the map, so that Object1 is located randomly inside Circle1.

     

    So this seems to be working fine and I know some of you will wonder why I didn't spawn the Object randomly inside the Marker instead. Well the answer is because I would like the Object to be something that moves. So that Circle1 has to be following Object1 when it moves. I don't mind if it still keeps the same relative position inside the circle while moving or if it refreshes into a new random position relative to the object.

    I tried doing Loops and While statements, but didn't get lucky.

    while {not isnull Object1} do {"Circle1" setMarkerPos _Pos; sleep 0.5; }; //Not Working :(

    This is where my scripting knowledge and research skills couldn't get any further.

    I would be grateful if someone can help me with the script, please! :)

     

    Thanks in advance!


  12. Hey!

    Thank you very much for the reply guys!

     

    I actually tried both Scripts.

     

    @Lucullus Nice input! SetUnitLoadout looks very intuitive and easy to use. I will give it a chance in future missions. Your code also worked perfectly and solved all my needs :) Great help!

    I'm afraid I ended using @Beerkan's alternative, because of the initPlayerLocal.sqf tipp. I wasn't aware of this file and I'm sure it will spare me a lot of init problems for MP from now on. Thank you for that! I also prefer using BIS_fnc while scripting, so I decided to give it a try. The lines you gave me did exactly what you said. So I just changed it to the following and it worked perfectly: 

    [player,'hgun_Pistol_heavy_02_F',1] call BIS_fnc_addWeapon;
    player setAmmo [handgunWeapon player, 4];

    (also thank you for the forEach tipp!)

     

    Both alternatives worked great! Thank you again guys!

     

    Problem solved.


  13. Hello,

    I'm having some issues trying to set the same custom loadout to every playable unit on my MP mission. I'm trying to spawn every player with only 4 rounds inside the handgun's mag and I can't get it to work on MP. I've got different outcomes, but generally players spawn without a single bullet. I'm using the following Init.sqf:

    removeAllWeapons player;
    removeAllItems player;
    removeAllAssignedItems player;
    removeUniform player;
    removeVest player;
    removeBackpack player;
    removeHeadgear player;
    removeGoggles player;
    
    player forceAddUniform "U_BG_Guerilla1_1";
    for "_i" from 1 to 2 do {player addItemToUniform "FirstAidKit";};
    
    player addVest "V_Rangemaster_belt";
    player addItemToVest "SmokeShell";
    player addBackpack "B_AssaultPack_Kerry";
    player addHeadgear "H_Bandanna_camo";
    
    player addWeapon "hgun_Pistol_heavy_02_F";
    player addWeapon "Binocular";
    
    player setAmmo [handgunWeapon player, 4];
    
    player linkItem "ItemCompass";
    player linkItem "ItemWatch";
    player linkItem "ItemRadio";

    There is no unit defined as "Player" just "Playable" ones, because the outcome for the "player" unit was always different, as I'm testing this on my dedicated server. The mission is meant to be played on server, but I also want it working on my dedicated server.

    Any Idea what is happening? What am I obviusly missing?

     

    Thank you in advance!

×