Jump to content

tinboye

Member
  • Content Count

    103
  • Joined

  • Last visited

  • Medals

Everything posted by tinboye

  1. I just made a bunch of bat files and in each 1 i would just change the ID# which matched what workshop ID i wanted. "steamcmd.exe" +login user password +set_steam_guard_code #### +force_install_dir c:\does\not\matter +"workshop_download_item 107410 463939057" validate +quit the force install path does not matter, it will always install the workshop item under SteamCmd\steamapps\workshop\content\107410\ in this case the workshop item is 463939057 so it would be a folder called 463939057 under 107410 the mod being @a2op so i would just copy folder 463939057 to my server folder and rename it to @A2OP
  2. I ended up making like 20 bat files to download them all. Now I have to make it so once downloaded it will x copy the folder to a destination and rename it. would be nice to have a program or script for Windows to plunk in all workshop ids and just download them
  3. tinboye

    Memory Crash at Startup

    There was a small update pushed yesterday I believe. Could be that. Sent from my SM-N910W8 using Tapatalk
  4. tinboye

    bulk adding objects

    thanks for this, i am new to eden, I was able to figure out how to import the objects successfully after I figured out that Extended Bases Mod was interfering. My challenge now is importing entities like actual AI soldiers. I have read over some of the 3den commands but not entirely sure what to use for some of these fields. [ "Exile_Trader_Equipment", //Trader Uniform _objType "Exile_Trader_Equipment", //Trader Inventory _objType "GreekHead_A3_09", //Face _objType ["Acts_TreatingWounded01"], //_enabled [14585.2,16759.8,0.126438], //_pos 225.994 // _rot ] this is what I need to import, (I put next to each a comment on what they are in the game) when I create this character in the mission. and export it with eden I get that line along with using _npcs [ [ "Exile_Trader_Equipment", //Trader Uniform "Exile_Trader_Equipment", //Trader Inventory "GreekHead_A3_09", //Face ["Acts_TreatingWounded01"], //Animation [14585.2,16759.8,0.126438], //Coords 225.994 //Direction - No Comma ] ]; { private _logic = "Logic" createVehicleLocal [0, 0, 0]; private _trader = (_x select 0) createVehicleLocal [0, 0, 0]; private _animations = _x select 1; _logic setPosWorld (_x select 5); _logic setVectorDirAndUp [_x select 6, _x select 7]; _trader setVariable ["BIS_enableRandomization", false]; _trader setVariable ["BIS_fnc_animalBehaviour_disable", true]; _trader setVariable ["ExileAnimations", _animations]; _trader setVariable ["ExileTraderType", _x select 2]; _trader disableAI "ANIM"; _trader disableAI "MOVE"; _trader disableAI "FSM"; _trader disableAI "AUTOTARGET"; _trader disableAI "TARGET"; _trader disableAI "CHECKVISIBLE"; _trader allowDamage false; _trader setFace (_x select 3); _trader setUnitLoadOut (_x select 4); _trader setPosWorld (_x select 5); _trader setVectorDirAndUp [_x select 6, _x select 7]; _trader reveal _logic; _trader attachTo [_logic, [0, 0, 0]]; _trader switchMove (_animations select 0); _trader addEventHandler ["AnimDone", {_this call ExileClient_object_trader_event_onAnimationDone}]; } forEach _npcs; I could not find anything regarding how to have multiple objects/skins and animation types within an eden import. any ideas?
  5. tinboye

    bulk adding objects

    Is there a way I can import objects into eden which were once in a sqf file, I basically if i want to take this: I opened the debug console and ran this to see if it would import them, but it does not. what would I need to add or to change the script to make it work?
  6. I am just curious if it is possible to import this [ "Exile_Trader_Equipment", //Trader Uniform "Exile_Trader_Equipment", //Trader Inventory "GreekHead_A3_09", //Face ["Acts_TreatingWounded01"], //Animation [14585.2,16759.8,0.126438], //Coords 225.994 //Direction - No Comma ] [ "Exile_Trader_Equipment", //Trader Uniform "Exile_Trader_Equipment", //Trader Inventory "GreekHead_A3_09", //Face ["Acts_TreatingWounded01"], //Animation [14585.2,16759.8,0.126438], //Coords 225.994 //Direction - No Comma ] into eden using an eden script when i export into sqf it looks like this. private _npcs = [ ["Exile_Trader_Food", ["Acts_CivilListening_2"], "Exile_Trader_Food", "WhiteHead_17", [[],[],[],["rds_uniform_Worker3",[]],[],[],"rds_Villager_cap4","G_Aviator",[],["","","","","",""]], [3738.84, 10200.7, 365.168], [0.82503, 0.565089, 0], [0, 0, 1]] ]; { private _logic = "Logic" createVehicleLocal [0, 0, 0]; private _trader = (_x select 0) createVehicleLocal [0, 0, 0]; private _animations = _x select 1; _logic setPosWorld (_x select 5); _logic setVectorDirAndUp [_x select 6, _x select 7]; _trader setVariable ["BIS_enableRandomization", false]; _trader setVariable ["BIS_fnc_animalBehaviour_disable", true]; _trader setVariable ["ExileAnimations", _animations]; _trader setVariable ["ExileTraderType", _x select 2]; _trader disableAI "ANIM"; _trader disableAI "MOVE"; _trader disableAI "FSM"; _trader disableAI "AUTOTARGET"; _trader disableAI "TARGET"; _trader disableAI "CHECKVISIBLE"; _trader allowDamage false; _trader setFace (_x select 3); _trader setUnitLoadOut (_x select 4); _trader setPosWorld (_x select 5); _trader setVectorDirAndUp [_x select 6, _x select 7]; _trader reveal _logic; _trader attachTo [_logic, [0, 0, 0]]; _trader switchMove (_animations select 0); _trader addEventHandler ["AnimDone", {_this call ExileClient_object_trader_event_onAnimationDone}]; } forEach _npcs; I am able to import objects using this: collect3DENHistory{ { private[ "_obj" ]; _x params[ "_type", "_pos", "_rot" ]; _obj = create3DENEntity [ "Object", _type, _pos, true ]; _obj set3DENAttribute [ "rotation",[ 0,0,_rot ] ]; }forEach [ but not sure how to use this for things like animations, uniform, face etc. any help would be appreciated
  7. tinboye

    Import "sqf" to eden?

    So i did a test but I cannot get my eden to import via this method, no idea why. I created an object within eden, then I exported into initserver.sqf code then I tried to import some other items back into the map, but none are showing up So the top line is what was exported. I then created a file objects.sqf and in the init.sqf I added [] execVm "objects.sqf"; these 2 files are in the same folder as my mission.sqm but when I load the mission.sqm, the objects do not appear on the map as defined as this objects file. In the object file I have tried the actual initserver.sqf code. I have tried I have tried and I have tried I am trying to import a bunch of objects that was created using m3editor
  8. tinboye

    Import "sqf" to eden?

    Is there anyway a person could import trader NPC's into eden, I believe the code is m3editor _workBench = "Land_Workbench_01_F" createVehicleLocal [0,0,0]; _workBench setDir 204.239; _workBench setPosATL [3816.36,8954.08,0.0464783]; _trader = [ "Exile_Trader_Hardware", "Exile_Trader_Hardware", "WhiteHead_17", ["InBaseMoves_sitHighUp1"], [0, 0, -0.5], 170, _workBench ] call ExileClient_object_trader_create; would be something like this
  9. has anyone figured out how to get a workshop collection downloaded to a dedicated server? I can do 1 workshop item at a time but I would like to be able to update a whole collection on my dedicated box. I do not have steam client installed, its strictly a windows 2008 server to host servers.
  10. is there a way to sort the entities I have in arma 3 editor. Im a bit OCD when it comes to things. I imported a bunch of markers. bit the icons are not the same. as you can see in screenshot, I want to be able to arrange these markers so icons match, or so the names match then when i export it will change the id#'s to the mission.sqm accordingly.
  11. tinboye

    RHS Escalation (AFRF and USAF)

    Thanks I will check it out.
  12. tinboye

    Import Markers

    ok what would be the proper script i can use, the issue I am having is as follows, I have the new arma 3 editor which changes the format of coordinates within markers, but i have old markers which I need to import into the new map. I have over 80 markers i need to import I Do not want to have to just create new ones within the editor but instead import my existing markers.
  13. So i am trying to import markers into my Chernarus map for arma 3 from what I understand I can add a script into the initserver.sqf and have that within the init.sqf and then load my mission.sqm to import them but my script does not seem to import. maybe someone can help me figure out why
  14. tinboye

    RHS Escalation (AFRF and USAF)

    I was hoping I didnt have to add EVERY class to the mission.sqm here is what it shows loading in rpt
  15. tinboye

    RHS Escalation (AFRF and USAF)

    I actually get no errors in my rpt about rhafrf. But I need to add something into the mission.sqm to force players to use it. Otherwise they won't see the content.
  16. tinboye

    RHS Escalation (AFRF and USAF)

    What do i need to add to my mission.sqm addons [] to require a player to use this mod? I am using every aspect of RHS: AFRF on my server, vehicles, weapons, uniforms etc. I can load my server fine and get no errors about Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted. thanks
  17. anybody had any issues with running a HC on the same dedicated box as the arma 3 server? I host with gtx gaming, rent a dedicated box. If i run a HC from my home pc to the dedicated box's arma 3 server the HC connects. When i create a HC on the same dedicated box. The hc never tries to connect. echo Starting ARMA 3 HC Server... start "arma3" /min /high "arma3HCserver.exe" -client -connect=127.0.0.1 -port=2362 "-mod=@Zombies and Demons;@Epoch" -nosound timeout 2 echo Started ARMA 3 HC Server... timeout 5 exit the white window comes up showing the client is running, but never goes beyond that.
  18. I am trying to figure out if there is a way to specify the main path to scripts within mission pbo. For example. I have the mpmissions\epoch.altis\ folder In there is my description.ext Since the latest epoch update they now have description.ext as: // Epoch Survival Gamemode #include "epoch_config\sandbox_config.hpp" which the sandbox_config.hpp contains all the description.ext information now I have my description.ext as: // Epoch Survival Gamemode #include "epoch_config\sandbox_config.hpp" #include "infiSTAR_AdminMenu.hpp" #include "addons\halv_spawn\spawndialog.hpp" #include "addons\halv_spawn\Halv_defines.hpp" #include "trader\tradedialog.hpp" #include "CfgMusic.hpp" #include "global.hpp" #include "scarCODE\VGS\main_VGS.hpp" class RscTitles { #include "VEMFr_client\gui\hpp_mainVEMFrClient.hpp" //************************ class radioChatterBar { idd = -1; onLoad = "uiNamespace setVariable ['radioChatterBar', _this select 0]"; onUnload = "uiNamespace setVariable ['radoiChatterBar', objNull]"; onDestroy = "uiNamespace setVariable ['radioChatterBar', objNull]"; fadein = 0; fadeout = 10; duration = 10e10; movingEnable = 0; controlsBackground[] = {}; objects[] = {}; class controls { class statusBarText { idc = 1010; x = safezoneX; y = safezoneY; // upper left hand corner //x = safezoneX + safezoneW - 1.5; //y = safezoneY + safezoneH - 0.4; //H w = 1; h = 0.3; //hopefully makes it 10 lines tall shadow = 2; colorBackground[] = { 1, 0.3, 0, 0.0 }; // uncomment and increase 4th number to have a background font = "PuristaSemibold"; size = 0.03; type = 13;// CT_TYPES = CT_STRUCTURED_TEXT style = 1; text="Loading server info..."; class Attributes { align="left"; color = "#FFFFFF"; //"#00FF09";BrightGreen //#FF8700 }; }; }; }; //*********************************** }; class CfgSounds { #include "HC\Zombies\infectedsounds.hpp" #include "Configs\CfgSounds.hpp" }; //ESVP class CfgNotifications { #include "SPKcode\ESVP\notifications.h" }; when I try to load my mission i get the error: ErrorMessage: Include file mpmissions\epoch.Altis\epoch_config\VEMFr_client\gui\hpp_mainVEMFrClient.hpp not found. so what i want to do is have it so i can specify the location of the #include "VEMFr_client\gui\hpp_mainVEMFrClient.hpp" I have tried #include "..\VEMFr_client\gui\hpp_mainVEMFrClient.hpp" or #include ".\VEMFr_client\gui\hpp_mainVEMFrClient.hpp" to tell the script to look in previous folder for the VEMFr_client folder but it doesnt recognize any change. So is there a variable to use like #include "x\VEMFr_client\gui\hpp_mainVEMFrClient.hpp" #include "q\VEMFr_client\gui\hpp_mainVEMFrClient.hpp" #include "z\VEMFr_client\gui\hpp_mainVEMFrClient.hpp" #include "m\VEMFr_client\gui\hpp_mainVEMFrClient.hpp" in the path to make the script be recognized in the root of the mission folder. thanks
  19. tinboye

    intermitt lag in mp server list

    Still have this issue. Cannot seem to get any answers why this is happening or how to reproduce this issue. Even with the latest arma 3 update. Reinstalling arma 3. Updating my video drivers. Still only have lag in the multiplayer screen. Once I join a server it's fine. And doesn't happen on a sp or campaign screen.
  20. I am sorry if this was asked before, but i did search and unable to find an answer. When I am in arma 3 and click on play, then click multiplayer, as soon as it loads the screen where i can choose from internet, recent, lan, friends or remote connect the background animation/sound lags and is choppy. when i try to click on anything or type in the remote connect box or filter box, i get lag there as well. i have completely uninstalled, reinstalled, reverified all arma 3 files. once i am loaded into a game i get 50+ fps. seems to only happen in the mp server list screen. this is my dxdag any help would be appreciated.
  21. tinboye

    RH Pistol pack

    i am trying to get this to work on my exile server on my server i have added "RH_de_cfg" to my mission.sqm addOns[] section also added it into requiredAddons[] under the config.cpp for exile_server_config pbo on my server i added the RHI.bikey into my keys folder my server launch i have @Exile;@ExileServer;@ZombiesandDemons;@RHPistolpack; on my pc i have the required mods enabled, exact same versions. but when i try to join the server i get the error: 16:51:12 Warning Message: Files "D:\Games\Steam\steamapps\common\Arma 3\@RHPistolpack\addons\rh_de.pbo" are not signed by a key accepted by this server. To play on this server, remove listed files or install additional accepted keys. i did add the same RHI.bikey into my D:\Games\Steam\steamapps\common\Arma 3\keys folder any ideas?
  22. im looking for assistance to clarify a couple things pls. im trying to get music added to the server so client can hear the music but not have to download a 50mb mission file. So what i have done so far is I made a mod that they have to download and enable. in that mod i have: @ambients enabled via -mod= as the client and on server side also have this added. in the mission file i have my cfgmusic class but a little unclear on if this is enough. would this be the proper format to get the audio from the mod? class intro4 { name = "intro4"; sound[] = {"@ambients\addons\ambients\samples\IntroSong4.ogg", db+1,1}; }; within the mod the structure is as follows: @ambients > addons > ambients.pbo inside that pbo ambients.pbo > config.cpp and folder samples which has all the music i have the prefix set up as ambients in the mission file i already have the triggers setup am i missing anything?
  23. is it possible for a person to use this to run music from the mission folder itself? like if i had a folder in my mission folder called music and then in the description.ext i specified class CfgMusic { class Track01_Proteus { name = "01: Track1"; sound[] = {"music\track1.ogg",1.0,1.0}; duration = 94; pack = "custom"; moods[] = {"darkness", "tension"}; album = "custom"; artist = "custom"; image = "images\image_ca.paa"; }; }; that sort of thing.
  24. i downloaded your port for arma 3, but having an issue with getting it to work. do you have a server key for this? or does the client only need to enable this on their end, and the mission will make it work? cause when i try to enable it on my server launch it will not let my mission start.
  25. there are 35 tracks, right now they are 22mb total size in ogg, how can i compress these without losing quality? i also tested this script out on my mission. but could not get the tracks to play at all. ive been searching for a script that i can use in my a3 epoch server which will play ambient music like a2 dayz. so far there is only 1 which i sorta made work but it does not play the tracks all the time. seems to only work when it wants to, and no errors in the rpt.
×