Jump to content
Sign in to follow this  
Placebo

Operation Arrowhead 1.52 Patch released (includes dedicated server exe)

Recommended Posts

Hmm seems when I "cleaned up" the thread last night I kinda deleted it completely without noticing, sorry bout that and all ;)

To bring all versions in line we released today the OA 1.52 update, the update also includes the Windows dedicated server for OA.

Not compatible with the Steam version of OA

===ARMA 2 Operation Arrowhead Patch 1.50 to 1.52 ===

Copyright © 2010 Bohemia Interactive. All rights reserved.

===SYSTEM REQUIREMENTS===

System requirements:

--------------------------------

• Fast Dual or Quad Core Core CPU

• 1 GB RAM

• GPU (NVIDIA GeForce 8600GT / ATI Radeon 3650 or faster) with Shader Model 3 and 512 MB VRAM

• Windows XP / Windows Vista / Windows 7

• DVD (Dual Layer compatible) for DVD version, 12 GB free HDD space

===HOW TO INSTALL THE PATCH===

Run the patch exe to apply the patch setup automatically.

It will install all content of the patch to the folder with your ArmA 2 installation (default is C:\Program Files\Bohemia Interactive\ArmA 2 or Bohemia Interactive\ArmA2).

Please note that it is not possible to rollback to a previous version after the installation of this patch, only a full reinstall of the game is possible, if you want to keep your previous version you may want to backup the entire game installation folder before applying this patch.

NOTE: This patch will also update your ARMA 2 1.05 to 1.07 if necessary.

CHANGELOG:

----------

===Engine===

* Fixed: C130 was crashing on takeoff.

* Fixed: Multiplayer UI - Cannot play after cancel.

* Improved: Helmet Mounted Display is drawn only for driver.

* Fixed: AutoSaves in MP.

* Improved: Show cargo unit name when speking in vehicle.

* Fixed: Crash with fired event handler.

* Fixed: Allow soldier to shoot if his target is too close and on higher ground.

* Improved: VON: speech encoding/decoding - dropout silence is not inserted so often.

* Improved: Blinking camp fires.

* Fixed: MP clients crash when they are ordered to turn on their flashlights or lasers.

* Fixed: Allow zeroing in external camera.

===Missions===

* "Pathfinder" tuned opfor positions and flow.

* "Coltan blues" inputting code has been tuned and timer delayed.

* "Coltan blues" FTL tuning.

* "From hell" tuned default weapons in MP.

* "From hell" optimized unit count and positions - improved FPS and playability.

* "Good morning T-stan" tuned winning conditions and FTL.

* "Good morning T-stan" convoy skill lowered and composition tweaked to decrease the mission difficulty.

* "Phoenix Op" optimized and tuned Opfor positions and unit count.

* "Laser show" fixed crashing chopper.

* "Press conference" fixed for MP.

* SP scenarios loading screens changed.

* SSM several fixes in the simple support module.

* surrendering fixed in "Pathfinder" and "From hell".

* Several localization fixes.

* Deathmatch and teamdeathmatch templates fixed.

* Several minor fixes of the singleplayer missions.

* UAV & ULB can now be used with terminal backpack on

===Data===

* Fixed: Healing by UH-60M MEV, Stryker MEV and S1203 ambulance.

* Fixed: Speed indicators in UAZs.

* Fixed: Missing shadow on V3S (Fuel).

* Fixed: Optics model of static AT-13 Metis.

* Fixed: L39 wreck geometry.

* Fixed: S1203 number plate.

* New: Microphone volume slider.

http://www.arma2.com/support/updates/folder.html?lang=en

Mirrors:

http://www.multiupload.com/KQ2D3UT56Z

(includes 8 mirrors such as Rapidshare, Megaupload, Hotfile etc. + multiupload direct mirror which is pretty fast).

http://solidfiles.com/d/bbbc/

http://www.kellys-heroes.eu:9000/Arma2/downloads/patches/A2OA_Patch_152.zip

http://mirror.dyneslott.com/arma2oa/A2OA_Patch_152.zip

http://kamran.cc/ARMA2/A2OA_Patch_152.zip

Torrent

http://community.bistudio.com/wiki/Arma_2OA:_Patch_v1.52#Download_Mirrors

Edited by Placebo
link to mirror list

Share this post


Link to post
Share on other sites

except if you have steam it thinks you now have a CD version of the Game after manually patching. So I guess Im screwed until I figure out how to roll back.

Share this post


Link to post
Share on other sites

I have the STEAM version downloaded which when starting the game says version 1.52.7xxx.

I don't see a dedicated server exe - Will I need to download this patch and install it manually over the steam version?

Share this post


Link to post
Share on other sites

DONT DO IT!!!!!!!!!!! I jsut did and it wrecked the Version. the game now thinks it is a DVD version and cannot play. I ham RE Dl'ing both ARMA2 and OA as I type this.

Share this post


Link to post
Share on other sites

Torrent added. Sorry for the delay in adding the torrent, the usual site I use is down right now unfortunately :(

Share this post


Link to post
Share on other sites
DONT DO IT!!!!!!!!!!! I jsut did and it wrecked the Version. the game now thinks it is a DVD version and cannot play. I ham RE Dl'ing both ARMA2 and OA as I type this.

Thanks for the heads up - I was about to ask as to whether the installing the patch would mess with the STEAM version (which you've now answered for me)

@Placebo - Any chance of asking the BIS DEV's if they could release the Windows Dedicated Server separately, and/or if they could include it in the next STEAM update?

Share this post


Link to post
Share on other sites

Thanks BI for the patch release, and the server executable !!

This is good job :yay:

Share this post


Link to post
Share on other sites
I have the Sprocket version of OA. Do I need the patch?

Yes, unless you can find the dedicated server .exe separately.

Share this post


Link to post
Share on other sites
Yes, unless you can find the dedicated server .exe separately.

Like this? :confused:

For those not wanting to download an over 100mb 1.52 patch, just for the dedicated server.exe...

1.52 arma2oaserver.exe (4.89mb)

Anyways; is that all? Is there no other reason why I should download the patch? No actual fixes? I have the Steam-version of the original ArmA 2. (Not OA.) Will this break the game, as some commented earlier in this thread?

Edited by St!gar

Share this post


Link to post
Share on other sites

My OA was working fine until my dumbass patched it from 1.5 to 1.52. It was only after getting the DVD read error that I read the info on it....NOT COMPATIBLE WITH THE STEAM VERSION OF THE GAME. And they are NOT kidding about this!! :(

It might not have been 1.5 so I don't know.

Share this post


Link to post
Share on other sites
My OA was working fine until my dumbass patched it from 1.5 to 1.52. It was only after getting the DVD read error that I read the info on it....NOT COMPATIBLE WITH THE STEAM VERSION OF THE GAME. And they are NOT kidding about this!! :(

It might not have been 1.5 so I don't know.

Are they talking about ArmA 2 or OA? :confused:

Share this post


Link to post
Share on other sites

Well Where in the Hell is the Steam Version?If You're going to Sell Your Game on Steam At least have the decency to put the Patch on there at the same Time.I mean I Paid My Money just like the Sprocket People did.

Share this post


Link to post
Share on other sites

Is your version of OA already 1.52.71816? If so then you already have the patch.

Share this post


Link to post
Share on other sites
Is your version of OA already 1.52.71816? If so then you already have the patch.

My Steam version of OA is 1.52.71612.

Share this post


Link to post
Share on other sites
Is your version of OA already 1.52.71816? If so then you already have the patch.

Mine also says "1.52.71612", so clearly I don't have the newest version. :butbut:

But here's the core of the problem: my original ArmA 2, (Not Arrowhead.), is on STEAM. And didn't you people just say that downloading the manual patch that has been provided in this thread messes up the STEAM-version? That's why I don't dare to patch it.

Share this post


Link to post
Share on other sites
Mine also says "1.52.71612", so clearly I don't have the newest version. :butbut:

But here's the core of the problem: my original ArmA 2, (Not Arrowhead.), is on STEAM. And didn't you people just say that downloading the manual patch that has been provided in this thread messes up the STEAM-version? That's why I don't dare to patch it.

The manual OA patch messes up the Steam version of OA. AFAIK, using the manual 1.07 patch on the Steam version of ArmA2 (though it's already patched on Steam so I don't see why you would) should work fine.

The problem with the OA version right now is that it messes with the Securom copy protection when you use the manual patch. It expects a DVD to be in the drive when, because you have a Steam version, there is none.

Besides, in another thread, BIS already confirmed that the "latest" build in the manual patch is unnecessary for Steam, in that it doesn't really make any major changes over the Steam version.

Share this post


Link to post
Share on other sites
The manual OA patch messes up the Steam version of OA. AFAIK, using the manual 1.07 patch on the Steam version of ArmA2 (though it's already patched on Steam so I don't see why you would) should work fine.

The problem with the OA version right now is that it messes with the Securom copy protection when you use the manual patch. It expects a DVD to be in the drive when, because you have a Steam version, there is none.

Besides, in another thread, BIS already confirmed that the "latest" build in the manual patch is unnecessary for Steam, in that it doesn't really make any major changes over the Steam version.

...Soooo, the manual 1.52 patch only messes up the STEAM version of OA, but not the STEAM version of Vanilla ArmA 2?

But what about the Sprocket version of OA? It still works after the patch?

Share this post


Link to post
Share on other sites
But what about the Sprocket version of OA? It still works after the patch?
Yes, that still worked fine after the patch for me.

Share this post


Link to post
Share on other sites
Yes, that still worked fine after the patch for me.

Thanks. I'll be trying, then.

*EDIT*

Appears to have worked. :)

Edited by St!gar

Share this post


Link to post
Share on other sites

Is this the only patch you need after installing 'combined operations'?

I see that out of the box ARMA 2 is patched to 1.06 on installation, but couldn't find what version OA it is.

Share this post


Link to post
Share on other sites

If your OA is not version 1.52 you have to apply this patch, UNLESS you have bought the game from Steam. But seeing you talk about a box I guess not.

This patch will also update your Arma 2 to version 1.07 if needed.

Share this post


Link to post
Share on other sites

Hi all,

I'm confused looking at the patch, says that it will update version 1.5 to 1.52.

I have version 1.52.71612 (Sprocket) and NOT version 1.52.71816.

Should I update with this patch??? Scared of screwing it up :eek:

Thanks in advance,

Laggy

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×