Jump to content
Sign in to follow this  
jpinard

Operation Arrowhead performance optimizations/comparisons

Recommended Posts

Looking into what specifically? There have been dozens of posts by numerous BIS staff on a number of issue, including performance issues.

Share this post


Link to post
Share on other sites

Here was my experience last night upon 1st boot up of OA.

I have a 295 GTX. Maxed out vis settings, no AA/AF. 1680x1050. Went in to take a look. Textures seemed washed out. Mouse control was floaty. I decided to make a nVidia profile for OA. Did so, and went back in. Whoah. Sharper/crisper textures/visuals. The game looks awesome now, and the floaty feel seemed to have disappeared.

Performance went up too. Waiting for an actual driver profile release now from nVidia so we have access to Ambient Occlusion. But so far this is what worked for me. No performance issues in and around villages either. Will test more tho. Pretty happy with the OA release.

295 GTX

Crosshair III

1090T BE

RAID 0

8 gb ram @ 1600

Win 7 Ult. 64 bit

Edited by Shataan

Share this post


Link to post
Share on other sites

In the editor, playing round with a handful of units performance is pretty good, as it also is in MP.

However, once there are a few scripts running, I experience stutters and can't set the vd above 2,000 without it being unpleasant to play.

Fire up Arma2 1.07, everything's perfectly smooth up to 5,000 vd and more, even with lots of AI doing their thing.

I think I'm going back to 1.07 until the recent improvements are patched in. For now, OA gives that same feeling as A2 originally did: you can change the graphics settings from everything to high to all on very low and it makes zero difference to the weird unsmooth feeling affecting performance.

Share this post


Link to post
Share on other sites
Looking into what specifically? There have been dozens of posts by numerous BIS staff on a number of issue, including performance issues.

just thought it would be nice if some staff confirmed these issues, the stuttering is really killing me in this game, if you take a look at my previous post it says that arma 2 runs fine, actually it runs so good its a huge letdown for me that OA performs worse

im not trying to attack you here or anything, just a bit anoyed this game isent working as intended at all

Edited by Silentspy

Share this post


Link to post
Share on other sites

I'll add my two cents as well: getting the stuttering problem too no matter what settings I use. Game stutters when I zoom in while aiming and when I get close to built up areas (I spawned a city on the desert map and on approaching it framerates stutter. A2 runs just fine.

Specs:

Q6600

GTX275

4gig ram

Vista

Share this post


Link to post
Share on other sites
just thought it would be nice if some staff confirmed these issues, the stuttering is really killing me in this game, if you take a look at my previous post it says that arma 2 runs fine, actually it runs so good its a huge letdown for me that OA performs worse

im not trying to attack you here or anything, just a bit anoyed this game isent working as intended at all

I understand :)

Regarding performance there are a number of posts by Marek which specifically address the possible causes of performance differences between ArmA 2 v1.07 and OA v 1.52, these are along the lines of:

1. OA 1.52 isn't quite as optimised as A2 v1.07 (more like 1.05) but the advancements will be rolled out in new patches as soon as they're ready.

2. OA isn't compatible with Crossfire/Dual GPU's in the same way that A2 now is (this is a driver issue) but renaming the exe to something that is compatible will improve things.

3. The new graphic settings have change the resulting performance so you need to find the right balance for you (there's a pinned thread in here where Marek explains the new settings and how they affect performance).

Hope that helps a little :)

Edited by Placebo

Share this post


Link to post
Share on other sites
hey guys' date=' try tuning HDRprecision to 0 in your arma2oa config.[/quote']

and what's that supposed to do ?

the only supported values are 8, 16 and 32

if different value used the game use default 8

see http://community.bistudio.com/wiki/arma2.cfg

Share this post


Link to post
Share on other sites

thanks dwarden. I thought it did something, because It was on 32.. put it to 0 and i got a big performance increase.

edit:

does it do anything at all performance wise?

Edited by Fox '09

Share this post


Link to post
Share on other sites
thanks dwarden. I thought it did something' date=' because It was on 32.. put it to 0 and i got a big performance increase.

edit:

does it do anything at all performance wise?[/quote']

Going on dwarden said, by setting it to 0 you effectively set it to 8 instead of 32, since the engine uses 8 if an invalid value is used.

So yes, you are probably seeing a performance increase by reducing the value to 8 from 32.

Share this post


Link to post
Share on other sites
If it is not using SLI, then you need to rename the executable "arma2oa.exe" to something the NVidia card will try and enable SLI for. For example you can trick it by using Crysis name "Crysis.exe" instead of "armaoa.exe". Usually a dual-gpu card should work fine if you just have the multi-gpu option selected in the Nvidia control panel (that's the way it was for my GTX295 which I no longer have).

just copy or rename it to arma2.exe to use same driver profile for ARMA 2

this will not work with Steam version but there is workaround

1. rename arma2oa.exe to arma2.exe

2. open Command propmpt

3. use path to your game

e.g.

cd C:\Program Files (x86)\Steam\SteamApps\common\ARMA 2 Operation Arrowhead

4. create symbolic link arma2oa.exe which targets arma2.exe

mklink arma2oa.exe arma2.exe

5. now steam will launch the game w/o complains

6. driver Crossfire / SLI profile should kick in and works by detecting arma2.exe

in some cases normal symlink might not be enough and hardlink is needed

mklink /h arma2oa.exe arma2.exe

that's all enjoy your game 'working' SLI / Crossfire

Share this post


Link to post
Share on other sites
Same here except that i get around 50fps but there are micro-stutters all the time too...

set mouse smoothing to min. 55%. Helped for me.

Share this post


Link to post
Share on other sites

Dwarden - the option I listed was to make it as easy as possible for people who might still want to launch ArmA2. Otherwise they're the exact same name.

Share this post


Link to post
Share on other sites
Why -exthreads 7 for hexacore cpus? Wouldn't that require 7 cores?

I think it depends on the hyper-threading.

Share this post


Link to post
Share on other sites
I think it depends on the hyper-threading.

No, as Maverick linked, threads has nothing to do with # of cores. That's what cpucount is for.

Also see this: http://dev-heaven.net/projects/cis/wiki/1_06_BETA

I have no doubt the next patch will bring the game in line with what we have for Arma2 (v1.07).

Share this post


Link to post
Share on other sites

-cpuCount=4 is what i put on my exe and my major stuttering is gone its nice and smooth now, granted the fps is not as fluid and high like 1.07 yet but this really helped me and really enjoying the game now. I have a I7 920 @ 3.8 and gtx 480's sli'd good stuff.:yay:

Share this post


Link to post
Share on other sites
-cpuCount=4 is what i put on my exe and my major stuttering is gone its nice and smooth now, granted the fps is not as fluid and high like 1.07 yet but this really helped me and really enjoying the game now. I have a I7 920 @ 3.8 and gtx 480's sli'd good stuff.:yay:

AWESOME! it worked for me now, no more stuttering :yay:

Share this post


Link to post
Share on other sites

^^ awesome glad it worked its so much more playable now and glad it wasnt a fluke.:bounce3:

Share this post


Link to post
Share on other sites
-cpuCount=4 is what i put on my exe and my major stuttering is gone its nice and smooth now, granted the fps is not as fluid and high like 1.07 yet but this really helped me and really enjoying the game now. I have a I7 920 @ 3.8 and gtx 480's sli'd good stuff.:yay:

how's that possible if -cpuCount=4 is on by default already ?

Share this post


Link to post
Share on other sites
how's that possible if -cpuCount=4 is on by default already ?

I don't think it is in OA. Only since the recent 1.07 ArmA2 patch is it set by default, but OA is only at 1.52 so far.

Share this post


Link to post
Share on other sites

what ever the case may be it worked for me and a couple others with I7's hopefully first patch will address this.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×