Jump to content
LurchiDerLurch

AC-130 Script for ARMA2 (0.3)

Recommended Posts

Thanks for the info. Regarding my second question, does the c130 just need the init for the action menu for pilot and copilot to control the guns?

Share this post


Link to post
Share on other sites

LurchiDerLuch, I tried copying the side, faction, class, initialization, everything that was in the test mission from the ac-130, the ac-130 on the ground and the player standing next to the one on the ground, and placed it in my domination (takistan) game. It didn't work! I could play with the AC-130, but domination didnt work. No missions popped up on the map or anything! I have no experience at all with scripting. Help :S

Share this post


Link to post
Share on other sites

you can send me a copy of your mission ;)

@Kremator: Basicly yes. You can add the init line IN THE EDITOR or make a c130j to an ac130 via script. in detail:

nul = [PLANE] execVM "LDL_ac130\Addon\ac130_init_AC130.sqf";

every ac130 MUST execute "ac130_init_AC130.sqf".

only then the "ac130_client.sqf" script identifies if a client is pilot or copilot and adds the actions to the menu.

Pilot:

LDL_ac130_plane addAction ["<t color=""#FA1845"">"+"AC130 Autopilot", "LDL_ac130\Actions\ac130_action_pilot.sqf",[1], 99, false, true];

Gunner:

LDL_ac130_plane addAction ["<t color=""#FA1845"">"+"AC130 Camera", "LDL_ac130\Actions\ac130_action_copilot.sqf",[2], 99, false, true];

The actions scripts now call the setup functions. f.e. pilot:

[LDL_ac130_plane,LDL_AC130_Adjustments select 0,LDL_AC130_Adjustments select 1,LDL_Adjustments select 6]call LDL_ac130_rot_setup;

You could call these setup scripts whenever you want:

http://lurchiderlurch.lu.funpic.de/readme.html#RunandcontrolAC130

Share this post


Link to post
Share on other sites

Thanks mate. I'm currently testing a mission for another author, so am not able to send yet :)

Share this post


Link to post
Share on other sites

Any chance someone can tell me how to get the UAV to fire the hellfire missles?

I have tried the addon version and script version.

With the addon version, I have added the LDL AC-130 init, Call UAV, and both the AC-130 gl's.

The AC-130's work great.

The UAV seems to be working fine, but whenever I fire a missle, the count goes down, but nothing is launched from the UAV, and nothing blows up on the ground.

I am using the latest Mando Missles with MMA XE Autolaunch.

I have added and removed the MMA gl's from the mission...nothing

I have tried with/without ACE.

Thank You

Share this post


Link to post
Share on other sites

strange... try it without any addons. the uav should at least fire the hellfire.

the UAV is still buggy especially the hellfire. Without mando missiles enabled they're quite useless. But I'm focusing on the AC130. The UAV is just a little addition ;)

If anybody feels qualified for adding some extras to the UAV or anything feel free to contact me.

By the way I just have to write the readme vor v.0.8 and it'll be released tomorrow or so ;)

Share this post


Link to post
Share on other sites

I haven't seen any major issues with 0.8 beta you sent me. Good luck for release mate !

Share this post


Link to post
Share on other sites

v.0.8 is released

See first post for details: http://forums.bistudio.com/showthread.php?p=1635824

README

Download page v.0.8:

Link

arma2oa2011-10-1411-373kzl.png arma2oa2011-10-1410-165d6l.png arma2oa2011-10-1410-169cas.png arma2oa2011-10-1410-03af9x.png arma2oa2011-10-1410-006e1x.png arma2oa2011-10-1409-583fbm.png

Changelog v.0.8:

  • Detailed online readme
  • New AC-130 Mode: Only functional in MP with two players (COOP pilot/gunner), more stable and interactive (see readme)
  • New designed HUD (with working buttons)
  • When hit ESC the script won't terminate any more: a dialog with the options "close" and "continue" appears (http://www.abload.de/img/arma2oa2011-10-1410-006e1x.png)
  • Improved some functions, scripts and fixed some minor bugs f.e: AI delay via parameters didn't work
  • Assign targets for AI AC-130 with Laser Marker is now possible (see readme)
  • Shells for invisible AC-130 (lite AC-130) need more time to hit the ground
  • Script uses new shells (thanks to B1n4ry)
  • Fixed: Exiting the script with FLIR enabled and starting a new camera lead to the issue that the new camera had FLIR enabled
  • Change camera modes with N is now possible
  • Change the radius and height of the AC-130 in the map is now possible with a dialog window
  • Rearming is only possible for a slow or standing AC-130
  • Help dialog (F1 or H) redesigned

Share this post


Link to post
Share on other sites

:pet13: Awesome!!! No sleep for me tonight... Can't wait to test this in coop. I love the new hud. THX LDL!

Share this post


Link to post
Share on other sites

I am not sure if anybody has posted this but i am to lazy to look-_-. So here it is, Whenever I try to go into the gunner mode it just gives me a white screen like someone put a white background in front of the screen. i can see the options like fltr, off, map, and help buttons.Then when i push the esc button and the menu comes up it turns back to normal(thermal).

Share this post


Link to post
Share on other sites
I am not sure if anybody has posted this but i am to lazy to look-_-. So here it is, Whenever I try to go into the gunner mode it just gives me a white screen like someone put a white background in front of the screen. i can see the options like fltr, off, map, and help buttons.Then when i push the esc button and the menu comes up it turns back to normal(thermal).

No seems a new bug... andybody else got issues like that?

:pet13: Awesome!!! No sleep for me tonight... Can't wait to test this in coop. I love the new hud. THX LDL!

I'm always glad about feedback especially in MP because I'm not able to test this properly ;) so give it a chance and if you have any ideas or something tell me :)

Edited by LurchiDerLurch

Share this post


Link to post
Share on other sites
No seems a new bug... andybody else got issues like that?

Yea, a friend of me had a similiar problem. He had no crosshair, just a white square he couldn't move the cam. But with the beta, it was fixed.

We will test the new version. We had some server problems, so we weren't able to test the beta full.

Whatever, thx Lurchi, awesome script ;D

ps: how is the Ac130 model doing ?

Share this post


Link to post
Share on other sites

Nice, so testing this later :) ... Death from above!

Share this post


Link to post
Share on other sites

Known Bugs

"Infantry strobes are hardly visible with FLIR enabled"

Good as you should not be able to see them at all !

Testing, we ran the beta for sometime with no issues reported. Although we generally ran the AI manned AC130.

Share this post


Link to post
Share on other sites
I am not sure if anybody has posted this but i am to lazy to look-_-. So here it is, Whenever I try to go into the gunner mode it just gives me a white screen like someone put a white background in front of the screen. i can see the options like fltr, off, map, and help buttons.Then when i push the esc button and the menu comes up it turns back to normal(thermal).

I have tried beta and it still is a white screen

Share this post


Link to post
Share on other sites
I have tried beta and it still is a white screen

Other dialogs are working? Try to change the menu size in the options of arma 2

Although we generally ran the AI manned AC130.

Then you will love the next update... but it will take a while :cool:

Edited by LurchiDerLurch

Share this post


Link to post
Share on other sites
I'm always glad about feedback especially in MP because I'm not able to test this properly ;) so give it a chance and if you have any ideas or something tell me :)

OK here it is...

After testing your AC130 in coop we stumbled across minor stuff, all in all it worked great. Especially for the team on the ground it was like the millennium New Year's Eve :D

1) even for the serverplayer the target camera shakes a little bit if you zoom in a lot. I'm well aware that this is most likely an arma/networkcode thing and therefore inevitable. Still it's absolutely playable and FUN.

2) When I applied for the gunner-coop seat I always got the message "Camera unavailable /..." - regardless of the flight altitude. Workaround was to close it and to use the action menu "camera view" and not the gunner-coop option. Minor problem, but I don't think that's the way you planned it.

3) My buddy (client) told me one time that the "N" button didn't work for him to switch to all the possible cameras. No big deal, because your panelbuttons around work well. I (server) didn't have this problem.

4) One time assigning a new target area didn't work for a while. Clicking on the map didn't change the target area. Got it working after closing the gunner view and opening the "camera view" again.

5) just an opinion of my buddies, they liked the old 40mm sound better. I didn't hear a difference though. They said it sounded more brutal/ louder (?) some versions earlier...

To sum it up it was awesome to see you killing-machine in action. We enjoyed it a lot.

Another good news: it also worked with the blastcore effects.

That's it for now. More to come. Keep it up.

Share this post


Link to post
Share on other sites
OK here it is...

After testing your AC130 in coop we stumbled across minor stuff, all in all it worked great. Especially for the team on the ground it was like the millennium New Year's Eve :D

1) even for the serverplayer the target camera shakes a little bit if you zoom in a lot. I'm well aware that this is most likely an arma/networkcode thing and therefore inevitable. Still it's absolutely playable and FUN.

2) When I applied for the gunner-coop seat I always got the message "Camera unavailable /..." - regardless of the flight altitude. Workaround was to close it and to use the action menu "camera view" and not the gunner-coop option. Minor problem, but I don't think that's the way you planned it.

3) My buddy (client) told me one time that the "N" button didn't work for him to switch to all the possible cameras. No big deal, because your panelbuttons around work well. I (server) didn't have this problem.

4) One time assigning a new target area didn't work for a while. Clicking on the map didn't change the target area. Got it working after closing the gunner view and opening the "camera view" again.

5) just an opinion of my buddies, they liked the old 40mm sound better. I didn't hear a difference though. They said it sounded more brutal/ louder (?) some versions earlier...

To sum it up it was awesome to see you killing-machine in action. We enjoyed it a lot.

Another good news: it also worked with the blastcore effects.

That's it for now. More to come. Keep it up.

ok thank you :)

1) Seems to be a general problem with ARMA... but it's better compared to the older versions?

2) That's exactly the way it was planned. The "camera view" and the "coop" are two seperate and different modes. The camera view is only a camera attached to the plane and can lag heavily due to the synchronization of the plane position and the camera position over the net...

The camera in coop is available as soon as the plane is in position... maybe I should add some more information ingame ;)

Share this post


Link to post
Share on other sites

The camera in coop is available as soon as the plane is in position... maybe I should add some more information ingame ;)

Now that's interessting. I completely missed that. What exactely do you mean by "in position"?

Friend of mine played the pilot and I played the gunner. (Plane was empty at the beginning of the mission, because we use the Marine Naval Aviator addon by Meatball0311) We started at an airfield and flew into the ao. I tried serveral times but the camera was always unavailable, so I used the "camera mode" to shoot... a bit laggy but it worked.

Does the gunner have to assign the target area first and then the coop-camera gets online once there?

Share this post


Link to post
Share on other sites
Now that's interessting. I completely missed that. What exactely do you mean by "in position"?

Friend of mine played the pilot and I played the gunner. (Plane was empty at the beginning of the mission, because we use the Marine Naval Aviator addon by Meatball0311) We started at an airfield and flew into the ao. I tried serveral times but the camera was always unavailable, so I used the "camera mode" to shoot... a bit laggy but it worked.

Does the gunner have to assign the target area first and then the coop-camera gets online once there?

the gunner can define a target area and the pilot can see this target area on his hud and with the datas on his HUD the pilot is able to get the plane in position. ;) As soon as the plane flies corretly in relation to the target the gunner has view on the target area.

http://lurchiderlurch.lu.funpic.de/arma/readme_ac130.html#Availabletypes

6: COOP for Multiplayer

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×