Jump to content
oktane

oktNoBlur - Signed Blur Remover Addon

Recommended Posts

Thank you. I just need this file for the update? I accidentally erased the version you released last week.

Share this post


Link to post
Share on other sites
Thanks, oktane!

"Oktane. Making ArmA2 playable with postprocessing enabled since 2010." :D

Hahah ^ too true!

Share this post


Link to post
Share on other sites
here's another temporary version updated

Many thanks oktane. When it rains it pours and BIS keeps pouring out the betas. SO much looking forward to your automated solution (or, better yet, to BIS adding an option to disable the blur through the gui).

Share this post


Link to post
Share on other sites
Thank you. I just need this file for the update? I accidentally erased the version you released last week.

Yeah it replaces the old ones temporarily. You just drop it in the arma directory, it provides noblur for the beta it was made for. If you want to use 1.05 you have to use the old 'released' one.

Share this post


Link to post
Share on other sites

Oktane, this is so invaluable. Thank you so much a hundred times over :)

Share this post


Link to post
Share on other sites

Any chance for a latest beta config for noGlow? I haven't actually tried it yet, but if it removes the ridiculous white glow above treetops whenever I have PP on, it'd be worth it. Good work otherwise!

Regards,

Wolfrug

Share this post


Link to post
Share on other sites

Yes thanks for keeping us provided with the latest version for the latest betas.

Share this post


Link to post
Share on other sites

Yes very eager to get an update, since this patch seems to be very promising.

Share this post


Link to post
Share on other sites

Should be no need to update - bin.pbo is the same as build 70709 (checked with HashCheck after extracting bin.pbo)

Share this post


Link to post
Share on other sites

Yep, they are the same.. config.bin is the important one. Contains the whole game config. And the shaders are important too, but less so.

But in the vein of discouraging people from running the wrong version with different beta's, I think I should just release every one. If they ARE different, it causes problems. I had a mismatched beta/noblur on my other guest PC accidentally and man it was crashing every 10 minutes.

I already made this one anyways.

For Beta 70951 only!

http://www.506th-pir.org/scripts/oktane/noblur/@okt_noBlur_1.5.70951.7z

Did you guys notice that the Horns are now network synced again, I've missed that feature since OFP or Arma. :D I wish they would fix the reloading anim over the network too, used to work back in the day so I wouldn't think it was a big deal to fix.

Edited by oktane

Share this post


Link to post
Share on other sites
Any chance for a latest beta config for noGlow? I haven't actually tried it yet, but if it removes the ridiculous white glow above treetops whenever I have PP on, it'd be worth it. Good work otherwise!

Regards,

Wolfrug

Do you use LOW pp setting?

I guess I don't know what the point would be of enabling PP if there were no glow effects. Which is why I stopped even making it, it was kind of a little used extra that turned out to be a timesuck (less so with the automated system) but moreso a usablity issue, making the configuration of the mod all complicated with 4 different batch files etc.. And then theres the large amount of people that don't read instructions and will assume glow is bad and disable it, just because its an option.

The glow is used for like everything, bright reflections, atmospheric effects, etc. With no glow, the game looks sorta flat like it does with PP off. Check out these comparison shots:

(too large to embed) Here is a picture of two screens overlay'd (pp on low, pp off, showing only DIFFERENCE), white showing the detail that glow adds to the picture. Notice that things that are shiny have the extra effect, edges, shiny plane parts, etc.

glow_diff_night.jpg

Here is a similar picture, but at night. Unfortunately the stars moved a bit but you can still see the difference in the NVG's. The glow is correct, that's what NVG's do to light sources. You can also see a small glow on the tung's headlamp cover, and some surfaces that are reflecting the moon. The black square is where I blocked out the radar because it had spun. Depending on the settings/quality of you monitor you may not even be able to see the subtle differences or the black box.

glow_trees.jpg

Last here is what I think you are complaining about, the glow that happens through trees. This is actually due to the sun being behind the trees, I had to try pretty hard adjusting the time to get this to happen. Bright sun shining through trees does this IRL, albiet not to this degree, but I think this minor issue is not a good enough reason to disable all of the glow. The sun plays a tactical part I'm sure you realize. If I could lessen just this effect, I would but it's all or nothing.

One thing I didn't even touch on because it is hard to show, is explosions and fire. Maybe I can make a SP mission and pause time to show that effect.. The glow makes the explosions look fantastic, it's the reason I turn PP on and made this mod in the first place.. I wanted glow + other effects without the blur.

Edited by oktane

Share this post


Link to post
Share on other sites

Indeed, the ability to have that glow without the excessive motion blur is surely the entire point of running this mod (thanks again BTW, love it). The sun blinds you in real life and it is appropriate to represent that in game, keep in mind that a monitor can of course never produce the luminance required to do so in precisely the same way as the sun does.

Share this post


Link to post
Share on other sites

@oktane

Edit: Nevermind, the weird PP is due to my brightness settings being cranked all the way up (which in turn is due to my monitor being a piece of crap), nothing else. But here's the original post anyway since it's got nice pics in it and all: ;)

Well, it seems then that I've got some kind of bug-like thing going on with my PP-effects, or maybe it's just my system being crappy? Whatever the case, THIS is what I get when I have PP on (any setting, Low in the example):

(>100kb)

Post-process effects ON

Post-process effects OFF

I've got a hunk-a-junk AMD Athlon 64 X2 +3800 with a 8600 GT 512 MB graphics card, running Win XP 32bit; with the lates betas it's actually running quite okay lately, but it sure ain't pretty :) Anyway, putting PP on low doesn't really lower my FPS that much, and it looks MUCH better in the night, but in the day...you can't see anything! It's all white. The sky doesn't exist! It's just a blob of overexposure! This depends a bit on the time of day, but this was all taken at the default Editor time (Oct 11, 9:20 AM), just outside of Novy Sobor.

But if you're telling me that the glow effect above is the same as all the other glow effects, and you can't remove the one without affecting the other, I'll take your word for it. But thank you anyway for responding, and good luck with this addon in the future!

Regards,

Wolfrug

Share this post


Link to post
Share on other sites

Wolfrug: I think I know what you are suffering from. So to control the saturation of the HDR try using GTD's HDR mod.

It's small, simple to use (accesible via the action menu) and has no impact on performance (AFAIK). The only drawback is that it requries CBA. Hope that helps.

Sakura's light fix also goes some way to making A2's lighting a little more subtle.

Share this post


Link to post
Share on other sites

Ah yes, very bad to crank the a2 brightness or gamma up! If you need to do that, try doing it via the monitor or the video card control panel instead of the game.. if done via the game it's going to squash everything to a blob of light.

Some parts are supposed to be really dark.. like if the moon isn't out at night, you can't see hardly at all.. this is normal and intentional.

From your screenshot with the brightness cranked up, I am going to wager that your video card control panel settings may have been mixed up and are making things dim.. and then you are trying to compensate for that by cranking the game's own sliders. There were quite a few nvidia driver releases that totally fubar'd this setting to minimum.. since been fixed.

You may want to go into the GFX card control panel 'color' or monitor settingss where you can adjust the gamma/brightness and 'reset to default' to see if it helps. In other words.. above all, try to make it so that you are happy to play the game (not too dim) without adjusting the in game brightness/gamma.. adjust everything else (non game) first.. the in-game slider is the last thing you want to touch mate. :D

Edited by oktane

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×