Jump to content
Sign in to follow this  
UNN

Update: RKSL Studios ArmA2.PBO and Countermeasures V2.01

Recommended Posts

We are pleased to release an update to the first Public BETA of the RKSL-Arma2.pbo V2.01

aug16_chaffflares_splash2.jpg

Stated a new thread, ask the moderators to close the old one. This is the latest version of our ArmA2 countermeasures system, with the following fixes applied.

Fixed "Deleted content error".

Fixed radarflareplayer property in description.ext didn't disable automatic flares for players.

Fixed multiple audio warnings.

Fixed flares launch vectors are disrupted by terrain.

Added support for the Extended Event Handler if installed.

New description.ext property radaraudiowarning. 0 Turns audio warnings off for players, 1 reactivates them.

Project Page: Arma2.pbo Project

Related Documentation:

System Core Documentation

Radar System Documentation

Required Addons:

RKSL Arma2 V2.01 - Applies RKSL systems to BIS vehicles and Aircraft

RKSL System V2.01 - Core system files required by all RKSL addons

RKSL Flares V2.01 - Chaff and Flare system

Share this post


Link to post
Share on other sites

wow, good stuff, downloading, thanks.

Added support for the Extended Event Handler if installed.

New description.ext property radaraudiowarning. 0 Turns audio warnings off for players, 1 reactivates them.

so i have to change those values in that file or in game?

Edited by InFireBaptize

Share this post


Link to post
Share on other sites

Thanks for the update!

MfG Lee :)

Edit:

Small bug(?)-report.

Editor(utes) -> UH-1(flying) -> player as gunner

I can fire the flares with the "minigun".

Bug or engine-limitation?

Edited by Lee_H._Oswald

Share this post


Link to post
Share on other sites
Guest RKSL-Rock
Dose this work with the Chinook yet?

Probably not, unless it directly inherits from a class that already enabled. We're not going to hard code anyone's addons into the flare system other than BIS or our own. The politics and the support problems that could cause arent worth it.

What we have done is make it fairly simple for people to add support to thier own projects. UNN is going to write up a quick guide once we get some feedback about the current release's performance and any issues.

Small bug(?)-report.

Editor(utes) -> UH-1(flying) -> player as gunner

I can fire the flares with the "minigun".

Bug or engine-limitation?

When you say you "can fire the flares with the "minigun"" do you mean you have the option to swap to flares or they fire at the same time as the minigun?

If its the later its OK its normal, its a "feature" of how the system was made.

Edited by RKSL-Rock

Share this post


Link to post
Share on other sites

You can select them when switching the fire modes.

M134(2000/min) -> M134(4000/min) -> Flares

Then you can manual fire the flares, but you see the muzzle flash on the minigun for a very short time.

MfG Lee

Share this post


Link to post
Share on other sites

The flares are available for either the primary gunner or the pilot. You still have the same amount. The muzzle flash is one of a few unfortunate side effects.

Share this post


Link to post
Share on other sites
Dose this work with the Chinook yet?

As it happens your in luck, the flare points were mapped out for the ACE CH47 in Arma1:

RKSLch47dSystem.zip

You can run this script from the init field in the mission or init.sqf:

[this,false] Compile PreProcessFile "RKSLch47dSystem.sqf"

If you respawn a heli or create one during a mission, you have to run the script again for the new vehicle.

But as Rock says, addons need to add support for the RKSL flares directly. It doesn't require any dependencies, the scripts can be setup to run only if the RKSL flares are installed.

Share this post


Link to post
Share on other sites
The flares are available for either the primary gunner or the pilot. You still have the same amount. The muzzle flash is one of a few unfortunate side effects.

Thank you for this info!

MfG Lee :)

Share this post


Link to post
Share on other sites

Possible bug: The beeping warning noise only seems to play after some flares have been launched - anywhere from a couple to 15 or so. Then it seems to always play.

I don't know if this is a feature or not, but surely the warning should sound as soon as the flares are launched?

Thanks

Share this post


Link to post
Share on other sites
Possible bug: The beeping warning noise only seems to play after some flares have been launched - anywhere from a couple to 15 or so. Then it seems to always play.

I don't know if this is a feature or not, but surely the warning should sound as soon as the flares are launched?

Thanks

Could you give us a more detailed description. SP or MP, Map, Aircraft and possible a simple example missions e.t.c

Cheers

Share this post


Link to post
Share on other sites

Sure:

- This is single-player in the editor and in sp missions. I don't know about multiplayer.

- It happens with any aircraft.

- It happens on every map, including custom maps.

- I've tried disabling the sound mods I use (VopSound, RH Heli, TRSM Tracked) as well as my other mods but it doesn't make a difference.

- From simple tests it seems that most of the time the sound kicks in after the 3rd flare is launched, beep for couple of flares, then cut out for 2 or 3 more flares, then go again. It seems fairly inconsistent though as I've had the beeps fail to play for much longer in other scenarios.

Another small issue I've noticed is that in 3rd person the cannon on the front of the su-25 (and I assume any gun) flashes very briefly every time a flare is fired, but I think you know about this.

I would attach an example mission, but it seems I can't :(. If you know an easy way I can send you it I'd be happy to.

The same problem occurs in the RKSL sample missions though.

Share this post


Link to post
Share on other sites
Guest RKSL-Rock
Sure:

- This is single-player in the editor and in sp missions. I don't know about multiplayer.

- It happens with any aircraft.

- It happens on every map, including custom maps.

- I've tried disabling the sound mods I use (VopSound, RH Heli, TRSM Tracked) as well as my other mods but it doesn't make a difference.

- From simple tests it seems that most of the time the sound kicks in after the 3rd flare is launched, beep for couple of flares, then cut out for 2 or 3 more flares, then go again. It seems fairly inconsistent though as I've had the beeps fail to play for much longer in other scenarios.

Another small issue I've noticed is that in 3rd person the cannon on the front of the su-25 (and I assume any gun) flashes very briefly every time a flare is fired, but I think you know about this.

I would attach an example mission, but it seems I can't :(. If you know an easy way I can send you it I'd be happy to.

The same problem occurs in the RKSL sample missions though.

Just to exclude one possible area of contention. What sound card are you using? Its not a old Audigy2 is it? And do any other sounds drop out or lag?

Share this post


Link to post
Share on other sites

I don't use a soundcard, so whatever my ASUS P5K Pro's onboard is.

I do actually get some sounds dropping out in ArmA 2, it's the problem where the game can't seem to cope with a lot of sounds at once - most typically when firing unguided rockets from an aircraft. I don't think this should affect the beeping though as I never have sounds drop out unless it's when a large number are playing at once.

Share this post


Link to post
Share on other sites
Possible bug: The beeping warning noise only seems to play after some flares have been launched - anywhere from a couple to 15 or so. Then it seems to always play.

Confirmed, thanks for the report, added to our bug tracker. Sorry I couldn't get back to you sooner. I have one more issue to resolve with the latest patch, will post an update once that fixed.

Share this post


Link to post
Share on other sites

no armaholic mirror?and how to install it?i see it is more complicated than normal addons....

Share this post


Link to post
Share on other sites
Guest RKSL-Rock
no armaholic mirror?and how to install it?i see it is more complicated than normal addons....

This is the ArmAholic Mirror (Its been on the site since the day it was released.) But I dont see why the RKSL one isnt good enough?

And the installation instructions are included in the readme. But here you go, just for you:

Installation:

Extract the contents of the RAR file into your "C:\Program Files\Bohemia Interactive\ArmA" folder. Then either use a mod folder launcher or modify your start up link include the @RKSL Mod folder eg:

Code:

"C:\Program Files\Bohemia Interactive\ArmA2\arma2.exe" -mod=@RKSL -nosplash

Share this post


Link to post
Share on other sites
Confirmed, thanks for the report, added to our bug tracker. Sorry I couldn't get back to you sooner. I have one more issue to resolve with the latest patch, will post an update once that fixed.

Thanks a lot, I look forward to the next version.

Share this post


Link to post
Share on other sites

Hi i have a small problem: mapping the custom control to "user action 20" on my joystick as instructed on your website does not work for me. If i program the "L" key to the useraction it works perfectly but even if i program my joystick key to the "L" under (turn on/of light) only the lights will go on and no flares are launced. Maybe i have missed something?

Edited by larsiano

Share this post


Link to post
Share on other sites

Since the Patch 1,5 an error message comes when starting of arma2 ErrorMessage: Invalid crew Civilian

RPT:

Updating base class ->Man, by ca\characters\config.bin/CfgVehicles/CAManBase/

Updating base class UH1_Base->Helicopter, by rksl\rksl-arma2\config.bin/cfgVehicles/UH1Y/

Exe version: 1.05.62017

Warning Message: Cannot open object bmp.p3d

Error: bin\config.bin/CfgVehicles/Helicopter/Turrets/MainTurret/: Turret body mainTurret not found while initializing the model bmp.p3d

Error: bin\config.bin/CfgVehicles/Helicopter/Turrets/MainTurret/: Turret gun mainGun not found while initializing the model bmp.p3d

Warning Message: Cannot load texture ca\air\data\optika_heli_tl.paa.

Warning Message: Cannot load texture ca\air\data\optika_heli_stred.paa.

Warning Message: Cannot load texture ca\air\data\optika_heli_bl.paa.

bmp.p3d: No geometry and no visual shape

bmp.p3d: No geometry and no visual shape

Cannot create entity with abstract type Civilian (scope = private?)

ErrorMessage: Invalid crew Civilian

Share this post


Link to post
Share on other sites
Guest RKSL-Rock
Lord_MDB;1522071']Since the Patch 1' date='5 an error message comes when starting of arma2 [b']ErrorMessage: Invalid crew Civilian[/b]

RPT:

Updating base class ->Man, by ca\characters\config.bin/CfgVehicles/CAManBase/

Updating base class UH1_Base->Helicopter, by rksl\rksl-arma2\config.bin/cfgVehicles/UH1Y/

Exe version: 1.05.62017

Warning Message: Cannot open object bmp.p3d

Error: bin\config.bin/CfgVehicles/Helicopter/Turrets/MainTurret/: Turret body mainTurret not found while initializing the model bmp.p3d

Error: bin\config.bin/CfgVehicles/Helicopter/Turrets/MainTurret/: Turret gun mainGun not found while initializing the model bmp.p3d

Warning Message: Cannot load texture ca\air\data\optika_heli_tl.paa.

Warning Message: Cannot load texture ca\air\data\optika_heli_stred.paa.

Warning Message: Cannot load texture ca\air\data\optika_heli_bl.paa.

bmp.p3d: No geometry and no visual shape

bmp.p3d: No geometry and no visual shape

Cannot create entity with abstract type Civilian (scope = private?)

ErrorMessage: Invalid crew Civilian

Thanks for posting. We found out ourselves when we tried the 1.05 patch. Its caused by the ArmA2.pbo file. It will be fixed in the next few days.

Share this post


Link to post
Share on other sites

Good News about the update!

Flying the new apache and get killed from everything with AA rockets is a bit boring.

MfG Lee :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×