Jump to content
dmarkwick

JTD Fire And Smoke

Recommended Posts

For example, I'm playing domination and after 2 hours, not only is there a heck of a lot of fire and smoke, but ArmAII tends to bog down for me after a couple of hours anyway.

yeah, same here too, i think there are scripting issues with most multiplayer maps (arma2 in general) because everything runs well the first couple of hours, but eventually my cti warfare and domi servers will crash (and it ain't the hardware either)

system:

i7 @ 3.8ghz

6gb ram

4850

Share this post


Link to post
Share on other sites

JIP players are getting the "cannot play or edit this mission. addon missing" error

Share this post


Link to post
Share on other sites

yeah, its a weird sync thing, but the mod does seem to work properly and based on my small testing, pre-existing fires/smoke do show up on JIP players screen

Share this post


Link to post
Share on other sites

Can someone please help me out? I can't figure out how to make this Smoke addon work. It says I need to use Extended Event Handler and I have that added to my launch options, but I'm not sure what else I need to do.

Here's my launch option:

-nosplash -mod=@IVD;@VopSound_2.1;@Pistolfied_Tracers;@CBA;@JTD

Edited by Griffin64

Share this post


Link to post
Share on other sites
Can someone please help me out? I can't figure out how to make this Smoke addon work. It says I need to use Extended Event Handler and I have that added to my launch options, but I'm not sure what else I need to do.

Here's my launch option:

-nosplash -mod=@IVD;@VopSound_2.1;@Pistolfied_Tracers;@CBA;@JTD

do you have the userconfig folder? in there is suppose to be a JTD folder and a hpp file inside it

Share this post


Link to post
Share on other sites
do you have the userconfig folder? in there is suppose to be a JTD folder and a hpp file inside it

Yup I do.

C:\Program Files\Valve\Steam\SteamApps\common\arma 2\userconfig\JTD

and the "JTD_FireAndSmoke_config.hpp" is in there.

Share this post


Link to post
Share on other sites

It looks like there's a space between the J and the TD in your launch params.

Make sure it is the real name of the folder, and probably better without spaces. :)

Share this post


Link to post
Share on other sites
Can someone please help me out? I can't figure out how to make this Smoke addon work. It says I need to use Extended Event Handler and I have that added to my launch options, but I'm not sure what else I need to do.

Here's my launch option:

-nosplash -mod=@IVD;@VopSound_2.1;@Pistolfied_Tracers;@CBA;@JTD

like TRex said, make sure the shortcut has exactly the same name as the folder.

Also, it's best to have CBA as the first thing that loads (i.e. -mod=@CBA;@xxx;@xxx etc.) Not saying that's the problem; but any addons that require it will not "see" it if it's loaded after them IIRC

Share this post


Link to post
Share on other sites

Gives me at AA2 launch the message:

"Addon ´JTD_FireAndSmoke´ requires addon ´extended eventhandlers´

I have CBA 0.13 installed...and yes I´ve installed the JTD 0.2 correctly...what gives???

Share this post


Link to post
Share on other sites

CBA is first.

here´s my addon list:

F:\Games\ArmA2\arma2.exe -nosplash -mod=@JBA -mod=@Chatter_Addon -mod=@TRSM_Tracked_Vehicles -mod=@RH_Heli_sound_mod_1.01 -mod=@FLIR v1.1 -@HiFi_Vehical_Weapons -mod=@HiFi_AIR -mod=SOW -mod=@SLX -mod=@JTD -mod=@Japahto -mod=@panthera -mod=@Mi28

JTD is the only one which gives the warning message.

Share this post


Link to post
Share on other sites

You don't need to type -mod= all the time, just do it like -mod=@mymod1;@mymod2 ... you can use ; to separate several modfolders.

Also, your shortcut shows -mod=@JBA instead of CBA, that might be the problem ;)

Share this post


Link to post
Share on other sites

Also, your shortcut shows -mod=@JBA instead of CBA, that might be the problem ;)

LOL.

Typo pwnd!

Of course, I've never done that! :p

I didn't know you could separate mod calls with just a semi colon. Nice one.

Share this post


Link to post
Share on other sites
You don't need to type -mod= all the time, just do it like -mod=@mymod1;@mymod2 ... you can use ; to separate several modfolders.

Also, your shortcut shows -mod=@JBA instead of CBA, that might be the problem ;)

no go removing that @-sign, still gives me the "finger"... :confused:

Got arma2 1.04 505-dvd version, all other addons work fine.

Share this post


Link to post
Share on other sites

oops, wait, don't remove the @ sign, you should still use it as long as your modfolders have it. You had a typo in the CBA modfolder, you had @JBA in your shortcut while you should have @CBA there.

This is what your shortcut should look like:

F:\Games\ArmA2\arma2.exe -nosplash -mod=@CBA;@Chatter_Addon;@TRSM_Tracked_Vehicles;@RH_Heli_sound_mod_1.01;@FLIR v1.1;@HiFi_Vehical_Weapons;@HiFi_AIR;SOW;@SLX;@JTD;@Japahto;@panthera;@Mi28

and you should have your modfolders called @CBA, @Chatter_Addon etc..

Share this post


Link to post
Share on other sites

Try it only with addon @JTD eg

F:\Games\ArmA2\beta\arma2.exe -nosplash -mod=beta;@CBA;@JTD or without beta eg

F:\Games\ArmA2\arma2.exe -nosplash -mod=@CBA;@JTD

be sure all of your addon folders are named with "@<name>" and have a "Addons" folder inside including *.pbo files ;)

Share this post


Link to post
Share on other sites
oops, wait, don't remove the @ sign, you should still use it as long as your modfolders have it. You had a typo in the CBA modfolder, you had @JBA in your shortcut while you should have @CBA there.

This is what your shortcut should look like:

F:\Games\ArmA2\arma2.exe -nosplash -mod=@CBA;@Chatter_Addon;@TRSM_Tracked_Vehicles;@RH_Heli_sound_mod_1.01;@FLIR v1.1;@HiFi_Vehical_Weapons;@HiFi_AIR;SOW;@SLX;@JTD;@Japahto;@panthera;@Mi28

and you should have your modfolders called @CBA, @Chatter_Addon etc..

AARG!! youre right...got a typo, man! i need glasses.

:eek:

Thanks man! now it works!

:yay::yay:

Share this post


Link to post
Share on other sites

Congrats DMarkwick, excellent job done here! I finally came around to install and test it - big fun. To spread the fire to trees and bushes really makes the difference :D

VictorFarbau

Share this post


Link to post
Share on other sites

Hope someone can help me with this. i'm a huge fan of this mod but playing Benny's warfare this afternoon and an idiot AI chopper pilot crashed into the HQ zone, and the resulting fires spread across the whole base. I'd just nipped out to take a town and noticed the AI i'd left behind started croaking and things were being destroyed, so i rushed back to find that the area of effect from the heat had destroyed all but the HQ. IS there anyway i can reduced the effectiveness over distance. I don't want to play A2 without this mod.

Thx.

Share this post


Link to post
Share on other sites
Hope someone can help me with this. i'm a huge fan of this mod but playing Benny's warfare this afternoon and an idiot AI chopper pilot crashed into the HQ zone, and the resulting fires spread across the whole base. I'd just nipped out to take a town and noticed the AI i'd left behind started croaking and things were being destroyed, so i rushed back to find that the area of effect from the heat had destroyed all but the HQ. IS there anyway i can reduced the effectiveness over distance. I don't want to play A2 without this mod.

Thx.

You can actually turn the fire propagation off completely or make it slower in the .hpp file.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×