Jump to content
Sign in to follow this  
i0n0s

[Alpha] RTE for ArmA II

Recommended Posts

I am having a problem getting this to work with combined Ops, it loads fine and everything i can even use the editor, but i never get a connect option so i cant export anyhing...

i'm running the steam version if that helps.

thank you

vartan

Share this post


Link to post
Share on other sites

Hi, I tried this tool and I really love it !

It's pretty fun to use with missions with dynamic missions like W.I.C.T., Seize zones or Flashpoint Chernarus.

Share this post


Link to post
Share on other sites

you NEED to rename your EXE vartan to Arma2.exe, else the program will not pick up that you're running arma 2.

OP, is this still being supported? I have had little or no bugs apart from a VERY annoying one which consists of the units having a double SETPOS command, which can cause issues such as them running off.

I've used this in every mission now... just makes placement so much easier.

Share this post


Link to post
Share on other sites

is there way to edit the RTE.db or some else file for to change objective into OA one?

in clear language, i place object on map, then i want to edit its class name to OA building (so i can actually even use OA buildings in RTE)?

i tryed to edit the RTE.db but it crashes arma after reload :(

Share this post


Link to post
Share on other sites
I am having a problem getting this to work with combined Ops, it loads fine and everything i can even use the editor, but i never get a connect option so i cant export anyhing...

i'm running the steam version if that helps.

thank you

vartan

having the same problem. Cant change the name to arma2 else Steam has a fit. Steam does not like you changing the name of the exe. Otherwise it thinks you dont have it. Need a different way.

Share this post


Link to post
Share on other sites

I was wondering how to get the bank & pitch to work? (under B).

i bank object it works untill i merge it with mission, what im doing wrong or forgetting?

is there better way for this than merging into mission?

Share this post


Link to post
Share on other sites

I can't get this working.

I ran the installer, got everything setup with correct paths and such.

I run arma2, add a unit in the editor, preview it, press escape, but there's no "RTE" button in the menu.

Share this post


Link to post
Share on other sites

Ok, I got it working by using combined operations and loading the addon through the expansions list. But RTE capture doesn't let me export or save ingame. It tells me that there is no link or something established between RTE capture.

Share this post


Link to post
Share on other sites

I'm having major problems now and I can't get this thing to work.

Before OA came out, I would launch the game, then when the game was on I could open rte capture and then push Activate Monitoring.

Then when OA came out, I changed the executable stuff so that it said arma2oa.exe instead of arma2.exe. And then It didn't work, I checked the box at the bottom that says Use RTeCapture DLL. and i got it to work by launching rte capture first, then launch the game from capture.

Yesterday RTE updated and now it doesn't work at all. If i launch game from Capture, the "launch arma2" button, the game loads and the buttun changes to read Activate monitoring, but it's grayed out. And next to it it stays saying "inactive"

I had everything perfect until the update it did two days ago, and now it doesn't work at all.

Share this post


Link to post
Share on other sites

after i add a unite on map and press Esc i am gat No connection to RTE capture established. Extort wont work. to fix this establish a connection and reload the mission.

so i press reload and i get ""injectionlibrary: pipe is not open""

can anybody help me out.

Share this post


Link to post
Share on other sites

Stop using the RTE Capture DLL, use ArmA2Lib instead.

Share this post


Link to post
Share on other sites

Ok, maybe someone can help me.

I have used RTE in the past ,before OA came out and it worked great. I never had any problems getting it installed, running or capturing.

I have not tried to use it since OA came out, but I worked all day trying to get it to work. Most of the time RTEcapture does not know the game is running and it keeps giving the button for launch game. I read that if you change arma2oa.exe to arma2.exe it would work. I tried that and RTEcapture would see the game running ,but still will not connect. In the single player editor I can get RTE to open up fine, but it says there is no connection. I check RTEcapture and the button is "active monitoring" grayed out and beside it says "inactive".

Another problem, I cannot get RTE to open in the MP editor. I get the action for it but noting happens. Yes I am using the maps for MP from the website. I have used them in the past and never had a problem.

I am running A2+OA, lastest CBA, Jayarma2lib and RTE. I dropped all my mods and just used those three. I have made sure my folders for Arma are not write protected (running wins 7). I have also checked all my paths in RTE.

I did test RTE just using just A2, @cba, @jayarma2lib and @RTE. When I launched the game RTEcapture does switch to "activate monitoring". It does matter though in game. Both editors single player and multiplayer say a " script not found". Single player I can open RTE but when i click "activate monitoring" it still says inactive, and in game it says no connection. Mp editor I can't get RTE to open even though I get the action to open it.

from .rpt

[1175,51.391,0,"WARNING: isServer is true while isDedicated is false; You can safely ignore this if this is a hosted game; otherwise please report asap"]

Warning Message: Script not found

ion_rte_dta\ion_pipe.p3d: No geometry and no visual shape

ion_rte_dta\ion_pipe.p3d: No geometry and no visual shape

ion_rte_dta\ion_pipe.p3d: No geometry and no visual shape

ion_rte_dta\ion_pipe.p3d: No geometry and no visual shape

[1198,52.993,0,"XEH: VehicleInit Started"]

[1198,52.993,0,"XEH: VehicleInit Finished PostInit Started"]

[1802,63,0,"WARNING: PostInit did not finish in a timely fashion"]

Any help would be appreciated. I took a break from mission making ,but now I want to get back to it. RTE is too wonderful a tool not to use

Nomadd

Edited by Nomadd

Share this post


Link to post
Share on other sites

Simple guide how to use RTE with OA:

Required:

JayArmA2Lib

  • Start RTE Capture
  • Start OA with mods CBA, JayArmA2Lib, RTE using you're favorite way to do it
  • Open the RTE (this will take some time...)

Don't use the "monitor" stuff, no action inside RTE Capture require. Just keep it open.

About the MP editor:

The StartRTE_MP is broken due a design change. It currently only checks if CBA is used.

Use this code to start the RTE:

[] spawn ION_RTE_pStartRTE

Share this post


Link to post
Share on other sites

@i0n0s

Thanks for the reply. I will give it a go and let you know what happens.

Nomadd

Share this post


Link to post
Share on other sites

So I dont have to rename the exe cause that doesn't work with steam?

Share this post


Link to post
Share on other sites

@i0n0s

I did what you said and used the code for MP editor. RTE opens up in MP ,but in both SP editor and MP editor, I get the same message when I try and export anything.

"RTE capture not started"

Is there something else I should do? I alt tab out and checked. RTEcapture is running. Should I not try to export? Is there another way to save now?

Sorry if this has been answered. I have looked at all the posts and read the RTE Capture Manual. I read where others were having this problem ,but I never found an answer.

Nomadd

Edited by Nomadd

Share this post


Link to post
Share on other sites

i also tried that and it didnt work for me;-(

would be nice if you tell us what to do, this is such a nice tool!

Share this post


Link to post
Share on other sites

  1. Install JayArmA2Lib
  2. Configure the profiles within RTE Capture:
    Settings within RTE Capture:
    wj4c23qo.png
    Settings within RTE Capture using the beta:
    28aa3szv.png
  3. Run the profile by clicking on the icon for the profile.
    If you have only one profile, simple click on the "Launch ArmA (II)" button.
  4. Within ArmA, open the RTE

Q: Do I need to do something else within RTE Capture?

A: No, nothing need to be done.

Q: RTE Capture doesn't detect Operation Arrowhead.

A: The current version only looks for arma.exe and arma2.exe, not for arma2oa.exe. So it can't detect Operation Arrowhead. But you don't nead to inject when using JayArmA2Lib.

Q: ArmA is open but RTE Capture doesn't connect.

A: Due to JayArmA2Lib a design change was required. RTE Capture now only connects if RTE is opened within ArmA.

Q: RTE failed to connect when reopening.

A: Restart ArmA and RTE Capture. Due to a design issue some times the pipe doesn't get closed and can't be used any more.

Q: Opening the RTE does take some time.

A: Yes, it does take some time...

Q: Which version do I require?

A: RTE Capture: 1.56, ION_RTE: 533, ION_RTE_Dta: 532

Q: How to find out if the pbos are up to date

A: :x

Share this post


Link to post
Share on other sites

Thanks! working now. i had a script error first, but the i copied the dll file from JayArma2Lib over and it worked. the only thing which is not working for me is starting with the beta without CD. allways it says insert the disc, also if i use the beta and expansion/beta addons.

Share this post


Link to post
Share on other sites

@Coffeecat

Glad I came back and read the last post you made. I still could not get RTE to work. I went and checked and the .dll was in the wrong folder.

I have been pulling my hair out and it was right in front of me.

Nomadd

BTW: RTE is working fine now.

Share this post


Link to post
Share on other sites

Keep crashing in OA when I try to put unit after putting center and group.

Share this post


Link to post
Share on other sites

How do you create a center within the RTE? :confused_o:

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×