Jump to content
Sign in to follow this  
i0n0s

[Alpha] RTE for ArmA II

Recommended Posts

This with 0. seems to be a bug.

Hopefully will be fixed in the next RTE Capture release.

But I can't promise that I release soon. Still some work cleaning up the code.

About the templates:

Their basically compositions. But you seem to talk about simple export:

As long as you don't edit the init-line, they shouldn't be effected by any movements.

But this unevenly may be effect of the init-line.

Try to remove it. Next version will have an option to disable the init line.

About the misplacing:

This will happen every time you reload it within RTE. But it should stop as soon as you merge it within the mission.sqm. I need to take a look if "CAN_COLLIDE" would solve the problem.

For programmer: RTE saves its data to RTE.db, a mysqlite database. In there you should be able to change "FORMATION" or "NONE" to "CAN_COLLIDE".

As the solution:

You did something different: You need to select all objects, then use the cursor keys. The correct position is saved internal, but A2 does misplace them. When moving, they will get placed to the correct position (just shifted a little). This will restore your work.

Share this post


Link to post
Share on other sites

I0n0s,

Ok just to clarify, I select everything (or just only the misplaced objects?) and use the keyboard cursor keys to nudge them back into place and save it?

Or like you said its saved internally in right positions, I just nudge them back while I resume the project to finish up the rest of the base in RTE and merge with mission.sqm when finally finished building the base and filling it?

It's been awhile since AA1, so I was wondering if I just merge what I have so far with mission.sqm, if I can go back and edit further? Or once something is merged with the mission.sqm you can't edit it anymore?

(I think back in AA1 I did similar but I messed up horribly, because I had 2 bases on top of each other, LOL. So I figured I should ask you first before me doing something stupid again and messing up everything. :p )

Sorry about all the questions, mate. I'm trying to make sure I understand completely and for future. Just know all of your help is greatly, greatly appreciated. It has been awhile, so once I get the hang of everything again, I should be a building machine. :D

Thanks again for the help! :yay:

Share this post


Link to post
Share on other sites

You select all the objects which belong to the misplaced objects. So in the above picture you also select the bunker at the bottom.

Or like you said its saved internally in right positions, I just nudge them back while I resume the project to finish up the rest of the base in RTE and merge with mission.sqm when finally finished building the base and filling it?

Yes, this should work.

It's been awhile since AA1, so I was wondering if I just merge what I have so far with mission.sqm, if I can go back and edit further? Or once something is merged with the mission.sqm you can't edit it anymore?

Once a object is within the mission.sqm, you need to remove the init line and then you can move then as usual in the 2D editor.

Share this post


Link to post
Share on other sites

Hi i0n0s,

I've got a problem with the editor and exporting in the current version.

1. The unit list on the right side of the screen - i cannot click on or select any unit in the below half of a populated list. I have to collapse groups in the top half so units I want move up to the top half.

2. When I export selected units, for a large list it will take a very long while to export some of the units, but not all that were highlighted.

Onto my query. With earlier versions I extracted the contents of ION_RTE and included it in my missions so players didnt require the mod installed (I had a modified InitRTE.sqf to load required functions and libraries only, cut down the size).

Currently I can get units to spawn and follow waypoints etc, but they wont engage enemy units?

Does anyone have a set of standalone scripts such that we can use exported .sqf from RTEditor without the addon installed? It's driving me nuts.

Edit: Resolved by adding a unit from each side into the editor.

Thanks!

Edited by trooper_ryan

Share this post


Link to post
Share on other sites

I'm wondering, how do I turn a template that is in .xml form into an .sqf file? Or even just make it where i can actually load the template into the game.

Share this post


Link to post
Share on other sites
1. The unit list on the right side of the screen - i cannot click on or select any unit in the below half of a populated list. I have to collapse groups in the top half so units I want move up to the top half.

This seems to be a bug, but a non understandable since it uses BIS list implementation.

@Darkhorse:

RTE Capture can create a SQF file out of the xml file.

To load the template simple execute the script with a given position.

But be aware that it requires the RTE installed, at least on the server side.

Share this post


Link to post
Share on other sites

Hi

just a quick question.

Are there any plans to make this system work on multiplayer, so multiple people could enjoy the mission on the spot?

Is this possible?

Share this post


Link to post
Share on other sites

Loved this mod since i downloaded it, quick suggestion, is it possible adding options to raise/lower the object/vehicle so it can be placed on carriers etc.

Share this post


Link to post
Share on other sites
This seems to be a bug, but a non understandable since it uses BIS list implementation.

@Darkhorse:

RTE Capture can create a SQF file out of the xml file.

To load the template simple execute the script with a given position.

But be aware that it requires the RTE installed, at least on the server side.

I am having the same issue where I cannot select anything past halway down the pull down menu. I like what you have done with this tool, it si good work. I would like to use it further but due to having many addons, I cannot. Is there any way to create a scroll bar in the dialog option, using XML coding? Some coding like this.. if (UI textsize is small, faction list contains 12) then {allow window, scroll box from pull down menu) else {do nothing}. ?

Edited by zolop0

Share this post


Link to post
Share on other sites

Hey, iOnOs,

LOVE the editor! fantastic - brilliant! a must have for any mission maker

i have a question, tho...

if i export my mission as a .sqf script, will it depend on addon-defined functions? i mean, if i use it to create an mp mission that spawns blocks of RTE-built bases on the fly, will players (or the server) need RTE installed so the functions will run?

and if so, how do i make it so that all needed scripts are loaded with the mission (addon-less)

another: is there any way to duplicate an object? like ctrl+c, ctrl+v ?

great addon!

cheerz

Share this post


Link to post
Share on other sites

The error with the scrollbars is within ArmA II?

Then maybe my scrollbar definition is wrong :(

@Moach_Mayhem:

It either requires to have the RTE installed on the server or use the "RTE_Export.sqf" script, but this is a little outdated.

ctrl + k, ctrl + p ;)

Share this post


Link to post
Share on other sites

The regrouping doesn't work.

EDIT: Whoops, yes it does.

This mod looks like it can be a great utility; that is, if it's possible to save. Is exporting the only way to save? Or is there a way that will allow me to save the mission? Do I need to make my changes with the RTE, then go back to the normal editor and save from there?

Edited by Lucan946

Share this post


Link to post
Share on other sites

You can save within the RTE using the project administration.

But to get the units/objects into your mission you need to export it and merge it into the mission.sqm.

Share this post


Link to post
Share on other sites

Okay, thanks for clearing that up. I must say, this is a great asset; I'll be a very happy camper when it comes out of alpha, because right now it isn't too reliable, some functions don't seem to work, etc

Still, a great tool.

Share this post


Link to post
Share on other sites

About the alpha:

I'm still working on bringing RTE Capture to a clean code base. I'm currently working on the merge-system. But this takes time and motivation.

Once this is done I will remove the current bugs and will move it to beta.

Share this post


Link to post
Share on other sites

Excellent news! Looking forward to a beta! Used very often here for sure ;)

Share this post


Link to post
Share on other sites

Can someone please help me, I've looked and checked the forums but cant seem to find the answer. When i place triggers, Im unable to move or delete them. It says in the RTE manual that triggers are used in the same way as the normal editor, but clearly for me that is'nt the case. when i move the mouse pointer over them it doesn't register a trigger at all, Please someone put me out of misery.

Share this post


Link to post
Share on other sites

I mean. I have created some sqf with the mod, in my computer. All is working OK. Then I call for them via a trigger with something like:

[] execVm "rte_exported_script.sqf";

In my computer the execution of the script populates correctly a zone with units.

The problem comes when i run the mission on the dedicated server.Then the script is not running, or i think so. No one unit is created.

The dedicated server is luched with -mod=@RTEditor

What is the problem here?

Can be used this mod for this pourpose?

Thank u

Share this post


Link to post
Share on other sites

I don't get the "RealTimeEditor" then I press "ESC" :(

EDIT: Forgot to add RTE mod parameter X)

Edited by nicke157

Share this post


Link to post
Share on other sites

@Boreas:

Make sure you have CBA loaded too. Otherwise the RTE won't be initialized and the script will do nothing.

Share this post


Link to post
Share on other sites
Does this work with arrowhead?

Yes, rename Arma2OA.exe to Arma2.exe :)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×