Jump to content
Sign in to follow this  
ginger mcale

Any progress at graphic artefacts with ATI cards?

Recommended Posts

This thread is about the problem with ATI cards.

It's not a problem with ATI cards. Only with NVIDIA cards. You have an individual problem like overheating card or similar.

Share this post


Link to post
Share on other sites

I have an ATI POWERCOLOR HD3870 512mb, running Vista 64Bits with 9.8 ATI Drivers. I use the graphics on Very High but i turn off AA, AF & Postpone efects (i think i didn't write it wrong), and i put the shadows in low.

Last Saturday i played for about 4 hours strait & i didn't have any problem.

I had to put the fan at 60%, beacuse it was rebooting due to very high temps.

Edited by Nuno Basto

Share this post


Link to post
Share on other sites
It's not a problem with ATI cards. Only with NVIDIA cards. You have an individual problem like overheating card or similar.

Another person not reading the thread and posting his wrong assumption. Oh, i wish people would read before posting. :rolleyes:

I think beeing a moderator here on the forums is a fulltime job. :yay:

@Nuno Basto: Max please AF and shadows and make fly a few minutes over the biggest city a the south. If you still not get it, there must be some other factor we do not know, or maybe its a 32 bit or 64 bit thing. I am not sure if we had made such a observation hmmm. Interesting!

Edited by Ginger McAle

Share this post


Link to post
Share on other sites

@Nuno Basto: Max please AF and shadows and make fly a few minutes over the biggest city a the south. If you still not get it, there must be some other factor we do not know, or maybe its a 32 bit or 64 bit thing. I am not sure if we had made such a observation hmmm. Interesting!

I'll try it tonight and i'll post the results here! ;)

Share this post


Link to post
Share on other sites
...

@Nuno Basto: Max please AF and shadows and make fly a few minutes over the biggest city a the south. If you still not get it, there must be some other factor we do not know, or maybe its a 32 bit or 64 bit thing. I am not sure if we had made such a observation hmmm. Interesting!

well to think a 4850 512mb can run max AF and MAX shadows is shaky. 512mb its a normal setting card. Now that still doesn't change the fact you get spikes and such. Also your VD should be at 1500...max, but if you fly that VD sux ,you want 3500 or 5000, but your card isnt in that league. Then the rez? a 4850 is a 1280/1024 card (for this game).

When i test and debug i install a new OS, and the driver(s) i am testing, with the latest bios ect.. If you can buy another HDD (40$) or use a old one, you can really go all out, XP64 has trial time(90days).So do other winOS, from windows. I for the life of me cant get your issue on 64bit and i have 512mb ATi cards, 1950xtx and 2900xt... i have been testing much more than playing, but i dont fly, But other ati users with 512mb cards who fly can get it(scary being the chopper!...) and they haven't done a clean install either( to many drivers left over)...next for me is the oldxp 32...

One thing you might try is to down clock your vram. in the OD of your CCC, set a profile.

Share this post


Link to post
Share on other sites
If you still not get it, there must be some other factor we do not know, or maybe its a 32 bit or 64 bit thing. I am not sure if we had made such a observation hmmm. Interesting!

The Arma 2 executable is 32bit. Its not even Large Address Aware (i checked with cff explorer) so basically it doesn't make any difference as it can not go above 2gb ram. Basically a 32bit application with Large Address Aware can go above 2gb without being 64bit. But this does not apply with Arma 2.

Edited by connos

Share this post


Link to post
Share on other sites

@kklownboy: Good post, good to know, thanks.

No, i dont think i can play with my card with the highest setting, its just the fastest way to get the artifacts (more texture memory needed), so people see if they have the problem or they do not have it and we have another person and his settings and can add it to our observations and make another conclusions.

Max texture size and max AF do only make a 1-3 frames difference here at 1680x1050. I normally play with AF at normal. And its also not the point with flying or driving or walking. Flying over the biggest city is jus also the fastest way to get the artefacts i think. At the moment if i play the game, i need to set textures to low :butbut: and texture memory to low to not get the artefacts somewhere (after 2 minutes, or after 10 minutes, depends on the location you are on the map). And thats the biggest problem, the game looks with textures low and texture memory low very ugly. Check it out :D:eek::yay:

Setting the default clocks at core and memory of the graphics card did not change anything. This and temperatures was the first thing i did check after having the artefacts problem the first time months ago because when getting this artefacts its usually means your overclocking is to high and/or your temperatures are to high. In this case, this things can be exluded.

The Arma 2 executable is 32bit. Its not even Large Address Aware (i checked with cff explorer) so basically it doesn't make any difference as it can not go above 2gb ram. Basically a 32bit application with Large Address Aware can go above 2gb without being 64bit. But this does not apply with Arma 2.

Okay cool good to know, thanks connos!

Maybe there is something else that is different between 32bit and 64bit.

Share this post


Link to post
Share on other sites

I tryed your sugestion, but i didn't have any artifacts.

Everything was on max, and the VD was at 1400 +/- so i could at least get the chopper from the ground.

I flown over the city for about 10min and no artifacts what so ever.

My system is:

E8200@2.66

ASUS P5KC

4GB Corsair 800Mhz

HD3870

2x samsung 160GB in raid0

CRT monitor 17" @ 1280x1024

Windows Vista Ultimate 64Bits

ATI 9.8 Drivers

Share this post


Link to post
Share on other sites

Thanks Nuno Basto! I checked it now also with your settings, maxed almost everything (post processing effects disabled and anti aliasing disabled too). Other settings maximum and view distance 1400 too. Got artefacts after ca. one minute. So maybe 64 bit is the point here. Good to know. I will check the sticky thread one more time to see if i can see if people with 32 bit operating system have artefacts only.

My system:

E8200@3.84

MSI P35 Neo2

4GB Mushkin @ 960 mhz

HD4850 with 512 MB RAM

Windows XP 32 bit

ATI 9.8 drivers

@all people with ATI cards with 512 MB videoram:

Are you at a 64 bit operating system or 32 bit?

Edited by Ginger McAle

Share this post


Link to post
Share on other sites
Another person not reading the thread and posting his wrong assumption. Oh, i wish people would read before posting. :rolleyes:

I think beeing a moderator here on the forums is a fulltime job. :yay:

@Nuno Basto: Max please AF and shadows and make fly a few minutes over the biggest city a the south. If you still not get it, there must be some other factor we do not know, or maybe its a 32 bit or 64 bit thing. I am not sure if we had made such a observation hmmm. Interesting!

No you are not reading. I had this in ARMA with NVIDIA, but 10x worse. Never had anything like this with 4870 512mb.

Share this post


Link to post
Share on other sites
the arma 2 executable is 32bit. its not even large address aware (i checked with cff explorer) so basically it doesn't make any difference as it can not go above 2gb ram. Basically a 32bit application with large address aware can go above 2gb without being 64bit. But this does not apply with arma 2.

wow § shame !

---------- Post added at 05:17 AM ---------- Previous post was at 05:13 AM ----------

Another person not reading the thread and posting his wrong assumption. Oh, i wish people would read before posting. :rolleyes:

I think beeing a moderator here on the forums is a fulltime job. :yay:

@Nuno Basto: Max please AF and shadows and make fly a few minutes over the biggest city a the south. If you still not get it, there must be some other factor we do not know, or maybe its a 32 bit or 64 bit thing. I am not sure if we had made such a observation hmmm. Interesting!

AF has nothing to do with memory usage :p

Share this post


Link to post
Share on other sites

InFireBaptize

ok.

temperature/voltage u say?

im using hi-end water-cooling system, case with well ventilation and 750wtt Thermaltake PSU.

gpu temp ingame is about 48-50', memory and mosfets temperature is also in permissible range.

But im still experiencing graphic glitches in ArmA2, and Only in ArmA2.

_

XP Sp2 32

Q6600 @ 3.8

HD4870 (512)

4GB ram

Share this post


Link to post
Share on other sites

Hey Ginger,

Right here is my experience. Was running Vista64 but A2 was slow(ish) then I changed to XP32. Although the frame rate was much higher I was getting artifacts just like you whenever I approached Chernogorsk.

THEN I changed my OS to Windows7 (64 bit) and there were no more artifacts. I could fly low/high/all day over Chenarus (especially around Chernogorsk) flawlessly. It also removed my stuttering and increased my FPS even more ! Now I normally pilot so I have ION_VIEWDISTANCE so that I can change VD during a mission if I need to and after kju's VD tweak I now sit at 6km VD so that building appear at 6km and vehicles at 3.1km

Now as to my system. I haven't changed any hardware and was running 9.7 when I did the above changes. I'm now running 9.8 (and even the hotfix) and its smooth!

Ati Radeon 4870 (512Mb)

Core i7 920 2.67GHz (OCd to 3.9GHz) HT turned OFF

6Gig RAM

8Gig Pagefile

All settings NORMAL, PP OFF, AA OFF, SHADOWS OFF, Terrain detail V HIGH.

I hope this helps. I think Windows7 64bit has better VRAM control - I never go above 50%RAM usage and 50%CPU.

Don't listen to the 'so-called' experts that keep chiming in with their (it's temp/PSU etc) nonsense.

Share this post


Link to post
Share on other sites

After reading Kremator's theread i belife that XP 32bits is the problem! Why!? Don't make any idea why! If someone with XP64 could test if its an XP problem or an 32bit SO problem!

Share this post


Link to post
Share on other sites
Hey Ginger,

Right here is my experience. Was running Vista64 but A2 was slow(ish) then I changed to XP32. Although the frame rate was much higher I was getting artifacts just like you whenever I approached Chernogorsk.

THEN I changed my OS to Windows7 (64 bit) and there were no more artifacts. I could fly low/high/all day over Chenarus (especially around Chernogorsk) flawlessly. It also removed my stuttering and increased my FPS even more ! Now I normally pilot so I have ION_VIEWDISTANCE so that I can change VD during a mission if I need to and after kju's VD tweak I now sit at 6km VD so that building appear at 6km and vehicles at 3.1km

Now as to my system. I haven't changed any hardware and was running 9.7 when I did the above changes. I'm now running 9.8 (and even the hotfix) and its smooth!

Ati Radeon 4870 (512Mb)

Core i7 920 2.67GHz (OCd to 3.9GHz) HT turned OFF

6Gig RAM

8Gig Pagefile

All settings NORMAL, PP OFF, AA OFF, SHADOWS OFF, Terrain detail V HIGH.

I hope this helps. I think Windows7 64bit has better VRAM control - I never go above 50%RAM usage and 50%CPU.

Don't listen to the 'so-called' experts that keep chiming in with their (it's temp/PSU etc) nonsense.

I had the same issue in my system. Windows 7 64bit handling of VRAM seems way better than Vista 64bit. Arma 2 and Stalker Clear Sky was the only games that I had problems with VRAM. Windows 7 64bit fixed this for both games.

---------- Post added at 02:20 PM ---------- Previous post was at 02:14 PM ----------

wow § shame !

---------- Post added at 05:17 AM ---------- Previous post was at 05:13 AM ----------

AF has nothing to do with memory usage :p

You can manually do the Arma 2 executable Large Address Aware but you will not gain anything as the engine don't even pass the 2gb(i tried it).

Some games that gave me crashes due to this i manually do them Large Address Aware with cff explorer. Arma 2 will definitely benefit from more ram usage and a Large Address Aware exe.

Share this post


Link to post
Share on other sites

OK, poeple this is NOT the only game that does this for ATI Cards. Try this. Uninstall JUST your catalyst drivers, NOT display drivers. It will go away. Or uninstall all of your ATI drivers then re-install JUST the display drivers without the catalyst ATI drivers. Hey presto ITS gone. WHY because ATI has some serious driver issues with certain games. Another thing try OMEGA ati drivers instead, those catalyst ones are a real pain. Same with Crysis did this for me with the 1900xt cards. Someone said get rid of the catalyst suite and it was gone.

Edited by nyran125

Share this post


Link to post
Share on other sites

No artefact problems for me in Windows Vista and Windows 7 64-bit.

However when I tested the game in Windows XP 32-bit, I could only play for about a minute before serious graphical glitches and shortly after them a crash to desktop. I thought it was some sort of issue with 4 GB memory installed and only 32-bit OS but now it seems it might have been some problem with ATI card.

Share this post


Link to post
Share on other sites

I never had any serious issues from Catalyst Drivers and i only buy ATI cards (9800, 2600, 3870, 4870).

Edited by connos

Share this post


Link to post
Share on other sites

Hello,

is there any progress from the official side on this artefacts issue?

Regards

Mariusz aka ginger

Share this post


Link to post
Share on other sites

Im getting these bugs too and im running XP 32 bit with a 4870 512MB and Ati-Catalyst 9.8.

I'll try to install Win7 64bit RC this weekend and then i will post my experience here.

The thing with this graphic:

http://img199.imageshack.us/img199/8859/arma2graphatt.png

is that when you set VRAM to high and Textures also the whole time in the game the VRAM is full and the bug only appear in big towns and for me in the northwest of Chenarus.

So my assumption is that is something wrong with the textures or the amount of textures or how they are loaded into the VRAM.

Sorry for my bad English

Edited by Gna Morg

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×