Jump to content
Sign in to follow this  
suma

ArmA 2 Demo feedback

Do you like the demo?  

492 members have voted

  1. 1. Do you like the demo?

    • the demo is great
      235
    • the demo is good
      148
    • the demo is so-so
      50
    • the demo is not good, I do not like the game
      13
    • the demo is not good, I have problems installing it
      20
    • the demo is not good, I have problems playing it
      51


Recommended Posts

Looks like Arma2 scales pretty well to older systems. :)

Do you or anyone else also get increased stuttering when running around far out in the randomly generated terrain?

Yes ArmA2 Demo seems to run nice in old systems, at least in mine it does.

Can you elaborate please, im not quite understanding what you mean.

EDIT1:

Negative obs: What i don't like so far is when i increase the interface size to smallest in options i get my squad icons in the middle of the screen, it should be at bottom left as usual. (forgot i needed to restart the game to apply the GUI) duh!

Positive obs: the performance is very nice, comparing to ArmA1 with the same System i would say ARMA2 runs better then ARMA1.

Edit2:

Positive obs: Also i like the way it loads the map.. much faster then in ARMA1

Edited by bravo 6

Share this post


Link to post
Share on other sites

Demo is great i wish i had a super computer,.

AMD Athlon 64 x2 dual core 4200+ win xp 2Gig ram,gforce 8600GT.

Full diskdefrag all drivers & windows uptodate etc.

Only getting 15fps benchmark mission,with everything turned down,still playable though.

Well done BIS. :]

Share this post


Link to post
Share on other sites

- Quick download from Filefront (1h)

- Installation went almost without any trouble (had the X3DAudio1_6.dll error, but driver errors are normal and updates are quickly installed)

- Started the game, adjusted the settings in title screen... everything on very high / high (gotta test what it gives huh :p ) and it actually ran pretty good.. on maxxed settings it gave around 20-25 fps (check link in signature for my system).

Haven't had the time to play/test a lot, but I played most parts of the bootcamp and all of that went well, so for now, all runs well @ max settings

Later today I'm gonna play around a bit with the mission editor and add more AI and stuff to see if fps stays that nice :)

And also check if fps goes up enough when I lower the graphics settings..

Headbobbing and blur are ok for me for now.. but it certainly is different than OFP and ArmA, so i'll have to get used to it.. or make some adjustments in the settings :p

Share this post


Link to post
Share on other sites

Negative obs: What i don't like so far is when i increase the interface size to smallest in options i get my squad icons in the middle of the screen, it should be at bottom left as usual. (forgot i needed to restart the game to apply the GUI) duh!

TROLL NOOOB! ;)

Just glad it's working for you now :)

Share this post


Link to post
Share on other sites

It's a demo .. it's free .. so i don't think there is copy-protection on it..

You don't have to activate it like the full game :p

Share this post


Link to post
Share on other sites

more trolling from me hihi :D

Positive: We can keep the old profiles, all you need is to change the name to "username.ArmA2DemoProfile" and old ARMA1 keys and settings will be ready. Using this its easy to compare how ARMA2 runs comparing to ARMA1.

Positive:I like all the available options all very useful

Share this post


Link to post
Share on other sites

How does the "supress" command works in the demo ? anybody has an idea ?

(press spacebar then left alt, you need to have a squad under your command btw)

Edited by MQ-9 Reaper

Share this post


Link to post
Share on other sites

Running great here

Q9660

260GTX

Did some of the training camp missions and played a little with the limited editor that was included, really easy to create a simple missions :)

Online had some problems though, went to some server, got shot, died and reborn as a bird :confused: Next attempt crashed with out of memory error

Share this post


Link to post
Share on other sites

I'm very impressed how this demo works with my comp.

I have

E5200 dual core 2.5Ghz

4gb ram

HD2600 xt 256mb

Resolution is 1280x1024 (this is fine as I have 19" monitor)

medium-high settings

no AA

Benchmark fps 22

And it runs smooth! I thought it wouldn't even run this with very low. I love everything what I have seen for now! Blur is fantastic for me. Now I have to buy this game

Share this post


Link to post
Share on other sites
Can you elaborate please, im not quite understanding what you mean.

1. Fire up the demo.

2. Open Chernarus in the editor.

3. Zoom all the way out. Note that the small square of populated land is surrounded by empty hills.

4. Place yourself as a unit into the empty hill space, far in the top left corner.

5. Start the game, look toward the north-west (away from the main playing area). Start running.

Do you notice any stuttering while moving? The framerate out there in the open is insanely high, but for me it starts stuttering heavily whenever I move.

Share this post


Link to post
Share on other sites
got shot, died and reborn as a bird :confused

aaah great, makes me remember some OFP moments :D

If no respawntype is set, you'll respawn as a bird. That is normal ;)

That game is over for you then and you'll have to wait until the next game/mission is started.

Share this post


Link to post
Share on other sites
Just played the demo for two hours and I basically like it. It's like OFP! The athmosphere, the style, the graphics...

Honestly, is it normal that I have to play it on mostly everything off or low with an Athlon64 6000+, Nvidia 8800GT and 2GB RAM under Win XP SP2? And I still have texture loading issues. I already got the newest Nvidia driver, but that didn't change much.

So my feed back to the demo is: So-so. The athmosphere is nice, but the performance not so.

is it a dual core or quad core cpu? :) the minimum is dual core cpu at least.

Share this post


Link to post
Share on other sites

Is there a way to create missions in demo and play them with friends?

Share this post


Link to post
Share on other sites

Ahh finally played the demo. First ran more benchmarks to get a good balance from my system and then did the training which went just fine, no issues except when I was training with AT gear against wooden tanks and firing a few rockets at the tanks nothing else all of a sudden fire from an AI started coming in. The commander went prone but I kept looking around to see if I could see who/where and saw nothing, next thing I died. I don't know why except maybe the commander got hit by backblast and I was the target after?

Anyway did the first mission, well started it, damn it is good, bloody challenging but saw the AI doing stupid things which does detract from it somewhat although I also saw the AI doing smart things with cover as well.

Emersion is amazing, I really felt like I was in a village and it was quite stressful at times.

On my rig I have everything minimum high with shadow at very high and AA also on Very High and it is very smooth 95% of the time with the odd stuuter which does not matter. Oh and view distance was set at 4000, maybe I'll try more.

Would like to add I can see a huge effort has gone into this game and I am more than happy to pay the $50 for it bugs and all. Great job BIS.

Q6600 2.4@2.8

2GB RAM

ATI 4870 1GB (Standard speeds)

WIN XP 32bit SP3

Catalyst 2.6

Edited by Dogtags

Share this post


Link to post
Share on other sites
No wai ! :confused: :confused: :eek:

Obviously I'd assume not but if I say no someone might try to prove me wrong ;)

Share this post


Link to post
Share on other sites

Well took the demo to my mates place today and installed it on his pretty decent system:

XFX 780i

E8400 @ 4Ghz

2GB DDR2 1066

2x 8800GT 1GB in SLI

Win XP SP3

Nvidia 186.18

I can confirm that the game does NOT use SLI at all... he has a G15 keyboard and rivatuner configured to show many stats, including both GPU temps and fan speed.

GPU0 was working hard and fan was at 60%

GPU1 was idling, fan was at lowest 33.3% and it was at idle temp....

The game ren ok, about the same as my 8800GTX... so its quite disappointing that such a demanding and new game does not use SLI.

I hope a patch fixes this or newer drivers enable SLI, if its possible?

I searched this thread and there is no mention of SLI... so I guess not many here have SLI or tried the demo yet? Is there a known fix or hotfix to get SLI working?

Thanks,

Yapa

Share this post


Link to post
Share on other sites

I just played the game... needed alot of refamiliarization. apparently, ARMA2 VETERAN is not the same as ARMA1 VETERAN (difficulty settings). enemies are very hard to see. they blend in quite well

Overall Im impressed. performance run great. set everything on high. VD default at 1600 and got avg 35fps on the benchmark mission

my specs:

mobo: ASUS P5QL PRO

processor: Core 2 Quad Q9550 (i think) 2.83ghz (no OC)

Gfx: ASUS HD4870 512mb (driver ver 8.523.0.0, the CD that came in with the card, havent tried 9.6 yet)

RAM: 4gb

OS: Vista ultimate 64bit

ingame resolution: 1280*1024

Edited by Mr_Centipede

Share this post


Link to post
Share on other sites

Question:Does trackIr work for the demo version?

I cant make mine work..

EDIT:

Answer: yes it does you stupid head. Like people said before you need to enable it in the options, Asshole.

EDIT2: Positive: The helicopter piloting is awesome, much more improved then ArmA1 also TrackIr feeling.

This game keeps better and better in every test. GOOD job BIS

Edited by bravo 6

Share this post


Link to post
Share on other sites
Is there a way to create missions in demo and play them with friends?

I didn't find any save mission option from the editor that comes with demo, so based on my little experiments done yesterday, I would say no.

Basically you just set some parameters, units, friendly and hostile, weather, time of day etc...and then launch the mission you just created, no save possibility..or at least I didn't find

Share this post


Link to post
Share on other sites

Just found the thread about the EVGA SLI Hotfix utility which enables SLI :)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×