Jump to content
Sign in to follow this  
argh9R

Radiosound + Mouse Lag Problem

Recommended Posts

thanks for the vid Misurugi. its the bug i have too. you will notice the mouse lag is way worse at low fps. but its even there with high fps. i stopped posting in this forum because i don't think it will help. i am totaly asthonished the admin of this forum says he don't has the problem. i think thats the problem BIS has. they don't see their bugs because apparently they're not playing other fps. You have to be an experienced pc-gamer to feel the difference.

btw: i HAVE high fps :) and this prerender flipflop quesize thingithong didn't help.

i've deinstalled the game a week ago and its not my problem anymore. i will sell it to someone who doesn't care about it or simply has not the problem due to some kind of immunity :D (the same type of guys who says they feel no difference between 30fps and 100 fps ---- ahahhahhahaha. its so sad:( )

Share this post


Link to post
Share on other sites
i am totaly asthonished the admin of this forum says he don't has the problem. i think thats the problem BIS has. they don't see their bugs because apparently they're not playing other fps.

Why are you astonished? He doesn't have it and neither do I nor my friends. Do you think we are lying? The world doesn't revolve around you I'm afraid. Just because you have it doesn't mean others who don't are lying, grow up maybe.

You have to be an experienced pc-gamer to feel the difference.

What's your definition of experienced? I've owned a PC since 1994 and have been gaming with it ever since besides building my own and others systems since 2001 . Before that it was I was gaming on atari, intellivision, colecovision... I could go on. Does that qualify?

i will sell it to someone who doesn't care about it or simply has not the problem due to some kind of immunity :D (the same type of guys who says they feel no difference between 30fps and 100 fps ---- ahahhahhahaha. its so sad:( )

Is this a shot at me because I said I was immune? Not funny buddy and if you selling the game does this mean you'll be gone from here? Because, that would be sad:yay::yay::yay:

---------- Post added at 07:31 PM ---------- Previous post was at 06:48 PM ----------

I am still scratching my head over why doing the following has completely fixed my game. I now have no mouse lag or slow gameplay, but I cannot explain why this would fix it. Can someone else do what I have just done and explain to me why this has fixed things. I have changed just two setting in the game options for this fix - I have set interface resolution to 1280x768 and the 3D resolution to 1600x960. I also set Anti alias to 2 in the config.

I did try other resolutions some lower than this, but I then get mouse lag and slow game play. This is the only resolution that stops all this for me. I hope you try this and give some feedback.

BTW - I have a Geforce 260 GTX.

This post might interest some with mouse lag.

Share this post


Link to post
Share on other sites
and if you selling the game does this mean you'll be gone from here?

Yes.

The "immune"-thing was no direct offense, no.

Share this post


Link to post
Share on other sites

Got a new computer now, i7-920 with HD4890 and 4GB DDR3. Hadn't overclocked or made any major tweaks yet. I can say the game DEFINITELY has some sort of a weapon turning acceleration system, and with this computer it works smoothly and I can aim great (while it actually feels like my speed/acceleration is limited). Therefore I'll say the the problem is that the aiming acceleration system simply becomes very hard to control as FPS goes down. Not sure what the pre-render limit has to do with it, though, but tweaking it definitely made the problem less severe on my old computer.

Share this post


Link to post
Share on other sites
Yes.

The "immune"-thing was no direct offense, no.

Alright fair enough, it seemed like it was directed at me, no worries.:)

I'm just here to trying to help people with this and other problems because I feel I owe it to this community for helping me when I needed it.

I'm sorry you have mouse lag problems, honest I am. I don't, but I am trying to narrow down the cause in hopes of eliminating it. Maybe it is game related or it could possibly be a combination of both hardware/software? That's why I've asked dumb questions and added ways to try and combat the problem.

It's too bad some of my suggestions didn't work for you, hopefully they have for others though.

I guess we won't really know what the exact cause of the problem is unless the developers chime in with their thoughts on the matter.

Share this post


Link to post
Share on other sites

I know what you mean about the mouselag, but I dont ruin the game for me, there are worse issues than this. I tend to have the lag when my weapon is lowered. As soon as I aim down the sights its smoothe and responsive.

The mouse exceleration with vehicals though is a major problem, and using the keys causes oversteer. X-Box controller works fine i hear, so mayb thats a solution. I ahev a theory that this build of Arma is really a plannned X-Box version on the PC first. With most console crossover games, there can often be a mouselag problem, due to the development to optomise for a games controller. Deadspace is probably the worst offender here.

Share this post


Link to post
Share on other sites

hi

can any of you help,i have problem mouse steady,what is fps 100,how can i turn smoothing ffps to 30fps,i never had this problem other games like call of duty world at war,other games.

thanks:mad:

Share this post


Link to post
Share on other sites

I wouldn't expect keyboard/mouse driving to be effective. BIS are probably pretty helpless here, as good driving almost requires an analog input. Just think about how you'd like your car IRL to behave if you tried driving it with a mouse and keyboard. There's no real solution here unfortunately :(

As for the mouselag, can anyone else confirm my observations?

Share this post


Link to post
Share on other sites

Everybody I know that plays online games always disables mouse acceleration. Google accelfix, that completely disables mouse acceleration in windows. Seems Arma2 still has acceleration though, on my system at least. Very annoying, feels like my mouse is constantly drifting and whats worse the crosshair slows down when passing a tree or any object that isn't terrain. very off putting as a gamer

Share this post


Link to post
Share on other sites

I figured I would bump this because I'm having the exact same mouse lag problems, and others on the gaming forum I visit are too.

My specs:

Intel E6750

Nvidia 8800GT

4gb ram

SB Audigy

MS Intellimouse Optical

Like others have said before me, lag gets better when FPS goes *very* high like over 80 or 90 fps, but when you go to 50fps or lower it starts to get unplayable. I have tried all of the possible "fixes" (forcing vsync off, prerendered frames, etc.), none of that makes any difference.

This is literally blocking me from buying this game, because it's just too frustrating to play. There obviously has to be some common ground here between all these users that have this input lag.

One other game I've played that had a completely unfixable mouse lag just like Arma/Arma 2 was Far Cry 2. Anyone else with the lag problems in Arma every try playing that game?

Share this post


Link to post
Share on other sites

....

hello. Like most people here i think the mouse lag is ruinning the game.
+1

btw. I've had mouse lag in ArmA1 but in FarCry2 not at all. Have not tried ArmA2 yet, but if the lag still exists I'm not buying the game.

Edited by funkee

Share this post


Link to post
Share on other sites

I dont want to bitch or saying that your guys problem doesnt exist.

But in the video

i dont see any mouselag.....For me its exactly the same and that feels normal to me,......

Are you guys talking about the gun moving first and then the actual screen? Cause its indeed always been like that, and thats a feature i think.

Even so, i hope you guys get a solution for your problem

Share this post


Link to post
Share on other sites
I dont want to bitch or saying that your guys problem doesnt exist.

But in the video

i dont see any mouselag.....For me its exactly the same and that feels normal to me,......

Are you guys talking about the gun moving first and then the actual screen? Cause its indeed always been like that, and thats a feature i think.

Even so, i hope you guys get a solution for your problem

Watch the guys hand on the bottom and you will really notice the lag.

I'm having the same problem in Windows 7 RC although not to the extent of the guy in the video.

Share this post


Link to post
Share on other sites

I believe i watched it 5 times now, as soon as he moves his hand, the gun moves....the screen moves later.

either im blind, or im used to it..

*edit* with the left right movement i really dont see any lag, i watched it 5 times in a row. In the up down movement i might see a tiny microsecond of lag

Edited by Phr34k

Share this post


Link to post
Share on other sites
I dont want to bitch or saying that your guys problem doesnt exist.

But in the video

i dont see any mouselag.....For me its exactly the same and that feels normal to me,......

Are you guys talking about the gun moving first and then the actual screen? Cause its indeed always been like that, and thats a feature i think.

Even so, i hope you guys get a solution for your problem

No, it's NOT just the way the gun site moves. Come on, we're not stupid. BTW, in that video, I don't see much input lag compared to what I've been getting.

Share this post


Link to post
Share on other sites

This video shows the problem a lot better and this is more like how my input lag gets when FPS drops below 50:

Share this post


Link to post
Share on other sites
No, it's NOT just the way the gun site moves. Come on, we're not stupid. BTW, in that video, I don't see much input lag compared to what I've been getting.

Where did i say you where stupid, i friendly tried to make over my point.

That video does not clearly show the problem to me, if that video shows the issue, then i have it aswell, as its exactly the same for me.

The difference being i dont feel the game is "unplayable" because of it.

HOWEVER

Indeed shows it MUCH better, and i do not have that problem and indeed looks like a serious bug.

I hope for you guys this gets solved.

Share this post


Link to post
Share on other sites

I just popped here to comment that I had the same mouse lag problem (Mouse lags and the lag gets worse as you tweak the graphics settings higher and vice versa) I have had this same problem with Crysis and Stalker.

For some time I've suspected that my bluetooth was to blame and when I finally got my hands on ArmA 2 and being crippled with this same problem, I just went and bought myself sidewinder x8 mouse to bypass the bluetooth link.

I just tried the mouse and there seems to be no mouse lag at any gfx settings so it worked for me.

Ive read that some of you have mouse lag problems without bluetooth keyboard/mouse so there is probably more causes than 1, but some of you might benefit from not using bluetooth mouse.

I'm off to finally start the first campaign mission, good times!

Share this post


Link to post
Share on other sites

Hmm, that is interesting Poodle. I had the same problems with Crysis too.

My motherboard has PS2 ports, I may try borrowing a PS2 kb and mouse set from someone and seeing what changes, if any, that makes.

Share this post


Link to post
Share on other sites

Now that Ive tested it more I still have a slight delay, could be somekind of inertia modelling as it stays the same regardless of gfx settings... it increases slightly between low-very high settings. Nevertheless, the game is now much improved for me. Still it isn't Red Orchestra type of control, still slightly floaty.

Share this post


Link to post
Share on other sites

Like I said, it seems like they made some reasonable inertia modeling (small enough that you don't really notice it unless you make some unrealistically rapid movements), however when your performance takes a hit that inertia model becomes extremely excessive and unplayable. The last video shows this great.

Share this post


Link to post
Share on other sites

to everyone with MOUSE LAG issue!!!

first time I launched ArmA2 demo (nvidia display driver v.185.85) I got nasty mouse lag like in ArmA1. then I reinstalled nvidia driver to the nevest one (186.18), disabled "enhance mouse cursor" option in windows control panel: click! and the game runs pretty smooth now! I'm getting 45-52 fps in training mission (where it starts) on erverything (except posteffects and antialiasing) set to very high and mouse lag is gone! :D

my system specs: E8400@4GHz, GF 8800 GTS 512, 2 GB RAM

Edited by funkee

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×