Jump to content
Sign in to follow this  
icebreakr

Island Panthera (ArmA 2)

Recommended Posts

I'm planning to release map Panthera for ArmA for the new engine (Arma2) as soon as the official tools are available. But you can play the A1 version in A2 too if you follow these instructions:

p.s. moderators please move this to A2-Complete.

Here are instructions how to make Panthera v1.1 work in ArmA 2:

(note: you need files of original first ArmA)

1. Create folder @A1 in main game folder and another one inside named addons

2. Move next files to addons from ArmA1/Addons:

Buildings.pbo

Plants.pbo

Roads.pbo

Misc.pbo

Rocks.pbo

3. Unpack Island Panthera v1.1 files and move all three .pbo files to the same addons folder.

4. Run simulation with parameter -mod=@A1

panthera_arma2.jpg

panthera_su25.jpg

Voila, map can be found under Single Player - Editor for a quick test. Let me know how it feels.

Know issues:

- I'm getting "Device Freed error" when alt-tabbing or using preview button in Editor (sometimes). Dunno what causes this yet...

Edited by IceBreakr

Share this post


Link to post
Share on other sites

I understand your wishes and feelings. IMO its the right thing to do, now that ArmA1 is dieing.

Good luck! ;)

Share this post


Link to post
Share on other sites

OFPIP will be out very soon. :)

Basically you only need to remap the cfgWorld class to Utes or Chernarus.

A1 objects will be available as part of OAC soon (standalone releases).

For the start you can just put plants.pbo, rocks.pbo etc from A1 into A2 addons folders.

Share this post


Link to post
Share on other sites

Thank you kju. I'll release A1 version soon and then we'll figure out how to do this.

Share this post


Link to post
Share on other sites

I'm still waiting for patch v1.03 to unwrap my A2...

buda_arma2.jpg

... did anyone manage to put Panthera in A2 by adding A1 pbos, can he post a screenshot or two?

Share this post


Link to post
Share on other sites

Why are you waiting ? There is not much wrong with 1.02.

You might as well wait for patch 1.12 if you everything sorted !

Share this post


Link to post
Share on other sites

I own Morphicon german version with 1.02.... :) but your right, I'll reinstall 505 today and try to put Panthera v1.1 to A2.

Share this post


Link to post
Share on other sites

That map looks wicked. I'm glad to hear A2 will get it.

Fire up v1.02. Honestly, it's not anywhere near as bad as the rap it's received. It must like my system so it runs very well. So did v1.01 to be honest.

Share this post


Link to post
Share on other sites

Hi IceBreakr,

I managed to get Panthera working with Arma2 a few weeks ago, I'm using the addons from that CAA1 project that also lets you use Sahrani and a lot of the other custom community built islands from ArmA1 - the ones that need the ArmA1 objects 'etc'. Much better than just trying to copy my ArmA files into my Arma2 mod folders.

panthera1.jpg

The only problem is that it tends to crash sometimes with the 'device freed' error message when you switch between the editor and the game itself, grass tends to grow out of the runways and the AI aircraft can't cope with the steep mountains, but apart from that everything seems to be working fine.

The only thing I needed to do to make it work was add another config file to enable it with CAA1. I can send this across to you sometime if needed?

Regards,

-- Archangel

Edited by [SEN]Archangel
Typos & Clarification

Share this post


Link to post
Share on other sites

Ok, moderators please move this to Complete.

Here are instructions how to make Panthera v1.1 work in ArmA 2:

(note: you need files of original first ArmA)

1. Create folder @A1 in main game folder and another one inside named addons

2. Move next files to addons from ArmA1/Addons:

Buildings.pbo

Plants.pbo

Roads.pbo

Misc.pbo

Rocks.pbo

3. Unpack Island Panthera v1.1 files and move all three .pbo files to the same addons folder.

4. Run simulation with parameter -mod=@A1

panthera_arma2.jpg

panthera_su25.jpg

Voila, map can be found under Single Player - Editor for a quick test. Let me know how it feels.

---------- Post added at 02:50 PM ---------- Previous post was at 02:25 PM ----------

Archangel: tnx, please send me the file via PM.

I'm getting Device Freed error myself, too. Dunno what causes this yet...

Edited by IceBreakr

Share this post


Link to post
Share on other sites
3. Rename all new files to CA*.pbo, so you'll have CABuildings.pbo, CAPlants.pbo etc.

Why would you rename the pbo's?

Share this post


Link to post
Share on other sites

kju: is it out yet, I can't seem to find the download link? :o

Share this post


Link to post
Share on other sites

Go to the wiki and read:

# How to download releases (YAS or HTTP download available)

# Port your ArmA island to ArmA II

Share this post


Link to post
Share on other sites

I still hope you're working on a clean way to make this island for Arma2. I really don't like this idea of melting arma1 and 2 addons. And even if I do, I don't have Arma1 :p

Share this post


Link to post
Share on other sites
Go to the wiki and read:

# How to download releases (YAS or HTTP download available)

# Port your ArmA island to ArmA II

KJU: Will there be a release in the future with one big download and all the files zipped in a correct directory structure? At the moment installing it is very error prone because of all the download, I really don't feel like installing a fourth party program just to install addons.

Share this post


Link to post
Share on other sites

Yes. For the official release there will be an install and torrent download.

The more people test and join the project helping out coding, the faster it will be ready. :)

Share this post


Link to post
Share on other sites

If anyone knows what causes "Error: Device freed" when alt-tabbing to engine or using preview button in editor (occurs only sometimes) please let me know.

Share this post


Link to post
Share on other sites

Where am I getting these files from? I dont have arma 1 installed??

from ArmA1/Addons:

Buildings.pbo

Plants.pbo

Roads.pbo

Misc.pbo

Rocks.pbo

Share this post


Link to post
Share on other sites

Files are over than a gig and of course, they are from Arma I.

Share this post


Link to post
Share on other sites

Ok thanks was able to get them without having to reinstall the game

Edited by Breeze

Share this post


Link to post
Share on other sites

Is there any interest to see Panthera v2.0 remade for ArmA II? I'm still waiting on official info what causes "Error: Device freed" on alt-tab, I even tried recompiling with new A2 tools, same prob.

f35_panthera.jpg

V2.0 would have all A1 objects (files: buildings, misc, roads, plants, rocks) replaced by A2, but I'm affraid that would be too much work, even with replace object option? I'm using v1.03 and I would really not spend numerous hours on a map that would CTD all the time.

Share this post


Link to post
Share on other sites

Did you convert all textures with the new texview?

Did you binarize the rvmat and wrp with the new binarize?

I am just starting to test this with CAA1.

Another test might be to remove all objects and see if it crashes.

It would be very sad not to see the great piece in a2. :)

Share this post


Link to post
Share on other sites

kju: yeah, tested everything out.

These are only errors from log not connected to BIS stuff:

Convert world p:\ib\panthera\panthera.wrp -> p:\temp\2000a\ib\panthera\panthera.wrp

<world = "p:\ib\panthera\panthera.wrp">

ReportStack: ib\ib_plants\ib_grass.p3d///ca\plants\data\clutter_trava_dlouha1.rvmat

Unknown flag AlphaInstancing

Error: Clutter ib\ib_plants\ib_grass.p3d uses alpha blending - use renderflag AlphaTest instead

ReportStack: ib\ib_plants\ib_grass_long.p3d///ca\plants\data\clutter_grass_long.rvmat

Unknown flag AlphaInstancing

Clutter ca\plants\clutter_grass_sevenbaeuty.p3d uses alpha blending in some LOD - use renderflag AlphaTest instead

Clutter ca\plants\clutter_grass_yellow.p3d uses alpha blending in some LOD - use renderflag AlphaTest instead

Clutter ib\ib_plants\ib_grass_desert.p3d uses alpha blending in some LOD - use renderflag AlphaTest instead

Error: Clutter ib\ib_plants\ib_grass.p3d uses alpha blending - use renderflag AlphaTest instead

</world>

Even with all the objects removed from the map the error is present. I think its connected somehow to old clutter or main config file.

Edited by IceBreakr

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×