Jump to content
Sign in to follow this  
gonza

HALO, how to add it ?

Recommended Posts

how can I add Halo in my mission

Share this post


Link to post
Share on other sites

Write this in a trigger

Name_of_Aircraft lock false;

Name_of_Player action [ "eject", BIS_MV22];

Name_of_Player setvelocity [0,0,0];

[Name_of_Player] exec "ca\air2\halo\data\Scripts\HALO_getout.sqs";

Regards Intruder

Share this post


Link to post
Share on other sites
Write this in a trigger

Regards Intruder

all you need is > [this] exec "ca\air2\halo\data\Scripts\HALO_getout.sqs" < in each units inits unless you wanna force the Eject then u need a Para jump script :)

Share this post


Link to post
Share on other sites

Yes, it does work great! However, is there a way to make it so you can HALO after you respawn. Using the method Junker posted works great initially, but if you respawn and want to HALO or HAHO again, it doesn't work. Any help is appreciated.

Thanks,

Monty

Share this post


Link to post
Share on other sites

it don't work for me because I don't want to use after ejecting a plane but after a setpos at 2000 meter

Share this post


Link to post
Share on other sites
Yes, it does work great! However, is there a way to make it so you can HALO after you respawn. Using the method Junker posted works great initially, but if you respawn and want to HALO or HAHO again, it doesn't work. Any help is appreciated.

Thanks,

Monty

Try it this way, create a init.sqf in the mission folder which contains this:

[] execVM "bla.sqf";

And put this into the bla.sqf

while {true} do {

waitUntil {!alive player};

_p = player;

waitUntil {alive player};

_p = player;

_p exec "ca\air2\halo\data\Scripts\HALO_getout.sqs";

};

Share this post


Link to post
Share on other sites
it don't work for me because I don't want to use after ejecting a plane but after a setpos at 2000 meter

found

after a setpos you must use

[player] exec "ca\air2\halo\data\Scripts\HALO.sqs";

:yay:

Share this post


Link to post
Share on other sites

Using the above method, doesnt allow you to control the direction of your descent before opening you chute. Is there anyway of getting full HALO control using the setpos?

Share this post


Link to post
Share on other sites
Try it this way, create a init.sqf in the mission folder which contains this:

[] execVM "bla.sqf";

And put this into the bla.sqf

while {true} do {

waitUntil {!alive player};

_p = player;

waitUntil {alive player};

_p = player;

_p exec "ca\air2\halo\data\Scripts\HALO_getout.sqs";

};

Something not right here. It's not working after respawning. Any ideas on what might be wrong?

Share this post


Link to post
Share on other sites

I've also got that one problem with it:

After setting position at a 1000 meters and engaging in HALO, i can't steer the direction i'm going during the jump.

That means i land waaaay off target and have to trek several kilometres to the actual objective.

Also, this problem might be just on my side, but after opening the chute my camera bounces all over the place.

---------- Post added at 05:41 PM ---------- Previous post was at 04:07 PM ----------

Some further experimentation shows me that it is not the camera shaking around so badly, but the player itself.

If i am in first person or third person mode the camera shakes horribly, but when i use the command camera it is fine, and i can see that the parachute itself is shaking around so badly.

Share this post


Link to post
Share on other sites

try this code work's for AI too ;)

but this in the init line of the unit

this setpos [getpos this select 0, getpos this select 1,(getpos this select 2) +1000];

this flyinheight 1000;

this setvelocity [0,0,0];

[this] exec "ca\air2\halo\data\Scripts\HALO_init.sqs";

Share this post


Link to post
Share on other sites
I've also got that one problem with it:

After setting position at a 1000 meters and engaging in HALO, i can't steer the direction i'm going during the jump.

That means i land waaaay off target and have to trek several kilometres to the actual objective.

Also, this problem might be just on my side, but after opening the chute my camera bounces all over the place.

---------- Post added at 05:41 PM ---------- Previous post was at 04:07 PM ----------

Some further experimentation shows me that it is not the camera shaking around so badly, but the player itself.

If i am in first person or third person mode the camera shakes horribly, but when i use the command camera it is fine, and i can see that the parachute itself is shaking around so badly.

Ditto, it's seriously annoying.

Eth

Share this post


Link to post
Share on other sites

Can anyone help me with this issue... even if an AI unit is executing the script, my screen temporarily blacks out when the script is triggered, as if I'm the one doing the HALO jump (this is when using HALO_getout.sqs).

Share this post


Link to post
Share on other sites
Can anyone help me with this issue... even if an AI unit is executing the script, my screen temporarily blacks out when the script is triggered, as if I'm the one doing the HALO jump (this is when using HALO_getout.sqs).

yea i ve got same problem

Share this post


Link to post
Share on other sites

As per the camera shaking problem mentioned above, does anybody have a fix or answer as to why the camera goes spaz once the parachute is opened?

Share this post


Link to post
Share on other sites

Got the same problem too. Can't check right now, but does this occur if you start the unit in a heli, then force eject?

Share this post


Link to post
Share on other sites

Perhaps, but it seems fine until I select open parachute, then it just goes spastic. I'll experiment more when I can and if I have any success will let you know :)

Share this post


Link to post
Share on other sites

I tried it out of a chopper, still the same effect. I'm going to tear up some other missions that use a HALO drop... see what I can find.

Share this post


Link to post
Share on other sites

Yeah I haven't had much luck with it yet, but have not had much of chance to work on it much either :P

Currently my guy ejects from a moving plane, does his freefall, and once I activate the open chute, it flicks about like crazy.

I used the teleport/halo jump in Domination whilst playing online I believe, and I think I did notice some minor flicker on my second jump, but nowhere near as crazy as I'm seeing it during what I have scripted.

I have considered adding some velocity to the setVelocity part of the code to try and make it match the vehicle I am exiting, but I am no programmer, so it will definately take some time for me to work out. Although considering that the freefall part of the jump works fine, I don't think it is a velocity issue.

Share this post


Link to post
Share on other sites

Thanks for the scripts guys it works great and its awesome most of the time....BUT,

I have 2 problems problems so I cant use:

1) Random deaths at ejection point.

(Not sure if my setvelocity has anything to do with this: 0,0,0) I even tried to have the c130 clmb slightly...still the often death at ejection for some players.

2) Also, a random case where a teammate landed on a hill and couldnt leave the parachute. This I could probably live with..maybe he twisted his ankle..ha

Any help or ideas would be appreciated, it is awesome when it works.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×