Jump to content
Sign in to follow this  
gonza

HALO, how to add it ?

Recommended Posts

2) Also, a random case where a teammate landed on a hill and couldnt leave the parachute. This I could probably live with..maybe he twisted his ankle..ha

This seems to be universal for HALO drops, I did it just last night on Domination, moments before being shredded by a Tunguska. Steep hills seem to cause this.

Share this post


Link to post
Share on other sites

Well I've narrowed the crazy chute problem to the sleep 0.001 in the parachute_init file. 0.001 is the smoothest it gets unfortunately. I cannot think of way to fix it's stuttering. I also noticed that during the parachute tutorial it slightly stutters :(

Share this post


Link to post
Share on other sites

With what I am doing, yes sometimes. I thought it was because of the fact my guy launched up a bit when ejecting (so helicopter propellor got him) or perhaps the wings clip me when moving fast. But yes, deaths do occur, though rare.

Share this post


Link to post
Share on other sites

Alright I'm stumped on this one. I've been making a mission that starts with a HALO insertion for myself as group leader and the other 3 AI members of my team. Well I've been testing the mission in the editor this morning and simply moving enemies around for better effect. I haven't added anything to the mission. The first 3 times I jumped this morning HALO worked perfectly, and it's worked for 3 days since I added to the mission. But now my player can not move while in the air anymore until after I open the chute. I seem to get stuck facing north and the movement keys barely work. I can slow all the way down to 0 but I can barely move my positioning left or right. Every time I hit the A or D key all I get is a jerking, slight movement. By the time I get turned 180 degrees to the original direction I was facing when I jumped I'm already splattered on the ground. I can steer the chute when it's deployed but can't move prior.

I'm absolutely stumped. Again, I didn't change a thing except the placement of a few things. I've tried restarting the game and computer but nothing helps fix the issue.

Can someone provide some insight or PM me if you'd being willing to check out the issue for yourself. The mission isn't complicated at all and getting close to a beta state. It won't be to difficult to check out how I got it set up.

I'd appreciate the help.

Share this post


Link to post
Share on other sites

Try making your mouse sensitivity higher and turning using your mouse? I have my mouse at max sensitivity (G5) and it takes a bit to turn, but it does turn.

Share this post


Link to post
Share on other sites

Let me ask this...

I am trying to insert my unit by Airborne drop. I want to addAction to my player in order to control when the unit disembarks the plane.

I tried adding this in the "init.sqf"

player addAction ["JUMP", "jump.sqf"];

no action is added until after I "Eject" from plane???

- how can I add an action at game start to the players action menu so they can control when the unit "jumps" out of plane?

- also what will I use in the sqf.script that will tell every member of the unit to "jump" when I use the added action?

Share this post


Link to post
Share on other sites

So all I want is a script that allows a player to HALO jump multiple times, after respawning. No AI involved. Could someone please post that script or help me find it? Thanks

Share this post


Link to post
Share on other sites

You could look at and use Norrin's revive script which includes a Helicopter respawn point which allows you to jump out and Halo (fall to ground) / parachute. It does not have the proper Halo animation if I remember correctly

Share this post


Link to post
Share on other sites

I know this is quite off-topic but. Do you have sounds while "flying" after ejection from a plane ? The rendering of the HALO is quite good but I was wondering if it was some conflicts due to sound mods or if it doesn't have sound from the very beginning. It seems to have only ambient sound on a ground, ok... why not. But what about the wind ? I mean we are falling from the sky at crazy speed, and it's dead silent ?o_o. Sounds too wrong.

Share this post


Link to post
Share on other sites

Welcome back ! I'm trying to make a mission with HALO but I have a huge probleme... Halo is running really slowly when there is even only few things in the editor. I observed that scripts are having trouble to launch and work well. I tried also the UAV module in a large scale HQ on Utes ( with many waypoints everywhere , 2-3 others module ). And it's a pain in the ass. Even Halo can't be played whell. It's like the game is slowed down because of ressources but it isn't... It's running smooth and I don't have any FPS losses. Only scripts that are slowing. Is there a way to avoid this ?

Thanks

Share this post


Link to post
Share on other sites

Thanks for the help so far everybody, been reading all the threads I can find on HALO and got it to work up to a point. That is to say I have a 4 man team (each individually named), player as the leader with

{_x moveInCargo c1} foreach units this;

in his init line. I have a chopper c1, flying at 500 plus, with waypoints and a trigger, Blufor present, with

TL action [ "eject", c1]; TL setvelocity [0,0,0]; [TL] exec "ca\air2\halo\data\Scripts\HALO_getout.sqs"; DS action [ "eject", c1]; DS setvelocity [0,0,0]; [DS] exec "ca\air2\halo\data\Scripts\HALO_getout.sqs"; AR action [ "eject", c1]; AR setvelocity [0,0,0]; [AR] exec "ca\air2\halo\data\Scripts\HALO_getout.sqs"; AG action [ "eject", c1]; AG setvelocity [0,0,0]; [AG] exec "ca\air2\halo\data\Scripts\HALO_getout.sqs";

so all works good enough....But the AI's seem to drop almost vertically down, even landing behind the position of the trigger whereas I am moving forward with the natural velocity of jumping from an aircraft, as you would expect, so that we land a Km or more away from each other. Unless I turn and head towards them. Is there anyway to mark the landing zone for the AI's to head for while parachuting. So that I can keep the team together and accurately land at a precise spot and not get separated in the Drop.

Share this post


Link to post
Share on other sites
try this code work's for AI too ;)

this setpos [getpos this select 0, getpos this select 1,(getpos this select 2) +1000];

this flyinheight 1000;

this setvelocity [0,0,0];

[this] exec "ca\air2\halo\data\Scripts\HALO_init.sqs";

but this in the init line of the unit

This works, but thanks to BlackAlpha's help in another thread...this works even better:

[this, 1950] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"

where the 1950 in the above code is the units starting altitude. No need for setpos any more. Units will start out already in freefall, so if you want to skip the jumping part and just start with the falling part.

Share this post


Link to post
Share on other sites

I have HALO working as well as advertised, but the main problem is that the halo script will always make me face north. I want to point at a dynamic marker so I tried

[u1, 2000] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"
[u2, 1800] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"
[u3, 1850] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"
[u4, 1875] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"
[u5, 1900] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"
[u6, 1950] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"
[u7, 1975] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"
[u8, 2050] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"
_lzpos = getMarkerPos "lz";
_dropDirection = (position player select 0) - (_lzpos select 0) atan2 (position player select 1) - (_lzpos select 1);
player setdir _dropDirection;

but still I always point north. I doublechecked all names and they are correct

Share this post


Link to post
Share on other sites

Yeah, it is the default parachute you get when you call "ca\air2\halo\data\Scripts\HALO_getout.sqs".

Last time I used it though it was buggy (camera glitches and is very annoying), but it works.

Share this post


Link to post
Share on other sites

This also works:

[this, 1950] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"

Which I thought might restore the sound effects you are supposed to be hearing while falling (i.e. BIS_HALO_Flapping and BIS_Steerable_Parachute_Opening), but in neither case do I hear these sounds during the jump.

I also went back to boot camp and played the parachute training mission again and heard no additional sounds there either, other than the chopper fading away after ejection and then the environment sounds when I am quite close to the ground.

Is the sound bugged?

---------- Post added at 02:34 AM ---------- Previous post was at 02:24 AM ----------

edit:

I think I found the problem by peeking in the config.bin. CfgSounds contains these sounds which call the following files: "\ca\air2\halo\data\flapping.ogg" and "\ca\air2\halo\data\parachute_opening.ogg", neither of which are located there. Did BIS forget to add them?

---------- Post added at 02:54 AM ---------- Previous post was at 02:34 AM ----------

edit 2:

Yep, they forgot them. Put some test sounds into air2.pbo with the file names and location called and replayed the parachute training mission. Now I can hear sounds related to the jump.

I wonder if this has been added to the bug list on the A2 Community Issue Tracker.

---------- Post added at 03:15 AM ---------- Previous post was at 02:54 AM ----------

edit 3: Couldn't find anything on the tracker so added a new issue.

Edited by KaBoNG

Share this post


Link to post
Share on other sites

Edit 4:

I have fudged in some sounds to replace the missing ones. Freefall sounds preety cool but it walks on the chute opening sound - don't know how to fix this but I'm sure it's doable. I think it would be better to have a third sound that plays when "flying" the parachute (light wind sounds, quiet fabric flapping, possibly unit breathing too). Have added this to the tracker (#3780, btw).

Share this post


Link to post
Share on other sites

Camera glitchyness on steerable parachute seems to be fixed on patch 1.03. Still slightly there but nowhere near as bad and very useable now.

Share this post


Link to post
Share on other sites

Heya, my AI team just fall to the ground with this;

this setpos [(getpos this select 0), (getpos this select 1), 1000]; [this] exec "ca\air2\halo\data\Scripts\HALO.sqs";

How can I get them to open their chutes?

Share this post


Link to post
Share on other sites
Heya, my AI team just fall to the ground with this;

this setpos [(getpos this select 0), (getpos this select 1), 1000]; [this] exec "ca\air2\halo\data\Scripts\HALO.sqs";

How can I get them to open their chutes?

use this code:

[this, 1000] exec "ca\air2\halo\data\Scripts\HALO_init.sqs"

what you wrote calls halo.sqs, you need to call halo_init.sqs

Share this post


Link to post
Share on other sites

in the init i ve got this:

this addaction ["HALO Insert","script\halojump1.sqs"];

in multiplayer coop, when the plane has been destroyed then respawned "HALO Insert" command is not available anymore in the menu. i think it's a problem with respawn script.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×