Jump to content
Sign in to follow this  
Desert

ArmA2 8GB RAM Problem

Recommended Posts

It seems that ArmA2 have the same/a similar Problem with 8GB RAM. I have some major Textureproblems with 8GB RAM (Gras is black, Trees are big Blocks and so on, Buildings are totally messed up), it looks normally only in a 640x480 Resolution. When i`m limit my System to 3328MB RAM ArmA2 works fine in 1680x1050.

P.S.: Sorry for my bad english, i hope you understand what i mean. I`m trying to do some Screenshots later because the "print" key doesnt work.

Share this post


Link to post
Share on other sites

I don't think so. I have Vista x64 and 9 GB RAM on a i7-920 overcloccked at 3.4 GHz and it is running perfectly fine with no such efefcts that you observe.

Michael

Share this post


Link to post
Share on other sites

Here are some Screens:

with 8GB:

arma28gb.th.jpg

with 4GB:

arma24gb.th.jpg

We have here on the armed-assault.de Forums a few People with the same Problem, different Systems (Vista/XP/32/64bit/SP1/SP2) and GFX Cards but all with 8GB RAM.

Edit:

These are my System Specs:

Asus P5Q Board

Intel Q9300 @2,5GHz

8GB RAM

HD 4870 1GB

Vista 64bit SP2

Edit2:

When I launch ArmA2 with the 640x480 Resolution, the Textures shows normal. If i switch now to the native Resolution of my TFT (1680x1050) the Textures are still normal an they stay normal till i stop playing.

Edited by Desert

Share this post


Link to post
Share on other sites

Hi Guys,

same problem here...

Intel Q9550

8 GB RAM

1 GB Radeon 4870

Vista 64

black boxes everywhere and even in lowest setting, no more than 20fps...

suggest they will fix it in a patch coming soon....

regards

Share this post


Link to post
Share on other sites

Yes, like in the old ArmA 1 days mostly with ATI cards, after cutting 4gb with msconfig, the problem was gone, and the perfomance was really nice, all settings cranked up to max with 10km viewdistance and runs now great.

vista x64

Q9300 2.5GHz

8gb ram

4870 1gb

Share this post


Link to post
Share on other sites

Do problem exist in -window mode?

Is it possible that it's problem of 1GB videocard memory not the 8GB of DDRAM?

Share this post


Link to post
Share on other sites

hey schuubars,

which catalyst version do you have and in which resolution do you play?

i have 9.3 and can only play in 1440x900 to get good performance. 1920x1200 is too sluggish...

br

Share this post


Link to post
Share on other sites

I think it's just a problem in conjunction with 8gb and ati card(driver), well either Bohemia has to fix it or ATi, but i remember that some NV users had the same problems just not as many as ATi users.

Edit: @slimSpencer cata 9.5, and 1680x1050, but without AA, and cata A.I. deactivated.

Edited by schuubars

Share this post


Link to post
Share on other sites

I know 2 Guys with Nvidia Cards with the same Problem (1x8800GT, 1x285GTX).

Share this post


Link to post
Share on other sites

There are problems with 8GB Vista 64bit and ATI drivers go over to the AMD game forums and check it out

But I am pretty sure they fixed this problem, it wasn't just limited to one game

Maybe they didn't test for 8GB ram, so limit the amount of RAM it can use like the other guy said 3GB should be plenty for the game alone lol, although it should get fixed if it is a problem, not nice to buy 8GB and not use it properly

Share this post


Link to post
Share on other sites
Yes, like in the old ArmA 1 days mostly with ATI cards, after cutting 4gb with msconfig, the problem was gone, and the perfomance was really nice, all settings cranked up to max with 10km viewdistance and runs now great.

vista x64

Q9300 2.5GHz

8gb ram

4870 1gb

What is your Fillrate Optimizer set to? (In advanced graphic options)

Share this post


Link to post
Share on other sites

Usually 100% but 150 worked too.

What is your Fillrate Optimizer set to? (In advanced graphic options)

Share this post


Link to post
Share on other sites

This happens to me to. Vista X64, 4gb Ram and GTX 280 with latest 185.85 driver.

Looks like a memory leak to me as it crashes in the end with "not enough memory" error.

Share this post


Link to post
Share on other sites

i had this issue on my rig for arma 1, the beta fixed it, but then i kept getting blue screens after ATI driver change (yes i removed old ones before installing new ones) and in end game was unplayable unless i done msconfig and used 3gb of RAM. any how after constant blue screens, i got in touch with the company that made my rig and they sent me another 3 different brand cards (4870X2). all failed. ATI's advice to them to pass on was fresh vista install, making sure ATI driver was 1st to be installed, no good. so to fix it, i got a 295 GTX and aint looked back. the main reason for this, althought happens to limited n vidia users is ATI drivers being poor. i went thru weeks and weeks of crap cos of it. im currently running the last but nvidia driver, 8.3 or wot ever, as the newest 1 screwed my comp up an i couldnt b arsed with wasting time, however i have removed arma from my system totally cos it went nuts when i tried installing invasion 44 mod, so time will tell if i get the same issue again with arma 2, but i had a friend in US with a brand new alien ware pc, I7, x58 board with 12GB of ram and he had no issues at all.

Share this post


Link to post
Share on other sites

I had the same problem. In my case I realized that Arma2 kept detecting 128MB of video ram(I also have 8GB of RAM). Check arma2.cfg - localVRAM=128974848;nonlocalVRAM=128974848;. Also in game I was unable to increase texture details from normal quality. Manual change of values didn't help.

solution - I removed nvidia 185.85 driver, rebooted a installed older beta driver, rewrited values to 780MB of localVRAM and 2GB of nonlocalVRAM. Everything fixed ;)

on Vista buss 64-bit

Share this post


Link to post
Share on other sites

Nice finds GhostX.

All fine here on Win7 x64, i7 3.2, GTX 280, 6 GB ram, 2560x1600. Using latest drivers.

Share this post


Link to post
Share on other sites
I had the same problem. In my case I realized that Arma2 kept detecting 128MB of video ram(I also have 8GB of RAM). Check arma2.cfg - localVRAM=128974848;nonlocalVRAM=128974848;. Also in game I was unable to increase texture details from normal quality. Manual change of values didn't help.

solution - I removed nvidia 185.85 driver, rebooted a installed older beta driver, rewrited values to 780MB of localVRAM and 2GB of nonlocalVRAM. Everything fixed ;)

on Vista buss 64-bit

I tried this but the VRAM Values on my System seems ok so it did not help. :( I really think we have to wait for a Fix from BiS for this Issue.

Share this post


Link to post
Share on other sites

Doh!!! Please not :(:(

I ordered another 4GB Ram with a HD4890 exclusively for Arma2 and now i read within two days that both devices will cause very bad "bugs" like we had them in Arma1?!?! :rolleyes::(

Is there a ticket about it already? I think this is really important to fix with the next patch!

Share this post


Link to post
Share on other sites
Guest RKSL-Rock
I think it's just a problem in conjunction with 8gb and ati card(driver), well either Bohemia has to fix it or ATi, but i remember that some NV users had the same problems just not as many as ATi users.

Edit: @slimSpencer cata 9.5, and 1680x1050, but without AA, and cata A.I. deactivated.

Actually i get the "black grass" bug when i update to the latest Nvidia drivers. Ive reverted to an earlier build and its all fine. IM getting 30-60fps most of the time.

C2D 8400 @3Ghz

8Gb PC6400

EVGA 8800GT KO 512mb on Forceware 178.24.

Vista Home Premium x64

I upgrade to 185.85 and its black grass and no textures.

Share this post


Link to post
Share on other sites

For your information: All my ArmA 2 development is done on Vista with 8 GB RAM and I periodically switch between nVidia and ATI cards to make sure there are no obvious compatibility issues this time, like they were in ArmA. I think I can therefore say at least the basic compatibility level should be there this time.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×