Jump to content
Sign in to follow this  

Where to find the RPT file in case of CTD?

Recommended Posts

Hi erverybody

In some of my missions I experience CTD after save game. I rebuild one from scratch cause I have the bad habit to copy and paste units to gain time during the mission editing. At first I thought it might have something to do with the fact that I copy units . . . so I rebuild the mission. Still CTD after save game. Does anyone have a clue how to fix this?:mad:

Now I've read on the PMC Tactical Wiki about the RPT file which is created when game CTD. Put where can this file be found it might help me to debug the mission.

Any feedback is appreciated.

Thanks in advance.


p.s. My apologies in case I posted in the wrong section.

Share this post

Link to post
Share on other sites

It's in your arma/profiles folder and can be opened with any text editor.

Share this post

Link to post
Share on other sites

Thanks for the hint hamis.



edit: Today 21.29 hours

I just loaded the mission and it CTD. I went to my Arma/userfolder wich is not located in my BIS folder. I searched everywhere but couldn't find the RPT file. I used my computer search. no RPt file found on my computer. this is really strange. :mad:

Edited by nettrucker
Problem not solved

Share this post

Link to post
Share on other sites

Are you on XP or VISTA?

Share this post

Link to post
Share on other sites

Hi Yoma

I'm actually using only two 3rd party addons which is Lowfly's editor update and the OFPEC anim viewer and that's it. I made former missions without any problems of CTD after save game nonetheless both addons were always in the original addon folder. My game version is up to date to the last official patch released. What bugs me most is that I can't find the damn rpt file after CTD that would gave me some idea what kind of errors are in the missions and maybe I could debug them. I consulted the Wiki, searched everywhere but couldn't find the file on my computer using the searchfunction. In case a rpt file has been created the search function would have revealed it's exact location and path. But it couldn't find a trace.

BTW I'm running on XP. Thanks anyway for your reply.



Share this post

Link to post
Share on other sites

Took me a while to find, but was located by searching globally for *.rpt

Mine was located in C:\Documents and Settings\[user profile]\Local Settings\Application Data\ArmA

My installation is on F: btw

Edit: Im on XP

Share this post

Link to post
Share on other sites

Hi everyone

I finally managed to get the rpt file after CTD. My user mission folder was located in C: documents and settings. It has been placed there automatically after saving my first mission attempt in ArmA. I haven't changed the path settings. Now I placed my ArmA folder in application data and after the usual CTD I was finally able to find the rpt file. Seems that

C:\Documents and Settings\[user profile]\Local Settings\Application Data\ArmA

is the default path where the rpt file is generated at least that's what I suppose.

I read the report but I must admit I'm as clueless as before.

Honestly said there is an Access violation reported but I haven't any idea what is it relating to. Addons listed.

Here is one part of the rpt file related to the mission where I experience constantly CTD's.

I hope that someone's able to understand what is this all about, cause I'm not.

Date: 05/24/09 Time: 18:18:50


Exception code: C0000005 ACCESS_VIOLATION at 005A0482

graphics: D3D9, Device: NVIDIA GeForce 8600 GTS, Driver:nv4_disp.dll

resolution: 1024x768x32


Datsun_armed_DBE1 in CA\DBE1\datsun_armed\

CTI_buildingsBmp2_hq in ca\cti_buildings\bmp2_hq\

CTI_buildingsM113_hq in ca\cti_buildings\m113_hq\, DBE1 in CA\DBE1\

CA_Hotfix in ca\hotfix\, SaraLite in ca\saralite\, Desert in ca\desert\

CAIntroAnims in ca\introanims\

WarfareBuildings_TOW_Tripod in ca\cti_buildings\tow_stat\, CASounds in ca\sounds\

WarfareBuildings_T72_RACS in ca\cti_buildings\t72_racs\, DBE1_UI in CA\DBE1\ui\

Desert2_Buildings in ca\Desert2\build\

CA_Missions_Armory1 in ca\missions\armory1.intro\

CAweapons3_m107 in CA\weapons3\m107\

CAweapons3_m16a4_acg in CA\weapons3\m16a4_acg\, CAWheeled in ca\wheeled\

Desert2_Objects in ca\Desert2\objects\, CA_Missions in ca\missions\

CARoads in ca\roads\, CAWheeled3_TT650 in CA\wheeled3\tt650\, CAAir in ca\air\

CA_Anims in ca\anims\, MK19_Tripod in ca\cti_buildings\mk19_stat\

CAUSMCD in ca\usmcd\, CAAnimals in CA\animals\

CA_desert2_Characters in ca\Desert2\characters\, CAUI in ca\ui\

CAWeapons in ca\weapons\, CAweapons3_m16a4 in CA\weapons3\m16a4\

CAWeapons3_ammocrates in CA\weapons3\ammocrates\, CAAir3_Su34 in CA\air3\su34\

CACharacters in ca\characters\, CA_CutSceneAnims in ca\cutSceneAnims\

DC3_DBE1 in CA\DBE1\dc3\, DBE1_Hotfix in ca\hotfix\dbe1\, CASigns in CA\signs\

CAFonts in ca\UIFonts\, CAweapons3_m16a4_gl in CA\weapons3\m16a4_gl\

CAWeapons3 in CA\weapons3\, CAWheeled3_M1030 in CA\wheeled3\m1030\

CAAir3 in CA\air3\, DSHkM_Mini in ca\cti_buildings\dshkm_stat\

EditorUpdate_v102 in editorupdate_v102\, CAMisc in ca\misc\, CAPlants in CA\plants\

CAVoice in ca\voice\, CAData in ca\

WarfareBuildings_Stinger_Twice_static in ca\cti_buildings\stinger_stat\

CALanguage in ca\language\, CAWater in CA\water\

CAweapons3_aks74pso in CA\weapons3\aks74pso\

CA_Anims_Char in ca\anims\characters\, WarfareBuildings in ca\cti_buildings\

M2HD_Mini in ca\cti_buildings\m2_stat2\, CATracked in ca\tracked\

Warfare in warfare\, CAweapons3_ksvk in CA\weapons3\ksvk\, CAA10 in ca\a10\

Porto in ca\Desert2\, 6G30_DBE1 in CA\DBE1\6g30\, Sara in ca\sara\

CAWheeled3 in CA\wheeled3\, CABuildings in ca\buildings\

Hilux_armed_DBE1 in CA\DBE1\hilux_armed\

CA_Hotfix_vez_ropa in ca\hotfix\vez_ropa\, CARocks in Ca\Rocks\

CAweapons3_m16a4_acg_gl in CA\weapons3\m16a4_acg_gl\

Mods: CA

Distribution: 1294

Version 1.14.5256

Fault address: 005A0482 01:0019F482 C:\Program files\Bohemia Interactive\ArmA\arma.exe

file: DeadlyBusiness

world: saralite

Prev. code bytes: 8B 06 8B CE FF 90 8C 05 00 00 8B 40 24 8B 40 04

Fault code bytes: 8B 98 4C 07 00 00 8D 8E 48 02 00 00 3B 19 74 06


EAX:00000000 EBX:00000000

ECX:0125F458 EDX:0125F464

ESI:13958800 EDI:133E7C00


SS:ESP:0023:0125F474 EBP:0125F484

DS:0023 ES:0023 FS:003B GS:0000



note: Minidump has been generated into the file C:\Documents and Settings\KOS\Impostazioni locali\Dati applicazioni\ArmA\arma.mdmp

Any help is really appreciated. I rebuild the mission several times from scratch with the same result.

I'm using vanilla ArmA. Latest official patch.

Addons: Lowfly's editor upgrade

ofpec anim viewer

For all other addons I'm using mod folders.

One thing I want to mention is that I added in all my missions a save game in the action menu. JFYI. For 80% of all missions I did so far it doesn't represent an issue. But there are 3-4 missions where I continiously experience CTD.

Thanks in advance for any advice.

best regards


p.s. I updated my Video card driver to the latest version availlable

Edited by nettrucker

Share this post

Link to post
Share on other sites

hm can you remove all lines in the rpt. start arma and get the CTD.

then pack the rpt with 7-zip and upload to http://dump.no/

You do not use addons for it right?

Too many groups by chance?

Share this post

Link to post
Share on other sites

Hi kju

sorry for my very late reply, but I'm so damn busy with real life issues that it takes me some time to get back. My sincere apologies. Well I did some extensive testing and I found out that also older missions which had no problem whatsoever, started to CTD. Now since I had everything organized in Mod folders I thought it couldn't be the reason for CTD. The problem was getting worse from day to day and it was exasperating. In the end I opted for a clean and fresh new install of ArmA. I removed all the mod folders and installed ArmA new on my hard drive. For the time being it seems to work, but for being sure I need still some time testing different things:D

Anyway thanks for your support which I really appreciated.

Keep up your outstanding work



Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this