Jump to content
Sign in to follow this  
$able

BattlEye problems

Recommended Posts

well the insult is not nearly as useless as the battle eye....

simply put .... i am still trying to run 1.14 and now i cannot play any public server... even when i set up a dedi server running from my own machine with battle eye disabled. I simply get booted from my own machine after a few minutes of play with a "battle eye could not update" error message.

any other info needed?

Share this post


Link to post
Share on other sites

is the battle eye program required for arma2 multiplayer?

Share this post


Link to post
Share on other sites

Hey all!

I recently upgraded from dial up to DSL, but a problem with my connection just arose concerning Battle Eye.

I tried to join the SL 1.69 server (I tried on a different server with Battle Eye so i'm pretty sure its not the server), and I do the Receiving Data thing, it says "Battle Eye client: Initialized, then in about 33 seconds, it's pretty much the exact same amount of time every time, I get the error message "Kicked by Battle Eye: Client not responding." Happens I believe at almost exactly the same amount of time after it's done receiving data.

But the part I don't get is that before I got DSL, I didn't have this problem while trying to play with dial up (when I didn't get session lost for long load time that is, but that's besides the point). When I managed to get in when I had dial up, it usually let me stay for a long time. Now, with DSL, I get past the receiving data no problem, but this kicked for client not responding is confusing me.

Any help would be greatly appreciated, thanks!

EDIT: I opened my be client file in local setting etc with notepad and here's what it says:

TLOSS error

SING error

DOMAIN error

R6034

An application has made an attempt to load the C runtime library incorrectly.

Please contact the application's support team for more information.

R6033

- Attempt to use MSIL code from this assembly during native code initialization

This indicates a bug in your application. It is most likely the result of calling an MSIL-compiled (/clr) function from a native constructor or from DllMain.

R6032

- not enough space for locale information

R6031

- Attempt to initialize the CRT more than once.

This indicates a bug in your application.

R6030

- CRT not initialized

R6028

- unable to initialize heap

R6027

- not enough space for lowio initialization

R6026

- not enough space for stdio initialization

R6025

- pure virtual function call

R6024

- not enough space for _onexit/atexit table

R6019

- unable to open console device

R6018

- unexpected heap error

R6017

- unexpected multithread lock error

R6016

- not enough space for thread data

This application has requested the Runtime to terminate it in an unusual way.

Please contact the application's support team for more information.

R6009

- not enough space for environment

R6008

- not enough space for arguments

R6002

- floating point support not loaded

Microsoft Visual C++ Runtime Library

... <program name unknown> Runtime Error!

Program:

There's alot more gibberish with symbols and random numbers that I didn't post that probably wouldn't help.

Can anyone make anything of this?

Hope it helps!

Edited by Twan

Share this post


Link to post
Share on other sites

Twan, unfortunately there is not much you can do other than playing on a 1.16 beta server as this issue is related to problems in ArmA's netcode in 1.14.

On a side note, it doesn't help to post the contents of the BE Client file because it's the same for everyone and doesn't contain any information concerning your problem.

Share this post


Link to post
Share on other sites

Oh sorry, and thanks.

But there's a wierd thing with this. I went into local settings and replaced the beclient file with one that somebody linked on the SL forums, and then replaced the beclient and beserver files in arma-->battle eye from program files, and it worked!

BUT! I logged off and tried to reconnect, and it started doing the same thing again. So I re-overwrote the files I mentioned previously, and it worked again.

However, now I can't figure out the exact order I replaced the files in, and can't get it to work anymore.

This is strange? What made it work once when I overwrote the files then just stop working again after I log off?

Share this post


Link to post
Share on other sites

Hello, a friend of mine keeps having "battleye initialization failed" errors while trying to connect to battleye servers with arma2.

I allready read that this might correlate with Battleye not beeing installed.

(It is to mention that we regarded putting the battleye folder into the main arma2 directionary. It is also to mention, that we both run Win 7 64bit)

So first I gave him my Battleye folder (I never had any problems)

- didnt work

Second he tried this tip:

-------------------------------------------------------------------------

"Hi.

Download this:

http://www.battleye.com/downloads/arma2/BEClient.dll

And

http://www.battleye.com/downloads/arma2/BEServer.dll

(Put these files into the BattlEye folder of your ArmA 2 installdirectory) "

-------------------------------------------------------------------------------------

- didnt work

Third he downloaded battleye client version from www.battleye.com which appears to only be a single dll. and put it to the battleye folder

- didnt work

fourth he tried downloading battleye version 1.1 and then updating

- it came a could not connect to... error

next he is trying to reinstall arma2 and patching again.

Well.....why the hell doesnt this work? =/ He currently baught a brand new arma2 version (from england - we are located in germany) and we are afraight that possibly the arma key might be allready banned...

Another friend of mine has the same problem with connecting to battleye servers and its ...let me say...driving me crazy because we had allready a lot of frustrating moments because of that.

I really hope you can help us.

Best wishes

H.K.

Share this post


Link to post
Share on other sites

ArmA Server v1.18 final:

0:01:05 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:01:05 BattlEye Server: Update attempt failed

0:03:00 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:03:00 BattlEye Server: Update attempt failed

0:04:55 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:04:55 BattlEye Server: Update attempt failed

0:06:50 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:06:50 BattlEye Server: Update attempt failed

0:08:45 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:08:45 BattlEye Server: Update attempt failed

0:10:40 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:10:40 BattlEye Server: Update attempt failed

0:12:35 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:12:35 BattlEye Server: Update attempt failed

0:14:30 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:14:30 BattlEye Server: Update attempt failed

0:16:25 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:16:25 BattlEye Server: Update attempt failed

0:18:20 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:18:20 BattlEye Server: Update attempt failed

0:20:15 BattlEye Server: Failed to resolve BE Master 'arma1.battleye.com'

0:20:15 BattlEye Server: Update attempt failed

It's ok?

Share this post


Link to post
Share on other sites

seems like some technical difficulties, please be patient till it's resolved

Share this post


Link to post
Share on other sites

Battleye is kicking me off on every server i used to play ......with this message (unknow game version) i purchased this game (arma combine oparations)on amazons new and i been playing with no issues until now.....what is going on with battleeye?

Share this post


Link to post
Share on other sites
Battleye is kicking me off on every server i used to play ......with this message (unknow game version) i purchased this game (arma combine oparations)on amazons new and i been playing with no issues until now.....what is going on with battleeye?

This issue is fixed now and the issue is "client not responding" on a mass scale

Share this post


Link to post
Share on other sites
Battleye is kicking me off on every server i used to play ......with this message (unknow game version) i purchased this game (arma combine oparations)on amazons new and i been playing with no issues until now.....what is going on with battleeye?

Im having the exact same issue and have tried manually updating battleye using the dll on the battleye website. I have done a full reinstall and nothing seems to work. I even heard rumor of joining an empty server to allow battleye to update. Nothing is working and the forums arent pointing to a solution.

Share this post


Link to post
Share on other sites

version 1.60.87546

I did a search and deleted all instances of BEclient, installed from the web site, and now I get the error "resource title BTC_Hud not found". I also see that battleye doesn't seem to be initializing when I enter the game.

Share this post


Link to post
Share on other sites

hi $able the new OA beta gives a 18:15:20 Player -=XTRA=-Larsiano kicked off by BattlEye: Unknown Game Version

Share this post


Link to post
Share on other sites

That means he has a different version to the server that is required, I did not think it allows players to connect if patch if different client 1.59 - server 1.60 but maybe his running a old beta and the server does not allow them ? My server (ArmA) is having problems connecting to the master server don't know why. It tries, fails then might connect but drops again.

HAZ

Share this post


Link to post
Share on other sites
That means he has a different version to the server that is required
No its means BE is not updated yet for the new Arma2:OA Béta patch (SU r57 launched today).

Whats your server reportingIP="arma2pc.master.gamespy.com"; turned to? and is your router portforwarded?

Share this post


Link to post
Share on other sites

This is the BattlEye thread for ArmA ? ArmA as in Armed Assault 1 not 2. My server is rented and my server log says this:

19:01:32 BattlEye Server: Could not connect to BE Master

19:01:32 BattlEye Server: Update attempt failed

19:03:28 BattlEye Server: Could not connect to BE Master

19:03:28 BattlEye Server: Update attempt failed

19:05:24 BattlEye Server: Could not connect to BE Master

19:05:24 BattlEye Server: Update attempt failed

19:07:20 BattlEye Server: Could not connect to BE Master

19:07:20 BattlEye Server: Update attempt failed

19:09:16 BattlEye Server: Could not connect to BE Master

19:09:16 BattlEye Server: Update attempt failed

19:11:12 BattlEye Server: Could not connect to BE Master

19:11:12 BattlEye Server: Update attempt failed

19:13:08 BattlEye Server: Could not connect to BE Master

19:13:08 BattlEye Server: Update attempt failed

19:15:04 BattlEye Server: Could not conn

It is still running but its not got anymore past that time for some reason, I also restarted it after that time.

Share this post


Link to post
Share on other sites

ARMA 1 master server is supended and offline, too old codebase to support

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×