Jump to content
Sign in to follow this  
DaSquade

Flickering textures

Recommended Posts

Hi,

8800GTX card user here since it's release.

I was wondering if everybody has it that ArmA has a lot of flickering textures, be it shadows and textures, wich flip on and off in the distance?

I come from an ATI 9800pro and had it there aswell. Afaik, this was 'normal' then as the card didn't had the Z-buffer, where the nvidia counterpart had that buffer and never heard of flickering textures with that card. That was one of the reasons i stepped back to nvidia...but since i got it i still got the flickering textures/shadows.

Can't really post a movie of it, but i'm sure lots know what i'm talking about and no need to tell this is pretty annoying at times (and not what you expect of a top range videocard).

So i was wondering if anybody know what is causing it and how to fix it. Any help would be much appreciated.

PS: I didn't searched icon_rolleyes.gif .

Share this post


Link to post
Share on other sites

8800gts 320mb user here. I've getting this rapid texture (LOD?) flickering a lot lately, alt+tab/FLUSH usually doesn't work for more than 30 sec, then it just degrades into a crash or me turning ArmA off.

Share this post


Link to post
Share on other sites

I have the same card as Dasquade and the same flikkering as well.

As far as I remember in the beginning when I first installed arma (first release) I could have sworn there was no flikkering of the textures. Or at least not as much as nowadays.

.......

Or maybe thats "wishfull remembering"? wink_o.gif

Share this post


Link to post
Share on other sites

Agree Fox. Well afaik we did had some flickering, but only white textures like on the poles and fences. Could be wrong, but somewhere allong the line of updating and patching i think the number of 'flickers' has gained again sad_o.gif.

PS: Running XP pro, 2048GB DDR2, EVGA 8800GTX (AC3), latest arma patch, latest (official) EVGA drivers etc...

<table border="0" align="center" width="95%" cellpadding="0" cellspacing="0"><tr><td>Code Sample </td></tr><tr><td id="CODE">viewDistance=4718;

terrainGrid=3.125000;

gamma=0.993951;

brightness=1.044354;

sceneComplexity=1000000.000000;

shadingQuality=100;

shadowQuality=4;

soundEnableEAX=1;

soundEnableHW=0;

anisoFilter=4;

TexQuality=3;

postFX=0;

useWBuffer=0;

3D_Performance=9615.000000;

Resolution_W=1280;

Resolution_H=1024;

Resolution_Bpp=32;

refresh=85;

FSAA=4;

HDRPrecision=32;

localVRAM=786063360;

nonlocalVRAM=258998271;

I wonder what the 'useWBuffer=0;' means?

Share this post


Link to post
Share on other sites
I wonder what the 'useWBuffer=0;' means?

Old school texture usage. Google is your friend. Since the 9700 it is a dead buffer for ATI, and i think since the 6xxx series its gone now for NVDA. 9700s have a z-buffer. The flashing on my Ati cards was bad (Buildings) but since 1.05 and the 7.3s? its a non issue. Most likely its your drivers.

Share this post


Link to post
Share on other sites

Thanks for the info kklownboy (w buffer).

Well could be it is driver issue releated, but it is not like i will roll back several versions to get it away or slightly away, and to have other issues (like performence).

But what i do wonder is if every 8800 user os having this issue? If 'you' don't, please post what could have fixed it for you...

Atm i'm using the latest official driver of EVGA: 163.75.

Only use game settings afaik.

I do have nHancer but don't use it atm as if i make adjustments, witch i think would be an improvement, it doesn't load my game and reboots my pc (latest version of nHancer by the way).

I just tried lowering several settings one by one, like texture detail and shadings, but non of them fixed anything.

Not sure if nHancer settings could help get ride of it...as i have no idea what is causing it.

PS: Although fully maxed out, the game runs very smooth, so don't directly think it is the lack of memory or HD buffer etc.

help.gif

Share this post


Link to post
Share on other sites

mine went away with newer drivers, i think the 7.5? but i had to turn down object detail when it was bad.

Share this post


Link to post
Share on other sites

Turning down object detail (very low) doesn't help here sad_o.gif. Only 'deletes' lots of objects in far distance, but in scope view it is disco all again yay.gif .

Share this post


Link to post
Share on other sites

i have the same problem with 8800GTS 640mb

normally i have to alt+tab or to flush the v memory...flushing works well...but needs to be done often..

the other annoying and dangerous thing icon_rolleyes.gif is that sometimes the night vision flickers as you zoom in..and you end up dead...:)

Share this post


Link to post
Share on other sites

I have the same problem on an 8800GTS

There seem to be a few on the web mentioning the same problem.

I wonder if anyone is going to sort this out?

Share this post


Link to post
Share on other sites
i have the same problem with 8800GTS 640mb

normally i have to alt+tab or to flush the v memory...flushing works well...but needs to be done often..

the other annoying and dangerous thing  icon_rolleyes.gif is that sometimes the night vision flickers as you zoom in..and you end up dead...:)

The NV flickering happens to me as well..

But i use a Leadtekk GF 8500GT 512mb HP..

Share this post


Link to post
Share on other sites

Flickering here as well...flushing sometimes helps..but it is usually short lived. I was having the same night vision flickering...and I was about to blow a gasket about it when a mate told me he had fixed it by setting his textures to default...and badda boom badda bing...dey gone...smooth nite vision again. I also remember flickering on my 7800gt...but only after the 107 beta...at least that is what my fading memory is telling me... biggrin_o.gif.

Share this post


Link to post
Share on other sites

This is nvidia own problem with the cards... some cards work some don't. I've tried to solve it for almost half a year soon - you can't fix it. In other games it's even worse,

Share this post


Link to post
Share on other sites

@Lepardi

I think, though related, that the windows flickering on the buildings (at the start of that video) is a different issue than the flickering ground textures and other textures.

I have ATI now, but used to have NVidia, and have seen those windows on buildings flicker too using both types of card, and several different models of those cards on OFP and now ArmA.  But also with other programs, like Flight Simulator too.

So In ArmA I do see the added-later windows flickering at range from some angles, but the ground-feature textures and others I do not see flickering unless a texture of something that I have _placed_ in the editor happens to duck down below the ground level, or for instance, or is embedded inside another object.

With the standard ArmA textures such as runways that are _already_ placed on the Islands I see no such glitches at all.

Seems that for it to be worse on NVidia that there may be some very subtle difference in the way NVIdia cards apply the maths to the direction from which you are viewing the flickering texture. Perhaps a rounding or floating point thing, or maybe that an axis works the opposite way around on the hardware or that zero itself works differently? These are guesses only based on the observed phenomena, but somebody out there will know the answer to these thoughts - any volunteers?

I see similar things on Flight Simulator - usually when the runway is just exactly flush with the ground.  From some angles it draws in a given place, from some angles it does not as if it's under the ground surface from some angles only - same on the buildings with extra textures that are drawn afterwards.  And I do still see these flickering textures on FlightSim with ATI cards. When building airports from scratch in FlightSim the simplest fix for the designer is to raise the runway very very slightly above ground level, then the texture will draw properly from all angles.  So if an offset were calculated by ArmA and FS to make-offset ALL applied-after-obect-drawn textures slightly away from the object surface on which they are to be drawn, then the problem would go away.

Probably an offset of 0.0001 would be enough, but the direction to offset them _may_ be card-manufacturer specific.

Maybe DirectX should (already) compensate for these subtle 'errors' in the cards (if that is the cause) but uses 'best fit for all' instead of doing it properly, or maybe a standard workaround that will work on both ATI and NVidia should be sought and published to banish these graphical annoyances once and for all.  If it's a simple math difference problem then it shouldn't be too hard?

But even the mighty Microsoft haven't managed to fix this yet I think, and it must have annoyed them too..

Okay, I seem to have rambled on a bit. Any others have any thoughts on these issues I raised? Am I talking out of an orifice here?

Share this post


Link to post
Share on other sites
WarWolf @ Nov. 13 2007,07:36)]So In ArmA I do see the added-later windows flickering at range from some angles, but the ground-feature textures and others I do not see flickering unless a texture of something that I have _placed_ in the editor happens to duck down below the ground level, or for instance, or is embedded inside another object.

Indeed, thats exactly what happens with me as well, nvidia card.

@Lepardi

Nice video, thanks for sharing, luckely its not that bad here.

Share this post


Link to post
Share on other sites
I was wondering if everybody has it that ArmA has a lot of flickering textures, be it shadows and textures, wich flip on and off in the distance?

I have that annoying flickering on my old nVidia GF6600 GT as well on my never nVidia GF7950 GT using different drivers.

If I remember correctly it become much worse after the 1.05 patch, before 1.05 I didn't noticed it but after that patch it became very annoying when looking thru bin/scopes etc. only BIS knows what happend...

Nice theory you have there WarWolf, would be nice if someone in the knows can provide an answer....

/KC

Share this post


Link to post
Share on other sites

Have it here too lol... got used to it over the last year of playing it though.

Had it with my 7900 and my my 2900

Share this post


Link to post
Share on other sites
Have it here too lol... got used to it over the last year of playing it though.

Had it with my 7900 and my my 2900

This is mainly a NVidia problem since they had choosen to prefer high FPS vs. image quality.

The flicker appears in a lot of games with NVidia cards...unfortunatly I also own such a card.

I just was able to confirm it myself that ATI based cards, albeit slower, don't have this flickering problem.

The key seems to be some filtering that ATI keept, and NV dropped to gain FPS.

I read about this topic somewhere in a review of the 8xxx chipset...

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×