Jump to content
Sign in to follow this  
mluoto

Vista x64 + Radeon X1900XT unplayable

Recommended Posts

Hi,

has anybody got this game to work with Vista x64 and X1900XT?

Game loads okay, but main menu doesn't have any text or textures as shown in this image.

arma-small.jpg

I've tried different drivers (Cat 7.3, 7.4 and 7.5)

Game is updated from 1.04 to 1.08.

comp. specs are:

AMD A64 X2 5600+

MSI K9N SLI Platinum

4GB Kingston Hyperx low-latency

ATI Radeon X1900XT 512MB

2 x Western Digital WD2500 in RAID-0

2 x Hitachi HDS722516 in RAID-1

Sound Blaster X-Fi ExtremeMusic

Viewsonic VX2025WM

Share this post


Link to post
Share on other sites
heh, good luck in finding a fix:

http://www.flashpoint1985.com/cgi-bin....+screen

http://www.flashpoint1985.com/cgi-bin....62;st=0

ATI released some new drivers today (7.6) download and install them if you dont already have them in use.

no change with 7.6.

still a rpt full of "Failed to create surface texture" and a blackish menu screen in vista64/x1900xt. :-(

Share this post


Link to post
Share on other sites
go back to XP, and use  VISTA next year

why would i want to do that?. everything else works fine, including all my other games.

my rig is made purely for games (core 2 quad extreme, 4gb ballistix 1066mhz)  and this is the only game that is totally screwed up.

It worked not long ago (although not very well) so it cannot be entirely vista's fault.

Share this post


Link to post
Share on other sites

For one thing, ArmA is not supported under Vista. And afaik not under any 64-bit OS, that aside, please try to change your values in your My Documents\ArmA\yournick.ARMAPROFILE

to these:

<table border="0" align="center" width="95%" cellpadding="0" cellspacing="0"><tr><td>Code Sample </td></tr><tr><td id="CODE">

sceneComplexity=500000.000000;

shadingQuality=100;

shadowQuality=4;

anisoFilter=4;

TexQuality=3;

postFX=2;

useWBuffer=0;

Please copy/paste your current values to a post, so we can compare. Alternatively, try TexQuality=4;

I have seen really strange things happening on my rig with texture&shading detail set to lower than normal

Another tryout, please try to add: -maxmem=512

(or 256), to your ArmA startup shortcut to see if it makes any difference, altough I don't think these problems relate, but better safe than sorry.

Share this post


Link to post
Share on other sites

to these:

<table border="0" align="center" width="95%" cellpadding="0" cellspacing="0"><tr><td>Code Sample </td></tr><tr><td id="CODE">

sceneComplexity=500000.000000;

shadingQuality=100;

shadowQuality=4;

anisoFilter=4;

TexQuality=3;

postFX=2;

useWBuffer=0;

Please copy/paste your current values to a post, so we can compare. Alternatively, try TexQuality=4;

I had default settings and tried your settings, didn't help.

Quote[/b] ]

Another tryout, please try to add: -maxmem=512

(or 256), to your ArmA startup shortcut to see if it makes any difference, altough I don't think these problems relate, but better safe than sorry.

No help, tried 256, 512 and 1024.

go back to XP, and use VISTA next year

Yeah, sure.

Every other software I use, works fine on 64bit Vista.

Also I'll lose 1GB of memory with 32bit XP.

Share this post


Link to post
Share on other sites
go back to XP, and use VISTA next year

why would i want to do that?. everything else works fine, including all my other games.

my rig is made purely for games (core 2 quad extreme, 4gb ballistix 1066mhz) and this is the only game that is totally screwed up.

It worked not long ago (although not very well) so it cannot be entirely vista's fault.

My Armed Assault works perfect under Vista x64, i have the memory =512 thingy added to my shortcut, and i disabled the shadows in the options and i havn't gotten any memory crashs yet and all my settings are on Very high, so it could be your video card.

Share this post


Link to post
Share on other sites

I had this problem also on my 1900xt I was using dual monitors and a buddy said try disabling the second monitor and bam ARMA worked. After that I was able to re-enable my second monitor and it still worked.

So if you run dual monitors try disabling one and running ARMA again.

Also see this post:

http://www.flashpoint1985.com/cgi-bin....=vbawol

Now since Ive gotten a 2900xt the problem came back and the disabling second monitor thing doesn't work.

Vista x64 + Radeon HD 2900XT unplayable

Share this post


Link to post
Share on other sites

I have the exact same problem on Vista x64. I've tried all the steps above, no joy, and I can't seem to find a way to disable the second monitor (I only use the one screen anyway). I'm obviously using Catalyst 7.6, ArmA patch 1.08 and all the latest drivers and windows updates. PLEASE find a fix! I've not played the game yet and I bought it when it was released!

System spec:

Intel Core 2 6700 running at 3.57Ghz

Asus P5B WiFi Deluxe

MSI K9N SLI Platinum

4GB Kingston Hyperx

ATI Radeon X1900XT 512MB

2 x Western Digital WD2500 in RAID-0

Sound Blaster X-Fi ExtremeMusic

Sharp LL-191-B 19' TFT

Share this post


Link to post
Share on other sites

I have this problem too!!

I have: Vista Home premium 64bit

ASUS P5k Motherboard

ASUS EN8800GTX

4Gb Geil Ultra ddr2 memory

Intel Core 2 Duo 6600

Please, sbdy help me, because i really want to play this game!!

Share this post


Link to post
Share on other sites

I was wondering if this problem is not the same that happens in other games that were not made to suport 64bits systems or memory adresses over 2gb.

Supremecommander have the same problem, but you could use a tool called editbin and solve the issues to use high textures and resolution on Vista64.

But Arma and many other protected games, there is no way to try, as the protection validates the exe.

Many developers are taking some time to discovers that a simple tweak in the compiler to allow its programs to adreess over 2gb of memory will solve a lot of issues!

*edit*

Find the right post that explain what i just said:

http://forums.cluboverclocker.com/showthread.php?p=73616

I hope some BI coders look at this and check if they already did this tweak, as dumpbim tells that arma.exe cant address over 2gb of ram.

*added*

My Rig information as i having the exact same problem as the image in this post:

Core2Duo E6600

4GB DDR2 800mhz

Asus P5B Deluxe Wifi

XFX 8800GTX

300GB Samsung SataII Hard Disk.

Sound Max HD Audio Sound OnBoard on P5B

Vista Busines 64bits.

Share this post


Link to post
Share on other sites

UPGRADED GRAPHICS CARD, NOW I HAVE SAME PROBLEM!!

I am/have been using this game fine on VIsta 64bit no problems

I have:

e6850 CPU

4 gig 1066 DDR2 ram

*NEW* eVGA 8800 GTX 768

(Upgraded from 8800 GTS 320)

This game worked FINE , I just upgraded my GRAPHICS CARD THATS IT, and BAM (USING SAME DRIVERS ---yes I uninstalled , reinstalled the drivers for the new card)

Now my screen looks the same as the original posters. EXACTLY.

Share this post


Link to post
Share on other sites

this is my post from the other thread

Quote[/b] ]My ArmA was working with -maxmem=256 rock solid on my rig

E6600@3700

Commando MB

BFG 8800GTX

2x1024 Cell Shock 6800 Mem @ 460FSB (920Mhz)

RAID 0

X-FI

Win Vista Ultimate x64

Today other 2 Dimm of mem (same as above) came from RMA (been there 2 months sad_o.gif)

I instaled the dimms, and guess what.... the same problem as you guys! I DIDNT CHANGE ANYTHING, only put the 2 dimm in place.

icon_rolleyes.gif

I know ArmA doent support Vista, but does it suport 4gb of ram?

Share this post


Link to post
Share on other sites

i dont know if someone allready advice this, if yes, im sorry.

dual booteble disk

Vista and XP

that would solve ur problem.

Share this post


Link to post
Share on other sites
.

go back to XP, and use  VISTA next year

Yeah, sure.

Every other software I use, works fine on 64bit Vista.

Also I'll lose 1GB of memory with 32bit XP.

actauly u lose not 1Gb, u lose only bout 800MB RAM on XP , and if take in acount Vista request duble ammount RAM than XP, u will ,actualy, square on RAM.

Share this post


Link to post
Share on other sites
I was wondering if this problem is not the same that happens in other games that were not made to suport 64bits systems or memory adresses over 2gb.

Supremecommander have the same problem, but you could use a tool called editbin and solve the issues to use high textures and resolution on Vista64.

But Arma and many other protected games, there is no way to try, as the protection validates the exe.

Many developers are taking some time to discovers that a simple tweak in the compiler to allow its programs to adreess over 2gb of memory will solve a lot of issues!

*edit*

Find the right post that explain what i just said:

http://forums.cluboverclocker.com/showthread.php?p=73616

I hope some BI coders look at this and check if they already did this tweak, as dumpbim tells that arma.exe cant address over 2gb of ram.

*added*

My Rig information as i having the exact same problem as the image in this post:

Core2Duo E6600

4GB DDR2 800mhz

Asus P5B Deluxe Wifi

XFX 8800GTX

300GB Samsung SataII Hard Disk.

Sound Max HD Audio Sound OnBoard on P5B

Vista Busines 64bits.

I have np problems with Arma using XP Pro x64 also it see's 4GIG too. If tthe games not made for Vista thats it. Maybe some one should of read the requirments on the box so not the games fault. Maybe they will add more support.

Share this post


Link to post
Share on other sites

With each new driver from Nvidia, I'm just simply testing all options. With 163.44 beta, I'm now able to remove the -maxmem=512, and now able to run at my native res of 2560x1600.

My game 1st loaded up as the TS, with 163.44, but disabling memory hole remapping or 4gig down to 2gig, has it playing very nicely. SLI isn't an option for the ArmA profile, which I renamed arma.exe to FEAR.exe so I could test SLI, which infact is working, and the sli load bars stay well above it's halfway mark. I have not done a 9 day test as before...yet..but have gone a few hours with no problems.

This is the 1st driver that has let my sli run w/ArmA without the acid screens after 5 mins of playing.

I still blame Nvidia and not Vista for the graphic issues from before...it's to simple...things are getting better with Nvidia drivers, without any ArmA patches/hotfixes.

Share this post


Link to post
Share on other sites
I have this problem too!!

I have: Vista Home premium 64bit

          ASUS P5k Motherboard

          ASUS EN8800GTX

          4Gb Geil Ultra ddr2 memory

          Intel Core 2 Duo 6600

Please, sbdy help me, because i really want to play this game!!

Bro,

I got the game to work with a similar system...I accidently uninstalled nTUNE and lost what settings I had.

Ill post them as soon as I figure it out again.

Share this post


Link to post
Share on other sites

I have the exact same problem. Maybe Bohemia should step up the efforts to resolve Vista compatibility?

Share this post


Link to post
Share on other sites

I have the same problem now as soon as I upgraded from 2 GB of ram to 4 on Vista 64bit. It was running fine with Nvidia drives 162.something

As soon as I went to 4GB all hell broke loose. Now I'm dead in the water till we get a patch or fix sad_o.gif

Share this post


Link to post
Share on other sites

Ok update:

I was also getting CD protection errors when running with 4GB of Ram.

I even updated my Nvidia graphics driver to 163-Beta.

It did not solve the issue.

As soon as I removed the 2 GB of additional Ram the game now works flawlessly biggrin_o.gif

I can confirm now that its 4GB ram issue with vista.

I guess Vista users with 4GB or ram need to wait for a patch or remove the extra 2GB sad_o.gif

I'm running 64 bit Vista

Nvidia GTS8800

2.4 GHZ Quadcore.

Share this post


Link to post
Share on other sites
Ok update:

I was also getting CD protection errors when running with 4GB of Ram.

I even updated my Nvidia graphics driver to 163-Beta.

It did not solve the issue.

As soon as I removed the 2 GB of additional Ram the game now works flawlessly :D

I can confirm now that its 4GB ram issue with vista.

I guess Vista users with 4GB or ram need to wait for a patch or remove the extra 2GB :(

I'm running 64 bit Vista

Nvidia GTS8800

2.4 GHZ Quadcore.

you could try adjusting the amount of ram that vista recognizes. start -run - msconfig - boot - advanced options - maximium memory. this way you wouldn't have to physically remove the ram and could readjust the ram by changing the amount and restarting vista. i prefer it to yanking ram or dual-booting into a legacy os. <g>

it works for my ati card. i can't say if it'd address any game stability issues that forceware users have from the 4gb.

Share this post


Link to post
Share on other sites
Ok update:

I was also getting CD protection errors when running with 4GB of Ram.

I even updated my Nvidia graphics driver to 163-Beta.

It did not solve the issue.

As soon as I removed the 2 GB of additional Ram the game now works flawlessly biggrin_o.gif

I can confirm now that its 4GB ram issue with vista.

I guess Vista users with 4GB or ram need to wait for a patch or remove the extra 2GB sad_o.gif

I'm running 64 bit Vista

Nvidia GTS8800

2.4 GHZ Quadcore.

you could try adjusting the amount of ram that vista recognizes. start -run - msconfig - boot - advanced options - maximium memory. this way you wouldn't have to physically remove the ram and could readjust the ram by changing the amount and restarting vista. i prefer it to yanking ram or dual-booting into a legacy os. <g>

it works for my ati card. i can't say if it'd address any game stability issues that forceware users have from the 4gb.

And that my friends, is the solution. smile_o.gif

(for now, get going BIS)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×