Jump to content
Sign in to follow this  
Callaghan

Converting missions to 1.4

Recommended Posts

Just before the 505 1.4 version came out. I finished making a very large multiplayer mission. When I tried playing it (LAN) it gave other players the message "You cannot play/edit this mission as it contains downloadable content that has been deleted". After speaking to a few people it turns out that missions from 1.2 are not compatible with 1.4, so, I remade it, from scratch, on 1.4. Even after many hours work it still comes up with the same error for other players. I cannot work out what is wrong, I didnt copy + paste anything from the other mission I made the entire thing from scratch. Could there be something wrong with my installation as i had the German 1.2 before the UK 1.4? Someone please help it is very frustrating as this is a good mission and i want to release it to the community.

Share this post


Link to post
Share on other sites

Happens to me sometimes..

In the mission.sqm you will find at the top... this...

Quote[/b] ]version=11;

class Mission

{

addOns[]=

{

"cacharacters",

"cawheeled",

"caweapons",

"sara",

"camisc",

"CATracked",

"CAAir"

};

addOnsAuto[]=

{

"cacharacters",

"CATracked",

"CAAir",

"cawheeled",

"caweapons",

"camisc",

"sara"

};

Just delete everthing with the " ## "

so it will look like this..

Quote[/b] ]

version=11;

class Mission

{

addOns[]=

{

};

addOnsAuto[]=

{

};

Then load the mission into the editor and save it again and your problem should be gone... thats how you convert from 1.2 - 1.4 if you get the error. even though its just a weapon name change rofl.gif

Share this post


Link to post
Share on other sites

ok i kinda got the mission working MP by editing the sqm and adding every possible addon manually but only 50% of the people that try connecting can actually play and they all still get the error message. im presuming patch .5 will fix this and im not going to make missions till it comes out. Get on the ball BIS you're getting far too complacent after ofp, the novelty is no longer there and you cannot get away with leaving any aspect unpolished.

Share this post


Link to post
Share on other sites

wow, is this for real? 1.2 missions (like all the missions out there) have to be edited in the .sqm to run on 1.4?

Have to agree, good greif, this does seem like something majorly overlooked in the new patch (arent patches supposed to *fix* stuff, not break?tounge2.gif)

Great, cant wait to see what my mission is gonna do with new patch now too ...

Share this post


Link to post
Share on other sites

This happend to me too, without conversions. I actually made and ran my mission on a german 1.02 Morphicon release, and it gives me the error message while running createVehicle. This is indeed weird. I'll better go and file a bug report.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×