Jump to content
Sign in to follow this  
stainer

Multiplayer Freeze

Recommended Posts

Before anyone says anything I must point out that I did a search before posting, but did not find any info.

I have:

OFP:R 1.96

Windows XP

P4 3.00GHz Processor

1024mb RAM

128mb ATI Radeon x300

2mb ADSL connection

The problem is this:

Normal OFP is fine, but when I click Multiplayer on the main screen OFP freezes and I am forced to reset my PC from the mains.

I have tried a clean install, but it still resulted in the same effects.

My Video card has the latest drivers, I downloaded them just 2 weeks ago.

Any suggestions?

Share this post


Link to post
Share on other sites

It's probably a Firewall problem, i had a similair problem aswell.

I've got the firewall 'Zonealarm', and whenever i did a clean install of OFP, and i clicked on 'Multiplayer', my OFP froze. At least, that's what i though. But it was because Zonealarm popped up this 'accept' or 'decline' pop-up. Which i couldn't see because of my OFP being in the way, useing the shortcuts helped, or allowing your OFP in your firewall beforehand.

But yes .. sorry for this long story, check your firewall, and make sure OFP is accepted.

Good luck.

- Viper

Share this post


Link to post
Share on other sites

Until Opf is running problem free in all areas it can be quite useful to run it windowed until you have everything configured how you like it, just add -window to the shortcut as in the image below......

905.jpg

Share this post


Link to post
Share on other sites

Well I did some tinkering and it's now sorted. Thanks everyone!  biggrin_o.gif

You can lock if you want.

Share this post


Link to post
Share on other sites

What was preventing me from getting on to the screen was my firewall coming up, so I changed that, but when I tried to change "Implementation: Direct Play" to "Sockets" it froze again. Eventually I managed to access "sockets" and MP works fine, just I still can't change from "directplay" to "sockets". I can live with that.

Thanks again for all your help. smile_o.gif

Share this post


Link to post
Share on other sites

Hey have a friend with a simalar prob. What's stopping u from going directpay to sockets and how do you correct that?

How did u get back to sockets?

Share this post


Link to post
Share on other sites

Open the flashpoint\users\<your username>\userinfo.cfg and change the line useSockets=0; to useSockets=1;

I think that will work.

Share this post


Link to post
Share on other sites

i had that same problem but it wouldnt do it everytime what happened is my firewall poped up forcing ofp to minimize but when i minimized my flashpoint froze but now ive sorted it buy installing the latest drivers now i can alt+tab

Share this post


Link to post
Share on other sites
Open the flashpoint\users\<your username>\userinfo.cfg and change the line useSockets=0; to useSockets=1;

I think that will work.

Yup, that will work.

456820 you can just run OFP in a window as Placebo said above by adding the parameter -window to the target line

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×