Jump to content

Server only starts correctly with mission .pbo deleted

Recommended Posts

So I'm trying to start a hosted server via streamline servers.I've setup the MySQL database, exile client files, exile mod files and done the 64bit exile conversion. When I start the server up without Exile.Altis.pbo in the mpmissions folder it starts fine and I can join server, although obviously there are no AI and no missions. If I put the Exile.Altis.pbo file in the mpmissions folder, in the console of the streamline panel it gets to "ExileServer - Server is loading..." before it says "CallExtension extDB2 could not be found" "ExileServer - MySQL connection error".


As I said before, if I shut the server down then delete the Exile.Altis.pbo from the mpmissions folder, the server will start up fine. Any ideas why it is doing this?

Share this post

Link to post
Share on other sites

To disable SAFEMODE.. / Strict mode

1. Disable Strict Mode via my.cnf/my.ini

This method disables it by changing the value of  SQL_MODE in my.cnf file (for Linux) OR my.ini file (for windows server) and restarting the MySQL server.  my.cnf file can be found in one of a few locations (depending on which distribution you’re using). The most common locations are /etc/my.cnf and /etc/mysql/my.cnf .
NOTE: Make the following changes in the my.ini (for Windows Operating System) or my.cnf (for Linux Operating System). Inside that file, look for a heading like [mysqld] and then look for the value of sql_mode. It might look like this (the actual value of sql_mode may vary):

    Look for the following line:
    You can change the value of sql_mode to NO_ENGINE_SUBSTITUTION to completely disable strict mode, but you may want to look up each mode that is configured before disabling it or you can simply change it to:
    sql-mode="" (i.e. Blank)
    If sql_mode isn’t set, you can add it under the [mysqld] heading, then save the file, and restart MySQL.
    Restart the MySQL Service.

2. To Disable Strict Mode via SQL

This method allows you to disable the strict mode on your MySQL server by running the following command.
$ mysql -u root -p -e "SET GLOBAL sql_mode = ’NO_ENGINE_SUBSTITUTION’;"

Now, you can verify that the mode is set by running the following:
$ mysql -u root -p -e "SELECT @@GLOBAL.sql_mode;"


And also make sure you remove all 32 bit dll

Share this post

Link to post
Share on other sites