Jump to content

Arma 3 dedicated server lagging after a few hours (memory cap)

Recommended Posts

I'm desperate...
I've been facing this problem for more than a week now, tried countless fixes but came up with nothing.

I think I read every single article on dedicated server lag out there without finding someone having the exact same problem without any match so i'm trying my luck here.


The situation :

 I'm hosting an Arma 3 dedicated server on my computer to play antistasi plus with some friends, i boot the server for 4 to 7 hours sessions in mind. Game and server running allongside (and discord in the background) with no problem whatsoever (at least for a time), the total memory usage will be around 18G on 32G.

But after 1 to 2 hours the server is gonna start lagging out from nowhere, freezes, desync, becomes gradually unplayable. During that time the memory usage of my computer will be caped at 16G (50%), event if i'm opening other applications the memory won't exceed 16G until the server crashes. Problem resets at server restart.

If you're familiar with arma troubleshooting you know that this is a common error on clients, a lot of people have/had it and i had it too at first (note that client and server encountered the problem at the exact same moment in the begining), but i fixed it by switching from the basic to the profiling version of the game and from 32 to 64x and it worked so thats that taken care of.


What i've tried :

-Tried the basic, Beta and profiling version of the server -> no changes

-Tried 32 and 64 bits -> 32bits started lagging after 1h to 1.5hrs

-Tried setting maxMem au MaxVRAM accordingly to the specs of my pc (specs at the end) -> nothing

-Tried to change the malloc parameter from tbb4malloc_bi to jemalloc_bi and system -> nothing

-Tried modded and vanilla (modlist at the end) -> same thing

-Tried the server from the dedicated server app (steam id=233780) and the server from the arma 3 app (steam id=107410) -> same

-Updated quite literraly all my drivers -> pc up to date but still the same problem


Diagnosis :

The problem seems to be coming from the memory allocation: for wathever reasons it seems to thinks that my system only has 16G and does everything it can to avoid going over. All other processes are fine during that, so well that they'll get confortable and take a so much ressources that i won't be able to get my system back to a 10G where the server could work without to many problems. This is just a guess based on what i could observe, i tried searching into the rpt files before realising that i can't understand shit (but no obvious error around the time the lag begins that could explain it from what i can tell, can be wrong tho)


Specs :

My computer :

                          -Intel core i7-10700k 3.8Ghz

                          -32GB of RAM

                          -Server is located on a 1TB SSD

                          -Nvidia Geforce RTX 2060

                          -Windows 10

Mods :








                          -Ace extension: attachment switching

                          -JSRS SOUNDMOD + JSRS RHSUSAF support

                          -DUI squad radar

                          -Enhanced movement

                          -Advanced towing

                          -Advanced sling loading

                          -BettIr (legacy)

                          -Better CAS environment

                          -ACE Compat with RHSAFRF, RHSUSAF, RHSGREF, RHSSAF

                          -Antistasi Plus 2.0

server config :


hostname        = "[EXESERV]";
password        = "********";
passwordAdmin    = "********";
maxPlayers        = 69;
persistent        = 1;


disableVoN        = 0;
vonCodecQuality    = 30;

voteMissionPlayers    = 1;
voteThreshold        = 0.5;
allowedVoteCmds[] =
    {"admin", false, false},
    {"kick", false, true, 0.51},
    {"missions", false, false},
    {"mission", false, false},
    {"restart", false, false},
    {"reassign", false, false}

motd[] =
    "ici ça démonte des daronnes",
motdInterval = 3;

class Missions {
   class Mission1 {
       template ="Antistasi_Altis.Altis";
       difficulty = "Regular";
       class Params {
          LogLevel = 2;
          A3A_logDebugConsole = 1;

admins[] = 

timeStampFormat    = "short";
logFile            = "server_console.log";

BattlEye            = 0;
verifySignatures        = 0;
kickDuplicate            = 1;

headlessClients[]    = {""};
localClient[]        = {""};  


startup parameters :


start arma3server_x64.exe -autoInit -malloc=system -port=29099 -config=D:\serv\servarma\CONFIG_server.cfg -profiles=D:\serv\servarma -netlog "-mod=@ace;@ACE Extension - Attachment Switching;@Advanced Sling Loading;@Advanced Towing;@Better CAS Environment (BCE);@BettIR (Legacy v0.2.1);@CBA_A3;@DUI - Squad Radar;@Enhanced Movement;@RHSUSAF;@ACE Compat - RHS AFRF;@ACE Compat - RHS- GREF;@ACE Compat - RHS- SAF;@ACE Compat - RHS USAF;@Antistasi Plus 2.0;@RHSAFRF;@RHSGREF;@RHSSAF"



only from 5 min before the problem occured to the server shutdown (because of pastebin limit, i can provide other parts or entirety on demand)


Thanks in advance for any help you can provide.

I've got a pretty good knowledge in dedicated servers but i'm new to the arma environment, i'm not in anyway a pro in this and there's a lot i don't know.

I've searched for a good amount of time but at this point i'm not excluding any solution so if you've got a solution that may sound stupid try anyway, won't shame you for helping me.

sorry for any spelling mistakes, not my mother tongue.

I can provide additional data on demand


exebill    :)

Share this post

Link to post
Share on other sites

I have a similar problem, but when I create a local server for a single player game, the server itself and not the game starts to lag terribly after a while the functions of the antistasis itself, I tried many methods for optimization, I increased the FPS, but the situation didn’t change, I thought that there would be no such problem on dedicated servers, but it turns out I’m not the only one, I also don’t know the solution to this problem, unfortunately 

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now