Jump to content

[Solved] Problems with hideObjectGlobal for layers

Recommended Posts

Hi there,

I'm attempting to unhide a layer that I have previously hidden using the following code in the mission init.sqf, with "layer_checkpointwest" being my layer:


        _x hideObjectGlobal true;
    } forEach (getMissionLayerEntities "layer_checkpointwest" select 0);

I want to unhide everything in this layer at some point later on in the mission. Originally I had it set up in an addAction for a Zeus player to trigger:

zeus1 addAction ["4. Unhide Checkpoint Ambush Scene", {{_x hideObjectGlobal false;} forEach (getMissionLayerEntities "layer_checkpointwest" select 0);}, nil, 1.5, false, true, "", "true", 3];

For SP and locally hosted MP this works fine, however on a dedicated server nothing seems to happen. I am thinking it's something to do with the way hideObjectGlobal needs to be called on the server - but even using a trigger to remoteExec a script > "[] remoteExec ["unhidecheckpoint.sqf", 2, false];" with essentially the opposite of the init.sqf code doesn't seem to work either.

I've been reading so much on this and I don't feel like I'm fully understanding what I'm missing!

Any help or advice with this is much appreciated.

Share this post

Link to post
Share on other sites

You're on the right track, hideObjectGlobal indeed needs to be executed on the server.


4 hours ago, Jamio said:

[] remoteExec ["unhidecheckpoint.sqf", 2, false];


You can't remoteExec an .sqf directly, only functions or script commands. So, you could try something along the lines of:

"unhidecheckpoint.sqf" remoteExec ["execVM", 2]; //third param is false by default




  • Like 2
  • Thanks 1

Share this post

Link to post
Share on other sites
9 hours ago, Harzach said:

"unhidecheckpoint.sqf" remoteExec ["execVM", 2]; //third param is false by default

This worked like a charm - thank you!

I don't know how I forgot about execVM for .sqf's but oh well. Back to the wiki I go😥

  • Like 1

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now