Jump to content
GRE_Himbeerketon

Object Builder | Walls vanishing from Object

Recommended Posts

I have created the model of a building as an .obj file. When importing it into object builder and viewing it in Buldozer I have noticed that walls randomly appear and disappear depending on how you look at the model. I thought this was a glitch in the Viewing software but when importing the object into the Game I noticed this persists. My theory is that it might be related to the fact that each wall basically consists out of 2 meshes (1 per side), because the wall is 3 Dimensional.

[I attached some images: https://imgur.com/a/j6j27rX]

An Additional Problem is that I can walk through the walls.

Can anyone help me please with one or more of these issues?
Thanks

Addition: I allready tried posting this on steam, but it seems noone was able to help me

Share this post


Link to post
Share on other sites

The faces disappearing and re-appearing is probably down to Buldozer being a bit wonky when it comes to zooming in. Rather than zooming in and out on your model with the + and - keys try using WSAD to move the camera around instead. Zooming with + and - often leads to a fish-eye effect with a bit of distortion, at least that is my experience when working on weapon models.

 

Walking through the walls is caused by you not giving your model a Geometry LOD. Check out this link and this link for a bit more information on that.

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you for your answer.

 

However as I mentioned earlier the issue with the walls isn't exclusive to bulldozer but remains when importing the object into arma. In one of the linked pages it says "If the geometry LOD is larger then the size limit, it gets glitchy (collision does not work for example and the object may disappear at certain view angles). The exact value of the limit is not yet known, but it is somewhere around 50-60 meter from the center of origin" however my model is at max 80 m long. i tried centering it on the grid in object builder and using wasd to move around in bulldozer but the problem seems to remain. I might try to import the correctly centered version into arma though at a later point. (Also I guess this refers to the object as a whole and not just parts of it.)

The LOD guide is very helpful to me, however I don't quite understand how I can rename the mesh. I got the Alt+L window open but don't know how to edit the mesh name. (it is probably so easy it isn't mentioned anywhere)

Edited by GRE_Himbeerketon
spelling

Share this post


Link to post
Share on other sites

I did manage to make the Mesh collide with the player. However finding out about  Infantry Metrics I will now have to rebuild the model from scratch which is kinda painful (I orientated myself on a real blueprint while creating the model, but it seems Arma soldiers are fat or something :D). Also the Faces still look broken: Images

Share this post


Link to post
Share on other sites

That happens when the plane is inverted, it may be that in Blender you see it correct but is it inverted.

In OB you select the face - Faces - Reverse

 

 https://prnt.sc/192a19l

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×