Jump to content
Sign in to follow this  
maxjoiner

Custom Head, injury RVMAT strange bug (FIXED)

Recommended Posts

Hi all,

I developed a Custom Head and it works fine

but if I add the injury RVMAT in the config I get this error :

 

Untitled.png

 

I can guarantee you I checked a lot of times, the RVMAT address is right!

Of course, I tried with "\" before the address and without it.

I tried also to move it into another folder, I tried to change the RVMAT

with a new one, another taken from a works Addon but nothing I always get the same error.

But the thing very strange is this, If I copy the address of an RVMAT, like for example:

 

materialWounded1 = "A3\Characters_F\Heads\Data\m_White_01_injury.rvmat";

materialWounded2 = "A3\Characters_F\Heads\Data\m_White_01_injury.rvmat";

 

it works fine with that, of course, I can't use that because the textures are for another Head.

 

this is my config:

 

----------------------------------------------------------------------------------------------------------------------------------------------------------------

 

class CfgFaces
{
    class Default;
    class Man_A3: Default
 {
  class Default;
  class max_hitman: Default
  {
    name = "Hitman";
    displayname = "Agent47";
    identityTypes[] = {"max_hitman"};
    author = "Maxjoiner";
    head = "hitman_Head";
    texture = "\max_Hitman\head\data\hitman.paa";
    material = "\max_Hitman\head\data\hitman.rvmat";
    materialWounded1 = "\max_Hitman\head\data\hitman_injury.rvmat";
    materialWounded2 = "\max_Hitman\head\data\hitman_injury.rvmat";
    textureHL = "\max_Hitman\head\data\skin_co.paa";
    materialHL = "A3\Characters_F\Heads\Data\hl_White_hairy_muscular.rvmat";
    textureHL2 = "\max_Hitman\head\data\skin_co.paa";
    materialHL2 = "A3\Characters_F\Heads\Data\hl_White_hairy_muscular.rvmat";
    disabled = 0;
        };   
 
 
    };
};


class CfgHeads
{
    class Default_A3;
    
    class hitman_Head: Default_A3
    {
        model = "\max_Hitman\head\head.p3d";

        class Wounds {
            tex[] = {};
            mat[] = {"\max_Hitman\head\data\hitman.rvmat", "\max_Hitman\head\data\hitman_injury.rvmat", "\max_Hitman\head\data\Hitman_injury.rvmat"};
        };
        
        selectionHeadWound = "injury_head";
        selectionPersonality = "personality";

    };
    
    
};

 

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

 

Please anyone knows why I get that error?!

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
6 hours ago, reyhard said:
18 hours ago, maxjoiner said:

 

Of course, I tried with "\" before the address and without it.

I tried also to move it into another folder, I tried to change the RVMAT

with a new one, another taken from a works Addon but nothing I always get the same error.

But the thing very strange is this, If I copy the address of an RVMAT, like for example:

 

materialWounded1 = "A3\Characters_F\Heads\Data\m_White_01_injury.rvmat";

materialWounded2 = "A3\Characters_F\Heads\Data\m_White_01_injury.rvmat";

Try removing leading slashes from your paths

 

Thanks mate, but I tried with them and without them, the result is the same....

A little update, also with the Uniforms I have that error...

It seems ArmA3 doesn't accept my custom RVMATs....

 

Share this post


Link to post
Share on other sites

Can I prepare a PBO with RVMATS only for You?

Can I send the link in private?

Share this post


Link to post
Share on other sites

As it turns out, RVMAT was missing from PBO 🙂

In general, A3 Tools (& older Bohemia ones too) are moving only files which are referenced by p3d. Injury materials are not linked in P3D and therefore they need to be included manually. Simplest solution would be adding all RVMATs to this list

obraz.png.45a19164ec2c74a8c6ec77fd493e625f.png

Alternatively I've highly recommend using PBO Project.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×